Following are network parameters, grouped into the following sections:
0 - Indicates the original functionality in AIX 4.3.
1 - Indicates that link local addresses will be resolved by
querying each interface for the link local address.
2 - Indicates that link local addresses will only be examined for
the interface defined by main_if6.
3 - Indicates that link local addresses will only be examined for
the interface defined by main_if6, and site local addresses will
only be routed for the main_site6 interface.
The default value is zero (policing off). Values of
net_malloc_police larger than 1024 will allocate that many items in
the kernel buffer for tracing. This is a run-time attribute.
ISNO: ifconfig interface rfc1323
NewValue
OR
chdev -l interface -a rfc1323=NewValue
The ifconfig command sets values temporarily, making it
useful for testing. The chdev command alters the ODM, so
custom values return after system reboots.
This is a configuration decision with performance consequences. If the
subnets do not all have the same MTU, fragmentation at bridges may degrade
performance. If the subnets do have the same MTU, and
subnetsarelocal is 0, TCP sessions may use an unnecessarily small
MSS. This is a run-time attribute.
ISNO: ifconfig interface
tcp_mssdflt NewValue
OR
chdev -l interface -a
tcp_mssdflt=NewValue
The ifconfig command sets values temporarily, making it
useful for testing. The chdev command alters the ODM, so
custom values return after system reboots.
ISNO: ifconfig interface
tcp_recvspace NewValue
OR
chdev -l interface -a
tcp_recvspace=NewValue
The ifconfig command sets values temporarily, making it
useful for testing. The chdev command alters the ODM, so
custom values return after system reboots.
Lower bandwidth networks, such as Serial Line Internet Protocol (SLIP), or
higher bandwidth networks, such as Serial Optical Link, should have different
optimum buffer sizes. The optimum buffer size is the product of the
media bandwidth and the average round-trip time of a packet.
The tcp_recvspace attribute must specify a socket buffer size less
than or equal to the setting of the sb_max attribute. This
is a run-time attribute, but for daemons started by the inetd
daemon, run the following commands: stopsrc -s inetd ;
startsrc -s inetd
ISNO: ifconfig interface
tcp_sendspace NewValue
OR
chdev -l interface -a
tcp_sendspace=NewValue
The ifconfig command sets values temporarily, making it
useful for testing. The chdev command alters the ODM, so
custom values return after system reboots.
Calculate the number of NFS operations that are being received per second at
the NFS server and multiply this by 4. This will produce a duplicate
cache size that should be sufficient to allow correct response from the NFS
server. The operations that are affected by the duplicate cache are the
following: setattr(), write(),
create(), remove(), rename(),
link(), symlink(), mkdir(),
rmdir().
This allows for a floating timeout value along with adjusting the transfer
sizes used. All of this is done based on an accumulative history of the
NFS server's response time. In most cases, this parameter does not
need to be adjusted. There are some instances where the straightforward
timeout behavior is desired for the NFS client. In these cases, the
value should be set to 0 before mounting file systems.
MAX ((filesize/8)-1, 32)
.
This option can be used if the NFS server is overloading the system (lowering
or making the nfsd daemon less favored). It can also be used
if you want the nfsd daemons be one of the most favored processes
on the server. Use caution when setting the parameter because it can
render the system almost unusable by other processes. This situation
can occur if the NFS server is very busy and will essentially lock out other
processes from having run time on the server.
"Normal" system read-ahead is controlled by VMM. In AIX
4.2.1, the more aggressive top-half JFS read-ahead was
introduced. This mechanism is less susceptible to read-ahead breaking
down due to out-of-order requests (which are typical in the NFS server
case). When the mechanism is activated, it will read an entire cluster
(128 KB, the LVM logical track group size).
Calculate the number of NFS operations that are being received per second at
the NFS server and multiply this by 4. The result is a duplicate cache
size that should be sufficient to allow correct response from the NFS
server. The operations that are affected by the duplicate cache are the
following: setattr(), write(),
create(), remove(), rename(),
link(), symlink(), mkdir(),
rmdir().
Calculate the number of NFS operations that are being received per second at
the NFS server and multiply this by 4. The result is a duplicate cache
size that should be sufficient to allow correct response from the NFS
server. The operations that are affected by the duplicate cache are the
following: setattr(), write(),
create(), remove(), rename(),
link(), symlink(), mkdir(),
rmdir().
The following streams tunable attributes only apply for AIX 4.2 or later.