Creates a logical volume.
mklv [ -a Position ] [ -b BadBlocks ] [ -c Copies ] [ -d Schedule ] [ -e Range ] [ -i ] [ -L Label ] [ -m MapFile ] [ -o Y / N ] [ -r Relocate ] [ -s Strict ] [ -t Type ] [ -u UpperBound ] [ -v Verify ] [ -w MirrorWriteConsistency ] [ -x Maximum ] [ -y NewLogicalVolume | -Y Prefix ] [ -S StripeSize ] [ -U Userid ] [ -G Groupid ] [ -P Modes ] VolumeGroup Number [ PhysicalVolume ... ]
The mklv command creates a new logical volume within the VolumeGroup. For example, all file systems must be on separate logical volumes. The mklv command allocates the number of logical partitions to the new logical volume. If you specify one or more physical volumes with the PhysicalVolume parameter, only those physical volumes are available for allocating physical partitions; otherwise, all the physical volumes within the volume group are available.
The default settings provide the most commonly used characteristics, but use flags to tailor the logical volume to the requirements of your system. After a logical volume is created, its characteristics can be changed with the chlv command.
The default allocation policy is to use a minimum number of physical volumes per logical volume copy, to place the physical partitions belonging to a copy as contiguously as possible, and then to place the physical partitions in the desired region specified by the -a flag. Also, by default, each copy of a logical partition is placed on a separate physical volume.
The -m flag specifies exact physical partitions to be used when creating the logical volume.
If the volume group in which the logical volume is being created is in big vg format, U, G, and P flags can be used to set the ownership, group, and permissions respectively, of the special device files. Only root user will be able to set these values. If the volume group is exported, these values can be restored upon import if R flag is specified with importvg command.
You can specify logical volumes sizes in 512 Blocks/KB/MB/GB when using the mklv command. (See Examples.)
Physical partitions are numbered starting at the outermost edge with number one.
You can use the Volumes application in Web-based System Manager to change volume characteristics. You could also use the System Management Interface Tool (SMIT) smit mklv fast path to run this command.
-a Position | Sets the intra-physical volume allocation policy (the position of
the logical partitions on the physical volume). The Position variable can be one of the following:
|
-b BadBlocks | Sets the bad-block relocation policy. The Relocation variable can be one of the following: |
-c Copies | Sets the number of physical partitions allocated for each logical partition. The Copies variable can be set to a value from 1 to 3; the default is 1. |
-d Schedule | Sets the scheduling policy when more than one logical partition is
written. The Schedule variable can be one of the
following:
|
-e Range | Sets the inter-physical volume allocation policy (the number of physical volumes to extend across, using the volumes that provide the best allocation). The Range value is limited by the UpperBound variable, (set with the -u flag) and can be one of the following: |
-G Groupid | Specifies group ID for the logical volume special file. |
-i | Reads the PhysicalVolume parameter from standard input. Use the -i flag only when PhysicalVolume is entered through standard input. |
-L | Sets the logical volume label. The default label is None. The maximum size of the label file is 127 characters.
Note
If the logical volume is going to be used as a journaled file system (JFS),
then the JFS will use this field to store the mount point of the file system
on that logical volume for future reference. |
-m MapFile | Specifies the exact physical partitions to allocate. Partitions are used in the order given in the MapFile parameter. Used partitions in the MapFile parameter are not legal, because the new logical volume cannot occupy the same physical space as a previously allocated logical volume. All physical partitions belonging to a copy are allocated before allocating for the next copy of the logical volume. The MapFile parameter format is: PVname:PPnum1[-PPnum2]. In this example, PVname is a physical volume name (for example, hdisk0) as specified by the system. It is one record per physical partition or a range of consecutive physical partitions. PPnum is the physical partition number. |
-oY / N | Turns on/off serialization of overlapping IOs. If serialization is turned on then overlapping IOs are not allowed on a block range and only a single IO in a block range is proccessed at any one time. Most applications like file systems and databases do serialization so serialization should be turned off. The default for new logical volumes is off. |
-P Modes | Specifies permissions (file modes) for the logical volume special file. |
-r Relocate | Sets the reorganization relocation flag. For striped logical volumes, the Relocate parameter must be set to n (the default for striped logical volumes). The Relocate parameter can be one of the following: |
-s Strict | Determines the strict allocation policy. Copies of a logical partition
can be allocated to share or not to share the same physical volume. The Strict parameter is represented by one of the following:
|
-S StripeSize | Specifies the number of bytes per striped. Must be a power of two,
between 4K and 128K , for example 4K, 8K, 16K, 32K, 64K, or 128K.
Note
The -d, -e, and -s flags are not valid when creating a striped logical
volume using the -S flag. |
-t Type | Sets the logical volume type. The standard types are jfs (journaled file systems), jfslog (journaled
file system logs), jfs2 (enhanced journaled file system), jfs2log (enhanced journaled file system logs), and paging (paging spaces), but a user can define other logical volume types
with this flag. You cannot create a striped logical volume of type boot. The default is jfs. If a log is manually
created for a filesystem, the user must run the logform command to clean out the new jfslog before the log can be used. For example, to format the logical
volume logdev, type:
logform /dev/logdev where /dev/logdev is the absolute path to the logical volume. |
-U Userid | Specifies user ID for logical volume special file. |
-u UpperBound | Sets the maximum number of physical volumes for new allocation. The
value of the Upperbound variable should be between
one and the total number of physical volumes. When using striped logical
volumes or super strictness the upper bound indicates the maximum number of
physical volumes allowed for each mirror copy.
Note
When creating
a super strict logical volume you must specify physical volumes or use the -u flag. |
-v Verify | Sets the write-verify state for the logical volume. Causes (y) all writes to the logical volume to either be verified with a follow-up read, or prevents (n) the verification of all writes to the logical volume. The Verify parameter is represented by one of the following: |
-w MirrorWriteConsistency |
|
-x Maximum | Sets the maximum number of logical partitions that can be allocated to the logical volume. The default value is 512. The number represented by the Number parameter must be equal to or less than the number represented by the Maximum variable. The maximum number of logical partitions per logical volume is 32,512. |
-y NewLogicalVolume | Specifies the logical volume name to use instead of using a system-generated name. Logical volume names must be unique system wide name, and can range from 1 to 15 characters. If the volume group is varied on in concurrent mode, the new name should be unique across all the concurrent nodes the volume group is varied on. The name cannot begin with a prefix already defined in the PdDv class in the Device Configuration Database for other devices. |
-Y Prefix | Specifies the Prefix to use instead of the prefix in a system-generated name for the new logical volume. The prefix must be less than or equal to 13 characters. The name cannot begin with a prefix already defined in the PdDv class in the Device Configuration Database for other devices, nor be a name already used by another device. |
mklv -c 2 vg02 1
mklv -c 3 -u 2 -s n vg03 9
mklv -a c -t paging -b n vg04 5
mklv vg03 15 hdisk5 hdisk6 hdisk9
mklv -u 3 -S 64K vg05 12
mklv -S 8K vg05 12 hdisk1 hdisk2 hdisk3
mklv VGNAME 10M #
The mklv command will determine the number of partitions needed to create a logical volume of at least that size.
You can use uppercase and lowercase letters as follows:
B/b 512 byte blocks K/k KB M/m MB G/g GB
The chfs command, chlv command, chpv command, extendlv command, mklvcopy command, rmlvcopy command, syncvg command.
The Logical Volume Storage Overview in AIX 5L Version 5.2 System Management Concepts: Operating System and Devices.
For information on installing the Web-based System Manager, see Chapter 2: Installation and System Requirements in AIX 5L Version 5.2 Web-based System Manager Administration Guide.
The System Management Interface Tool (SMIT) Overview in AIX 5L Version 5.2 System Management Concepts: Operating System and Devices.