Creates boot image.
bosboot -Action [ -d Device ] [ -Options ... ]
bosboot -a [ -d Device ] [ -p Proto ] [ -k Kernel ] [ -I | -D ] [ -l LVdev ] [ -L] [ -M { Norm | Serv | Both } ] [ -T Type ] [ -b FileName ] [ -q ]
The bosboot command creates the boot image that interfaces with the machine boot ROS (Read-Only Storage) EPROM (Erasable Programmable Read-Only Memory).
The bosboot command creates a boot file (boot image) from a RAM (Random Access Memory) disk file system and a kernel. This boot image is transferred to a particular media that the ROS boot code recognizes. When the machine is powered on or rebooted, the ROS boot code loads the boot image from the media into memory. ROS then transfers control to the loaded images kernel.
The associated RAM disk file system contains device configuration routines that make the machine's devices and file systems available. The RAM disk file system contains differing configuration files depending upon the boot device. A mkfs prototype file is supplied for each type of device. (See note 6 below.) Currently supported devices are:
A network device may be a token ring, Ethernet, or Fiber-Distributed Data Interface (FDDI) used to boot from a network boot server over a local area network (LAN).
The boot image varies for each type of device booted and is compressed to fit on certain media and to lessen real memory requirements. The boot logical volume must be large enough for the boot image.
In addition to creating a boot image, the bosboot command always saves device configuration data for disk. It does not update the list of boot devices in the NVRAM (nonvolatile random access memory). You can modify the list with the bootlist command.
The bosboot command is usually called during the Base Operating System installation and by the updatep command when the operating system is upgraded.
lsvg -M rootvg
This command displays a map of all logical volumes. The default boot logical volume is hd5. Use the disk device that contains the boot logical volume.
The hardware platform type is an abstraction which allows machines to be grouped according to fundamental configuration characteristics such as number of processors or I/O bus structure or both. Machines with different hardware platform types will have basic differences in the way their devices are dynamically configured at boot time. The hardware platform type rs6k in AIX 5.1 and earlier applies to all Micro Channel-based uni-processor models through AIX 5.1 only. The type rs6ksmp applies to all Micro Channel-based symmetric multi-processor models through AIX 5.1 only. The type rspc in AIX 5.1 and earlier applies to all ISA-bus models. As new models are developed, their hardware platform types will either be one of the aforementioned types or, if fundamental configuration differences exist, new types will be defined. Boot images for a given boot device type will generally be different for machines with different hardware platform types.
"The prototype file used by bosboot is constructed by starting with a copy of the base prototype file for the platform type and boot device (for example, /usr/lib/boot/chrp.disk.proto). Next the bosboot command looks at the pcfg file for the platform type being used (for example, /usr/lib/boot/chrp.pcfg). The pcfg file contains entries which bosboot uses in a template to search for proto extension files. These files, located in the directory /usr/lib/boot/protoext, provide extensions to the prototype file under construction. For example, if the platform type is chrp and the boot device is disk, and the file /usr/lib/boot/protoext/chrp.pcfg contains the following:
scsi. chrp. chrp_lpar. fcp. graphics. ide. isa_sio. pci. ssa. sys.pci. tty. usbif.
The bosboot command will start with the base prototype file /usr/lib/boot/chrp.disk.proto, and search the directory /usr/lib/boot/protoext for any files that match the template disk.proto.ext.scsi.*. The contents of these files are added to the prototype file under construction. Next, the contents of files matching the template /usr/lib/boot/protoext/disk.proto.ext.scsi.* are added to the prototype file under construction. This continues until all lines in the pcfg file have been processed. At this point the prototype file under construction is complete. The bosboot command passes this prototype file to the mkfs command which builds the RAM disk file system.
This is reflected in the names of these prototype files:
/usr/lib/boot/chrp.disk.proto
/usr/lib/boot/chrp.cd.proto
/usr/lib/boot/chrp.tape.proto
/usr/lib/boot/network/chrp.ent.proto
/usr/lib/boot/network/chrp.tok.proto
/usr/lib/boot/network/chrp.atm.proto
/usr/lib/boot/network/chrp.fddi.proto
The system device type is an abstraction that allows machines to be grouped according to fundamental configuration characteristics, such as number of processors and I/O bus structure. The system device is the highest-level device in the system node, which consists of all physical devices in the system.
Machines with different system device types have basic differences in the way their devices are dynamically configured at boot time.
The bosboot command, by default, uses the prototype file that matches the system device type of the machine executing the command. The -p option allows you to specify the system device type of the prototype file.
-d device | Specifies the boot device. This flag is optional for hard disk. |
The following flags are action flags. One and only one flag must be specified.
-a | Creates complete boot image and device. |
The following flags are option flags:
Access Control: Only the root user can read and execute this command.
bosboot -a
bosboot -ad /dev/rmt0 -b /tmp/tape.bootimage
bosboot -ad /dev/ent0
bosboot -ad /dev/tok -T chrp
The bootlist command, mkboot command, and locktrace command.