crfs -v VfsType { -g VolumeGroup | -d Device } [ -l LogPartitions ] -m MountPoint [ -n NodeName ] [ -u MountGroup ] [ -A { yes | no } ] [ -p {ro | rw } ] [ -a Attribute= Value ... ] [ -t { yes | no } ]
The crfs command creates a file system on a logical volume within a previously created volume group. A new logical volume is created for the file system unless the name of an existing logical volume is specified using the -d. An entry for the file system is put into the /etc/filesystems file.
Note: The file system is created with the setgid (set group ID) bit enabled. This determines the default group permissions. All directories created under the new file system will have the same default group permissions.
You can use the File Systems application in Web-based System Manager (wsm) to change file system characteristics. You could also use the System Management Interface Tool (SMIT) smit crfs fast path to run this command.
JFS applies to the POWER-based platform only, and JFS2 is common to both platforms.
-a Attribute=Value | Specifies a virtual file system-dependent attribute/value pair. To
specify more than one attribute/value pair, provide multiple
-a Attribute=Value parameters (see example).
The following attribute/value pairs are specific to the Journaled File System (JFS): |
| |
| |
| |
| |
| |
| |
| |
The maximum size of a JFS file system is a function of its fragment size and the nbpi value. These values yield the following size restrictions:
nbpi Fragment size in bytes Maximum size in 512-byte blocks 512 512, 1024, 2048, 4096 16777216 1024 512, 1024, 2048, 4096 33554432 2048 512, 1024, 2048, 4096 67108864 4096 512, 1024, 2048, 4096 134217728 8192 512, 1024, 2048, 4096 268435456 16384 512 268435456 16384 1024, 2048, 4096 536870912 32768 512 268435456 32768 1024 536870912 32768 2048, 4096 1073741824 65536, 131072 512 268435456 65536, 131072 1024 536870912 65536, 131072 2048 1073741824 65536, 131072 4096 2147483648 AIX 4.1 is limited to NBPI values from 512 to 16384. In AIX 4.3, you can have NBPI values from 512 to 128K, with corresponding maximum file system sizes. | |
The volume group in which the file system resides defines a maximum logical volume size and also limits the file system size. Notes:
| |
The following attribute/value pairs are specific to the Enhanced Journaled
File System (JFS2):
| |
| |
| |
| |
| |
| |
Note: The agblksize and dense attributes are set at file system creation and cannot be changed after the file system is successfully created. The size attribute defines the minimum file system size, and you cannot decrease it once the file system is created. | |
-A | Specifies whether the file system is mounted at each system
restart:
|
-d Device | Specifies the device name of a device or logical volume on which to make the file system. This is used to create a file system on an already existing logical volume. |
-g VolumeGroup | Specifies an existing volume group on which to make the file system. A volume group is a collection of one or more physical volumes. |
-l LogPartitions | Specifies the size of the log logical volume, expressed as a number of logical partitions. This flag applies only to JFS and JFS2 file systems that do not already have a log device. |
-m MountPoint | Specifies the mount point, which is the directory where the file system
will be made available.
Note: If you specify a relative path name, it is converted to an absolute path name before being inserted into the /etc/filesystems file. |
-n NodeName | Specifies the remote host name where the file system resides. This flag is only valid with remote virtual file systems such as the Network File System (NFS). |
-p | Sets the permissions for the file system.
|
-t | Specifies whether the file system is to be processed by the accounting
subsystem:
|
-u MountGroup | Specifies the mount group. |
-v VfsType | Specifies the virtual file system type. |
Access Control: Only the root user can run this command.
To make a JFS on the
rootvg volume group with nondefault fragment size and nondefault
nbpi, enter:
crfs -v jfs -g
rootvg -m /test -a \
size=32768 -a frag=512 -a nbpi=1024
This command creates the /test file system on the rootvg volume group with a fragment size of 512 bytes, a number of bytes per i-node (nbpi) ratio of 1024, and an initial size of 16MB (512 * 32768).
/etc/filesystems | Lists the known file systems and defines their characteristics. |
The chfs command, mkfs command, mklv command.
The File Systems Overview for System Management in AIX 5L Version 5.1 System Management Concepts: Operating System and Devices explains file system types, management, structure, and maintenance.
For information on installing the Web-based System Manager, see Chapter 2: Installation and System Requirements in AIX 5L Version 5.1 Web-based System Manager Administration Guide.
The System Management Interface Tool (SMIT): Overview in AIX 5L Version 5.1 System Management Concepts: Operating System and Devices explains SMIT structure, main menus, and tasks.
Understanding Journaled File System Size Limitations in AIX 5L Version 5.1 System Management Concepts: Operating System and Devices.