[ Previous | Next | Table of Contents | Index | Library Home | Legal | Search ]

Network Installation Management Guide and Reference


Configuring the NIM Master and Creating Basic Installation Resources

Using this procedure, you can configure the NIM master, create the minimum basic installation resources required to install NIM client machines, and manage the resources for diskless and dataless clients.

Note: This procedure produces a large amount of output, especially when creating the SPOT resource. Be sure to scan through the output to look for nonfatal errors and warnings that may not be evident from a successful return code.

Prerequisites

The NIM master must have at least 750MB of available disk space. If such space is not available, see Using Client Machines as Resource Servers, Defining /usr versus non-/usr SPOTs , and Defining an lpp_source on CD-ROM versus Disk .

From Web-based System Manager

  1. Insert the AIX 5.1 Server Product media into the appropriate drive of the designated master machine.
  2. Start the Web-based System Manager Software application by entering wsm.
  3. In the navigation area, expand and select the NIM container, then follow the directions in the wizard.

From SMIT

  1. Insert the AIX 5.1 Server Product media into the appropriate drive of the designated master machine.
  2. To install the bos.sysmgt.nim fileset, enter the smit install_latest fast path.
  3. Using the LIST option, select /dev/cd0 or /dev/rmt0 for the INPUT device / directory for software.
  4. Specify bos.sysmgt.nim as the SOFTWARE to install.
  5. Accept the default values for all other fields on this screen. After successful completion of this installation, exit SMIT.
  6. To configure the NIM master, enter the smit nim_config_env fast path.
  7. Using the LIST option, select the Primary Network Interface for the NIM Master.
  8. Using the LIST option, select /dev/cd0 or /dev/rmt0 for the Input device for installation \ images field.
  9. If you will be supporting diskless and dataless clients, select yes at the Create Diskless/Dataless Machine Resources? field, and supply names for the resources to be created.
  10. Select yes at the Remove all newly added NIM definitions and file systems if any part of this operation fails? field. This will make it easier to restart this procedure if failures occur.
  11. Accept the default values for all other fields on this screen.

Notes:

From the Command Line

  1. Insert the AIX 5.1 Server Product CD or tape into the CD-ROM or tape drive of the designated master machine.
  2. If installing from a tape, skip to step 5. To create a mount point for the CD, enter:

    mkdir /cdfs
    
  3. To create a cdrom file system, enter:

    crfs -v cdrfs -p ro -d'cd0' -m'/cdfs'
    
  4. To mount the CD, enter:

    mount /cdfs
    
  5. To install the bos.sysmgt.nim fileset from the CD, enter:

    installp -agX -d /cdfs/usr/sys/inst.images bos.sysmgt.nim
    

    To install the bos.sysmgt.nim fileset from a tape, enter:

    installp -agX -d /dev/rmt0 bos.sysmgt.nim
    
  6. If installing from CD, to unmount the cdrom file system, enter:

    unmount /cdfs
    
  7. To configure the NIM master using the nimconfig command, enter:

    nimconfig -a attr1=value1 \
    -a attr2=value2 \
    ...
    

    For example, to configure a NIM master with the following configuration:

    master host name = master1
    primary network interface = tr0
    ring speed = 16
    platform = rspc
    kernel type = mp
    

    Enter the following command sequence:

    nimconfig -a netname=network1 -a pif_name=tr0 \
    -a ring_speed1=16 -a platform=rspc -a netboot_kernel=mp 
    

    Note:S ee the nimconfig command for additional attribute information.
  8. To create a file system in the rootvg volume group with 400MB of space with a mount point of /export/lpp_source, enter:

    crfs -v jfs -g rootvg -a size=$((2000*400)) \
    -m /export/lpp_source -A yes -p rw -t no \
    -a frag=4096 -a nbpi=4096 -a compress=no
    
  9. To mount the file system, enter:

    mount /export/lpp_source
    
  10. The lpp_source contains the installation images copied from the source device (in this example, the CD-ROM). The server of the lpp_source will be the NIM master. The images will be stored in the /export/lpp_source/lpp_source1 directory. To create the lpp_source resource named lpp_source1, enter:

    nim -o define -t lpp_source -a source=/dev/cd0 \
    -a server=master -a location=/export/lpp_source/lpp_source1 \
    lpp_source1
    
  11. To create a file system in the rootvg volume group with 200MB of space with a mount point of /export/spot, enter:

    crfs -v jfs -g rootvg -a size=$((2000*200)) \
    -m /export/spot -A yes -p rw -t no \
    -a frag=4096 -a nbpi=4096 -a compress=no
    
  12. To mount the file system, enter:

    mount /export/spot
    
  13. The SPOT resource will be installed from images in the image source (in this case, the lpp_source that was created in step 10). The server of the resource will be the NIM master, and the SPOT will be stored in the /export/spot/spot1 directory. To create the SPOT resource named spot1, enter:

    nim -o define -t spot -a source=lpp_source1 \
    -a server=master -a location=/export/spot spot1
    
  14. If you are not supporting diskless and dataless clients, you do not need to continue with this procedure. If you are supporting diskless and dataless clients, create and mount a file system for their resources.

    To create a file system in the rootvg volume group with 150MB of space and a mount point of /export/dd_resource, enter:

    crfs -v jfs -g rootvg -a size=$((2000*150)) \
    -m /export/dd_resource -A yes -p rw -t no \
    -a frag=4096 -a nbpi=4096 -a compress=no
    
  15. To mount the file system, enter:

    mount /export/dd_resource
    
  16. Create the diskless and dataless client resources in subdirectories of the /export/dd_resource directory. Not all resources are required. Create only the resources to be used in your environment.

    To create the root resource named root1 (required for diskless and dataless clients), enter:

    nim -o define -t root -a server=master \
    -a location=/export/dd_resource/root1 root1
    

    To create the dump resource named dump1 (required for diskless and dataless clients), enter:

    nim -o define -t dump -a server=master \
    -a location=/export/dd_resource/dump1 dump1
    

    To create the paging resource named paging1 (required for diskless clients), enter:

    nim -o define -t paging -a server=master \
    -a location=/export/dd_resource/paging1 paging1
    

    To create the home resource named home1 (optional), enter:

    nim -o define -t home -a server=master \
    -a location=/export/dd_resource/home1 home1
    

    To create the shared_home resource named shared_home1 (optional), enter:

    nim -o define -t shared-home -a server=master \
    -a location=/export/dd_resource/shared_home1 shared_home1
    

    To create the tmp resource named tmp1 (optional), enter:

    nim -o define -t tmp -a server=master \
    -a location=/export/dd_resource/tmp1 tmp1
    

Notes:


[ Previous | Next | Table of Contents | Index | Library Home | Legal | Search ]