[ Previous | Next | Contents | Glossary | Home | Search ]
AIX Version 4.3 Commands Reference, Volume 1

bosboot Command

Purpose

Creates boot image.

Syntax

For General Use:

bosboot -Action-d Device ] [ -Options ... ]

To Create a Device Boot Image:

bosboot -a-d Device ] [ -p Proto ] [ -k Kernel ] [ -U ] [ -I -D ] [ -l LVdev ] [-L] [ -M Norm Serv Both } ] [ -O Number ] [ -T Type  ] -b FileName ] [ -q ]

To Copy a Device Boot Image:

bosboot -w FileName-d Device ] [ -q ]

To Create a ROS Emulation Boot Image:

bosboot -r FileName-d Device ] [ -l LVdev ] [ -M Norm Serv Both } ] [ -q ]

Description

The bosboot command creates the boot image that interfaces with the machine boot ROS (Read-Only Storage) EPROM (Eraseable Programmable Read-Only Memory).

The bosboot command creates a boot file (boot image) from a RAM (Random Access Memory) disk file system and a kernel. This boot image is transferred to a particular media that the ROS boot code recognizes. When the machine is powered on or rebooted, the ROS boot code loads the boot image from the media into memory. ROS then transfers control to the loaded image's kernel.

The associated RAM disk file system contains device configuration routines that make the machine's devices and file systems available. The RAM disk file system contains differing configuration files depending upon the boot device. A mkfs prototype file is supplied for each type of device. (See note 6 below.) Currently supported devices are:

A network device may be a token ring, Ethernet, or Fiber-Distributed Data Interface (FDDI) used to boot from a network boot server over a local area network (LAN).

The boot image varies for each type of device booted and is compressed by default to fit on certain media and to lessen real memory requirements. The boot image can be left uncompressed by specifying the -U flag. The logical volume must be large enough for the uncompressed boot image.

In addition to creating a boot image, the bosboot command always saves device configuration data for disk. It does not update the list of boot devices in the NVRAM (nonvolatile random access memory). You can modify the list with the bootlist command.

The bosboot command is normally called during the Base Operating System installation and by the updatep command when the operating system is upgraded.

Notes:
  1. You must have root user authority to use the bosboot command.
  2. Do not reboot the machine if the bosboot command is unsuccessful with a message not to do so while creating a boot disk. The problem should be resolved and the bosboot command run to successful completion.
  3. The bosboot command requires some space in the /tmp file system and the file system where the target image is to reside, if there is such an image.
  4. The bosboot command requires that the specified physical disk contain the boot logical volume. To determine which disk device to specify, issue the following command:
    lsvg -M rootvg
    This command displays a map of all logical volumes. The default boot logical volume is hd5. Use the disk device that contains the boot logical volume.
  5. When the device is not specified with the -d flag, the bosboot command assumes the default device is the disk the system is booted from. However, if the prototype file is specified with a -p flag, the device must also be specified with a -d flag.
  6. The prototype file used by the bosboot command to build the RAM disk file system depends on the boot device and the hardware platform (sys0) type of the machine the boot image will run on.

    The hardware platform type is an abstraction which allows machines to be grouped according to fundamental configuration characteristics such as number of processors and/or I/O bus structure. Machines with different hardware platform types will have basic differences in the way their devices are dynamically configured at boot time. The hardware platform type rs6k applies to all Micro Channel-based uni-processor models. The type rs6ksmp applies to all Micro Channel-based symmetric multi-processor models. The type rspc applies to all ISA-bus models. As new models are developed, their hardware platform types will either be one of the aforementioned types or, if fundamental configuration differences exist, new types will be defined. Boot images for a given boot device type will generally be different for machines with different hardware platform types.

    The prototype file used by bosboot is constructed by starting with a copy of the base prototype file for the platform type and boot device (e.g. /usr/lib/boot/rs6k.disk.proto). Next the bosboot command looks at the pcfg file for the platform type being used (e.g /usr/lib/boot/rs6k.pcfg). The pcfg file contains entries which bosboot uses in a template to search for proto extension files. These files, located in the directory /usr/lib/boot/protoext, provide extensions to the prototype file under construction. As an example, if the platform type is rs6k and the boot device is disk, and the file /usr/lib/boot/protoext/rs6k.pcfg contains the following:

    mca.

    scsi.

    .

    .

    .

    The bosboot command will start with the base prototype file /usr/lib/boot/rs6k.disk.proto and search the directory /usr/lib/boot/protoext for any files that match the template disk.proto.ext.mca.*. The contents of these files are added to the prototype file under construction. Next, the contents of files matching the template /usr/lib/boot/protoext/disk.proto.ext.scsi.* are added to the prototype file under construction. This continues until all lines in the pcfg file have been processed. At this point the prototype file under construction is complete. The bosboot command passes this prototype file to the mkfs command which builds the RAM disk file system.

  7. In AIX Version 3.2.5, the prototype files used by the BOSBOOT command to build boot images were dependent on the boot device. This is still true in AIX Version 4.1.3, but in addition, the prototype files are dependent on the system device type (sys0) of the machine for which the boot image is built.

    This is reflected in the names of the prototype files:

    /usr/lib/boot/rs6k.disk.proto

    /usr/lib/boot/rs6ksmp.disk.proto

    /usr/lib/boot/rs6k.tape.proto

    /usr/lib/boot/rs6ksmp.tape.proto

    /usr/lib/boot/rs6k.cd.proto

    /usr/lib/boot/rs6ksmp.cd.proto

    /usr/lib/boot/network/rs6k.tok.proto

    /usr/lib/boot/network/rs6ksmp.tok.proto

    /usr/lib/boot/network/rs6k.ent.proto

    /usr/lib/boot/network/rs6ksmp.ent.proto

    /usr/lib/boot/network/rs6k.fddi.proto

    /usr/lib/boot/rspc.disk.proto

    /usr/lib/boot/rspc.cd.proto

    /usr/lib/boot/network/rspc.tok.proto

    /usr/lib/boot/network/rspc.ent.proto

    The system device type is an abstraction that allows machines to be grouped according to fundamental configuration characteristics, such as number of processors and I/O bus structure. The system device is the highest-level device in the system node, which consists of all physical devices in the system.

    Machines with different system device types have basic differences in the way their devices are dynamically configured at boot time. The system device type RS6K applies to all of the RS/6000(*) models supported by AIX versions prior to 4.1. The type RS6KSMP applies to symmetric multiprocessor models.

    The bosboot command, by default, uses the prototype file that matches the system device type of the machine executing the command. The -T option allows you to specify the system device type of the prototype file. To determine the system device type of a machine, enter:

    bootinfo -T
    Note: The bootinfo command does not apply to AIX Version 4.2 or later.

Flags

-d device Specifies the boot device. This flag is optional for hard disk.

The following flags are action flags. One and only one flag must be specified.

-a Creates complete boot image and device.
-r FileName Creates a ROS emulation boot image. A ROS emulation boot image is created from a file containing the ROS emulation code. This image is used to provide network boot capability to machines whose ROS does not provide it. A ROS emulation boot image is transferred to a diskette, tape, or boot logical volume. ROS will load the image from the media into memory, whereupon ROS will transfer control to the ROS emulation code. This code emulates the later version ROS code that supports network boot.
-w FileName Copies the specified device boot image to device.

The following flags are option flags:

-D Loads the low level debugger. This flag is optional.
-I (upper case i) Loads and invokes the low-level debugger. This flag is optional.
-k Allows to specify an alternate kernel file. If this flag is not specified, /unix is the default.
-L Enables lock instrumentation for MP systems. This flag has no effect on systems that are not using the MP kernel.
-M Norm|Serv|Both Specifies the boot mode. The options are:
norm
Indicates normal mode.
serv
Indicates service mode.
both
Indicates both modes.
-O Number Uses specified number as the offset (in 512-byte blocks) for CD-ROM boot image from the beginning of the CD-ROM device. This flag is optional.
-T Type Specifies the hardware platform type (see note 6). This causes the bosboot command to create a boot image for the hardware platform type specified. If the type is not specified, the bosboot command creates a boot image whose hardware platform type matches that of the currently running machine. This flag is optional.
-U Creates an uncompressed boot image. This flag is optional.
-b FileName Uses specified file name as the boot image name. This flag is optional.
-k Kernel Uses the specified kernel file for the boot image. This flag is optional.
-l (lower case L) LVDev Uses target boot logical volume for boot image. This flag is optional.
-q Determines how much disk space is required in which file system to create the boot image. Boot image is not created. This flag is optional.
-p Proto Uses the specified prototype file for the RAM disk file system. This flag is optional.

Security

Access Control: Only the root user can read and execute this command.

Examples

  1. To create a boot image on the default boot logical volume on the fixed disk from which the system is booted, enter:
    bosboot -a
  2. To create a bootable image called /tmp/tape.bootimage for a tape device, enter:
    bosboot -ad /dev/rmt0 -b /tmp/tape.bootimage
  3. To copy a given tape boot image to a tape device, enter:
    bosboot -w /tmp/tape.bootimage -d rmt0
  4. To create a boot image file for an Ethernet boot, enter:
    bosboot -ad /dev/ent0 -M both
  5. To create an uncompressed boot image for a hard disk /dev/hdisk1, enter:
    bosboot -ad /dev/hdisk1 -U
  6. To create a token ring boot image for a machine whose hardware platform type is rspc while you are running on a machine whose hardware platform type is rs6k, enter:
    bosboot -ad /dev/tok -T rspc

Files

/usr/sbin/mkboot Specifies boot creation routine.
/usr/lib/boot/rs6k.disk.proto
/usr/lib/boot/rs6ksmp.disk.proto
/usr/lib/boot/rspc.disk.proto Specifies disk RAM file system template.
/usr/lib/boot/rs6k.tape.proto
/usr/lib/boot/rs6ksmp.tape.proto Specifies tape RAM file system template.
/usr/lib/boot/rs6k.cd.proto
/usr/lib/boot/rs6ksmp.cd.proto
/usr/lib/boot/rspc.cd.proto Specifies CD-ROM RAM file system template.
/usr/lib/boot/network/rs6k.tok.proto
/usr/lib/boot/network/rs6ksmp.tok.proto
/usr/lib/boot/network/rspc.tok.proto Specifies token-ring RAM file system template
/usr/lib/boot/network/rs6k.ent.proto
/usr/lib/boot/network/rs6ksmp.ent.proto
/usr/lib/boot/network/rspc.ent.proto Specifies Ethernet RAM file system template.
/usr/lib/boot/network/rs6k.fddi.proto Specifies FDDI RAM file system template.

Related Information

The bootlist command, mkboot command, and lockstat command.

Understanding the Boot Process in AIX Version 4.3 System Management Guide: Operating System and Devices.


[ Previous | Next | Contents | Glossary | Home | Search ]