[ Previous | Next | Contents | Glossary | Home | Search ]
AIX Version 4.3 Network Installation Management Guide and Reference

NIM Operations

A large number of operations can be performed to manage a NIM environment and perform software installation and maintenance. The Web-based System Manager and SMIT interfaces are designed to hide much of the detail required for the command line interface. Therefore, this section only documents the operations for the command line. All of this information applies to the other interfaces as well, but discussion of those interfaces is deferred to the online contextual help available for those applications.

Most NIM operations are performed by running the nim command with various attributes for each possible operation. The command line syntax is as follows:

nim -o OperationName -a Attribute=Value ... TargetName

The following sections describe the NIM operations you can perform.

define

Creates objects in the NIM environment. Networks, machines, and resources can be created using the define operation.

The command line syntax for the define operation is as follows:

nim -o define -t ObjectType -a Attribute=Value ... \
ObjectName

The attributes for the define operation vary for the different object types. For a complete description of the attributes required to define the various NIM objects, see "NIM Networks", "NIM Machines", "NIM Resources", and "NIM Groups".

change

The change operation is used to modify attributes of NIM objects. The command line syntax is as follows:

nim -F -o change -a Attribute=Value ... TargetName
-F (optional) Tells NIM to force the operation if the target is currently in use.

The target of a change operation can be any network, machine, resource, or group in the NIM environment. Not all attributes can be modified on targets. Usually, the attributes are changed automatically as parts of other operations, so there is little need for you to use the change operation explicitly.

remove

The remove operation is used to remove objects from the NIM environment. The command line syntax is as follows:

nim -o remove ObjectName

The remove operation does not take any attributes. The target of this operation can be any network, machine, resource, or group in the NIM environment.

bos_inst

The bos_inst operation is used to install the AIX Base Operating System on standalone clients.

The command line syntax for the bos_inst operation is as follows:

nim -o bos_inst -a source=Value -a Attribute=Value ... TargetName

The target of a bos_inst operation can be a standalone NIM client or a group of standalone NIM clients.

The following are required attributes that can be specified for the bos_inst operation to install and customize a machine:

-a lpp_source=Value Identifies the lpp_source resource to be used. The lpp_source specified must have the simages attribute. The lpp_source provides software for machine customization. It also provides the BOS image for installation if the source attribute is rte.
-a source=Value Identifies the source for BOS run-time files. Valid values are:
rte Installs from a BOS image in the lpp_source.
spot Copies BOS run-time files from the SPOT.
mksysb Installs the machine from a mksysb image.
-a spot=Value Identifies the SPOT resource to be used. The SPOT provides support for network boot and operations in the boot environment. It also provides the BOS run-time files if the source attribute is spot.

The following are optional attributes that can be specified for the bos_inst operation:

-a async=Value Specifies whether NIM should perform operations on group members asynchronously and not wait for the operation to complete on one member before beginning the operation on the next. The default value is async=yes.
-a auto_expand=Value Indicates whether or not to expand file systems when setting up a client for a force_push installation. The default value is auto_expand=yes.
-a boot_client=Value Indicates whether or not NIM should attempt to reboot the client immediately for BOS installation. The boot_client attribute is the converse of the no_client_boot attribute. The default value is boot_client=yes, indicating that NIM should attempt to reboot the client.
-a bosinst_data=Value Specifies the bosinst_data resource to use for non-prompted installation.
-a filesets=Value Specifies a list of filesets to install on the target after BOS installation.
-a force_push=Value Indicates whether or not a force_push installation should occur. A force_push should be used for installing machines that are running, but are not configured with the NIM client fileset. For example, to migrate a machine from AIX Version 3.2.5 to AIX Version 4.3.0, the machine must be installed with force_push=yes, because the NIM client fileset cannot be installed and configured on an AIX Version 3.2 machine. If force_push=yes is specified, a bosinst_data resource must also be used. The bootlist on the client system is set automatically to boot over the network on the next reboot. The default value is force_push=no. See the "force_push Attribute" for more information.
-a group=Value Specifies the name of a resource group to use for installation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes. If a resource group is specified, and it contains a SPOT and lpp_source, the spot and lpp_source attributes are no longer required.
-a image_data=Value Specifies an image_data resource to describe how physical and logical data is organized on the client.
-a installp_bundle=Value Specifies an installp_bundle resource that lists filesets to install on the target after BOS installation.
-a installp_flags=Value Tells installp how to apply the filesets specified by the filesets or installp_bundle attributes. The default value is installp_flags=-agQX.
-a mksysb=Value Provides the run-time files for BOS and other filesets if the source attribute is mksysb. The level of BOS run-time files in the mksysb must be equal to the level of the SPOT used for the installation.
-a no_client_boot=Value Indicates whether or not NIM should attempt to reboot the client immediately for BOS installation. The no_client_boot attribute is the converse of the boot_client attribute. The default value is no_client_boot=no, indicating that NIM should attempt to reboot the client.
-a no_nim_client=Value Indicates whether the target should remain in the NIM environment after installation completes. The default value is no, indicating that the target system should remain in the NIM environment.
-a preserve_res=Value Indicates whether or not resources in non-rootvg file systems should be preserved on the client system being installed. The default value is preserve_res=no.
-a resolv_conf=Value Specifies the resolv_conf resource to use for configuring domain and name resolution on a client.
-a script=Value Specifies the script resource to be run on the target system after all software has been installed.
-a set_bootlist=Value Indicates whether or not NIM should set the bootlist of the client so that the client boots over the network on the next reboot. Usually, set_bootlist would be yes if the client is not going to be rebooted immediately for installation (no_client_boot=yes or boot_client=no). The default value is set_bootlist=no.
-a show_progress=Value Indicates whether status should be displayed for each group member when the installation target is a group of machines. The default value is show_progress=yes.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

When a bos_inst operation is performed on a client, several things occur.

On the SPOT server:

  1. A link is created in /tftpboot to a boot image matching the platform type, kernel type, and network adapter of the client.
  2. The /etc/bootptab file is updated with client information to allow the boot image to be used.
  3. A ClientName.info file is created in /tftpboot to provide client-specific installation and configuration information in the boot environment.
  4. The /etc/tftpaccess.ctl file is modified, if necessary, to allow access to the /tftpboot directory.

On the target system:

  1. The bootlist is modified so the network adapter is the default boot device for normal mode boot, unless no_client_boot=yes, set_bootlist=no, and force_push=no are specified.
  2. The client is rebooted to begin the installation, unless no_client_boot=yes, boot_client=no, and force_push=no are specified.

When the client boots over the network adapter, it obtains the boot image from the SPOT server. The boot image configures devices and sets up the machine for the BOS install. The Client.info file is transferred to the client machine; and based on its contents, the network adapter is configured, routes are added, and NIM resources are mounted in the boot environment. Processing control is then passed to the BOS install program.

NIM BOS Installation Details

The BOS installation program requires access to an image that contains the BOS run-time files. This image is used by the BOS installation program to populate the target's /usr file system. In the NIM environment, this image can come from one of the three following resources:

Because a spot and lpp_source are always required to support the bos_inst operation, there are always at least two different kinds of BOS images available to the target. You can optionally create a mksysb image for your target machine. However, only one source can be used for BOS installation.

To indicate which BOS image to use, you need to specify the source attribute when performing the bos_inst operation. The source attribute may have one of the following values:

After the installation is initiated from the master, the NIM master attempts to contact the target and execute a script that will force the system to reboot. The target system issues a BOOTP request to the server after it has shut down. The bos_inst operation is considered complete even if the target does not immediately issue a BOOTP request. The target must issue a BOOTP request to load a network boot image from the server to start the installation.

If the master is unable to contact the target system for any reason (for example, the system is turned off, it is not a running NIM client, or there is a network problem), a warning message is displayed and user intervention is then required at the target to issue the BOOTP request using the IPL ROM. See "Booting a Machine Over the Network."

By default (no_nim_client=no ), NIM also includes the customization required for the target to remain a NIM client after the install. This customization includes the installation and configuration of the bos.sysmgt.nim.client fileset and its requisite filesets, bos.net.tcp.client and bos.net.nfs.client, so that the NIM master can communicate with and control the client after installation. The installp_flags are passed to the installp command for installing the software on the standalone client. The filesets attribute can be used to install a list of additional filesets or software packages from the allocated lpp_source.

To display BOS installation status information while the installation is progressing, enter the following command on the master:

lsnim -a info -a Cstate ClientName

or

lsnim -l ClientName

Errors in the allocation of a nim_script or boot resource type are fatal errors because the network BOS installation process cannot proceed without them. On the other hand, any error encountered during the attempt to cause the target to issue a BOOTP request is a nonfatal error to NIM because-at that point-NIM has successfully initialized the environment to perform a network installation. As soon as the target has successfully loaded its allocated network boot image, the BOS installation process begins.

force_push Attribute

When assigned a value of yes, the force_push attribute tells NIM that the target of the bos_inst operation does not necessarily have the bos.sysmgt.nim.client fileset installed and configured. For example, a machine running AIX Version 3.2 would not have the NIM software installed. NIM will attempt to NFS mount or copy the minimal client support to the target system to perform an unattended installation or migration of the base operating system. If client support is copied to the target machine, NIM will automatically expand the necessary file systems on the target unless the auto_expand attribute to bos_inst is set to no. The force_push attribute requires that the client grant root rsh permissions to the master and that the key on the client be in the normal position. The force_push attribute also requires that a bosinst_data file be allocated to the target machine to indicate that a no-prompt installation should occur. This function will not set up and migrate a machine from AIX version 3.1 to AIX version 4 and is not capable of providing unattended installation of hardware systems that do not support modification of the boot device list using the bootlist command. The force_push attribute is set to yes by setting the Force Unattended Installation Enablement? option to yes when using SMIT to perform the bos_inst operation.

boot_client Attribute

When assigned a value of no, the boot_client attribute is used to instruct NIM not to attempt to initiate the BOS installation on the target machine after setting up the installation with the bos_inst operation. This allows a BOS installation to be set up while deferring the actual installation until the client is rebooted at a later time. Also, if the client is not a running machine, this attribute will avoid waiting for the reboot attempt to time-out or fail. If the installation of the client system is going to be initiated later from the server, the normal mode boot device list on the client must be set so that a network boot is attempted when the client is rebooted. No attempt is made to modify the boot list when boot_client is set to no unless the force_push or set_bootlist attributes are specified and set to a value of yes. The boot_client attribute is set to no by setting Initiate Boot Operation on Client to no when using SMIT to perform the bos_inst operation.

set_bootlist Attribute

The set_bootlist attribute can be used with the boot_client attribute to modify the boot device list on the client for normal mode so a network boot is attempted when the client is rebooted. It is not necessary to specify the set_bootlist attribute if the force_push attribute is set to yes or if boot_client is unspecified or set to yes. In both instances, the boot list will be modified as the default. The only valid values for set_bootlist are yes and no. In order to use the set_bootlist attribute on bos_inst operations, the bos.sysmgt.nim.client fileset must be installed at Version 4.1.3.0 or later on target clients. The set_bootlist attribute is set to yes by setting Set Boot List if Boot not Initiated on Client? when using SMIT to perform the bos_inst operation.

preserve_res Attribute

The preserve_res attribute can be used to preserve the NIM database definitions for resources residing on a NIM client that is being reinstalled. When set to yes, any resources that reside in file systems which are being preserved by the BOS installation process will also be preserved.

cust

The cust operation is used to install software filesets and updates on standalone clients and SPOT resources.

See "Customizing NIM Clients and SPOT Resources" for information on performing a software customization of standalone NIM clients.

The command line syntax for the cust operation is as follows:

nim -o cust -a Attribute=Value ... TargetName

The target of a cust operation can be a standalone NIM client, a group of standalone NIM clients, or a SPOT resource

The following are required attributes that can be specified for the cust operation:

-a filesets=Value Specifies a list of filesets to install on the target. This attribute is required unless an installp_bundle is used for the operation.
-a installp_bundle=Value Specifies an installp_bundle resource that lists filesets to install on the target. This attribute is required unless the filesets attribute is specified.
-a lpp_source=Value Identifies the lpp_source resource that will provide the installation images for the cust operation.

The following are optional attributes that can be specified for the cust operation:

-a async=Value Specifies whether NIM should perform operations on group members asynchronously and not wait for the operation to complete on one member before beginning the operation on the next. The default value is async=yes.
-a fix_bundle=Value Contains a list of fixes to install on the target. Fixes should be listed in the fix_bundle resource by APAR number with one number per line.
-a fixes=Value Identifies a list of fixes to install on the target. Fixes should be listed by APAR number. For example, fixes="IX12345 IX54321 ".
-a group=Value Specifies the name of a resource group to use for the installation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes. If a resource group is specified, and it contains an lpp_source, the lpp_source attribute is no longer required.
-a installp_flags=Value Identifies the flags that tell installp how to apply the filesets specified by the filesets, installp_bundle, fixes, and fix_bundle attributes. The default value is installp_flags=agQX.
-a script=Value Specifies a script resource to be run on the target system after all software has been installed.
-a show_progress=Value Indicates whether status should be displayed as software is installed. The default value is show_progress=yes.
-a resolv_conf=Value Specifies a resolv_conf resource for configuring domain and name resolution on a client.

maint

The maint operation is used to deinstall software filesets and commit and reject updates on standalone clients and SPOT resources.

The command line syntax for the maint operation is as follows:

nim -o maint -a Attribute=Value ... TargetName

The target of a maint operation can be a standalone NIM client, a group of standalone NIM clients, or a SPOT resource

The following are required attributes that can be specified for the maint operation:

-a installp_flags=Value Identifies the flags that tell installp what to do with the installed software.

The following are optional attributes that can be specified for the maint operation:

-a async=Value Specifies whether NIM should perform operations on group members asynchronously and not wait for the operation to complete on one member before beginning the operation on the next. The default value is async=yes.
-a filesets=Value Specifies a list of filesets to be maintained on the target.
-a group=Value Specifies the name of a resource group to use for the operation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes.
-a installp_bundle=Value Specifies an installp_bundle resource that contains a list of filesets to be maintained on the target.
-a show_progress=Value Indicates whether status should be displayed as maintenance is performed. The default value is show_progress=yes.

check

The check operation is used to verify the usability of a machine or resource in the NIM environment.

The command line syntax for the check operation is as follows:

nim -F -o check -a debug=Value TargetName

The target of a check operation can be any NIM client, a group of NIM clients, a SPOT resource, or an lpp_source resource.

The following list includes all the flags and attributes that can be specified for the check operation:

-F (optional) Tells NIM to "force" the operation if the target is currently in use. If the -F flag is specified when the target is a SPOT resource, it will force the SPOT's network boot images to be rebuilt. The -F flag is typically not required when performing the check operation on client machines.
-a debug=Value (optional) Builds a SPOT's network boot images in debug mode if debug=yes is specified. This attribute is only valid if the target is a SPOT resource. The default value is debug=no. See "Producing Debug Output from a Network Boot Image" for more information on this attribute.

When applied to NIM clients, the check operation updates the machine state (Mstate) of the client. A ping test is performed to check whether or not the client is reachable. After the check operation is performed, the client's Mstate is set to either running or not running.

When applied to SPOT resources, the check operation performs root synchronization for diskless and dataless clients and rebuilds the SPOT's network boot images, if necessary.

When applied to lpp_source resources, the check operation updates the table of contents (.toc) file in the lpp_source directory. It also determines whether or not all filesets are included in the resources to qualify the lpp_source for the simages attribute.

reset

The reset operation is used to change the state of a NIM client or resource, so NIM operations can be performed with it. A reset may be required on a machine or resource if an operation was stopped before it completed successfully.

The command line syntax for the reset operation is as follows:

nim -F -o reset TargetName

The target of a reset operation can be any NIM client, a group of NIM clients, or a SPOT resource.

The following list includes all the flags and attributes that can be specified for the reset operation:

-F (optional) Tells NIM to "force" the operation if the target is currently in use.

When applied to NIM clients, the reset operation updates the control state (Cstate) of the client. After the reset operation is performed, the client's Cstate is set to ready, and it is possible to perform NIM operations on the client. Although the Cstate of the client is reset by the operation, resources are not deallocated automatically. See the deallocate operation for information on deallocating resources.

When applied to SPOT resources, the reset operation updates the resource state (Rstate) of the SPOT. After the reset operation is performed, the SPOT's Rstate is set to ready, and you can use the SPOT in NIM operations.

lppchk

The lppchk operation is used to verify that software was installed successfully by running the lppchk command on a NIM client or SPOT resource.

The command line syntax for the lppchk operation is as follows:

nim -o lppchk -a Attribute=Value ... TargetName

The target of a lppchk operation can be any standalone NIM client, a group of standalone NIM clients, or a SPOT resource.

The following are optional attributes that can be specified for the lppchk operation:

-a async=Value Specifies whether NIM should perform operations on group members asynchronously and not wait for the operation to complete on one member before beginning the operation on the next. The default value is async=yes.
-a filesets=Value Specifies a list of filesets on the target on which the lppchk operation will be performed.
-a lppchk_flags=Value Tells the lppchk command how to perform software verification.
-a show_progress=Value Indicates whether status should be displayed as the operation is performed. The default value is show_progress=yes.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.
Note: There are no required attributes for the lppchk operation.

showlog

The showlog operation is used to list software installed on a NIM client or SPOT resource.

The command line syntax for the showlog operation is as follows:

nim -o showlog -a Attribute=Value ... TargetName

The target of a showlog operation can be any standalone NIM client, a group of standalone NIM clients, or a SPOT resource.

The following are optional attributes that can be specified for the lppchk operation:

-a full_log=Value Indicates whether the entire log is displayed or only the last entry. The default value is full_log=no.
-a log_type=Value Specifies the type of log to display. The log types supported for both standalone clients and SPOT resources are:
boot Machine's boot log
bosinst Output from the BOS installation program
devinst Output from the installation of key system and device-driver software
lppchk Log of the output from the lppchk operation executed on a standalone NIM client
nimerr Errors encountered during execution of the nim command
niminst Output from the installation of user-specified software (including installation of NIM client software during a bos_inst operation)
script Output from any configuration script resources allocated for a bos_inst operation.
-a show_progress=Value Indicates whether status should be displayed as the operation is performed. The default value is show_progress=yes.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.
Note: There are no required attributes for the showlog operation.

maint_boot

The maint_boot operation is used to prepare resources for a client to be network-booted into maintenance mode.

The command line syntax for the maint_boot operation is as follows:

nim -o maint_boot -a Attribute=Value ... TargetName

The target of a maint_boot operation can be any standalone NIM client or group of standalone NIM clients.

The following are required attributes that can be specified for the maint_boot operation:

-a spot=Value Specifies the SPOT resource to be used to provide network boot and maintenance mode support.

The following are optional attributes that can be specified for the maint_boot operation:

-a group=Value Specifies the name of a resource group to use for the operation.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

After the maint_boot operation is performed, the client must be rebooted over the network to load the network boot image and enter maintenance mode.

diag

The diag operation is used to prepare resources for a client to be network-booted into diagnostics mode.

The command line syntax for the diag operation is as follows:

nim -o diag -a Attribute=Value ... TargetName

The target of a diag operation can be any standalone NIM client or group of standalone NIM clients.

The following are required attributes that can be specified for the diag operation:

-a spot=Value Specifies the SPOT resource to be used to provide network boot and diagnostics support.

The following are optional attributes that can be specified for the diag operation:

-a group=Value Specifies the name of a resource group to use for the operation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

dkls_init

The dkls_init operation is used to prepare resources for use by a diskless client.

The command line syntax for the dkls_init operation is as follows:

nim -o dkls_init -a Attribute=Value ... TargetName

The target of a dkls_init operation can be any diskless NIM client or group of diskless NIM clients.

The following are required attributes that can be specified for the dkls_init operation:

-a dump=Value Specifies the dump resource that contains client dump files.
-a paging=Value Specifies the paging resource that contains client paging files.
-a root=Value Specifies the root resource that contains the client root (/) directories. The root resource must be served by the same machine that serves the SPOT.
-a spot=Value Specifies the SPOT resource to be used to provide network boot support and the /usr file system for clients.

The following are optional attributes that can be specified for the dkls_init operation:

-a group=Value Specifies the name of a resource group to use for the installation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes.
-a home=Value Specifies the home resource that contains client /home directories.
-a resolv_conf=Value Specifies the resolv_conf resource to configure Domain Name Protocol name server information on the client.
-a shared_home=Value Specifies the shared_home resource that contains a common /home directory for multiple clients.
-a size=Value Specifies the size in megabytes for client paging files.
-a tmp=Value Specifies the tmp resource that contains client /tmp directories.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

The dkls_init operation populates client directories and creates client paging and dump files. A network boot image is also allocated to the client. When the client boots over the network, it obtains the boot image and is configured to mount the remaining resources.

dtls_init

The dtls_init operation is used to prepare resources for use by a dataless client.

The command line syntax for the dtls_init operation is as follows:

nim -o dtls_init -a Attribute=Value ... TargetName

The target of a dtls_init operation can be any dataless NIM client or group of dataless NIM clients.

The following are required attributes that can be specified for the dtls_init operation:

-a dump=Value Specifies the dump resource that contains client dump files.
-a spot=Value Specifies the SPOT resource to be used to provide network boot support and the /usr file system for clients.
-a root=Value Specifies the root resource that contains the client root (/) directories. The root resource must be served by the same machine that serves the SPOT.

The following are optional attributes that can be specified for the dtls_init operation:

-a paging=Value Specifies the paging resource containing client paging files.
-a group=Value Specifies the name of a resource group to use for the installation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes.
-a home=Value Specifies the home resource that contains client /home directories.
-a resolv_conf=Value Specifies the resolv_conf resource to configure Domain Name Protocol name server information on the client.
-a shared_home=Value Specifies the shared_home resource that contains a common /home directory for multiple clients.
-a size=Value Specifies the size in megabytes for client paging files.
-a tmp=Value Specifies the tmp resource that contains client /tmp directories.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

The dtls_init operation populates client directories and creates client paging and dump files. A network boot image is also allocated to the client. When the client boots over the network, it obtains the boot image and is configured to mount the remaining resources.

sync_roots

The sync_roots operation is used to verify that diskless and dataless clients have the correct root files for the SPOT resource they use.

The command line syntax for the sync_roots operation is as follows:

nim -F -o sync_roots -a num_parallel_syncs=Value TargetName

The target of a sync_roots operation must be a SPOT resource.

The following list includes all the flags and attributes that can be specified for the sync_roots operation:

-a num_parallel_syncs=Value Specifies the number of client root directories to simultaneously synchronize with the SPOT's root files. Valid values are numeric. The default value is num_parallel_syncs=5. This attribute is optional.
-F Specifies that NIM should force the operation. This flag is optional.

A sync_roots operation can be performed automatically when the check operation is performed on a SPOT.

fix_query

The fix_query operation is used to display whether specified fixes are installed on a client machine or a SPOT resource.

The command line syntax for the fix_query operation is as follows:

nim -o fix_query -a Attribute=Value ... TargetName

The target of a fix_query operation can be any standalone NIM client, group of standalone NIM clients, or SPOT resource.

The following are optional attributes that can be specified for the fix_query operation:

-a fix_bundle=Value Specifies a fix_bundle resource containing a list of fix keywords. This attribute is required unless the fixes attribute is specified for the operation.
-a fixes=Value Specifies a list of keywords for the fix_query operation. Fix keywords are APAR numbers used to identify software updates that can span multiple filesets. This attribute is required unless a fix_bundle is used for the operation.
-a group=Value Specifies the name of a resource group to use for the operation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes.
-a fix_query_flags=Value Tells the fix_query operation how to display information. Valid flags are those used by the instfix command.
-a show_progress=Value Indicates whether status should be displayed as the operation is performed. The default value is show_progress=yes.
Note: There are no required attributes for the fix_query operation.

reboot

The reboot operation is used to reboot a NIM client machine.

The command line syntax for the reboot operation is as follows:

nim -o reboot -a Attribute=Value ... TargetName

The target of a reboot operation can be any standalone NIM client or group of standalone NIM clients.

The following are optional attributes that can be specified for the reboot operation:

-a inst_warning=Value Indicates whether or not a warning should be displayed to warn users that the machine will be rebooted. The default value is inst_warning=yes.
Note: There are no required attributes for the reboot operation.

select

The select operation is used to include and exclude group members from operations performed on the group.

The command line syntax for the select operation is as follows:

nim -o select -a Attribute=Value ... TargetName

The target of a select operation must be a group of NIM clients.

The following are optional attributes that can be specified for the select operation:

-a exclude=Value Specifies the name of the group member to exclude from operations on the group.
-a exclude_all=Value Indicates that all members of the group should be excluded from operations on the group. Valid values are yes and no.
-a include=Value Specifies the name of the group member to include in operations on the group.
-a include_all=Value Indicates that all members of the group should be included in operations on the group. Valid values are yes and no.
-a verbose=Value Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

To display the group members that are included and excluded from operations, use the lsnim -g GroupName command syntax.

allocate

The allocate operation is used to make resources available to NIM clients for subsequent operations. In AIX Version 4.2 and later, it is generally unnecessary to perform explicit allocations prior to NIM operations, because the operations accept resource names as attributes to the command.

The command line syntax for the allocate operation is as follows:

nim -o allocate -a ResourceType=ResourceName ... TargetName

The target of an allocate operation may be a NIM client or group of NIM clients.

The following attribute can be specified for the allocate operation:

-a ResourceType=ResourceName (required) Specifies the resource to allocate to the client, for example, lpp_source=42_images .

When a resource is allocated to a client, an entry is added to the /etc/exports file on the resource server to NFS export the resource to the client. The allocation count for the resource is also incremented. When the allocation count is greater than 0, the resource cannot be modified. During NIM operations, a client mounts and uses the resources that have been allocated to it.

deallocate

The deallocate operation is used to unlock and unexport resources when they are no longer needed by NIM clients. It is generally unnecessary to perform explicit deallocations after NIM operations, because upon successful completion, operations will automatically deallocate resources from the clients.

The command line syntax for the deallocate operation is as follows:

nim -o deallocate -a ResourceType=ResourceName ... -a
subclass=all TargetName

The target of a deallocate operation may be a NIM client or group of NIM clients.

The following list includes all the attributes that can be specified for the deallocate operation:

-a ResourceType=ResourceName Specifies the resource to deallocate from the client, for example, lpp_source=42_images . This attribute is required.
-a subclass=all Specifies that all resources should be deallocated from the target. This attribute is optional.

When a resource is deallocated from a client, the /etc/exports file on the resource server is modified to unexport the resource from the client. The allocation count for the resource is also decremented.

showres

The showres operation is used to display the contents of a resource. The contents displayed will be appropriate for the type of resource on which the operation is run.

The command line syntax for the showres operation is as follows:

nim -o showres -a Attribute=Value ... TargetName

The target of a showres operation may be a SPOT, lpp_source, script, bosinst_data, image_data, installp_bundle, fix_bundle, resolv_conf, or exclude_files resource.

The following are optional attributes that can be specified for the showres operation:

-a filesets=Value Specifies a list of filesets for which information should be displayed. This attribute is only applicable to lpp_source and SPOT targets.
-a installp_flags=Value Specifies flags that tell the installp command how to format the display of filesets. This attribute is only applicable to lpp_source and SPOT targets.
-a instfix_flags=Value Specifies flags that tell the instfix command how to format the display of fixes. This attribute is only applicable to lpp_source targets.
-a lslpp_flags=Value Specifies flags that tell the lslpp command how to format the display of installed software. This attribute is only applicable to SPOT targets.
-a reference=Value Specifies a reference machine or SPOT resource for fileset comparison. This attribute is only applicable when the target of the operation is an lpp_source. Available filesets in the lpp_source are compared against installed filesets in the reference machine or SPOT. If the showres operation is performed from a NIM client, the reference attribute is automatically set to the name of the client.
-a resource=Value Specifies the name of the resource whose contents should be displayed. This attribute is only necessary when the showres operation is performed from a NIM client.
-a sm_inst_flags=Value Specifies flags that tell the sm_inst command how to format the display of filesets. This attribute is only applicable to lpp_source and SPOT targets. This attribute must be used in conjunction with the reference attribute and is normally used only within the SMIT application.
Note: There are no required attributes for the showres operation.

When the target of the showres operation is a SPOT, the list of filesets installed in the SPOT is displayed.

When the target of the showres operation is an lpp_source, the list of filesets contained in the lpp_source is displayed.

For all other resources that are valid targets for the showres operation, the character contents of the files are displayed.

unconfig

The unconfig operation is used to unconfigure the NIM master. The unconfig operation must be performed before the NIM master can be reconfigured or the NIM master fileset can be deinstalled.

Attention: Performing the unconfig operation removes all information from the NIM database and should be used with caution.

The command line syntax for the unconfig operation is as follows:

nim -o unconfig master

The target of the unconfig operation must be the NIM master.

No attributes can be specified for the unconfig operation.

The unconfig operation completely unconfigures the NIM master by performing the following:

alt_disk_install

The alt_disk_install operation (available in AIX Version 4.3) can be used to install a mksysb image on a client system's alternate disk or disks, or it can be used to clone a client running rootvg to an alternate disk.

The command line syntax for the alt_disk_install mksysb operation is as follows:

nim -o alt_disk_install -a source=mksysb -a mksysb=mksysb_resource \
-a disk=target_disk(s) -a attribute=Value....  TargetName

The command line syntax for the alt_disk_install rootvg clone operation is as follows:

nim -o alt_disk_install -a source=rootvg -a disk=target_disk(s) \
-a attribute=Value....  TargetName

The target of an alt_disk_install operation can be a standalone NIM client or a group of standalone NIM clients. The clients must be running AIX 4.1.4 or higher and have the bos.alt_disk_install.rte fileset installed.

The following are required attributes for alt_disk_install mksysb operation:

-a source=mksysb Specifies the type of alt_disk_install to perform.
-a disk=target_disk(s) Specifies the disks on the client system that the mksysb image will be restored. This disk or these disks must not currently contain any volume group definition. The lspv command should show these disks as belonging to volume group None. If you are specifying more than one disk, the disk names must be enclosed in a set of single quotes; for example, 'hdisk2 hdisk3' .
-a mksysb=mksysb_resource Specifies the mksysb resource to use. Currently, only 4.3 mksysb images are supported by the alt_disk_install command, but they can be installed on AIX 4.1.4 and higher systems.

The following are required attributes for the alt_disk_install rootvg clone operation:

-a source=rootvg Specifies the type of alt_disk_install to perform.
-a disk=target_disk(s) Specifies the disks on the client system that the mksysb image will be restored. This disk or these disks must not currently contain any volume group definition. The lspv command should show these disks as belonging to volume group None. If you are specifying more than one disk, the disk names must be enclosed in a set of single quotes; for example, 'hdisk2 hdisk3' .

The following are optional attributes that can be specified for both alt_disk_install mksysb and the alt_disk_install rootvg clone operation:

-a image_data=Value Specifies the image_data resource to use when creating the new alternate rootvg and its logical volumes and file systems. The new volume group created must be large enough to restore the mksysb image or a copy of the running rootvg. An exclude_files attribute can also be used with an alt_disk_install rootvg clone to specify files or directories that should not be backed up.
-a debug=Value Specifies whether to print debug (set -x) output from the alt_disk_install script. Value can be yes or no , where no is the default value. This output does not go to the screen, but is saved to the NIM log, /var/adm/ras/nim.alt_disk_install, on the client system. This file can be checked after the alt_disk_install has completed.
-a set_bootlist=Value Specifies whether to set the bootlist to point to the new rootvg when the install is complete. Value can be yes or no , where yes is the default value. The next time the system is rebooted, it will boot from the newly installed alternate disk if Value is set to yes .
-a boot_client=Value Specifies whether to reboot the client when the alt_disk_install operation is completed. Value can be yes or no , where no is the default value. This attribute would normally be set only if the set_bootlist attribute was also set to yes .
-a verbose=Value Specifies whether to show files as they are being backed up for a rootvg clone, or to show files as they are being restored for a mksysb install. Value can be yes or no , where no is the default value. The output goes to the alt_disk_install log on the client, /var/adm/ras/alt_disk_inst.log.
-a script=Value Specifies the script resource to call at the end of the alt_disk_install operation. This script is called on the running system before the /alt_inst file systems are unmounted, so files can be copied from the running system to the /alt_inst file systems before the reboot. This is the only opportunity to copy or modify files in the alternate file system because the logical volume names will be changed to match those of rootvg, and they will not be accessible until the system is rebooted with the new alternate rootvg.
-a resolv_conf=Value Specifies the resolv_conf resource to use for configuring the domain and name resolution on the client system when the system is rebooted. This is the /etc/resolv_conf file that will be copied into the alternate disk's file system. This may be useful if the mksysb image you are using has a different /etc/resolv_conf file than the one you want the client to retain.

The following are optional attributes that can be specified only for the alt_disk_install rootvg clone operation:

-a exclude_files=Value Specifies an exclude_files resource to use to exclude files and directories from the rootvg. Files and directories specified in this file will not be copied to the new cloned rootvg.
-a filesets=Value Specifies the list of filesets to install into the alternate rootvg after the clone of the rootvg is complete.
-a installp_bundle=Value Specifies an installp_bundle resource that lists filesets to install into the alternate rootvg after the clone of the running rootvg.
-a fixes=Value Specifies the APARs to install into the alternate rootvg after the clone of the running rootvg. The fixes are in the format "IX123456" or "update_all" .
-a fix_bundle=Value Specifies the fix_bundle resource that lists the APARs to install into the alternate rootvg after the clone of the running rootvg.
-a installp_flags=Value Tells installp how to apply the filesets, installp_bundle, fixes, or fix_bundles attributes. The default value is installp_flags=-acgX .

To display the alternate disk installation status while the installation is progressing, enter the following command on the master:

lsnim -a info -a Cstate ClientName

or

lsnim -l ClientName

[ Previous | Next | Contents | Glossary | Home | Search ]