[ Previous | Next | Contents | Glossary | Home | Search ]
AIX Version 4.3 Network Installation Management Guide and Reference

Configuring the NIM Master and Creating Resources to Support Diskless and Dataless Clients Only

Use this procedure only if the NIM environment is to be used exclusively for diskless and dataless client management. If the NIM environment is also to be used for installing and maintaining software on standalone machines, follow the procedure for "Configuring the NIM Master and Creating Basic Installation Resources".

Note: This procedure produces a large amount of output, especially when creating the SPOT resource. Be sure to scan through the output to look for nonfatal errors and warnings that may not be evident from a successful return code.

Prerequisites

The NIM master must have at least 300MB of available disk space. If such space is not available, see "Using Client Machines as Resource Servers", "Defining /usr versus non-/usr SPOTs", and "Defining an lpp_source on CD-ROM versus Disk".

From Web-based System Manager

  1. Insert the AIX Version 4.3 Server Product CD into the CD-ROM drive of the designated master machine, or insert the Server Product tape into the tape drive of the designated master machine.
  2. Start the Web-based System Manager Software application by entering the wsm software fast path.
  3. From the Software menu, select New Software (Install/Update) > Install Additional Software (Custom).
  4. In the Install Software dialog, select /dev/cd0 or /dev/rmt0 as the software source.
  5. Specify bos.sysmgt.nim as the software to install.
  6. Additional options are available by clicking Advanced. Exit the Software application.
  7. Start the Web-based System Manager NIM application by entering the wsm nim fast path.
  8. In the NIM container, double-click the Configure NIM TaskGuide.
  9. Follow the TaskGuide instructions to guide you through the configuration.
Note: You can also open a TaskGuide by selecting the icon, then selecting Open from the Selected menu.

From SMIT

  1. Insert the AIX Version 4.2 (or later) Server Product CD or tape into the CD-ROM or tape drive of the designated master machine.
  2. To install the bos.sysmgt.nim fileset, enter the smit install_latest fast path.
  3. Using the LIST option, select /dev/cd0 or /dev/rmt0 for the INPUT device / directory for software.
  4. Specify bos.sysmgt.nim as the SOFTWARE to install.
  5. Accept the default values for all other fields on this screen. After completion of this installation, exit SMIT.
  6. To configure the NIM master, enter the smit nimconfig fast path.
  7. Specify a name in the Network Name field to be assigned to the NIM master's network.
  8. Using the LIST option, select the Primary Network Interface for the NIM Master.
  9. Accept the default values for all other fields on this screen.
  10. After the master is configured, exit SMIT.
  11. Restart SMIT using the smit nim_mkres_dd_name_server fast path.
  12. When prompted, select the NIM master as the server of the client resources.
  13. Select yes in the Create a new SPOT? field, since there is not a SPOT currently defined in your environment.
  14. Using the LIST option, select /dev/cd0 or /dev/rmt0 as the input device for installation images.
  15. Specify a name in the SPOT Name field.
  16. Specify names for the other resources to be created in the NIM environment. If a name is not specified, the resource will not be created.
  17. Select yes at the Remove all newly added NIM definitions and file systems if any part of this operation fails? field. This will make it easier to restart this procedure if failures occur.
  18. Accept the default values for all other fields on this screen.
    Note: In most NIM environments, the SPOT will already exist to support base operating system installation operations on standalone machines. In such environments, it is not necessary to create a new SPOT.

From the Command Line

  1. Insert the AIX Version 4.2 (or later) Server Product CD or tape into the CD-ROM or tape drive of the designated master machine.
  2. If installing from a tape, skip to step 5. To create a mount point for the CD, enter:
    mkdir /cdfs
  3. To create a cdrom file system, enter:
    crfs -v cdrfs -p ro -d'cd0' -m'/cdfs'
  4. To mount the CD, enter:
    mount /cdfs
  5. To install the bos.sysmgt.nim fileset from the CD, enter:
    installp -agX -d /cdfs/usr/sys/inst.images bos.sysmgt.nim
    or to install the bos.sysmgt.nim fileset from a tape, enter:
    installp -agX -d /dev/rmt0 bos.sysmgt.nim
  6. If installing from CD, to unmount the cdrom file system, enter:
    unmount /cdfs
  7. To configure the NIM master using the nimconfig command, enter:
    nimconfig -a attr1=value1 \
              -a attr2=value2 \
              ...
    For example, to configure a NIM master with the following configuration:
    master host name = master1
    primary network interface = tr0
    ring speed = 16
    platform = rspc
    kernel type = mp
    enter the following command sequence:
    nimconfig -a netname=network1 -a pif_name=tr0 -a ring_speed=16 \
    -a platform=rspc -a netboot_kernel=mp  
    Note: See the "nimconfig Command" for additional attribute information.
  8. To create a file system in the rootvg volume group with 200 MB of space and a mount point of /export/spot , enter:
    crfs -v jfs -g rootvg -a size=$((2000*200)) \
    -m /export/spot -A yes -p rw -t no \
    -a frag=4096 -a nbpi=4096 -a compress=no
  9. To mount the file system, enter:
    mount /export/spot
  10. The SPOT resource will be installed from images in the image source (in this example, the CD). The server of the resource will be the NIM master, and the SPOT will be stored in the /export/spot/spot1 directory. To create the SPOT resource, enter:
    nim -o define -t spot -a source=/dev/cd0 -a server=master \
    -a location=/export/spot spot1
  11. To create a file system in the rootvg volume group with 150 MB of space and a mount point of /export/dd_resource , enter:
    crfs -v jfs -g rootvg -a size=$((2000*150)) \
    -m /export/dd_resource -A yes -p rw -t no \
    -a frag=4096 -a nbpi=4096 -a compress=no
  12. To mount the file system, enter:
    mount /export/dd_resource
  13. Create the diskless and dataless client resources in subdirectories of the /export/dd_resource directory. Not all resources are required. Create only the resources to be used in your environment.

    To create the root resource named root1 (required for diskless and dataless clients), enter:

    nim -o define -t root -a server=master \
    -a location=/export/dd_resource/root1 root1
    To create the dump resource named dump1 (required for diskless and dataless clients), enter:
    nim -o define -t dump -a server=master \
    -a location=/export/dd_resource/dump1 dump1
    To create the paging resource named paging1 (required for diskless clients), enter:
    nim -o define -t paging -a server=master \
    -a location=/export/dd_resource/paging1 paging1
    To create the home resource named home1 (optional), enter:
    nim -o define -t home -a server=master \
    -a location=/export/dd_resource/home1 home1
    To create the shared_home resource named shared_home1 (optional), enter:
    nim -o define -t shared_home -a server=master \
    -a location=/export/dd_resource/shared_home1 shared_home1
    To create the tmp resource named tmp1 (optional), enter:
    nim -o define -t tmp -a server=master \
    -a location=/export/dd_resource/tmp1 tmp1
    Notes:
    1. The file systems created for the NIM resources are not required, but they can be beneficial for storage management.
    2. For more information about NIM resources, see "NIM Resources".

[ Previous | Next | Contents | Glossary | Home | Search ]