HOWTO AIX:SNA SERVICES PROBLEM DETERMINATION
ITEM: RTA000035897
PLATFORM: RISCSYSTEM
*********************************************************************
** This item contains information that is intended to be helpful, **
** accurate and act as a guide of HOW TO accomplish a given system **
** task. The provided explanations, techniques and procedures **
** have been reviewed for technical accuracy and applicability, **
** but have not been tested in every possible environment or **
** situation. Normal precautions should be taken in adopting these **
** same techniques and procedures, because as product and system **
** interfaces change, so would the usage of this information **
** change. **
*********************************************************************
SCENARIO/EXPLANATION:
SOLUTION:
NOTE: ##############################################################
#####################################################################
## ##
## This item contains characters that may not print or display ##
## correctly on all systems. A flag line has been placed BENEATH ##
## each line that contains one or more of those characters. Flag ##
## lines can be identified by the characters "@@" in columns 71 ##
## and 72. The position of each unprintable or non-displayable ##
## character is identified by one of the following letters ##
## contained in the flag line and located directly beneath that ##
## character. ##
## ##
## A - left square bracket G - logical not ##
## B - right square bracket H - exclamation point ##
## C - left brace I - vertical bar ##
## D - right brace J - back slash ##
## E - percent sign K - tilde ##
## F - caret (circumflex) L - back quote (accent) ##
## ##
#####################################################################
#####################################################################
I. Introduction
When you experience a problem with SNA Services on the RISC/6000,
certain information is necessary to investigate your problem. The
purpose of this document is to inform you of what information is
available, how to create that information, and how to package that
information to send to the support center.
The more information that is available at the time you report the
problem, the quicker the problem can be resolved.
All of the traces that are generated are memory traces.
It is necessary to turn off tracing to insure that the last buffer
gets written to the trace file. (Stopping SNA will also flush the
buffers.)
It is very important that all information be collected at same
time. Synchronize the clocks of all of the machines involved in the
problem so that the time stamps of the events will be as close as
possible.
When a problem is reported, there are certain things that you
should be prepared to send to the support center. The information
should be put into a single directory. That directory should either
be sent to the support center in compressed tar format on a diskette
or uploaded to a mainframe (using binary format) and sent to the
support center over the network.
Throughout this document, all files are copied to a directory
called /tmp/pmr. This would be the directory that would be sent to
the support organization.
Section II of this document shows how to create the information
needed using AIX commands. Commands are shown with a prompt
character (#) before the command to indicate the root user.
The character string "ProfName" will be used to indicate the name
of the SNA Services attachment profile.
Section III gives additional information and shows how to use SMIT
to do the same functions listed in section II. A list of the
contents of each section is listed below:
ITEM Section Smit
of this document Description
1). Problem definition - II.A
2). SNA Services Profiles - II.B
3). SNA Internal Error Log - II.C III.A
4). SYSTEM Error Log - II.D III.B
5). Attachment Trace - II.E III.C
6). SNA API Trace - II.F III.D
7). 888 Error Codes - III.E
8). SYSTEM DUMP - III.F
9). LU0 TRACE - II.G
10). HCON TRACE - II.H
11). SNA_ABEND - II.I
12). USING HOOK ID's - II.J
II. Basic Information Required
Listed below are the items that should be provided to the support
organization that you are dealing with at the time you report the
problem. This list also shows the name of the file that needs to be
moved to the directory that is sent to the support center.
ITEM Section file
of this document to be saved
1). Problem definition - II.A README
2). SNA Services Profiles - II.B You Name it
3). SNA Internal Error Log - II.C /var/sna/snalog.1
4). SYSTEM Error Log - II.D /var/adm/ras/errlog
5). Attachment Trace - II.E /var/sna/bin/ProfName
Additional information that may be required as the problem is
investigated:
ITEM Section file
of this document to be saved
1). SNA API Trace - II.F /var/adm/ras/trcrpt
2). 888 Error Codes - III.E
3). SYSTEM DUMP - III.F
4). LU0 TRACE - II.G /var/lu0/LU0Sec
/var/lu0/LU0Prime
5). HCON TRACE - II.H hcon.trace
6). SNA_ABEND - II.I /var/sna/SNA_ABEND
7). USING HOOK ID's - II.J
II.A. PROBLEM DEFINITION
First and most important is a clear definition of the problem.
This should be included in a file called README on the diskette. This
file should also include a list of the files on the diskette and a
brief description of those files. Be sure to answer the following
questions in the problem description.
1). What happened?
2). Is it reproducible? If so list the steps to recreate.
3). What were the exact error messages that were generated?
This should include messages from all machines involved.
(AS/400, PS/2, MAINFRAMES).
4). What release of the SNA is active and committed?
5). What release of the AIX is active and committed?
6). What release of the HCON is active and committed?
7). What fixes have been applied to the system?
8). Has it ever worked? If so what changes occurred before it
stopped working?
II.B. PROFILES
You should always provide your profiles when you have a problem.
This is done by:
# exportsna -f /tmp/pmr/xxxxx.profiles
You may be requested to just provide the connection profile,
along with other profiles that are pointed to by the connection
profile. This is done by the following:
# exportsna -c ConnName -f /tmp/pmr/yyyyy.profiles
where ConnName is the name of your connection profile.
II.C. THE SNA INTERNAL ERROR LOG
The sna internal error log is used to keep track of SNA errors.
It is located in /var/sna/snalog.1. The internal error log can
be started automatically when SNA Services is started by changing
the node profile. See III.A for SMIT instructions to do this.
The following can be used to capture the internal error log:
# rm /var/sna/snalog.1 /* Remove old log
# startsrc -s sna /* Start sna
# traceson -s sna /* Turn on Internal Error Trace
*************************
* Reproduce Problem * /* Run Test Case
*************************
# tracesoff -s sna /* Turn off Internal Error Trace
# cp /var/sna/snalog.1 /tmp/pmr/snalog.1 /* Save it
II.D. THE SYSTEM ERROR LOG
--------------------------------------------------------------------
CLEARING the SYSTEM ERROR LOG
--------------------------------------------------------------------
The errclear command deletes error log entries that are older than
the number of days specified by the Days parameter. To delete all
error log entries, specify a 0 value for the Days parameter.
# errclear 0 /* Clear out system errlog
*************************
* Reproduce Problem * /* Run Test Case
*************************
# cp /var/adm/ras/errlog /tmp/pmr/errlog /* Save it
II.E. THE SNA ATTACHMENT TRACE
The attachment trace can be set to automatically start up when sna
is started by either using SMIT or by using the "chsnaobj" command.
The following command turns on tracing for a token ring attachment.
# chsnaobj -t log_toknrng -cyes -hlong ProfName /* Turn on
/* tracing
/* for T/R
The following senario can be used to start up an attachment trace
with out changing the profiles.
--------------------------------------------------------------------
Starting an Attachment Trace
--------------------------------------------------------------------
# startsrc -s sna /* Start sna
# traceson -l -t attachment -o ProfName
*************************
* Reproduce Problem * /* Run Test Case
*************************
# tracesoff -t attachment -o ProfName /* Turn off tracing
# cp /var/sna/bin/ProfName /tmp/pmr/ProfName /* Save it
II.F. THE SNA API TRACE
--------------------------------------------------------------------
SNA API Trace
--------------------------------------------------------------------
This trace logs the entry and exit points of the SNA API routines,
detailing the API commands executed by the application. Use the
following procedures for:
# startsrc -s sna /* Start sna
# trace -a -j 271 /* Start API trace
*************************
* Reproduce Problem * /* Run Test Case
*************************
# trcstop
# cp /var/adm/ras/trcfile /tmp/pmr/trcfile /* Save it
II.G. LU0 Information
--------------------------------------------------------------------
LU0 Configuration
--------------------------------------------------------------------
The lu0config command starts the LU0 configurator. The LU0
Configurator provides a set of menus to define the LU0 support
configuration. You can define, change, delete, or print a report
of these records.
To create a copy of the lu0 configuration:
# lu0config
Select option to Print
Select option to exit
This will create a file containing the lu0 configuration file.
The default is /var/lu0/lu0.cnf file.
--------------------------------------------------------------------
LU0 Line Trace
--------------------------------------------------------------------
The lu0 command initiates the LU0 Subsystem. By default, this
command starts the LU0 Subsystem with the /var/lu0/lu0.cnf
configuration file. The LU0 Subsystem initiates and centralizes
control of both the LU0 primary and secondary support servers. The
servers' data paths are independent of each other. However, passthru
support provides for the logical coupling of the two servers.
The lu0 command provides a common operator interface through the
interactive commands. These commands allow you to manipulate the
LU0 Subsystem while it is running as well as helping to minimize
system resource consumption. You can use the interactive commands
to display status summaries, start a secondary server, stop a
server, terminate all servers, and exit the program.
In addition, a trace facility for the subsystem can be initiated
with the lu0 command's -T flag. The trace facility records the
first 20 bytes of the SNA PIU block for traffic going in either
direction.
If the /var/lu0/lu0.cnf configuration file for an active logical
unit has the API trace enabled (a Y was entered in that field), then
the /var/lu0/ProfName file will be written, where the
ProfName parameter specifies the LU name for the device.
The /var/lu0/AttachmentName file is a text file, with fields in the
following format:
----------------------------------------------
|The /var/lu0/AttachmentName File Format |
I I @@
----------------------------------------------
|Field Name |Length |Format |
I I I I @@
----------------------------------------------
|record type |6 |string |
I I I I @@
----------------------------------------------
|length of piu |5 |integer |
I I I I @@
----------------------------------------------
|sna traffic type |3 |string |
I I I I @@
----------------------------------------------
|action |6 |string |
I I I I @@
----------------------------------------------
|req/rsp code |3 |string |
I I I I @@
----------------------------------------------
|transmit header |12 |hex |
I I I I @@
----------------------------------------------
|req/rsp header |6 |hex |
I I I I @@
----------------------------------------------
|req/rsp unit |30 |hex |
I I I I @@
----------------------------------------------
Up to 15 characters of ru data is saved in the file.
-T Enables server trace facilities. Two files are created
containing trace information for the primary server and the
secondary server, respectively: /var/lu0/LU0Prime and
/var/lu0/LU0Sec.
# startsrc -s sna /* Start sna
# lu0 -T -S ProfName -B
*************************
* Reproduce Problem * /* Run Test Case
*************************
# lu0 /* Send stop command
# cp /var/lu0/LU0Prime /tmp/pmr/LU0Prime /* Save it
# cp /var/lu0/LU0Sec /tmp/pmr/LU0Sec /* Save it
--------------------------------------------------------------------
LU0 API TRACE
--------------------------------------------------------------------
The lu0config command can also be used to turn on the API tracing
for LU0 calls. To set tracing on:
# startsrc -s sna /* Start sna
# lu0config
Select "Define LU0 SECONDARY/Primary
*************************
* Reproduce Problem * /* Run Test Case
*************************
# stopsrc -s sna /* Stop sna
# cp /var/lu0/LU0 /tmp/pmr/LU0 /* Save it
II.H. HCON TRACE
--------------------------------------------------------------------
HCON Trace
--------------------------------------------------------------------
HCON has a trace capability built into the product. This can be
used by:
# startsrc -s sna /* Start sna
# e789 -D hcon.trace Sessionid
*************************
* Reproduce Problem * /* Run Test Case
*************************
# stopsrc -s sna /* Stop SNA services
# cp hcon.trace /tmp/pmr/hcon.trace /* Save it
II.I. SNA_ABEND
--------------------------------------------------------------------
SNA_ABEND file
--------------------------------------------------------------------
The SNA_ABEND file is created any time that SNA Services
processes exits unexpectedly. Stopping Sna Services with the -c
option will also create this file.
If the /var/sna/SNA_ABEND file is being when the problem occurs,
it it will need to be sent to the support organization.
# rm /var/sna/SNA_ABEND
# startsrc -s sna /* Start sna
*************************
* Reproduce Problem * /* Run Test Case
*************************
# stopsrc -s sna /* Stop SNA services
# cp /var/sna/SNA_ABEND /tmp/pmr/SNA_ABEND /* Save it
II.J. Event Tracing
--------------------------------------------------------------------
Event Tracing
--------------------------------------------------------------------
There will be times that you are requested to generate an event
trace. All of the traces that we generate actually generate
arguments to the trace command. The trace command uses "Hook Id's:
to decide what to trace. We want both a formatted copy and an
unformatted copy sent to us.
Listed below are various hook id's that can be given as arguments
to the trace command. There are many more that are listed in
/usr/include/sys/trchkid.h.
Some of the hook id's that you may be asked to use are:
HOOK ID EVENT TRACED
1CD Ethernet Driver
1CE Token Ring Driver
224 MPQP Driver
225 X.25 Driver
227 X.25 Performance
245 SDLC Driver Performance
246 SDLC Driver monitor
254 HKWD_MBUF
270 SNA internal
271 SNA 6.2 API
280 SYSMSLA - HCON over DFT
281 SNA LU0 or FSNA API trace
282 SNA Network Management API
To create a trace file that monitors a LU6.2 program running on an
SDLC line, you would do the following:
# startsrc -s sna /* Start sna
# trace -a -j 224 246 271 1CE
*************************
* Reproduce Problem * /* Run Test Case
*************************
# stopsrc -s sna /* Stop SNA services
# trcrpt /var/adm/ras/trcfile > /tmp/pmr/trcfile.fmt /*Format
# cp /var/adm/ras/trcfile /tmp/pmr/trcfile /* Save it
III. Additional Problem Determination Information
III.A. THE SNA internal Error log
--------------------------------------------------------------------
i. Turning on Internal error logging in the node profile
--------------------------------------------------------------------
Internal error logging can be started by:
1). Changing the NODE profile to always perform error logging
2). Using SMIT to start and stop error logging
The following procedure explains how to change the NODE profile to
start the internal trace using the System Management Interface Tool
(SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snasnach takes you directly to step 8.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Configure SNA Services.
5. From the next SMIT menu, select Nodes
6. From the next SMIT menu, select Systems Network Architecture
7. From the next SMIT menu, select Change a Profile
8. Enter "sna" for the name of the profile and press ENTER,
then:
Change Perform ERROR LOGGING? to yes and press ENTER
or you can enter the following at the command line:
# chsnaobj -t sna -L yes sna
--------------------------------------------------------------------
ii. Starting an SNA Internal Error Trace
--------------------------------------------------------------------
The following procedure explains how to start an SNA internal error
trace, using the System Management Interface Tool (SMIT). This is
used after sna has been started.
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snainternerrs takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select SNA Internal Errors.
6. From the next SMIT menu, select Start Trace.
or you can enter the following at the command line:
# traceson -s sna
--------------------------------------------------------------------
iii. Stopping an SNA Internal Error Trace
--------------------------------------------------------------------
The following procedure explains how to stop an SNA internal error
trace, using the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snainternerrs takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select SNA Internal Errors.
6. From the next SMIT menu, select Stop Trace to stop the internal
trace.
or you can enter the following at the command line:
# tracesoff -s sna
--------------------------------------------------------------------
iv. Showing an SNA Internal Error Log
--------------------------------------------------------------------
The following procedure explains how to show an SNA internal error
log, using the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snainternerrs takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select SNA Internal Errors.
6. From the next SMIT menu, select Show Error Log.
or you can enter the following at the command line:
# pg /var/sna/snalog.*
III.B. THE SYSTEM ERROR LOG
--------------------------------------------------------------------
i. Clearing the SYSTEM ERROR LOG using SMIT
--------------------------------------------------------------------
The errclear command deletes error log entries that are older than
the number of days specified by the Days parameter. To delete all
error log entries, specify a 0 value for the Days parameter.
You can use the System Management Interface Tool (SMIT) to run the
errclear command by:
# smit errclear
or you can enter the following at the command line:
# errclear 0
--------------------------------------------------------------------
ii. Showing the SYSTEM ERROR LOG using SMIT
--------------------------------------------------------------------
The errpt command generates an error report from entries in the
system error log. The errpt command includes flags for limiting the
report to events matching specified criteria. A concurrent error
report flag is provided that formats and displays each error entry
at the time the entry is logged.
The default report is a summary report consisting of a single line
of data for each error entry. Error log entries are displayed with
the most recent entries first. Error reports can be written to a
file suitable for sending to a printer, instead of standard output.
# errclear 0 /* Clear the System Error Log
*************************
* Reproduce Problem * /* Run Test Case
*************************
# tracesoff -s sna /* Turn off Trace
# cp /var/adm/sna/errlog /tmp/pmr/errlog /* Save it
You can use the System Management Interface Tool (SMIT) to run the
errpt command by:
# smit errpt
or you can enter the following at the command line:
# errpt -a
III.C. THE SNA ATTACHMENT TRACE
--------------------------------------------------------------------
i. Starting an Attachment Trace using SMIT
--------------------------------------------------------------------
The following procedure explains how to start an attachment trace,
using the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snastarttrattc takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select Attachment Trace.
6. From the next SMIT menu, select Start Trace.
This displays a name select dialog asking for the ATTACHMENT profile
name. If you do not know the attachment profile name, press the F4
key (F4=List) to display a list of all known attachments.
7. Select the attachment you wish to start and press Enter
(Enter=Do).
or you can enter the following at the command line:
# traceson -l -t attachment -o ProfName
--------------------------------------------------------------------
ii. Stopping an Attachment Trace using SMIT
--------------------------------------------------------------------
The following procedure explains how to stop an attachment trace,
using the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snaapitrace takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select Attachment Trace.
6. From the next SMIT menu, select Stop Trace.
This displays a name select dialog asking for the ATTACHMENT profile
name. If you do not know the attachment profile name, press the F4
key (F4=List) to display a list of all known attachments.
7. Select the attachment you wish to stop and press Enter
(Enter=Do).
or you can enter the following at the command line:
# tracesoff -t attachment -o ProfName
--------------------------------------------------------------------
iii. Showing an Attachment Trace Report using SMIT
--------------------------------------------------------------------
The following procedure explains how to show an attachment trace
report, using the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snatracereport takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select Attachment Trace.
6. From the next SMIT menu, select Show Trace Report.
This displays a name select dialog asking for the ATTACHMENT
profile name. If you do not know the attachment profile
name, press the F4 key (F4=List) to display a list of all
known attachments.
7. Select the attachment for which you wish to see a report
and press Enter (Enter=Do).
or you can enter the following at the command line:
# trcrpt /var/sna/bin/ProfName
III.D. THE SNA API TRACE
--------------------------------------------------------------------
i. SNA API Trace using SMIT
--------------------------------------------------------------------
This trace logs the entry and exit points of the SNA API routines,
detailing the API commands executed by the application. Use the
following procedures for:
Starting an API Trace
The following procedure explains how to start an API trace, using
the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snaapitrace takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select SNA API Trace.
6. From the next SMIT menu, select Start Trace to start the API
trace.
or you can enter the following at the command line:
# trace -a -j 271
--------------------------------------------------------------------
ii. Stopping an API Trace using SMIT
--------------------------------------------------------------------
The following procedure explains how to stop an API trace, using the
System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snaapitrace takes you directly to step 6.
Entering smit trcstop issues the command.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select SNA API Trace.
6. From the next SMIT menu, select Stop Trace to stop the API
trace.
or you can enter the following at the command line:
# trcstop
--------------------------------------------------------------------
iii. Showing an API Trace Report using SMIT
--------------------------------------------------------------------
The following procedure explains how to show an API trace report,
using the System Management Interface Tool (SMIT).
1. Start the SMIT Interface by entering on the AIX command line:
# smit
Entering smit sna takes you directly to step 4.
Entering smit _snaapitrace takes you directly to step 6.
2. From the first menu, select Communications Applications and
Services
3. From the next SMIT menu, select SNA Services.
4. From the next SMIT menu, select Diagnose SNA Services.
5. From the next SMIT menu, select SNA API Trace.
6. From the next SMIT menu, select Show Trace Report to show the
API trace report.
or you can enter the following at the command line:
# trcrpt -d 271
III.E. FLASHING 888
A flashing 888 in the three-digit display indicates that there is a
message to be displayed, encoded as a string of three-digit display
values:
1. Turn the Key Mode Switch to the Normal or the Service position.
Note: Every time you press the Reset button, hold it for about one
second to allow the program to sense the change.
2. Press the Reset button to display the first value in the string.
3. Record this value.
4. Repeat steps 2 and 3 until a flashing 888 is displayed again.
Up to 41 three-digit display values may be included in the string.
If necessary, you can display the entire string of values again by
repeating this procedure.
The first value following the 888 indicates the type of information
contained in the remainder of the string. Find the first value in
the following list and take the action given:
--------------------------------------------------------------------
i. FLASHING 888-102
--------------------------------------------------------------------
An initial values of 102 indicates an unexpected system halt during
normal operation.
For unexpected system halts, the string of three-digit display
values has the following format:
888 102 mmm ddd
where mmm is a value indicating the cause of the halt and ddd is a
value indicating whether or not a system dump was obtained.
- Refer to the hardware problem determination procedures in the IBM
RISC System/6000 Diagnostics Programs: Operator Guide. If these
procedures return an SRN, record that SRN in item 4 of the Problem
Summary Form and report the problem to your service organization.
If Diagnostics does not detect a problem, record SRN 101-mmm in item
4 of the Problem Summary Form and report the problem to your
service organization. If a system dump was obtained, copy the dump
to removable media and be prepared to make it available to your
service organization.
The following list gives the possible values of mmm, the second
value following the 888; and the cause of the system halt invoking
that value:
200 Machine check due to memory bus error (RAS/CAS Parity).
201 Machine check due to memory timeout.
202 Machine check due to memory card failure.
203 Machine check due to address exception: address out of range.
204 Machine check due to attempted store into ROS.
205 Machine check due to uncorrectable ECC due to address parity.
206 Machine check due to uncorrectable ECC.
207 Machine check due to undefined error.
300 Data storage interrupt - processor type.
32x Data storage interrupt - input/out exception - IOCC. The
number represented by x is the BUID.
38x Data storage interrupt - input/output exception - SLA. The
number represented by x is the BUID.
400 Instruction storage interrupt.
500 External interrupt - Scrub - memory bus error (RAS/CAS Parity).
External interrupt - DMA - memory bus error (RAS/CAS Parity).
External interrupt - undefined error.
52x External interrupt - IOCC type - channel check.
External interrupt - IOCC type - bus timeout.
External interrupt - IOCC type - keyboard external.
The number represented by x is the IOCC number.
700 Program interrupt.
800 Floating point unavailable.
The value of ddd, the third value following the 888, indicates the
current dump status. The possible values and meanings of ddd are:
0c0 Dump completed successfully.
0c4 Partial dump completed.
0c5 Dump failed to start. An unexpected error occurred while the
system was attempting to write to the dump device.
0c8 Dump failed. No primary dump device is configured.
--------------------------------------------------------------------
ii. FLASHING 888-103
--------------------------------------------------------------------
An initial value of 103 indicates a diagnostic message. Diagnostic
messages are displayed in the three-digit display when the console
display is not present or is unavailable because of a display or
adapter failure, or when a failure is detected that prevents the
completion of IPL.
The string of three-digit display values identifies the SRN and up
to four Field Replacement Units (FRUs). The string of three-digit
display values has the following format:
888 103 nnn nnn c01 1ee 2ee 3dd 4dd 5 ss 6ss 7ff 8ff
c02 1ee 2ee 3dd 4dd 5ss 6ss 7ff 8ff
c03 1ee 2ee 3dd 4dd 5ss 6ss 7ff 8ff
c04 1ee 2ee 3dd 4dd 5ss 6ss 7ff 8ff
The two values nnn nnn represent the SRN. The values c01, c02, c03,
and c04 indicate the first, second, third, and fourth FRUs,
respectively. For each FRU, the value sequence 1ee 2ee 3dd 4dd 5ss
6ss 7ff 8ff is the location code. Refer to the IBM RISC System/6000
Diagnostics Programs: Operator Guide for information on interpreting
these location codes.
- Record the SRN in item 4 of the problem summary form and the
location codes in item 6 of the Problem Summary Form. Then, report
the problem to your service organization.
III.F. FORCING A SYSTEM DUMP
- If the system did not produce a dump automatically because of a
hang condition, obtain a dump while the problem exists.
Note: The use of the RESET button is the preferable method of
obtaining dumps, because in a hang condition it is the dump trigger
most likely to succeed. If the system has dumped and halted
automatically, the RESET button will scroll the LEDs rather than
trigger another dump.
Warning: Obtaining a dump overwrites a previous dump or other data
stored on the dump device.
If the console or a tty is accepting commands, you can start a dump
using the sysdumpstart command. The sysdumpstart command allows
you to start a dump to the primary or the secondary dump device.
If the system is accepting commands then:
- To determine which devices have been assigned as the primary and
secondary dump devices, enter:
# sysdumpdev -l
- To start a dump to the primary dump device with the sysdumpstart
command, log into the system as root user and enter:
# sysdumpstart -p
If the system is not accepting commands then try one of the following:
a). If there is a keyboard attached to the system unit, you can start
a dump using the dump key sequences (Ctrl-Alt-NumPad1 and
Ctrl-Alt-NumPad2). The dump key sequences allow you to start a dump
to the primary or the secondary dump device.
or
b). The Reset button can be used to start a dump to the primary dump
device. To start a dump, turn the Key Mode Switch to the Service
position and press the Reset button.
REFERENCES:
*****************************************************************
** If you have found this information to be informative and **
** useful, please let us know via a HONE FEEDBACK or via EQUAL.**
** Make sure in your evaluation to reference the appropriate **
** INFOSYS or FLASH number. **
** We would like to develop as many HOWTO items as needed **
** and solicit your suggestions, comments and recommendations **
** on how to make these entries more useful. We need to know **
** the value of this information to determine whether it is **
** worth IBM time and resource to continue to create and **
** maintain HOWTO items. **
*****************************************************************
---------- ---------- ---------- --------- ---------- ----------
This item was created from library item Q646343 NMTZ6
Additional search words:
$$A AIDS AIX ALTERNATE COMMUNICATIO DETERMINATIO DETERMINE HOWTO
INDEX IX NMTZ6 OCT93 OZNEW PROBLEM RISCSNA RISCSYSTEM SERVICE
SERVICES SNA SOFTWARE 3.2
WWQA: ITEM: RTA000035897 ITEM: RTA000035897
Dated: 11/1996 Category: RISCSNA
This HTML file was generated 99/06/24~12:43:13
Comments or suggestions?
Contact us