ITEM: D9943L
I can't add a jfs with SMIT.
Question:
I am running a RISC 980 on AIX 3.2.4. Recently, I installed 6 new
2GB drives. I am now trying to put a file system(FS) on one of the
drives. When I go into SMIT and try to add a FS on a mount point,
I get a group of messages that say:
mknod: Do not specify an existing file.
0516-822: mklv - unable to create lv
0506-902: crfs - cannot create logical volume
Even if I change the name of the filesystem to something more unique,
it gives me the same error.
Can you help me find out why I can't create filesystems?
Response:
The VG and PV appear to be fine. We were able to create a LV on
the VG without any problem. The error only occurs when trying to
add a filesystem whether its on a defined LV or not.
Response:
We ran the following commands to see where the mknod command would be
failing:
VG=`getlvodm -v rootvg`
MAJOR=`getlvodm -d $VG`
MINOR=`lvgenminor $MAJOR newlv` (where newlv is the name of the
new logical volume)
echo "$MAJOR $MINOR" (keep track of these \#'s)
mknod /dev/newlv b $MAJOR $MINOR
mknod /dev/rnewlv c $MAJOR $MINOR
These commands should point to the exact point where mknod is failing
during creating a LV.
Do the following to cleanup after the above steps.
lvrelminor newlv
rm -f /dev/newlv /dev/rnewlv
These commands gave us no errors. Still unable to add a filesystem
successfully. Researching further.
Response:
Possible solution is this:
Since this is the first filesystem in the volume group, no log logical
volume exists. So, when we attempt to create the filesystem, whether
it be on a new lv or an existing lv, the attempt to create the log lv
is failing. This could be caused by an erroneous file in /dev which
corresponds to the log lv name and thus would fail when attempting
to create the major and minor numbers. We will need to look in
the /dev directory for such an erroneous file.
Response:
There was an entry in /dev for loglv00.
Running 'lslv loglv00' gave us a "Device not in configuration database" error.
You moved "loglv00" and "rloglv00" to /tmp.
You then successfully created a filesystem on your new volume group
for the first time.
You can remove the "loglv00" files from /tmp and your system should
be fine.
Support Line: I can't add a jfs with SMIT. ITEM: D9943L
Dated: October 1993 Category: N/A
This HTML file was generated 99/06/24~13:30:55
Comments or suggestions?
Contact us