- 1. Which AIX levels are required for different
Java releases?
- To take advantage of recent AIX fixes, use the latest
AIX Maintenance Level from Fix
Central.
The minimum AIX level supported for each Java release is:
- Java 6: AIX 6.1.0.0, 5.3.0.30
- Java 5: AIX 6.1.0.0, 5.3.0.30 or 5.2.0.75
- Java 1.4: AIX 6.1.0.0, 5.3.0.0, 5.2.0.10 or 5.1.0.50
- WebSphere Real Time V2 for AIX: AIX 6.1.3.1 or
5.3.10.1
AIX 5.1 reached end of service in April 2006. AIX 5.2
reached end of service in April 2009.
- 2. What do I download?
-
For each release you can download the Developer Kit (JDK
or SDK) or the Runtime Environment (JRE):
- The Developer Kit is available in AIX
installp
format. There are Base install
images and Update images, also known as PTFs or fixes. You
must install the Base image before you install the Update
images.
- The Runtime Environment is intended for distributing
Java with your applications.
All installp images have Version, Release, Modification,
and Fix (VRMF) numbers associated with them. Run the command
lslpp -l | grep Java
on your system to see
which Java filesets are installed and what their VRMF
numbers are.
SDK 1.4.x installp images: All SDK 1.4.x installp
images (VRMF numbers 1.4.0.*, 1.4.1.*, and 1.4.2.*) install
into the same directories, because 1.4.1 and 1.4.2 are
maintenance levels for Java 1.4. The directories are
/usr/java14
for 32-bit code and
/usr/java14_64
for 64-bit code. If you want to
install Java 1.4, you must install the 1.4.0 base image,
followed by the latest 1.4.1 base images, and finally the
latest 1.4.2 base images. You can then update your
installation with any relevant Update images.
You can obtain the Base images and the Update images from
the release download page; AIX
Download and service information.
- 3. How do I extract tar or tar.gz files?
- Base images are compressed as tar or tar.gz files and
must be extracted before they are installed.
If you have the gunzip utility, download the tar.gz file
and run the command gunzip -c packagename.tar.gz | tar
-xvf
.
For example: gunzip -c
Java14.sdk.tar.gz | tar -xvf
.
To extract the tar file, run the command tar -xvf
packagename.tar
.
For example: tar -xvf
Java14.sdk.tar
.
- 4. How do I install the JDK/SDK base and update
images?
- Base and Update images are in AIX .bff file format,
which are ready to be installed. Remove any previous .toc
files that exist in the directory containing the .bff
images.
Use the smitty command to install the Base and Update
images.
Run "smitty install"
Select "Install and Update Software"
Select "Install Software"
Specify directory containing the images
...
- 5. Can different Java releases coexist on a
system?
- Yes, different Java releases can coexist on a system.
- 6. What are the installation directories?
- The installation directories are:
- Java 6 32-bit: /usr/java6
- Java 6 64-bit: /usr/java6_64
- Java 5 32-bit: /usr/java5
- Java 5 64-bit: /usr/java5_64
- Java 1.4 32-bit: /usr/java14
- Java 1.4 64-bit: /usr/java14_64
- WebSphere Real Time V2 for AIX on 32-bit POWER:
/usr/java-ppc32-60-srt
- WebSphere Real Time V2 for AIX on 64-bit POWER:
/usr/java-ppc64-60-srt
- 7. Which versions of Java do I have
installed?
- For Java 6, 5.0 and 1.4.2, use the java
-fullversion command to see information about your Java
installation.
For WebSphere Real Time V2 for AIX, this command is
java -Xgc:metronome -fullversion.
The system output is similar to
J2RE 1.4.1 IBM AIX build ca141-20030522
The build date for the code is shown in the format
YYYYMMDD.
Run the command from the
INSTALL_DIR/jre/bin directory, where
INSTALL_DIR is the installation directory.
See What
are the install directories?
Java 1.3.x: The command
/usr/java130/jre/bin/java -fullversion can show
1.3.1, because the support for 1.3.0 ended on 12/31/2002.
All 1.3.0 PTFs shipped after that date use 1.3.1 code.
Java 1.1.8: Installp installation for 1.1.8
creates symbolic links in the /usr/bin directory
for commands such as java and javac. However,
symbolic links are not created when later Java releases are
installed, which can result in the command java
-fullversion returning the value 1.1.8 when the PATH is
not set for the later release.
- 8. Which paths do I need to set to use a
specific Java release on my system?
-
Java version |
Path |
Java 6 64-bit |
PATH=/usr/java6_64/jre/bin:/usr/java6_64/bin:$PATH |
Java 6 32-bit |
PATH=/usr/java6/jre/bin:/usr/java6/bin:$PATH |
Java 5 64-bit |
PATH=/usr/java5_64/jre/bin:/usr/java5_64/bin:$PATH |
Java 5 32-bit |
PATH=/usr/java5/jre/bin:/usr/java5/bin:$PATH |
Java 1.4 |
PATH=/usr/java14/jre/bin:/usr/java14/bin:$PATH |
Java 1.4 64-bit |
PATH=/usr/java14_64/jre/bin:/usr/java14_64/bin:$PATH |
Java 1.3.1 |
PATH=/usr/java131/jre/bin:/usr/java131/bin:$PATH |
Java 1.3.1 64-bit |
PATH=/usr/java13_64/jre/bin:/usr/java13_64/bin:$PATH |
WebSphere Real Time V2 for AIX on 32-bit POWER |
PATH=/usr/java-ppc32-60-srt/jre/bin:/usr/java-ppc32-60-srt/bin:$PATH |
WebSphere Real Time V2 for AIX on 64-bit POWER |
PATH=/usr/java-ppc64-60-srt/jre/bin:/usr/java-ppc64-60-srt/bin:$PATH |
- 9. How do I know if an image file has been
downloaded successfully?
- If you cannot extract from a tar or tar.gz image file,
the file might have been corrupted. The download pages for
the JDK and SDK base images tell you the number of bytes for
all tar and tar.gz files. If the size of the file you
downloaded is different, try downloading again.
The "smitty install" utility cannot process a damaged
file. Download and extract the file again.
- 10. How do I get support information on Java
for AIX?
- See http://www-03.ibm.com/systems/p/support/index.html.
If you are a customer in the U.S.A. and have an AIX Support
Line contract, you can call 1-800-CALL-AIX for support.
- 11. Are there any forums for Java on AIX?
- Forum for Java on AIX: ibmpub.java.aix
General
forum for IBM Java Runtimes and SDKs: IBM
Java Runtimes and SDKs
General forum for AIX: AIX
forum