TITLE : Howto save a copy of print files that are sent to a printer OS LEVEL : AIX DATE : 12/03/99 VERSION : 1.0 ---------------------------------------------------------------------------- This procedure applies to printers that normally use piobe as the printer backend. 1, Create a file in /usr/lib/lpd called copy-piobe containing the following information :- #!/bin/ksh copyfile=/tmp/print-genpp-$$$$-`date +%d%m%y-%H%M%S` cp $* $copyfile /usr/lib/lpd/piobe $* 2, Change the permission of the file to -r-xr-sr-x using the command chmod 2555 /usr/lib/lpd/copy-piobe 3, Change the ownership of the file to bin using the command chown bin /usr/lib/copy-piobe 4, Change the group for the file to system using the command chgrp system /usr/lib/copy-piobe 5, Edit the /etc/qconfig file and change the backend of the printer queue required from piobe to copy-piobe Before Example:- ---------------- genpp: device = lp0 lp0: file = /dev/lp0 header = never trailer = never access = both backend = /usr/lib/lpd/piobe After Example:- --------------- genpp: device = lp0 lp0: file = /dev/lp0 header = never trailer = never access = both backend = /usr/lib/lpd/copy-piobe 6, Stop the qdaemon printer subsystem using the command stopsrc -s qdaemon 7, Check that the printer subsystem has stopped sucessfully using the command lssrc -s qdaemon If the printer subsystem does not stop sucessfully then it can be killed using the command kill -9 {pid of qdaemon listed in lssrc -s qdaemon} 7, Restart the printer subsystem using the command startsrc -s qdaemon Any print sent to queue genpp will be copied to /tmp as a file called print-genpp-{process id number}-{date}-{time}