TITLE : Setting up a dial out PPP connection OS LEVEL : AIX 4.x DATE : 20/05/99 VERSION : 1.2 ---------------------------------------------------------------------------- In the example below the system will dial the freeserve number and logon as user rs6000.freeserve.co.uk with the password of mypassword :- 1, Check that the Async Point to Point Protocol software is installed :- lslpp -l bos.net.ppp If not installed, then install using smit install_latest 2, Create a tty to attach the modem to :- smit maktty select "tty rs232 Asynchronous Terminal" select the parent adapter a, fill in the port number b, select the baud rate required c, set the flow control to rts (RTS/CTS) d, leave all other options at their default values 3, Test the connection to the modem You need to have cu installed on the machine, check this using :- lslpp -L bos.net.uucp If not installed, then install using smit install_latest Edit the /etc/uucp/Devices file and append the following line :- Direct tty## - baud_rate direct Where tty## is the tty created in step 1, and baud_rate is baud rate number set for that tty. cu -ml /tty## "CONNECTED" should be displayed. Enter 'at'. The modem should respond with "OK". You can enter a few at command to check the modem. Exit cu by entering a tilde (~) followed by a period (.) 4, Setting up PPP smit ppp select "Link Control Configuration" select "Add a Link Configuration" enter the following details :- a, PPP subsystem name [ppp] b, max server connections [0] c, max client connections [1] d, max demand connections [0] e, max ip interfaces [1] f, max async hdlc attachments [1] leave all other options at their default values 5, Setting up PAP Authentication smit ppp select "PAP Authentication" select "Add a User" enter the following details :- User name [rs6000.freeserve.co.uk] Remote host name [*] Password [mypassword] 6, Start PPP using :- startsrc -s pppcontrold Check that the ppp control daemon is running using:- lssrc -s pppcontrold Check that the pp# network interfaces have been created using :- netstat -in 7, Setting up a debug file. In /etc/syslog.conf add the line :- *.debug /tmp/ppp Create the file /tmp/ppp using :- touch /tmp/ppp chmod +w /tmp/ppp Start debug using :- refresh -s syslogd pppcontrold can be set to provide more detailed output :- lssrc -s pppcontrold Note the process id (PID) kill -30 PID-of-pppcontrold This output can be switched off by :- kill -31 PID-of-pppcontrold 8, Create a "Chat script". -------------chat--script--starts--below--this--line-------------------- '' atdt08450796699 login: rs6000.freeserve.co.uk word: mypassword ------------chat--script--ends--above--this--line----------------------- Save this script as for example ppp-chat1 9, Establishing a connection. pppattchd is started to establish a PPP link. It calls the pppdial program which uses the "chat script" to do the actual dial out. The dial out command to use should resemble :- /usr/sbin/pppattached client multilink peer pap tty## connect \ "/usr/sbin/pppdial -v -f ppp-chat1 After issuing this command, watch the progression of the dial out by executing the following command :- tail -f /tmp/ppp