TITLE : Procedure to create a dummy "defined" hard drive OS LEVEL : AIX 4 DATE : 03/03/99 VERSION : 1.0 ---------------------------------------------------------------------------- In this example hdisk1 is being created with a scsi id 2, on a machine that only has hdisk0 at scsi id 6. 1, mknod /dev/rhdisk1 c 12 2 2, mknod /dev/hdisk1 b 12 2 To check that the files have been created correctly, the output of ls -l /dev/*hdisk* should look simular to :- brw------- 1 root system 12, 1 28 Oct 16:56 hdisk0 brw-r--r-- 1 root system 12, 2 03 Mar 11:02 hdisk1 crw------- 2 root system 12, 1 28 Oct 14:15 rhdisk0 crw-r--r-- 1 root system 12, 2 03 Mar 11:02 rhdisk1 3, odmget -q "name=hdisk0" CuDv > /tmp/hdisk1.CuDv 4, odmget -q "name=hdisk0" CuAt > /tmp/hdisk1.CuAt 5, vi /tmp/hdisk1.CuDv The example below has been amended to the new drive settings. CuDv: name = "hdisk1" status = 0 chgstatus = 2 ddins = "scdisk" location = "00-00-0S-2,0" parent = "scsi0" connwhere = "2,0" PdDvLn = "disk/scsi/osdisk" Note :- name is changed to the new disk name status is changed from 1 (available) to 0 (defined) location is changed to suit the scsi address of the new drive connwhere is changed as per the new scsi address 6, vi /tmp/hdisk1.CuAt The example below has been amended to the new drive settings. CuAt: name = "hdisk1" attribute = "pvid" value = "0020108512334d350000000000000000" type = "R" generic = "D" rep = "s" nls_index = 2 Note :- name is changed to the new disk name just change one of the numbers in the value field, this field is the serial number of the drive and needs to be unique to the system 7, odmadd /tmp/hdisk1.CuDv 8, odmadd /tmp/hdisk1.CuAt To check that the new drive has been created correctly, the output of command lsdev -Cc disk should look like :- hdisk0 Available 00-00-0S-6,0 Other SCSI Disk Drive hdisk1 Defined 00-00-0S-2,0 Other SCSI Disk Drive Any new disks that are added to the system (not at scsi id 2) will now be numbered from hdisk2 onwards. To deleted hdisk1 :- rmdev -l hdisk1 -d