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Chapter 1. Installing and Starting Software Delivery Assistant
This section contains instructions for installing and starting Software Delivery
Assistant (SDA) version 1.3.

System requirements
SDA version 1.3 requires one of the following Microsoft® operating systems:
v Windows® 95
v Windows 98
v Windows NT® 4.0
v Windows 2000
v Windows Millennium Edition
v Windows XP

Installing Software Delivery Assistant
Do the following to perform an attended installation of Software Delivery Assistant
on a server, console, or client runnings Windows NT or Windows 98:
1. To download the program, go to the following IBM web page and search for
SDA:
http://www.ibm.com/pc/.
2. From the Windows Start menu, click Run.
3. In the Open field, type:
drive_letter:\directory\sdav13.exe
where drive_letter and directory are the drive and directory where the
installation program is located.
4. Click OK to start the installation program.
5. In the Welcome window, click Next to continue the installation.
6. Click Next.
The Software Delivery Assistant Installer installs the program files.
7. The Setup Complete window opens when the installation is complete. Click
Finish to confirm.

Starting Software Delivery Assistant
You can start SDA with one of these methods:
v Click Start → Programs → IBM Software Delivery Assistant v1.3.
v Double-click the SDAassist.exe file located within
C:\Program Files\SDAv13\SDAssist.exe.

Uninstalling Software Delivery Assistant
To remove Software Delivery Assistant from your system, do the following:
1. Click Start → Settings → Control Panel.
2. Double-click Add/Remove Programs.
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3. Select the IBM Software Delivery Assistant V1.3 program name from the
Install/Uninstall list.
4. Click Remove.
5. In the Confirm File Deletion window, click Yes.
6. Click OK.
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Chapter 2. Using Software Delivery Assistant
IBM® Software Delivery Assistant (SDA) helps with the deployment of a single
application set that you can use across an entire organization. SDA can create a
single common application set that you can deploy to all users, regardless of their
operating system, language, hardware configuration or business group (for
example, marketing, development, or finance).
With SDA, you package all of the unique application sets, based on business
groupings (such as Marketing or Manufacturing Development) within your
enterprise into a single installation SDA image. You can then combine this SDA
image with a base image, which contains an operating system, device drivers, and
core applications (such as an antivirus tool), to form a common superimage that
can be deployed to all users within your enterprise regardless of what business
group they are in.
SDA consists of two parts:
v SDA-Administrator
v SDA-Installer
You, the administrator, use SDA-Administrator to create an SDA image. Users use
SDA-Installer to install their application sets onto their computers from the SDA
image that you create. You can also set up SDA-Installer to run automatically on
the end users’ computers.

Overview
The following topics present an overview of the IBM SDA process.

Gathering information
Have the following information available before you begin:
v The operating systems that you are deploying applications to. The
SDA-Administrator can be used to create SDA images that support Microsoft
Windows 95, Windows 98, Windows NT 4.0, Windows 2000, Windows
Millennium Edition, and Windows XP.
v The languages that you are deploying applications to.
v The groups for which different suites of applications are needed. For example,
groups could include your company’s managers, marketing department, or
payroll division.
v The user-profile fields that you want to define. At a minimum, you will have a
group user-profile field, so that the user can indicate which suite of applications
is to be installed.

Creating a workspace
A workspace (.SSW) contains all the information that is required to build an SDA
image. You can create a new workspace, or you can import a workspace from an
SDA image that was previously built to create a new workspace. The SDA
image-creation wizard guides you through the process of setting up a new
workspace. The workspace interface resembles the Microsoft Windows Explorer
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interface. You can edit this workspace to add, copy, move, or delete languages,
groups, and applications to the workspace.

Translating the SDA image text
You can translate the group names and user-profile field names into the different
languages for the SDA image. The SDA-Administrator extracts the text from the
workspace into files that you can send to your translators. When you receive the
translations, reintegrate this translated text into your workspace.
The user-profile field names and group names can also be presented in different
languages.

Previewing the SDA image
To verify that you have specified the correct information in the workspace to create
the SDA image that you want, you can run a preview of the SDA image.
Previewing the image does not actually install any applications but instead
simulates the installation by showing which applications will be installed for a
selected business group.

Building the SDA image
When you are certain that you have specified the correct information in the
workspace, build the SDA image. Building the SDA image copies programs for all
the applications for deployment onto users’ computers to the SDA image.

Downloading the SDA image to the users’ computers
After you build the SDA image, download the SDA image to each user’s computer
(through a tool such as IBM Remote Deployment Manager, PowerQuest Drive
Image, or Norton Ghost). You can also copy the SDA image to a CD for
distribution.
Users can access the SDA image through the SDA-Installer to install their
application suites, or you can set the SDA-Installer to automatically install the
required applications.

Starting the SDA image
The user can start the SDA-Installer by running swselect.exe in the SDA image
after the computer has been restarted.

Installing software onto users’ computers
The first time SDA-Installer runs, the program prompts the user to select one of
the business groups that are defined in the SDA workspace. After the user selects a
business group, the SDA-Installer installs the required applications from the
Common group and the user’s selected business group.
You can set up the SDA image to do one of the following after the required
applications are installed:
v Leave all applications in the SDA image after the required applications are
installed.
v Delete the SDA image to free up space on the user’s hard disk (if the SDA image
is on the user’s hard disk).
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v Delete all application installation programs from the SDA image to free up space
on the hard disk and enable the user to install additional applications from
another SDA image either on the hard disk or on an attached network drive.
v Allow the user to select additional applications to install from the same SDA
image (applications designated as optional for the common group and the user’s
selected business group in the SDA workspace).

Getting started
After you compile your system and workspace information, you can create (or
import) the workspace. Before you begin, make sure that you have all the
necessary information for your workspace.
If you want to permanently hide the SDA - Administrator window, select the Do
not show this window again check box when the window opens. Until you do
this, the window opens whenever you start the program.

Getting familiar with the workspace
The SDA-Administrator builds and displays the workspace. The workspace
interface resembles the Microsoft Windows Explorer interface. The left pane of the
window displays the structure of the workspace, with each group listed within
each language. Each language contains its own set of user-profile fields, which you
can modify. In addition, each language contains a Common group and one or more
other groups. Furthermore, each group can contain one or more subgroups.
The right pane of the SDA-Administrator window displays the contents of the item
that you highlight in the left pane of the window.
Note: You must save the workspace file before you exit from the
SDA-Administrator. Click File → Save or File → Save As and save the file as
you would any other file.

Naming the workspace
Give the workspace a descriptive name in the Workspace name field.

Selecting languages
Select each language that you want the SDA image to support. These languages
must correspond to the language versions of the operating systems that you are
deploying.

Specifying groups
A group is a set of applications specific to a particular organization, job, or
discipline in your enterprise. (For example, in a university setting, groups might
include the Schools of Journalism, Dentistry, and Business). List the groups that
you want the SDA image to support. The list of groups must contain the Common
group, which contains the applications that are used by all groups.

Specifying user-profile fields
Create the user-profile fields that you want the users to complete the first time
they install the SDA image. (For example, a user-profile field might be an
employee ID, or a location.)

Opening an existing workspace
You can use an existing workspace that has not yet been used to build an SDA
image by clicking File → Open and navigating to the existing workspace. You can
then rename the workspace to create a new workspace and modify it as necessary.
Chapter 2. Using Software Delivery Assistant
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Importing a workspace from an existing SDA image
You can create a new workspace from an existing SDA image by importing a
workspace from the existing SDA image. You can then modify the workspace to
create a new SDA image. The SDA-Administrator will use installation (setup) files
from the existing SDA image rather than from the locations from which the files
were originally obtained when the existing SDA image was built.
The SDA-Administrator imports the new workspace as the active workspace. You
can edit the workspace to add applications to the groups and add, copy, move, and
delete items in the workspace. Information and error messages for the import
process are displayed in the information panel.

Toolbar buttons
From left to right, you find these toolbar buttons:
New

Click this button to create a new workspace. Using this option is the same
as clicking File → New.

Open

Click this button to open an existing workspace. Using this option is the
same as clicking File → Open.

Save

Click this button to save the active workspace. Using this option is the
same as clicking File → Save or File → Save As.

Cut

Click this button to delete the selected item from the workspace and copy
it to the Clipboard. Using this option is the same as clicking Edit → Cut.

Copy

Click this button to copy the selected item to the Clipboard. Using this
option is the same as clicking Edit → Copy.

Paste

Click this button to copy the contents of the Clipboard to the selected item.
Using this option is the same as clicking Edit → Paste.

Information panel
Click this button to show or hide the information panel, which displays the
results of build, import, and translation send and receive processes.
Help

Click this button to display help for the SDA-Administrator.

Menu options
Use the following menu options to manipulate the SDA workspaces.

File
You can use the File menu options to create, open, or import workspaces.
New

Click this option to create a new workspace. Using this option is the same
as clicking the New button on the toolbar.

Open

Click this option to open an existing workspace. Using this option is the
same as clicking the Open button on the toolbar.

Import
Click this option to import a workspace from an existing SDA image.

Edit
The Edit menu options resemble the editing options in many Microsoft Windows
applications.
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Selected object
Click this option to change the name of a workspace.
Delete Click this option to delete the selected language, group, or application.
Cut

Click this option to delete the selected language, group, or application and
save it to the Clipboard. Clicking this option is the same as clicking the
Cut button on the toolbar.

Copy

Click this option to copy the selected item to the Clipboard. Clicking this
option is the same as clicking the Copy button on the toolbar.

Paste

Click this option to copy the contents of the Clipboard to the selected item.
Clicking this option is the same as clicking the Paste button on the toolbar.

Find and update
Click this option to propagate a property change to many applications. For
example, you might want to change the location of the installation source
files for one or more applications within multiple groups and languages.
Perform a query to narrow the list of applications to update. You can
search on any of the application property fields, such as application name,
language, group, or location of the install files. Click Next.
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From the query results, select the application entries to update by selecting
the check box beside each entry in the query Results panel. Then choose
the field to update and the new value to assign.

Click the Update selection button to update only the selected applications,
or click the Update all results button to update all the applications in the
Results panel. Click Finish.

View
You can use the View menu options to change the appearance of the
SDA-Administrator window.
Toolbar
Click this option to show or hide the toolbar.
Status bar
Click this option to show or hide the status bar at the bottom of the
SDA-Administrator window. The status bar displays the function of a
highlighted menu item.
Information panel
Click this option to show or hide the information panel at the bottom of
the “SDA-Administrator” window. The information panel displays the
results of build, import, and translation send and receive processes.
Operating systems
Click this option to display applications for one operating system only. You
can choose to display applications for Microsoft Windows 95, Windows 98,
Windows NT 4.0, Windows 2000, Windows Millennium Edition, or
Windows XP.

Insert
Use the following menu options to insert a language, group, subgroup, application,
or profile field into an SDA image.
Language
Click this option to add one or more languages to a workspace.
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In the left pane of the SDA-Administrator window, click the workspace
name and then click the Insert → Language menu option. Or you can
right-click the workspace name and click Insert language.
In the “Insert language” window, click the languages that you want to add
to the workspace, and click OK.
Group Click this option to add a group to a language in a workspace.
In the left pane of the SDA-Administrator window, click the language to
which you want to add a group, and then click the Insert → Group menu
option. Or you can right-click the language, and click Insert group. In the
“Insert group” window, type the name of the new group, and click OK.
You can also assign a password to each group. After an image is deployed,
the user must type the password for the selected group’s application set to
be installed.
When adding a group to an SDA workspace in the “Insert group” window,
type the password in the Password field. You can also modify a
group-assigned password by right-clicking the group and clicking the Edit
option.
Subgroup
Click this option to create application subgroups within a group. This eases
the complexity of managing large numbers of groups by enabling you to
structure a hierarchy within a group. For example, you might have
different divisions within your enterprise. Within each division, unique
business groups may require unique application sets. SDA enables you to
create a group for each division and subgroups within each group.
The following illustrates how SDA manages groups and subgroups:

The following rules apply to adding groups and subgroups:
v Languages can contain groups and user-profile fields.
v Groups can contain subgroups and applications.
v Subgroups can contain only applications. Subgroups cannot contain
other subgroups.
v If you copy a subgroup into a language, the subgroup is converted into
a group.
Chapter 2. Using Software Delivery Assistant
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v If you copy a group into another group, the group is converted into a
subgroup.
Application
Click this option to add an application to a group or subgroup within a
language.
In the left pane of the SDA-Administrator window, click the group or
subgroup to which you want to add an application, and then click Insert →
Application. Or you can right-click the group and click Insert application.
In the “Insert application” window, specify information about the
application. When you are finished specifying the necessary information on
each tab, click OK.
Profile field
Click this option to add a user-profile field within a language. A
user-profile field helps identify the user who installs the software from
SDA. In the “User profile” window that opens, you can designate the field
as Required, meaning that the user must complete it. You can also define
the field size in characters and list valid entries from which the user
selects.
The responses by the user profile fields are saved in a hidden file at
c:\sdaprof.ini

Application insertion properties
You can add applications to the workspace in the “Insert application” window.
General: Use the fields in the General tab to specify basic information about an
application.

Change icon
This optional feature allows you to use an icon other than the default icon.
Click the Change icon button and browse to the file (usually an .EXE,
.ICO, or .DLL file) that is associated with the icon. Click the application,
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and click Open. You can select one of the icons that are displayed. The
system associates the icon that is displayed in the General tab with the
application in the SDA image.
Sample icons are included with SDA-Installer.
Application name
You must type the name of the application in this required field as you
want it to be displayed in the SDA image.
Operating system
You must select the operating system in which the application will be
deployed.
Note: If different operating systems require different versions of an
application, you must add them to the workspace separately.
Language and Group
These fields display the language and group to which the application
belongs. You cannot change these fields in the General tab.
Properties: All the items in the Properties tab provide the data that is displayed
in the optional-installation portion of the SDA-Installer. These optional items are
applicable only if you specify that the entire SDA image is to be left on the user’s
hard disk after SDA installs the required applications.

Version
Type the version number of the application as you want it to appear in the
SDA-Installer.
Disk space required (in MB)
Type the approximate amount of disk space that a typical installation of
the application requires. This value is only displayed in the SDA-Installer;
the information is not used by any program.
Flyover text
Type a brief description of the application to appear in the SDA-Installer
when the user positions the cursor over the application name.
Chapter 2. Using Software Delivery Assistant
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Application name in Windows Add/Remove Programs
To determine if an application has been installed and to be able to uninstall
the application through the SDA-Installer, type the name of the application
exactly as it will appear in the Windows Add/Remove Programs window.
Path to a file or directory where the application is installed
If an Add/Remove Programs name does not appear for the application
and you still want the SDA-installer to be able to determine where the
application is installed, type a fully qualified path to the application. This
gives SDA an alternative method to determine if an application is installed.
For example, the file could be:
C:\PROGRAM FILES\LOTUS\NOTES\NOTES.EXE.
Source: Use the fields in the Source tab to specify the location and names of
installation files. You must specify either a silent installation command file or a
custom installation command file; you can specify both. If you specify both, the
system defaults to the silent installation command.

Location of installation files
You must specify the path where the files that are used to install the
application are located. The path that you specify in this required field is
automatically displayed as the path for the Silent Installation Command
field on the Source tab.
Preinstallation command
You have the option to set a program to run immediately before a program
as part of the application installation process.
The preinstallation command enables you to customize the environment,
such as setting up a registry key or implementing a batch command.
Silent installation command
You must complete this field if you do not specify a custom installation
command. Type the name of the silent installation command, including
any switches that are required to run the silent installation (for example,
SETUP.EXE –S).
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A silent installation occurs without input from the user. You must make
sure that the program that you are using to install the applications (such as
InstallShield, WiseInstaller, or Windows Installer) supports silent
installation. Most installation programs support silent installation.
Custom installation command
You must complete this field if you do not specify a silent installation
command file. Type the name of the custom installation command file.
A custom installation occurs with input from the user, such as installation
options and destination directories.
Post-installation command
You have the option to set a program to run immediately after a program
as part of the application installation process.
The post-installation command enables you to customize the installed
application after the installation is complete. You can also custom configure
the application that is installed by the SDA-Installer.
An example of a post-installation command would be setting the automatic
update service for antivirus software.
Recognizer command
This command allows an application to have a recognizer program
associated with it, which determines whether the application is installable
on a particular system. Typically a recognizer will detect the existence of a
particular hardware device.
Recognizer programs return 0 if the condition is false, or 1 if the condition
is true. For example, a recognizer could check for the existence of a DVD
drive and return a 1 if true. In this example, a DVD player application
could specify this recognizer and it would only be installed if the DVD
drive exists on the system.
Note: You must provide recognizer programs.
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Installation: Use the fields in the Installation tab to specify installation properties
of the application.

Installation type
You must click one of the following options from the menu:
v Optional - Installation of the application is optional.
v Recommended - Installation of the application is also optional. However,
in the SDA-Installer window, the application is selected by default the
first time SDA-Installer runs. The user must deselect the application to
avoid installing it.
v Required - The application is unconditionally installed during the
auto-installation portion of the SDA-Installer.
The Optional and Recommended settings require that the user manually
select the application to install.
Installation sequence
Use this menu to assign the application an installation priority relative to
other applications that are being installed. The installation sequence begins
with 1, the highest priority and continues to Don’t care. Applications that
you assign the same priority are installed in random order relative to each
other.
Computer restart required
Select this check box if the computer must restart to complete the
installation of the application. This selection applies only to applications
that are installed during the optional-installation portion of the
SDA-Installer. When installation of the optional applications is complete,
SDA prompts the user to restart the computer.
SDA Version 1.3 installs both Common and business group applications together,
following a single sequence (if a sequence is designated).
Build: Use the fields in the Build tab to custom build a directory structure for the
installation files of the SDA image. The directory specified here is appended to the
Build Directory specified in the image properties to create the fully qualified path
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for the install source to be copied to.

Encrypt the installation (setup) files
This optional setting enables you to encrypt one or more applications with
PKZIP software using a password (specified in the image properties) when
building an SDA image.
Encryption prevents a user from manually navigating the SDA image
directory and installing an application that must not be installed (typically
for royalty or licensing reasons).
When an application is marked for encryption, the SDA-Administrator zips
the installation files with a password and copies the .ZIP file to the SDA
image. When SDA-Installer installs an encrypted application, the
installation source for the application unzips to a temporary directory on
the user’s hard disk. The installation program runs from the temporary
directory and is then deleted.
Note: Use application encryption only where license restrictions require it.
Encryption lengthens the installation time by decompressing each of
the encrypted applications before running the installation program.

Image
Use the following menu options to manipulate the SDA image that you bundle
into the workspace.

Preview
Click this option to ensure that you have the correct information in the workspace
to create the SDA image that you want. The preview SDA image simulates the
installation of applications through the SDA-Installer.
Previewing the image does not actually install any applications but instead
simulates the installation by showing which applications will be installed for a
selected business group.
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Build
Click this option to store the SDA image files in a build directory on your system.

Select the check box option Do not copy the installation files ... to allow the
application source to reside in the original source directory rather than copying the
source for each application to the SDA image. This helps keep the SDA image
small. However, you must have network access to install applications and the
install time will be longer due to the network access time.
Note: To ensure that you have the correct information in the workspace to create
the SDA image that you want, create a preview SDA image before you build
the SDA image.

Report
Click this option to generate a printable, formatted report containing a list of the
application sets within a workspace.
The report categorizes the applications by language. The report contains the
following default columns:
v Application name
v Group name
v Subgroup name
v Operating system
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You can customize the report by selecting which application properties to include
in the report. For example, you can add the location of the installation files and the
version for each application.

After you select the additional fields to include in the report, click OK to generate
the report file in a standard ASCII format.

Properties
Click this option to define what happens with the SDA image after the required
applications are installed on a user’s system.
Image contents: Use the options in the Image contents tab to specify what
happens to the SDA image after the auto-installation portion of the SDA-Installer
installs required applications.

Chapter 2. Using Software Delivery Assistant
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SDA image option

Result

Leave all applications

Allows the administrator to designate that ALL
applications in the SDA image are to stay in the
SDA image. Nothing will be deleted from the SDA
image after required applications are installed.

Leave only required and optional
applications in either the Common
group or the user’s selected business
group.

Enables users to either reinstall one of their
required applications (in case the installation ever
becomes damaged) or install an optional or
recommended application.

Leave only optional applications
Deletes all the required applications already
included in either the Common group installed. The user can install only the remaining
or the user’s selected business group. optional or recommended applications in either the
Common group or the user’s selected group.
Delete all applications and direct
SDA-Installer to another SDA image,
which can be on the user’s hard disk
or on a network drive.

Specifies an alternative SDA image that contains
another application set. This application set should
have optional applications that the user can choose
from. Required applications in the alternative
application set will not be automatically installed.

The following diagram illustrates the options that the Image window contains.

If you select the Delete all applications and direct SDA-Installer to another SDA
image option, you have the option to enter a username and password at the
Remote server username and Remote server password fields.
The username and password you enter here allow the user to install the
applications without having to enter such information. If you leave these fields
blank, the user will have to enter that information when installing the programs.
Image updates: You can provide updated versions of applications for multiple
SDA images on a file server. When the SDA-Installer installs the user’s application
set, it can look for a more recent version of each application in another SDA image
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(usually on a remote file server) before installing each application. If a more recent
version of an application is located, SDA-Installer installs that version instead of
the version that is in the SDA image on the user’s hard disk. The SDA image on
the user’s hard disk still determines the application set that is installed.
The following illustrates how an administrator can designate an updated SDA
image:

If you enter a location in the Location of an updated SDA image (on a file server),
you have the option to enter a username and password at the Remote server
username and Remote server password fields.
The username and password you enter here allow the user to install the latest
applications without having to enter such information. If you leave these fields
blank, the user will have to enter that information when installing the programs.
For each installed application, the SDA-Installer compares the version number of
the application on the local hard disk with the version number of the application
on the updated SDA image to determine which version is installed. If the version
on the updated SDA image is a more recent version, the user will be prompted to
verify that the newer version should be installed. For example, version 2.01 is more
recent than version 1.02.
The version number for each application is specified on the Properties tab for the
application. Version numbers must be in the form of a numeric value, such as 1.0,
1.01, or 4.62.
In addition, the version check is performed on an application only if the
SDA-Installer finds an application in the updated SDA image with the exact same
name, group, language, and operating system.
SDA-Installer settings: Use these settings to enable or disable functions in the
SDA-Installer program. You must specify the SDA image that is to be left on the
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user’s hard disk for these settings to be relevant. (To specify what you want to
happen to the SDA image, click Image → Properties and click the Image contents
tab.)

Change settings
Click this option to change settings (SDA image location, language, flyover
text, and display of the Custom installation check box) in the
optional-installation portion of the SDA-Installer.
Display flyover text
Click this option to display a description of each application when the user
positions the cursor over the application name.
If you click the Change settings option, the user can change the setting in
the SDA-Installer window to control the way the description is displayed.
(To create flyover text for an application, click the Properties tab in the
“Insert application” window.)
Make the custom-installation option available
Click this option to make the custom-installation option available to users.
If you click this option, a Custom installation check box is displayed with
each application for which a custom installation command file has been
specified. If you click the Change settings option, this option sets the
default and the user can change the setting in the SDA-Installer window to
show or hide the Custom installation check box.
Display a full-screen window while required applications are installing
Click this option to display a full screen bitmap in the background to
discourage users from accessing the Windows desktop while applications
are installing.
Specify a background bitmap (.bmp) to be displayed while applications are
installing
Type a fully qualified path to a bitmap file to display in the background. If
none is specified, the default desktop color will be used.
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Lock user out of the operating system
This completely locks the user out of Windows and hides all install
windows while applications are installing.
Attention: If any application requires intervention, this option should
NOT be used because the user will be locked out of the system and a hang
condition will occur.
SDA-Installer shortcut options
If you choose to leave the SDA-Installer program on the user’s hard disk,
you can select one or more of the following options:
v Run after required applications are installed
v Add a shortcut to the Windows Start menu
v Add a shortcut to the desktop
Advanced options: Use these setting to specify application encryption, header
graphic, and build directory properties.

Application encryption
You can provide a password to be used for applications that you choose to
encrypt (applications with the Encrypt the installation files check box
selected). These encrypted applications cannot be installed unless this
password is used to unencrypt the installation files.
Header graphic
Use this field to change the graphic at the top of the left pane of the
SDA-Installer window. In the Header graphic field, browse to the graphic
file. This file must be a transparent .GIF image and not more than 140 x
140 pixels.
The field in this tab is applicable only if you leave the SDA image on the
user’s hard disk after the auto-installation. (To specify what you want to
happen to the SDA image after the auto-installation, click Image →
Properties and click the Image contents tab.)
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Build directory
Use this field to specify a fully qualified path where application source is
copied to for applications that have a custom relative build value specified.
For example, if this field was set to C:\SDA\APPS and the Norton
Antivirus application had a relative build directory set to NORTON\1.0,
then the resulting directory where the install source is copied to during a
build would be C:\SDA\APPS\NORTON\1.0\<setup files>.

Translation
You can translate the group names and user-profile field names into other
languages. The SDA-Administrator extracts these text items into files (.INI) that
you can send to be translated.

Send
You can extract the text from the SDA image file and save it to a directory on your
hard disk.

Receive
After you have translated the text, the SDA-Administrator integrates (receives)
them back into the workspace.

Window
These options are similar to the window options in many Microsoft Windows
applications:
Cascade
Arrange the windows so that they overlap.
Tile

Arrange the windows as non-overlapping tiles either vertically or
horizontally.

Starting the SDA-Installer on the user’s computer
You can use any of the following ways to run the SDA-Installer on a user’s
computer after you deploy the image. SDA-Installer runs after the computer is
restarted.

Create an entry in the RunOnce registry key
To run SDA-Installer automatically when the computer is started, add
SDA-Installer to the RunOnce registry key. You can use .REG files like the
following examples to add the appropriate registry key:
v
For Windows 95, Windows 98, Windows NT 4.0, and Millennium Edition:
REGEDIT4
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RunOnce]
"Run SDA-Installer"="d:\sdaimage\SWSELECT.EXE

v
For Windows 2000:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RunOnce]
"Run SDA-Installer"="d:\sdaimage\SWSELECT.EXE"
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In these examples, d:\sdaimage is the drive and directory where the SDA image is
located.

Create a shortcut in the Startup folder
You can run the SDA-Installer automatically the first time the computer is started
if you create a shortcut in the Startup folder. In the Startup folder on the user’s
computer, create a shortcut to a batch file or program that starts the SDA-Installer
and then deletes the shortcut from the folder.

Allow the user to run SDA-Installer
You can allow the user to run the SDA-Installer on demand. Create a shortcut to
the SDA-Installer on the Windows desktop or in the Start menu.

Running the SDA-Installer with Windows NT
The installation processes for many applications include updating Microsoft
Windows resources, such as the registry and system directories; therefore, the user
account on a user’s computer must have administrator privileges to enable
applications to be installed on the computer through the SDA-Installer. If you do
not want the user account to have administrator privileges, you must use an
alternative method of providing the necessary access privileges to the
SDA-Installer.
The Windows NT Zero Administration Kit (ZAK) contains scripts and batch files
that Windows NT can use to call other programs to apply registry changes and
start programs such as the SDA-Installer.
See the Microsoft Web site (www.microsoft.com) for more information about ZAK
and how to integrate programs to run automatically at the end of Windows NT
Setup.

Tasks
The following procedures demonstrate how to use the Software Delivery Assistant.

Creating a new workspace
To create a new workspace, complete the following steps:
1. From the Software Delivery Assistant – Administrator window, click Create a
new workspace, and click OK.

If the Software Delivery Assistant – Administrator window is hidden, click File
→ New. The workspace-creation wizard assists you in setting up the new SDA
workspace.
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2. Type the name of the new workspace, and click Next.
3. Select the languages that you want the SDA image to support, and click Next.
4. Click the Add button to compile the groups that you want the SDA image to
support, and click Next.
For more information on Specifying groups, see page 24.
5. Click the Add button to compile the user-profile fields that you want users to
complete the first time they use the SDA-Installer, and click Finish.
You can now edit the workspace and add applications to each group.

Specifying groups
To
1.
2.
3.

add a group, complete the following steps:
Click the language that you want to add to the group.
Click Insert → Group, or right-click the language and click Insert group.
Type the name of the group, and press Enter.
Repeat this step for each group.

4. When you have listed all the groups that you want, click Next.
To delete a group from the list, click the group, and click Remove. To change the
name of a group in the list, click the group and click Edit. Type the new name and
press Enter.

Specifying user-profile fields
To add a user-profile field, complete the following steps:
1. Click the group from the language into which you want to add a user-profile
field.
2. Click Insert → Profile field, or right-click and click Insert profile field.
The “User profile” window opens.
3. In the Name field, type the name of the user-profile field that you want to add.
4. In the Size field, type the maximum number of characters that the field can
accommodate.
The system truncates entries that exceed the specified size.
5. If you want to require the user to complete the field, select the Required field
check box.
If you do not want to limit the valid entries for the field, click OK and go to
step 8.
If you want to restrict user input to a list of valid entries, click Add to create a
list of valid entries for the user.
6. Type an entry in the Valid set window, and press Enter.
For each additional entry, click Add, type the entry, and press Enter. When you
have listed all the entries that you want, click OK.
7. To delete an entry from the list, click the entry and click Remove. To change an
entry, click the entry, and click Edit. Then type the new entry and press Enter.
8. For each additional user-profile field, repeat steps 1 through 6.
You can now edit the workspace and add applications to each group.

Opening an existing workspace
To open an existing workspace, complete the following steps:
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1. If you are starting SDA, click Open an existing workspace from the Software
Delivery Assistant – Administrator window and click OK.

If the
Software Delivery Assistant – Administrator is not open, click File → Open.
2. Browse to the workspace file (.SSW) that you want to open.
3. Double-click the file, or click the file and click Open.

Importing a workspace from an existing SDA image
To import a workspace from an existing SDA image, complete the following steps:
1. From the Software Delivery Assistant – Administrator window, click Import a
workspace from an existing image and click OK.
If the Software Delivery Assistant – Administrator window is not open, click
File → Import.
2. Type the descriptive name (not the file name) of the workspace that you want
to create from the workspace that you are importing.
3. Type or browse to the drive and directory where the SDA image is located
(where the SWSELECT.EXE file and the DATA subdirectory are located), and
click OK.

Adding languages to a workspace
To add languages to the active workspace, complete the following steps:
1. In the left pane of the SDA-Administrator window, click the workspace name.
2. Click Insert.
3. Click Language. The “Insert language” window opens.
4. Select each language that you want to add to the workspace, and click OK.
Each language contains the Common group and a set of user-profile fields.

Adding groups to a language
To add a group to a language in the active workspace, complete the following
steps:
1. In the left pane of the SDA-Administrator window, click the language to which
you want to add a group.
2. Click Insert → Group. The “Insert group” window opens.
3. Type the name of the new group and click OK.

Adding subgroups to a group
To add a subgroup to a group, complete the following steps:
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1. In the left pane of the SDA-Administrator window, click the group to which
you want to add a subgroup.
2. Click Insert → Subgroup. The “Insert subgroup” window opens.
3. Type the name of the new group and click OK.

Adding applications to a group or subgroup
To add an application to a group or a subgroup in the active workspace, complete
the following steps:
1. In the left pane of the SDA-Administrator window, within the applicable
language, select the group to which you want to add an application.
2. Click Insert → Application. The “Insert application” window opens.
3. Specify the necessary information about the application in each of the tabs in
the “Insert application” window.
For more information on the “Insert application” window, see “Application
insertion properties” on page 10.
4. When you are finished specifying the necessary information on each tab, click
OK.

Adding user-profile fields
To add a user-profile field, complete the following steps:
1. In the left pane of the “SDA-Administrator” window, under the language for
which you want to add a user-profile field, click Profile. The current
user-profile fields are displayed in the right pane of the “SDA-Administrator”
window.
2. Click Insert → Profile. The “User profile” window opens.
You can also right-click Profile and click Insert profile field.
3. In the Name field, type the name of the user-profile field that you want to add.
4. In the Size field, type the maximum number of characters that the field
accommodates. SDA truncates entries that are too long.
5. If you do not want to limit the valid entries for the field, click OK to add the
new user-profile field and go to step 8.
If you want to limit the valid entries for the field, select the Required field
check box if you want to require the user to complete the field.
6. To create a list of valid entries, click the Add button.
7. Type an entry in the Valid set window and press Enter. Repeat steps 6 and 7
for each additional entry.
To delete an entry from the list, click the entry and click Remove. To change an
entry, click the entry and click Edit. Then type the new entry and press Enter.
8. When you have listed all the entries, click OK.

Automating group selection
At a minimum, you must have a group user-profile field in the SDA image so that
a user can indicate which suite of applications is to be installed. If you prefer, you
can enable the SDA-Installer to bypass the user-profile fields and automatically
determine the user’s group, preventing the user from selecting the wrong group.
There are two ways to do this: you can create either a 32-bit program or a registry
key.
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Creating a 32-bit program
1. Create a 32-bit program file, called C:\SDAPROF.INI, on the user’s hard disk.
The file must contain the following text:
Group=groupname

where groupname is the name of the user’s group.
2. Run the SDA-Installer program, which runs the GROUPCHK program and
creates the registry key and entry.

Adding an entry to the registry key
1. Create a 32-bit program, called GROUPCHK.EXE, that determines the user’s
group, creates a registry key, HKEY_CURRENT_USER \SOFTWARE\IBM\SS,
and creates the following entry in the registry key:
Group

“groupname”

where groupname is the name of the user’s group.
2. On the user’s hard disk, put the program file in the root directory that contains
the SWSELECT.EXE file and the DATA subdirectory for the SDA image.
3. Run the SDA-Installer program, which runs the GROUPCHK program and
creates the registry key and entry.

Creating a preview SDA image
To create a preview SDA image from the active workspace, complete the following
steps:
1. Click Image → Preview.
2. From the Language menu, click the language that you want to preview.
3. From the “Operating system” menu, click the operating system that you want
to preview, and click OK.
The SDA-Administrator builds the preview SDA image and starts the
SDA-Installer.
4. In the SDA-Installer, complete the user-profile fields, and click OK.
The SDA-Installer simulates installation of the applications in the Common
group and the group that you selected in the user profile.

Creating a new SDA image from an existing SDA image
To create a new SDA image from an existing SDA image, complete the following
steps:
1. Click File → Import to import a workspace from the existing SDA image.
2. Type the name for the new SDA image in the New workspace name field.
3. Type the drive and directory in the Image location field. You can also click the
Browse button and manually navigate to the directory.
4. Click OK.

Updating multiple applications
To update multiple applications, complete the following steps.
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1. Click Find → Update. The “Find and update application” window opens.

2. Click the field type to search.
The search field you select affects the value on which the engine searches. In
some search fields, you can perform an exact search by selecting the Exact
match only check box.
3. Enter the text you want to search for in the Value to search for field.
4. Click the Next button.
The “Find and update applications” window displays the search results in the
Results window.
5. Click the search result that you want to update.
6. Select the type of update you are making in the “Field to be updated” menu.
7. Enter or click the updated information in the New Value field. What you
selected in the Field to be updated menu determines your entry.
8. Click the Update Selection button to update only the applications that are
selected, or click the Update All Results button to update all applications in
the results list.
9. Click Finish to complete the updates.

Disabling the optional-installation portion of the SDA-Installer
To delete the SDA-Installer image from the user’s hard disk, which disables the
optional-installation portion of the SDA-Installer, complete the following steps:
1. Click Image → Properties.
The “Image properties” window opens.
2. Click the Image contents tab.
3. Click Remove SDA-Installer from the user’s hard disk and click OK.
For more information about SDA image management, see “Properties” on page 17.

Extracting text for translation
To extract the text from the active workspace, complete the following steps:
1. Click Translation → Send.
The Send window opens.
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2. Type the drive and directory where you want to store the files and click OK.
You can also navigate to this location by clicking the Browse button.
The information panel displays the results of the text extraction.

Integrating translated text
To integrate the translated text into the active workspace, complete the following
steps:
1. Click Translation → Receive.
The Receive window opens.
2. Type the drive and directory where you want to store the files and click OK.
You can also navigate to this location by clicking the Browse button.
The information panel displays the results of the text extraction.
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Appendix. Notices
IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:
IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of
express or implied warranties in certain transactions, therefore, this statement may
not apply to you.
This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
Any references in this publication to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product, and use of those Web sites is at your own risk.

© Copyright IBM Corp. 2002
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Trademarks
IBM is a registered trademark of International Business Machines Corporation in
the United States, other countries, or both:
Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.
Other company, product, or service names may be the trademarks or service marks
of others.
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