Note: Before using this information and the product it supports, be sure to read the general information in Appendix C, “Notices” on page 95.
## Contents

### Figures
- vii

### Tables
- ix

### About this book
- xi
  - How this book is organized: xi
  - Notices used in this book: xii
  - Related publications: xii

### Chapter 1. Introduction
- 1
  - New features: 1
  - Supported machine types: 3
  - Terms to know: 3
  - IBM FASIT Storage Manager Version 8.2 software:
    - Microsoft Virtual Machine: 4
    - Storage Manager 8.2 Client: 4
    - Redundant Disk Array Controller: 4
    - Storage Manager 8.2 Agent: 4
    - Storage Manager 8.2 Utility: 5
  - Storage subsystem management methods:
    - Host-agent (in-band) management method: 5
    - Direct-managed (out-of-band) method: 7
  - Where to install the software components:
    - Management stations: 9
    - Host computers: 9
  - Configuration types:
    - Standard (noncluster) configuration: 10
    - Cluster server configuration: 11
  - Installation types: 11
  - Managing coexisting storage subsystems: 14
  - System requirements:
    - Hardware requirements: 16
    - Firmware requirements: 17
    - Software requirements: 18
  - Operating system requirements: 18
  - Number of supported logical drives: 19

### Chapter 2. Preparing for installation
- 21
  - Storage-subsystem management methods: 21
  - Reviewing a sample network: 22
  - Preparing a network installation: 23
  - Naming the storage subsystems: 25
  - Identifying the hardware Ethernet MAC address for each controller: 25
  - Assigning IP addresses to hosts and controllers: 27
  - Setting up the DHCP or BOOTP-compatible server:
    - Setting up a Windows NT DHCP server: 28
    - Setting up a Windows 2000 DHCP server: 32
    - Setting up a NetWare DHCP server: 34
    - Setting up a UNIX BOOTP server: 37
  - Verifying the TCP/IP protocol and setting up the host or DNS table: 37

### Chapter 3. Installing software in a standard configuration
- 41
  - New installation process: 41
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Installing software in a cluster server environment</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Installing the hardware</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Configuration options</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Host adapters</td>
<td>50</td>
</tr>
<tr>
<td></td>
<td>Storage subsystems</td>
<td>51</td>
</tr>
<tr>
<td></td>
<td>Installing Storage Manager in a cluster environment</td>
<td>51</td>
</tr>
<tr>
<td></td>
<td>Installing the storage-management software</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td>Installing the Microsoft Virtual Machine</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td>Storage Manager 8.2 Client</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td>Redundant Disk Array Controller</td>
<td>54</td>
</tr>
<tr>
<td></td>
<td>Storage Manager 8.2 Agent</td>
<td>57</td>
</tr>
<tr>
<td></td>
<td>Storage Manager 8.2 Utility</td>
<td>58</td>
</tr>
<tr>
<td></td>
<td>Installing the cluster server software</td>
<td>59</td>
</tr>
<tr>
<td></td>
<td>Upgrading from a previous version of the storage-management software</td>
<td>60</td>
</tr>
<tr>
<td></td>
<td>Performing a scheduled upgrade</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td>Performing a rolling upgrade</td>
<td>62</td>
</tr>
<tr>
<td></td>
<td>Upgrading from Windows NT 4.0 to Windows 2000 in a cluster configuration</td>
<td>63</td>
</tr>
<tr>
<td>5</td>
<td>Completing the installation</td>
<td>67</td>
</tr>
<tr>
<td></td>
<td>Performing an initial automatic discovery of storage subsystems</td>
<td>67</td>
</tr>
<tr>
<td></td>
<td>Adding devices</td>
<td>69</td>
</tr>
<tr>
<td></td>
<td>Setting up alert notifications</td>
<td>69</td>
</tr>
<tr>
<td></td>
<td>Naming storage subsystems</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Downloading firmware and NVSRAM</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Downloading firmware</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>Downloading NVSRAM</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>Creating arrays and logical drives</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>Verifying and defining the default host type</td>
<td>72</td>
</tr>
<tr>
<td></td>
<td>Configuring heterogeneous hosts</td>
<td>72</td>
</tr>
<tr>
<td></td>
<td>Performing other storage-subsystem management tasks</td>
<td>72</td>
</tr>
<tr>
<td>6</td>
<td>Using the storage-management software</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Adding or deleting logical drives</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Standard (noncluster) configuration for Windows NT</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Cluster server configuration for Windows NT</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Standard (noncluster) configuration for Windows 2000</td>
<td>76</td>
</tr>
<tr>
<td></td>
<td>Cluster server configuration for Windows 2000</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Creating a FlashCopy logical drive</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Using the Remote Mirror feature</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Using the Hot Add utility</td>
<td>78</td>
</tr>
</tbody>
</table>
Figures

1. Host-agent-managed (in-band) storage subsystems ........................................ 6
2. Direct-managed (out-of-band) storage subsystems ....................................... 8
3. Sample standard (noncluster) configuration ............................................. 10
4. Sample cluster server configuration ....................................................... 11
5. Sample coexistence installation ............................................................... 15
6. Sample network using direct-managed and host-agent managed storage subsystems ................................................................. 23
7. Locating the Ethernet MAC address for machine type 3542 ....................... 26
8. Removing the controller-unit bezel (machine types 3552 and 1742) ............. 26
9. Replacing the controller-unit bezel (machine types 3552 and 1742) ............. 27
10. Create Scope - (Local) window ................................................................. 29
11. DHCP Options: Global window ............................................................... 30
12. IP Address Array Editor window ............................................................. 30
13. Active Leases window .............................................................................. 31
14. Add Option Type window ......................................................................... 31
15. New Scope Wizard: IP Address Range window .......................................... 33
16. Installing the storage subsystem on a Fibre Channel network .................... 50
17. Confirm Initial Automatic Discovery window ............................................ 67
18. Enterprise Management window .................................................................. 68
19. Subsystem Management window ................................................................ 70
# Tables

1. Machine types and supported storage-management software .......................... 3
2. New terminology ......................................................................................... 3
3. Configurations for existing storage subsystems ........................................... 12
4. Hardware requirements for Storage Manager 8.2 software .......................... 16
5. Installation requirements by software package ............................................ 18
6. Logical drives without the remote mirror option enabled ......................... 19
7. Logical drives using the remote mirror option ............................................ 19
8. Software component installation in a Windows environment ...................... 21
9. Sample information record .......................................................................... 25
10. Global options for a Windows NT DHCP server ........................................ 29
11. Required entries for setting up the UNIX BOOTP server ......................... 37
12. Windows NT and Windows 2000 limitations ............................................. 83
13. Storage subsystem information record and controller information record ..... 89
About this book

This book provides information about planning, installing, configuring, and working with IBM® Fibre Array Storage Technology (FAStT) Storage Manager Version 8.2 in a Microsoft® Windows NT® 4.0 or Windows® 2000 operating system environment. This Installation and Support Guide is for system administrators. Use this guide to:

- Determine the hardware and software that are required to install the storage-management software.
- Integrate the necessary hardware components into your network.
- Install the FASTT Storage Manager software.
- Upgrade controller firmware, if necessary.
- Identify storage-management features that are unique to your installation.

How this book is organized

Chapter 1, “Introduction” on page 1 provides an overview of IBM FAStT Storage Manager Version 8.2 and describes storage-subsystem management methods, configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation” on page 21 discusses preparing for a network installation, including setting up a Dynamic Host Configuration Protocol/Boot Protocol (DHCP/BOOTP) server on Windows NT 4.0, Windows 2000, Novell NetWare, and UNIX® platforms.

Chapter 3, “Installing software in a standard configuration” on page 41 provides instructions for installing the software components in a standard (noncluster) environment.

Chapter 4, “Installing software in a cluster server environment” on page 49 provides instructions for installing the software in a cluster server environment.

Chapter 5, “Completing the installation” on page 67 discusses starting the Enterprise Management window, performing an automatic discovery of storage subsystems, adding devices, setting up alert notifications, downloading firmware and NVSRAM, creating arrays and logical drives, and other storage subsystem management tasks.

Chapter 6, “Using the storage-management software” on page 75 provides information about adding and deleting logical drives, using the Hot Add and SMdevices utilities, starting and stopping the host-agent software, and uninstalling Storage Manager components.

Chapter 7, “Operating-system support” on page 83 discusses Windows NT and Windows 2000 operating system limitations and other operating-system issues.

Appendix A, “Storage subsystem and controller information” on page 89 provides a data sheet template that you can use to create a controller information record.

Appendix B, “Getting information, help, and service” on page 91 provides information about how to obtain help, service, or technical assistance.

Appendix C, “Notices” on page 95 provides product notices and trademark information.
Notices used in this book

This book contains the following notices designed to highlight key information:

- **Notes:** These notices provide important tips, guidance, or advice.
- **Important:** These notices provide information that might help you avoid inconvenient or problem situations.
- **Attention:** These notices indicate possible damage to programs, devices, or data. An attention notice is placed just before the instruction or situation in which damage could occur.

Related publications

The following publications are available in Adobe Acrobat Portable Document Format (PDF) on the IBM FAStT Storage Manager CD and at the http://www.ibm.com/pc/support/ Web site.

- IBM FAStT Storage Manager Version 8.2 Installation and Support Guide for Novell NetWare
- IBM FAStT Storage Manager Version 8.2 Installation and Support Guide for Linux®
- IBM TotalStorage™ FAStT700 Fibre Channel Storage Server Installation Guide
- IBM TotalStorage FAStT700 Fibre Channel Storage Server User’s Guide
- IBM FAStT700 Fibre Channel Cabling Instructions
- IBM FAStT FC-2 Host Bus Adapter Installation and User’s Guide
- IBM FAStT Remote Mirror Option Installation and User’s Guide
- IBM Netfinity FAStT500 RAID Controller Enclosure Unit Installation Guide
- IBM Netfinity FAStT500 RAID Controller Enclosure Unit User’s Guide
- IBM Netfinity Fibre Channel Cabling Instructions
- IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide
- IBM FAStT200 Fibre Channel Cabling Instructions

The following diagnostic publications might be of interest:

- IBM FAStT MSJ User’s Guide
- IBM Fibre Channel Hardware Maintenance Manual
- IBM Fibre Channel Problem Determination Guide
- IBM Fibre Channel Basic SAN Configuration Setup Guide

In addition, the following IBM Redbooks™ might be of interest:

- Fibre Array Storage Technology: A FAStT Introduction
- Implementing Netfinity Disk Subsystems: ServeRAID SCSI, Fibre Channel, and SSA
- Tuning Netfinity Servers for Performance: Getting the most out of Windows 2000 and Windows NT 4.0
- Netfinity Director: Integration and Tools
- Netfinity Clustering Planning Guide

You can download these books from the http://www.ibm.com/redbooks Web site.
Chapter 1. Introduction

This installation and support guide provides information on preparing, installing, configuring, and starting IBM FASiT Storage Manager Version 8.2 in a Windows NT 4.0 or Windows 2000 environment. Before you begin the installation of this product, consult the following documentation:

- README.TXT file - Read this first. The README file is located in the root directory of the installation CD. Refer to the IBM Web site at http://www.ibm.com/pc/support for the latest installation and user information.
- IBM FASiT Storage Manager Version 7.10 Concepts Guide - Use this document to become familiar with terminology and features of the IBM FASiT Storage Manager software. This book can be downloaded from the http://www.ibm.com/pc/support Web site.

When you finish the installation process, refer to the following online help systems:

- Enterprise Management window help - Use this online help system to learn more about working with the entire management domain.
- Subsystem Management window help - Use this online help system to learn more about managing individual storage subsystems.

You can access these help systems from within Storage Manager 8.2 Client. From either an Enterprise Management or Subsystem Management window, click Help or press F1.

After installing IBM FASiT Storage Manager Version 8.2, consider installing the FASiT Management Suite Java (FASiT MSJ) diagnostic program. You can use this program to verify the status of the Fibre Channel connections before using the storage subsystem. The program and the IBM FASiT MSJ User’s Guide are located on the IBM FASiT Storage Manager Version 8.2 CD.

New features

This section describes the new premium features and standard features that are part of the IBM FASiT Storage Manager Version 8.2 software. Your storage subsystem firmware must be at version 5.20.xx if you want to use any of the features listed in this section. If your controller firmware is at version 04.x or earlier, you must purchase a firmware upgrade option.

There are two premium features that can be enabled by purchasing a premium feature key. Descriptions of these premium features are as follows:

- Flashcopy is a premium feature that is part of the IBM FASiT Storage Manager 8.2 software and is enabled by purchasing a premium feature key. This feature supports the creation and management of FlashCopy logical drives. A FlashCopy logical drive is a logical point-in-time image of another logical drive, called a base logical drive, in the storage subsystem. A FlashCopy is the logical equivalent of a complete physical copy, but you create it much more quickly and it requires less disk space. Because a FlashCopy is a host addressable logical drive, you can perform backups using the FlashCopy while the base logical drive remains online and user-accessible. In addition, you can write to the FlashCopy logical drive to perform application testing or scenario development and analysis. The maximum FlashCopy logical drives allowed is one half of the total logical drives supported by your controller model.

- Remote Mirror Option - The Remote Mirror Option is a premium feature that is part of the IBM FASiT Storage Manager 8.2 software and is enabled by
purchasing a premium feature key. The Remote Mirror Option is used for online, real-time replication of data between storage subsystems over a remote distance. In the event of a disaster or unrecoverable error on one storage subsystem, the Remote Mirror Option enables you to promote a second storage subsystem to take over responsibility for normal input/output (I/O) operations. When the Remote Mirror option is enabled, the maximum number of logical drives per storage subsystem is reduced. For more information, refer to "Number of supported logical drives" on page 19.

In addition to the new premium features, the storage-management software includes the following new standard features:

- **Dynamic logical-drive expansion** - this feature enables you to increase the capacity of an existing logical drive. You can use the free capacity of a logical drive on an existing array, or add unconfigured capacity (new or unassigned drives) to that array. You can expand a logical drive dynamically without losing access to it, or to any other logical drives.

- **2048 logical drive support** - this feature enables you to increase the number of defined logical drives up to 2048 for each storage subsystem. The number of logical drives will depend on your controller model. For more information refer to "Number of supported logical drives" on page 19.

- **Storage Partitioning** - this feature gives you support for up to 64 storage partitions. Specifically, there is support for up to two host ports in each host and up to eight ports in each host group (supporting a four-way host group of dual-adapter hosts).

- **Script Engine and Command Line Interface (CLI) Language** - this feature expands previous version support to include: creating and deleting a FlashCopy logical drive, setting FlashCopy logical drive attributes, supporting dynamic logical drive expansion for standard or repository logical drives, disabling or recreating a FlashCopy, creating or deleting logical drive-to-LUN mappings, uploading Read Link Status data from a storage subsystem to a comma delimited file on a management station, and downloading a feature key file to a storage subsystem to enable a premium feature.

- **Read Link Status Diagnostic (RLS)** - this feature enhances controller diagnostics enabling you to isolate the source of link problems on a Fibre Channel loop. During communication between devices, RLS error counts are detected within the traffic flow of the loop. Error count information is accumulated over a period of time for every component and device on the loop. The baseline is automatically set by the controller; however, a new baseline is set manually through the Read Link Status Diagnostics window.

- **Redesigned user interface** - this feature supports a more integrated process of creating logical drives and then mapping them to hosts or host groups and logical unit numbers to create storage partitions. The previous Storage Partitions window is now a Mappings View that you can switch to from the Logical/Physical View. In the Subsystem Management window, the Mappings View displays storage partition topology such as the default and defined host groups, hosts, host ports in a tree, and FlashCopy logical drives.

- **Controller default IP address** - Unless a static IP address is assigned to the controller by the administrator, controllers A and B will automatically be assigned the following IP addresses:
  - Controller A (192.168.128.101)
  - Controller B (192.168.128.102)

  The subnet mask for the default IP address is 255.255.255.0.
Supported machine types

Table 1 provides a list of machine types and supported storage-management software.

Table 1. Machine types and supported storage-management software

<table>
<thead>
<tr>
<th>Product name</th>
<th>Machine type</th>
<th>Model</th>
<th>Firmware version</th>
<th>Supported storage-management software version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Netfinity Fibre Channel RAID Controller Unit</td>
<td>3526</td>
<td>1RU</td>
<td>4.x</td>
<td>7.0, 7.01, 7.02, 7.10, 8.0, 8.2</td>
</tr>
<tr>
<td>IBM FASIT200</td>
<td>3542</td>
<td>1RU</td>
<td>4.x, 5.20.x</td>
<td>7.02, 7.10, 8.0, 8.2</td>
</tr>
<tr>
<td>IBM FASIT200 HA</td>
<td>3542</td>
<td>2RU</td>
<td>4.x, 5.20.x</td>
<td>7.02, 7.10, 8.0, 8.2</td>
</tr>
<tr>
<td>Netfinity FAStT500 RAID Controller Enclosure Unit</td>
<td>3552</td>
<td>1RU</td>
<td>4.x, 5.00.x, 5.20.x</td>
<td>7.0, 7.01, 7.02, 7.10, 8.0, 8.2</td>
</tr>
<tr>
<td>IBM TotalStorage FAStT700 Fibre Channel Storage Server</td>
<td>1742</td>
<td>1RU</td>
<td>5.00.x, 5.20.x</td>
<td>8.0, 8.2</td>
</tr>
</tbody>
</table>

Note: Storage subsystem firmware must be at version 04.00.02.xx or higher to be managed with Storage Manager 8.0 or Storage Manager 8.2.

Terms to know

If you are upgrading from a previous version of the storage-management software, some of the terms you are familiar with have changed. It is important that you familiarize yourself with the new terminology. Table 2 provides a list of some of the changed terms.

Table 2. New terminology

<table>
<thead>
<tr>
<th>Term used in previous versions</th>
<th>New term</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAID module</td>
<td>Storage subsystem</td>
</tr>
<tr>
<td>Drive group</td>
<td>Array</td>
</tr>
<tr>
<td>Volume</td>
<td>Logical drive</td>
</tr>
</tbody>
</table>

It is important to understand the distinction between the following two terms when reading this document:

Management station
A management station is a system that is used to manage the storage subsystem. It can be attached to the storage subsystem in the following ways:
- Through a TCP/IP Ethernet connection to the controllers in the storage subsystem
- Through a TCP/IP connection to the host-agent software that is installed on a host computer, which in turn is directly attached to the storage subsystem through the Fibre Channel input/output (I/O) path

Host computer
A host computer is a system that is directly attached to the storage subsystem through a Fibre Channel I/O path. This system is used to do the following:
- Serve data (typically in the form of files) from the storage subsystem
- Function as a connection point to the storage subsystem for a remote-management station

**Notes:**
1. The terms host and host computer are used interchangeably throughout this book.
2. A host computer can also function as a management station.

---

**IBM FASTT Storage Manager Version 8.2 software**

Storage Manager Version 8.2 contains the following software components for Windows NT 4.0 and Windows 2000 environments:
- Microsoft Virtual Machine (for Windows NT 4.0 only)
- Storage Manager 8.2 Client (SMclient)
- Redundant Disk Array Controller (RDAC)
- Storage Manager 8.2 Agent (SMagent)
- Storage Manager 8.2 Utility (SMutil)

**Microsoft Virtual Machine**

For systems running Windows NT 4.0, the Microsoft Virtual Machine is required to support the following Storage Manager 8.2 components or options:
- Storage Manager 8.2 Agent
- Event Monitor option of the Storage Manager 8.2 Client

**Storage Manager 8.2 Client**

The Storage Manager 8.2 Client (SMclient) component provides the graphical user interface (GUI) for managing storage subsystems. The SMclient contains two main components:
- **Enterprise Management.** You can use the Enterprise Management component to add, remove, and monitor storage subsystems within the management domain.
- **Subsystem Management.** You can use the Subsystem Management component to manage the components of an individual storage subsystem.

The Event Monitor is a separate program that is bundled with the SMclient. If installed, it monitors storage subsystems whenever the Enterprise Management window is closed. It runs continuously in the background and can send alert notifications in the event of a critical problem.

**Redundant Disk Array Controller**

The Redundant Disk Array Controller (RDAC) contains the multi-path device driver that is necessary to provide controller failover support when a component on the Fibre Channel I/O path fails. For RDAC in Storage Manager 8 and higher, a maximum of four end-to-end fibre channel paths from the host to the storage subsystems supported.

**Storage Manager 8.2 Agent**

The Storage Manager Agent (SM Agent) provides a management conduit for the Storage Manager Client to configure and monitor the subsystem through the Fibre Channel I/O path. The agent also provides local or remote access to the Storage
Manager 8.2 client depending on whether the client is installed on the host or in a network management station over the TCP/IP network.

Storage Manager 8.2 Utility

The Storage Manager 8.2 Utility (SMutil) dynamically defines and maps new logical drives to the operating system. This software package contains the following components:

- **Hot Add utility.** The Hot Add utility enables you to register newly created logical drives with the operating system. For information on using the Hot Add utility, see “Using the Hot Add utility” on page 78.

- **SMdevices utility.** The SMdevices utility enables you to associate storage subsystem logical drives with operating-system device names. For information on using the SMdevices utility, see “Using the SMdevices utility” on page 78.

- **SMflashcopyassist utility.** The SMflashcopyassist utility enables you to do the following:
  - Flush cached data before creating a FlashCopy™ logical drive
  - Resolve duplicate logical drive signatures between the base logical drives and the FlashCopy logical drives (Windows NT only)

For more information on using the SMflashcopyassist utility, see “Using the SMflashcopyassist utility” on page 79.

**Note:** FlashCopy is a premium feature that must be purchased. Contact your IBM service representative for more information.

Storage subsystem management methods

The storage-management software provides two methods for managing storage subsystems: the host-agent management method and the direct management method. Depending on your specific storage-subsystem configurations, you can use either or both methods. The management methods you select will determine where you will need to install the software components.

Host-agent (in-band) management method

When you use the host-agent (in-band) management method, you manage the storage subsystems through the Fibre Channel I/O path to the host. The management information can either be processed in the host or passed to the management station through the network connection, as shown in Figure 1 on page 6.

Managing storage subsystems through the host-agent has the following advantages:

- Ethernet cables do not need to be run to the controllers.
- A DHCP/BOOTP server is not needed to connect the storage subsystems to the network.
- The controller network configuration tasks that are described in Chapter 2, “Preparing for installation” on page 21 do not need to be performed.
- A host name or IP address must only be specified for the host instead of for the individual controllers in a storage subsystem. Storage subsystems that are attached to the host are automatically discovered.

Managing storage subsystems through the host-agent has the following disadvantages:
The host-agent requires a special logical drive, called an *access logical drive*, to communicate with the controllers in the storage subsystem. Therefore, you are limited to configuring one less logical drive than the maximum number that is allowed by the operating system and the host adapter that you are using.

If the connection through the fibre channel is lost between the host and the subsystem, the subsystem cannot be managed or monitored.

**Note:** The access logical drive is also referred to as the *Universal Xport Device*.

**Important:** If your host already has the maximum number of logical drives configured, either use the direct management method or give up a logical drive for use as the access logical drive. For more information, see “Number of supported logical drives” on page 19.

---

**Direct-managed (out-of-band) method**

When you use the direct (out-of-band) management method, you manage storage subsystems directly over the network through a TCP/IP Ethernet connection to each controller. To manage the storage subsystem through the Ethernet connections, you must define the IP address and host name for each controller. The controller must be attached and a cable must be attached to the Ethernet connectors on each of the storage subsystem controllers, as shown in Figure 2 on page 8.
Managing storage subsystems using the direct (out-of-band) management method has the following advantages:

- The Ethernet connections to the controllers enable a management station running SMclient to manage storage subsystems that are connected to a host running any of the operating systems that are supported by Storage Manager 8.2.
- An access logical drive is not needed to communicate with the controllers. You can configure the maximum number of logical drives that are supported by the operating system and the host adapter that you are using.
- There is a constant management connection to the subsystem.

Managing storage subsystems using the direct (out-of-band) management method has the following disadvantages:

- You need two Ethernet cables to connect the storage subsystem controllers to a network.
- When adding devices, you must specify an IP address or host name for each controller.
- You might need a DHCP/BOOTP server and network preparation tasks are required. For a summary of the preparation tasks, see "Preparing a network installation" on page 23.

You can avoid DHCP/BOOTP server and network tasks by assigning static IP addresses to the controller, or by using a default IP address.

- To assign a static IP addresses, see the IBM support Web site for Retain Tip #H171389 Unable To Setup Networking Without DHCP/BOOTP.
- If the storage subsystem controllers have firmware version 05.00.xx. or later, they have the following default settings:

<table>
<thead>
<tr>
<th>Controller</th>
<th>IP address</th>
<th>Subnet mask</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>192.168.128.101</td>
<td>255.255.255.0</td>
</tr>
<tr>
<td>B</td>
<td>192.168.128.102</td>
<td>255.255.255.0</td>
</tr>
</tbody>
</table>
Figure 2 shows a system in which storage subsystems are managed using the direct (out-of-band) management method.

Figure 2. Direct-managed (out-of-band) storage subsystems
Where to install the software components

How you manage the storage subsystems determines where you must install the various software components.

Management stations

You must install the following software components on each management station:

- Storage Manager 8.2 Client (SMclient)
- Microsoft Virtual Machine (for Windows NT only)

Host computers

You must install the following software components on each host computer:

- Redundant Disk Array Controller (RDAC)
- Storage Manager 8.2 Utility (SMutil)

Depending on how you intend to manage the storage subsystems, you might need to install the following software components:

- Storage Manager 8.2 Agent (SMagent)
- Storage Manager 8.2 Client (SMclient)

The SMagent must be installed on a host computer if you intend to manage the storage subsystems using the host-agent management method.

The SMclient must be installed on a host computer if you intend the host computer to act as a management station. If the host computer is not connected to a network, it must have TCP/IP software installed, and be assigned an IP address.

Configuration types

You can install Storage Manager 8.2 in one of two configurations:

- Standard (noncluster) configuration
- Cluster server configuration
Standard (noncluster) configuration

Figure 3 shows a sample standard (noncluster) configuration.

The SMclient software can also be installed on the host computer.

Figure 3. Sample standard (noncluster) configuration
Cluster server configuration

Figure 4 shows a sample cluster configuration.

![Diagram of a sample cluster server configuration]

The SMclient software can also be installed on the cluster nodes.

Installation types

You can install the storage-management software in two types of hardware environments:

- **New storage subsystem environment.** You are installing the IBM TotalStorage FASiT Fibre Channel Storage Server using firmware 05.20.xx.xx and you will manage storage subsystems using Storage Manager 8.2.

- **Existing storage subsystem environment.** You are installing the storage-management software in an environment with existing storage subsystems. See Table 3 on page 12 for your installation options in an environment with existing storage subsystems.

**Note:** When instructed to uninstall Storage Manager software in the following table, be sure to uninstall the management software on all management systems or hosts that have access to the storage subsystem that has firmware 5.20.xx. The Storage Manager RDAC 8.2 has new functionality and features and it is compatible with older versions of firmware. To ensure the highest
level of compatibility and error-free operation the RDAC 8.2 must be installed on all host computers that have firmware level 5.20.xx.

Table 3. Configurations for existing storage subsystems

<table>
<thead>
<tr>
<th>Current environment</th>
<th>Planned environment</th>
<th>Action</th>
</tr>
</thead>
</table>
| (Machine type 3552) Existing storage subsystems with controllers that have firmware versions 04.00.xx.xx through 04.01.xx.xx | Upgrade firmware to version 05.20.xx.xx Manage all storage subsystems using Storage Manager 8.2. | 1. Purchase an upgrade option. Contact your IBM service representative for more information.  
2. Uninstall Storage Manager version 7.x. Refer to "Uninstalling storage-management software components" on page 80 for more information.  
3. Install Storage Manager 8.2. Refer to "New installation process" on page 41 for more information.  
4. Discover the storage subsystems. Refer to "Performing an initial automatic discovery of storage subsystems" on page 67 for more information.  
5. Download firmware and NVSRAM version 5.20.xx.xx. Refer to "Downloading firmware and NVSRAM" on page 70 for more information. |
| (Machine types 3526, 3542, 3552) Existing storage subsystems with controllers that have firmware versions 04.00.02.xx through 04.01.xx.xx | Retain existing firmware versions. Manage all storage subsystems using Storage Manager 8.2. | 1. Uninstall Storage Manager version 7.x. Refer to "Uninstalling storage-management software components" on page 80 for more information.  
2. Install Storage Manager 8.2. Refer to "New installation process" on page 41 for more information.  
3. Discover the storage subsystems. Refer to "Performing an initial automatic discovery of storage subsystems" on page 67 for more information. |
| (Machine types 3526, 3552) Existing storage subsystems with controllers that have firmware versions 04.00.xx.xx through 04.00.01.xx | Upgrade firmware to version 04.00.02.xx or higher. Manage all storage subsystems using Storage Manager 8.2. | 1. Uninstall Storage Manager version 7.x. Refer to "Uninstalling storage-management software components" on page 80 for more information.  
2. Install Storage Manager 8.2. Refer to "New installation process" on page 41 for more information.  
3. Discover the storage subsystems. Refer to "Performing an initial automatic discovery of storage subsystems" on page 67 for more information.  
4. Upgrade the firmware to version 4.00.02.xx or higher. Go to the IBM Web site; download the firmware and matching NVSRAM. |
### Table 3. Configurations for existing storage subsystems (continued)

<table>
<thead>
<tr>
<th>Current environment</th>
<th>Planned environment</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Machine types 3526, 3552) Existing storage subsystems with controllers that have firmware versions 04.00.xx.xx through 4.00.01.xx</td>
<td>Retain existing firmware versions. Manage existing storage subsystems using Storage Manager 7.01.</td>
<td>Set up a separate management station with Storage Manager 7.01 installed to manage the storage subsystems with controllers that have back-level firmware.</td>
</tr>
</tbody>
</table>
| (Machine types 1742, 3552) Existing storage subsystems with controllers that have firmware versions 05.00.xx.xx | Upgrade firmware to version 5.20.xx.xx Manage all storage subsystems using Storage Manager 8.2. | 1. Uninstall Storage Manager 8.0. See "Uninstalling storage-management software components" on page 80 for more information.  
2. Install Storage Manager 8.2. See "New installation process" on page 41 for more information.  
3. Discover the storage subsystems. See "Performing an initial automatic discovery of storage subsystems" on page 67 for more information.  
4. Download firmware and NVSRAM version 5.20.xx.xx. See "Downloading firmware and NVSRAM" on page 70 for more information. |
| (Machine type 3542) Existing storage subsystems with controllers that have firmware versions 04.00.02.xx through 04.01.xx.xx | Upgrade the firmware to version 5.20.xx.xx Manage all storage subsystems using Storage Manager 8.2. | 1. Purchase the upgrade option. Contact IBM for more information.  
2. Uninstall Storage Manager 7.0. See "Uninstalling storage-management software components" on page 80 for more information.  
3. Install Storage Manager 8.2. See "New installation process" on page 41 for more information.  
4. Discover the storage subsystems. See "Performing an initial automatic discovery of storage subsystems" on page 67 for more information.  
Go to the IBM Web site to download the 04.01.02.26 or higher firmware and matching NVSRAM. **Important:** The storage subsystem controllers must be at firmware level 04.01.02.26 or higher before downloading firmware level 05.20.xx and NVSRAM to the controllers.  
5. Download firmware level 04.01.02.26 or higher and its associated NVSRAM. See "Downloading firmware and NVSRAM" on page 70 for more information.  
Managing coexisting storage subsystems

Storage subsystems are *coexisting storage subsystems* when the following conditions are met:

- There are multiple storage subsystems with controllers running different versions of firmware.
- These storage subsystems are attached to the same host.

For example, a coexisting situation exists when you have a new storage subsystem with controllers running firmware version 05.20.xx.xx, and it is attached to the same host as one or more of the following configurations:

- A storage subsystem with controllers running firmware versions 04.00.xx.xx through 04.00.01.xx, which is managed by a separate management station with Storage Manager 7.01.
- A storage subsystem with controllers running firmware versions 04.00.02.xx through 04.01.xx.xx, which is managed with Storage Manager 8.2.

**Important:** The common host must have the latest level (8.2) of RDAC and Storage Manager Agent installed.
Figure 5 shows an example of an environment that includes coexisting storage subsystems.

**Important:** In a co-existing situation, the common host must have Storage Manager Version 8.2 RDAC and SMagent installed.

System requirements

This section provides detailed information about the hardware, software, and operating system requirements for Storage Manager 8.2.
Table 4 lists the hardware required for installing Storage Manager 8.2.

<table>
<thead>
<tr>
<th>Hardware component</th>
<th>Requirements</th>
</tr>
</thead>
</table>
| A DHCP/BOOTP server (only for directly managed storage subsystems) | One of the following BOOTP or BOOTP-compatible servers:  
  - Microsoft BOOTP-compatible DHCP server for Windows NT  
  - Microsoft BOOTP-compatible DHCP server for Windows 2000  
  - UNIX BOOTP server  
  - NetWare DHCP server |
| Note: If the controllers static IP addresses or default IP addresses are used, you do not need to setup the DHCP/BOOTP server. |
| Storage subsystems (one or more) | Storage subsystems with controllers running firmware version 04.00.02.xx through 05.20.xx.xx. |
| Fibre Channel (FC) host adapters | The following Fibre Channel host adapters were tested with the storage-management software:  
  - IBM Netfinity FASTT host adapter (part number: 00N6881)  
  - IBM FASTT FC-2 host bus adapter (part number: 19K1246) |
| For information on specific host adapter requirements: | For information on specific host adapter requirements:  
  - Refer to the README file in the \Host_Adapter directory on the installation CD.  
  - Read the host adapter documentation.  
| Fibre Channel (FC) fabric switches (if needed for the desired configuration) | The following Fibre Channel fabric switches were tested with the storage-management software:  
  - IBM 8-port Fibre Channel switch (machine type: 2109-S08)  
  - IBM 16-port Fibre Channel switch (machine type: 2109-S16)  
  - IBM 16-port 2 Gbps Fibre Channel switch (machine type: 2019-F16)  
  - IBM 8-port 2 Gbps Fibre Channel switch (machine type: 3534-F08) |
| For specific Fibre Channel switch setup requirements: | For specific Fibre Channel switch setup requirements:  
  - Read the switch documentation.  
| Fibre Channel (FC) managed hub (if needed for the desired configuration) | The IBM Fibre Channel managed hub (machine type: 3534) was tested with the storage management software.  
  For specific Fibre Channel managed hub setup requirements:  
  - Read the managed hub documentation.  
Table 4. Hardware requirements for Storage Manager 8.2 software (continued)

<table>
<thead>
<tr>
<th>Hardware component</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Management station (for client software)</td>
<td>Your management station computer will require:</td>
</tr>
<tr>
<td></td>
<td>• Intel® Pentium® or Pentium-equivalent microprocessor (450 MHz or faster)</td>
</tr>
<tr>
<td></td>
<td>• CD-ROM drive</td>
</tr>
<tr>
<td></td>
<td>• Mouse or similar pointing device</td>
</tr>
<tr>
<td></td>
<td>• System memory:</td>
</tr>
<tr>
<td></td>
<td>• For Windows NT 4.0: A minimum of 64 MB (128 MB recommended)</td>
</tr>
<tr>
<td></td>
<td>• For Windows 2000: A minimum of 128 MB (256 MB recommended)</td>
</tr>
<tr>
<td></td>
<td>• Ethernet network interface adapter</td>
</tr>
<tr>
<td></td>
<td>• AGP or PCI video adapter (AGP preferred), ISA adapters are not supported</td>
</tr>
<tr>
<td></td>
<td>• Monitor setting of 1024 x 768 pixels with 64,000 colors. The minimum display setting that is allowed is 800 x 600 pixels with 256 colors.</td>
</tr>
<tr>
<td></td>
<td>• Hardware-based Windows acceleration: Desktop computers that use system memory for video memory are not preferred for use with the storage-management software.</td>
</tr>
<tr>
<td><strong>Important:</strong></td>
<td>Many PC-based servers are not designed to run graphic-intensive software. If your server has difficulty running the storage-management software smoothly without video artifacts, you might need to upgrade the server video adapter.</td>
</tr>
</tbody>
</table>


**Firmware requirements**

To utilize all of the features of Storage Manager 8.2, your storage subsystem must contain controllers with firmware version 05.20.xx. To manage storage subsystems with Storage Manager 8.2, your storage subsystems must contain controllers with firmware versions 04.00.02.xx or higher.

To upgrade your firmware from versions 04.00.xx.xx to 05.20.xx. for machine types 3542 and 3552, you must purchase a firmware upgrade option. For more information, contact your IBM technical-support representative.

The Storage Manager 8.2 also supports the two premium feature options: FlashCopy and Remote Mirroring. For more information on these premium features, contact IBM.
Software requirements

Table 5 lists the disk space and administrator privileges required to install version 8.2 of the storage-management software.

Note: The disk space listed in table 5 is for the packages after the installation. During the installation of each software package, you might need up to 120M of free disk space.

Table 5. Installation requirements by software package

<table>
<thead>
<tr>
<th>Package</th>
<th>Disk space requirement</th>
<th>Administrator privilege</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Virtual Machine</td>
<td>1 MB / NA</td>
<td>Required / NA</td>
</tr>
<tr>
<td>Storage Manager 8.2 Client (SMclient)</td>
<td>40 MB</td>
<td>Not required / Not Required</td>
</tr>
<tr>
<td>Redundant Disk Array Controller (RDAC)</td>
<td>1 MB / 1 MB</td>
<td>Required</td>
</tr>
<tr>
<td>Storage Manager 8.2 Agent (SMagent)</td>
<td>1 MB / 1 MB</td>
<td>Required</td>
</tr>
<tr>
<td>Storage Manager 8.2 Utility (SMutil)</td>
<td>4 MB / 4 MB</td>
<td>Required</td>
</tr>
</tbody>
</table>

Operating system requirements

Each management station, host computer, or cluster node requires one of the following operating systems:

Management stations. Install one of the following operating systems:
- Windows NT 4.0 Server with Service Pack 6a
- Windows NT 4.0 Enterprise Edition with Service Pack 6a
- Windows NT 4.0 Workstation with Service Pack 6a
- Windows 2000 Server with Service Pack 2
- Windows 2000 Professional with Service Pack 2
- Windows 2000 Advanced Server with Service Pack 2

Host computers. Install one of the following operating systems:
- Windows NT 4.0 Server with Service Pack 6a
- Windows NT 4.0 Enterprise Edition with Service Pack 6a
- Windows NT 4.0 Workstation with Service Pack 6a
- Windows 2000 Server with Service Pack 2
- Windows 2000 Professional with Service Pack 2
- Windows 2000 Advanced Server with Service Pack 2

Cluster nodes. Install one of the following operating systems:
- Windows NT 4.0 Enterprise Edition with Service Pack 6a
- Windows 2000 Advanced Server with Service Pack 2

Number of supported logical drives

Supported logical drive limits for Windows NT 4.0 and Windows 2000 are as follows:

- Windows NT 4.0 with Service Pack 6a supports up to 32 logical drives per storage subsystem (LUNs 0-31) when using IBM-approved FASTT adapters and their supported device drivers.
- Windows 2000 supports up to 32 logical drives per storage subsystem (LUNs 0-31) when using IBM-approved FASTT adapters and their supported device drivers.
- The maximum number of logical drives that a FASTT storage subsystem supports with firmware version 05.20.xx.xx depends on the model of the FASTT storage subsystem.

Table 6. Logical drives without the remote mirror option enabled

<table>
<thead>
<tr>
<th>Model Type</th>
<th>Maximum logical drives</th>
<th>Maximum logical drives per storage unit partition</th>
<th>Maximum flashcopy logical drives</th>
</tr>
</thead>
<tbody>
<tr>
<td>3542</td>
<td>512^1</td>
<td>32^5</td>
<td>256^2</td>
</tr>
<tr>
<td>3552</td>
<td>512^1</td>
<td>32^5</td>
<td>256^2</td>
</tr>
<tr>
<td>1742</td>
<td>2048^1</td>
<td>32^5</td>
<td>1024^2</td>
</tr>
</tbody>
</table>

Table 7. Logical drives using the remote mirror option

<table>
<thead>
<tr>
<th>Model Type</th>
<th>Maximum logical drives</th>
<th>Maximum logical drives per storage unit partition</th>
<th>Maximum flashcopy logical drives</th>
</tr>
</thead>
<tbody>
<tr>
<td>3542</td>
<td>N / A</td>
<td>N / A</td>
<td>N / A</td>
</tr>
<tr>
<td>3552</td>
<td>128^3,6</td>
<td>32^5</td>
<td>64^2</td>
</tr>
<tr>
<td>1742</td>
<td>256^1,4,6</td>
<td>32^5</td>
<td>128^2</td>
</tr>
</tbody>
</table>

Note: The access logical drive is also referred to as the Universal Xport Device.

1. When using firmware version 5.xx.xx, the firmware reserves one logical drive for use by the system.

2. Maximum of four Flashcopy logical drives for each standard logical drive

3. Maximum of eight remote mirror pairs

4. Maximum of 16 remote mirror pairs

5. The host-agent management method uses a special logical drive, called an access logical drive, to communicate with the controllers on the storage subsystem. The access logical drive uses one of the available LUNs. Therefore, managing storage subsystems with the host-agent software limits you to one fewer LUN than the maximum number supported by the operating system and the host adapter.

6. For firmware version 05.20.xx.xx, the maximum number of logical drives includes the flashcopy repository logical drives and the remote mirror logical drives in addition to the standard data logical drives. If the remote mirror option is enabled, two logical drives are reserved for use by the system.
Chapter 2. Preparing for installation

This chapter provides information to help you plan the installation of the storage-management software.

Table 8 contains information about where the Storage Manager software components need to be installed.

Table 8. Software component installation in a Windows environment

<table>
<thead>
<tr>
<th>System type</th>
<th>Software installation sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Management station</td>
<td>1. Microsoft Virtual Machine (for Windows NT only)</td>
</tr>
<tr>
<td></td>
<td>• Optional package</td>
</tr>
<tr>
<td></td>
<td>• Necessary if you plan to install the Event Monitor option of the SMclient</td>
</tr>
<tr>
<td></td>
<td>2. Storage Manager 8.2 Client (SMclient)</td>
</tr>
<tr>
<td>Host computer / cluster node</td>
<td>1. Microsoft Virtual Machine (for Windows NT only)</td>
</tr>
<tr>
<td></td>
<td>• Optional package</td>
</tr>
<tr>
<td></td>
<td>• Necessary if you plan to install the Event Monitor option of the SMclient</td>
</tr>
<tr>
<td></td>
<td>2. Storage Manager 8.2 Client (SMclient)</td>
</tr>
<tr>
<td></td>
<td>• Optional component</td>
</tr>
<tr>
<td></td>
<td>• Necessary if you intend to manage the storage subsystem from the host computer</td>
</tr>
<tr>
<td></td>
<td>3. Redundant Disk Array Controller (RDAC)</td>
</tr>
<tr>
<td></td>
<td>• Required component</td>
</tr>
<tr>
<td></td>
<td>• On Windows NT, you must assign static drive letters to existing local drives before installing RDAC. This process requires a minimum of two disk partitions (the BOOT partition and one other partition).</td>
</tr>
<tr>
<td></td>
<td>4. Storage Manager 8.2 Agent (SMagent)</td>
</tr>
<tr>
<td></td>
<td>• Optional component</td>
</tr>
<tr>
<td></td>
<td>• Necessary if you intend to use the host-agent management method.</td>
</tr>
<tr>
<td></td>
<td>5. Storage Manager 8.2 Utility (SMutil)</td>
</tr>
<tr>
<td></td>
<td>• Required component</td>
</tr>
<tr>
<td></td>
<td>• Contains the Hot Add, SMdevices, and SMflashcopyassist utilities</td>
</tr>
</tbody>
</table>

Storage-subsystem management methods

If you have not already done so, see Chapter 1, “Introduction” on page 1 for information about the following two methods for managing storage subsystems:

- **Direct (out-of band) management**: The storage subsystems are managed through a TCP/IP Ethernet connection to each controller on the storage subsystem.

- **Host-agent (in-band) management**: The storage subsystems are managed through host-agent software that is installed on a host computer connected through the fibre channel connection to the storage subsystem.
You can use one or both methods. However, because many of the preparation tasks for installation depend on which method you use, decide how you want to manage the storage subsystems on your network before you begin.

Reviewing a sample network

Figure 6 on page 23 shows an example of a network containing both a directly-managed storage subsystem (Network A) and a host-agent-managed storage subsystem (Network B).

Directly-managed storage subsystem: Network A is a directly-managed storage subsystem. Network A contains the following components:

- DHCP/BOOTP server
- Network Management Station (NMS) for Simple Network Management Protocol (SNMP) traps
- Host that is connected to a storage subsystem through a Fibre Channel I/O path
- Management station connected by Ethernet cable to the storage subsystem controllers
- If the controllers static IP addresses or default IP addresses are used, you do not need to setup the DHCP/BOOTP server.

Host-agent-managed storage subsystem: Network B is a host-agent-managed storage subsystem. Network B contains the following components:

- Host that is connected to a storage subsystem through a Fibre Channel I/O path
- Management station connected by Ethernet cable to the host computer
Preparing a network installation

To begin installing the storage-management software, ensure that the network components are set up and operating properly, and that you have all the host and controller information needed for the software to operate correctly.

The following list provides an overview of the tasks involved in setting up a network installation.

1. Install all hardware components (host computers, storage subsystems, and cables) that you want to connect to the network. You might need to refer to the installation guides specific to the hardware components.

2. Establish a naming convention for the storage subsystems connected to the network. Refer to "Naming the storage subsystems on page 25" for more information.

3. Record the storage subsystem names and management types in Table 13 on page 89. An example of a completed information record is shown in Table 9 on page 25.

Note: Throughout the remaining steps, you will need to return to Table 13 on page 89 to record information such as hardware Ethernet addresses and IP addresses.
4. (For a direct-managed system only) Determine the hardware Ethernet address for each controller in storage subsystems connected to the network. Refer to "Identifying the hardware Ethernet MAC address for each controller" on page 25 for more information.

5. (For a Direct managed system only) If you are using a default controller IP addresses, go to step 7. Otherwise, Obtain the TCP/IP address and host name for each of the controllers in the storage subsystems on the network from the network administrator. Refer to "Assigning IP addresses to hosts and controllers" on page 27.

(For a host-managed system only) Obtain the The IP address and host name of the host computer on which the host-agent software will run from the network administrator. Refer to "Assigning IP addresses to hosts and controllers" on page 27.

6. (For a direct-managed system only) Set up the DHCP/BOOTP server to provide network configuration information for a specific controller, however, if you are using a controller static IP addresses, skip this step.

7. Verify that the TCP/IP software is installed. For more information, see "Verifying the TCP/IP protocol and setting up the host or DNS table" on page 37.

8. (For a direct-managed system only) Set up the host or Domain Name Server (DNS) table. For more information, see "Verifying the TCP/IP protocol and setting up the host or DNS table" on page 37.

9. Power on the devices connected to the network.

Table 9 on page 25 shows a sample information record for the network shown in Figure 6 on page 23. This network contains storage subsystems managed using both the direct-management and host-agent-management method.
Table 9. Sample information record

<table>
<thead>
<tr>
<th>Storage subsystem name</th>
<th>Management type</th>
<th>Controllers—Ethernet and IP addresses, and host name</th>
<th>Host—IP address and host name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Controller A</td>
<td>Controller B</td>
</tr>
<tr>
<td>Finance</td>
<td>Direct</td>
<td>Hardware Ethernet address = 00a0b8020420</td>
<td>Hardware Ethernet address = 00a0b80000d8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IP address = 192.168.128.101</td>
<td>IP address = 192.168.128.102</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Host = Denver_a</td>
<td>Host = Denver_b</td>
</tr>
<tr>
<td>Engineering</td>
<td>Host-agent</td>
<td>IP address = 192.168.2.22</td>
<td>Host = Atlanta</td>
</tr>
</tbody>
</table>

Naming the storage subsystems

As you set up your network, decide on a naming convention for the storage subsystems. When you install the storage-management software and start it for the first time, all storage subsystems in the management domain are displayed as <unnamed>. Use the Subsystem Management window to rename the individual storage subsystems.

Consider the following when naming storage subsystems:
- There is a 30-character limit. All leading and trailing spaces are deleted from the name.
- Use a unique, meaningful naming scheme that is easy to understand and remember.
- Avoid arbitrary names or names that might quickly lose their meaning.
- The software displays storage-subsystem names with the prefix Storage Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is displayed as:
  Storage Subsystem Engineering

After you decide on a naming scheme, record the storage subsystem names in the information record (Table 13 on page 89).

If you plan to manage your storage subsystem using the direct-management method, go to “Identifying the hardware Ethernet MAC address for each controller.” If you plan to manage your storage subsystem using the host-agent method, go to “Assigning IP addresses to hosts and controllers” on page 27.

Identifying the hardware Ethernet MAC address for each controller

To manage your storage subsystem using the direct-management method, you need to identify the hardware Ethernet MAC address for each controller.

To identify the hardware Ethernet MAC address for machine type 3542, do the following:

1. Locate the Ethernet MAC address at the back of the unit, under the controller Gigabit Interface Converter (GBIC) ports, as shown in Figure 7 on page 26. The number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.20.00.d8).
2. Record each Ethernet address in the information record (Table 13 on page 89).

To identify the hardware Ethernet MAC address for machine types 3552 and 1742, do the following:

1. Remove the front bezel from the storage subsystem, as shown in Figure 8.
   Carefully pull the bottom of the bezel out 1 to release the pins; then, slide the bezel down 2.

2. On the front of each controller, look for a label with the hardware Ethernet MAC address. The number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.20.00.d8).

3. Record each Ethernet address in the information record (Table 13 on page 89).

4. To replace the bezel, slide the top edge under the lip on the chassis 1; then, push the bezel bottom until the pins snap into the mounting holes 2, as shown in Figure 9 on page 27.
Assigning IP addresses to hosts and controllers

If you plan to manage your storage subsystem using the direct-management method, assign a unique IP address for every controller in all storage subsystems on the network. Record the IP address for each controller in the information record (Table 13 on page 89). Then, go to “Setting up the DHCP or BOOTP-compatible server.”

Note: If you want to assign static IP addresses for the controllers, refer to the IBM support Web site for Retain Tip #H171389 Unable to setup networking without DHCP/BOOTP. Then, go to “Verifying the TCP/IP protocol and setting up the host or DNS table” on page 37.

If you plan to manage your storage subsystem using the host-agent management method, assign an IP address for each host on which you will install the host-agent software. Record the IP address for each host in the information record (Table 13 on page 89). Then, go to “Verifying the TCP/IP protocol and setting up the host or DNS table” on page 37.

Setting up the DHCP or BOOTP-compatible server

To directly manage storage subsystems through the Ethernet connection to each controller, you will need to set up a DHCP or BOOTP-compatible server and configure the following options:

- Router/Gateway
- DNS Server
- Hostname
- DNS Domain Name

This section provides instructions for setting up a DHCP server on Windows NT, Windows 2000, and Novell NetWare, as well as instructions for setting up a UNIX BOOT server.

Note: The remote management station (RMS) and network management station (NMS) entries used in previous versions of the storage-management software are not required when using Storage Manager 8.2.
Setting up a Windows NT DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is installed on the system, go to “Setting up a DHCP server.” If a DHCP Manager is not installed, use the following installation procedure to install one.

Installing the DHCP Manager

Use the following procedure to install the DHCP Manager:

3. Click Services.
4. From the Services tab, click Add.
5. Click Microsoft DHCP Server; then, click OK.
6. Specify the path to the Windows NT Install file; then, click Continue. A dialogue windows opens, stating that a static IP address is required.
7. Click OK. The Network window opens.
8. Click Protocols.
9. Click TCP/IP Protocol; then, click Properties.
10. Verify that the IP address information is correct; then, click OK.
11. Continue to “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to its online help for additional information.

Setting up a DHCP server

Use the following procedure, along with the information you recorded in Table 13 on page 89 to set up a DHCP server.

1. Click Start → Programs → Administrative Tools → DHCP Manager. The DHCP Manager window opens.
2. Create a scope. A scope defines a group of TCP/IP addresses that you want the DHCP server to use to assign to the controllers.
   a. Click Local Machine.
   b. Click Scope → Create. The Create Scope - (Local) window opens.
c. Type the starting and ending IP addresses of the controllers that you are configuring for the network.
   For example, if you are configuring 50 controllers on a 153.79.144.0 subnet, set the starting address to 153.79.144.1 and the ending address to 153.79.144.50.

   **Note:** If each field does not contain at least three characters, press the period (.) key to advance to the next field. If you have only one controller, type its address for both the starting and ending address.

d. Type the subnet mask (obtained from your network administrator).

e. Set the Lease Duration to **Unlimited**. This makes the DHCP connection permanent.

   f. Type a scope name and comment.

g. Click **OK**.

   h. When the scope successfully completes, click **Yes** to activate it. This returns you to the DHCP Manager window.

3. Configure global scope options. Table 10 shows the global options that need to be set.

   **Table 10. Global options for a Windows NT DHCP server**

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>003</td>
<td>Router/Gateway</td>
<td></td>
</tr>
<tr>
<td>006</td>
<td>DNS Server</td>
<td></td>
</tr>
<tr>
<td>012</td>
<td>Host name</td>
<td>Unique for each controller</td>
</tr>
<tr>
<td>015</td>
<td>DNS domain name</td>
<td>For example, ibm.com</td>
</tr>
<tr>
<td>165</td>
<td>Network Management Station</td>
<td>Defines where the controller should send SNMP alerts</td>
</tr>
</tbody>
</table>

   You can apply options to specific controllers later using step 5 on page 31.

   a. Click **DHCP Options → Global**. The DHCP Options: Global window opens.
b. To make a global option active, select an item in the Unused Options list; then, click **Add** to move it to the Active options list.

c. Click **Value** to assign a value to the active option.

If the **Value** field is not available, click **Edit Array**; the Edit Array Editor window opens. Do one of the following:

- If you need to add an IP address, complete the following procedure:
  1) Click **Edit Array**. The IP Address Array Editor window opens.
  2) Type a unique IP address for the option that you added.
  3) Click **Add** to move the New IP Address to the IP Addresses list.
  4) Click **OK**. This returns you to the DHCP Options: Global window.

- If you do not need to add an IP address, click **Cancel**. This returns you to the DHCP Options: Global window.

d. Repeat step b through step c until all global options are added.

e. When you finish adding the Global Scope Options, click **OK** at the DHCP Options: Global window.

4. Create a reservation for each controller. Use the information record (Table 13 on page 89) to make sure that you include all of the controllers on the network.

   a. Click **Scope** → **Add Reservations**.

   b. In the **IP Address** field, type the IP address for the first controller on your data sheet.

   c. In the **Unique Identifier** field, type the controller hardware Ethernet address. Do not type decimal points or spaces.
d. In the **Client Name** field, type the controller eight-character name.

e. Click **Add**.

f. Repeat step 4b on page 30 through step 4e on page 31 for each controller that is listed on information record (Table 13 on page 89).

g. When you finish adding the information for all of the controllers, click **Close**. This returns you to the DHCP Manager window.

5. Configure controller-specific options. By creating a controller-specific option, you can associate a controller configuration entry with a specific controller.

   **Note:** If you set an option as **Global Scope**, it applies to every controller in this group and does not need to be added again.

   a. Click **Scope → Active Leases**. The Active Leases window opens.

   b. Select a controller in the list.

   c. Click **Properties**. The Add Option Type window opens. The Unique Identifier is the hardware Ethernet address from step 4c.

   d. Click **Options**. The DHCP Options: Reservations window opens.

   e. Select an option from the Unused Options list, and click **Add** to move it to the Active Options list.

   f. Click **Value** to assign a value to the active option.
g. Type the information for the value of the option. For example, type the host name for the controller from your information record (Table 13 on page 89) in the String field. Click Edit if the value that you need to add is an IP address for a router.

h. Repeat step 5e on page 31 through step 5g until you finish adding specific options for this controller.

i. Click OK. This returns you to the Add Option Type window.

j. Click OK. This returns you to the Active Leases window.

k. Repeat step 5b on page 31 through step 5i until you finish adding controller-specific options for every controller.

l. Click OK on the Active Leases window. This returns you to the DHCP Manager window.

6. Continue with “Verifying the TCP/IP protocol and setting up the host or DNS table” on page 37.

Setting up a Windows 2000 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is installed on the system, go to “Setting up a DHCP server”.

Installing the DHCP Manager

To install the DHCP Manager, do the following:


2. In the left pane, double-click Networking; then, click DHCP.

3. In the right pane, click Start. The Windows Components Wizard starts.

4. In the Components field, select Networking Services; then, click Details. The Networking Services window opens.

Note: Do not select the check box; you do not want to install all of the Networking Services subcomponents.

5. In the Subcomponents of Networking Services field, select Dynamic Host Configuration Protocol (DHCP).

6. Click OK; the Windows Components Wizard window opens.

7. Click Next to start the installation process.

8. If prompted, type the full path to the Windows 2000 distribution files and click Continue.

9. When the installation has successfully completed, the Windows Components Wizard window close, and the Configure Your Server Window opens.

10. Click Next.

11. Click Open the DHCP Manager. The DHCP window opens.

12. Continue with step 2 on page 33 of “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to the DHCP Manager online help for additional information.

Setting up a DHCP server

Use the following procedure to create a scope and to set up a DHCP server. A scope defines a group of controllers by their IP addresses. You must create and configure a scope so that dynamic IP addresses can be assigned to controllers on your network. Refer to the information record (Table 13 on page 89). Before you
begin, read through the instructions to determine what information is required; then, request the information from your network administrator.

1. Click **Start → Programs → Administrative Tools → DHCP**. The DHCP window opens.

2. In the Console tree, right-click the server you want to configure; click **New Scope**. The New Scope Wizard starts.

3. Follow the on-screen instructions to define the scope of IP addresses for TCP/IP clients. You will define the following:
   a. Scope name and description
   b. IP address range for the subnet mask, and the controllers you are configuring.

4. When you have defined the scope, click **Yes, I want to activate this scope now**. The wizard ends, and the DHCP window appears.

5. In the Console tree, open the scope folder.

6. Right-click **Reservations**; then, select **New Reservations**. The New Reservations window opens.

7. To define the IP address reservation, type the following information:
   a. Reservation name
   b. IP address
   c. Ethernet hardware MAC address
   d. Description

8. In the **Supported Type** field, select **Both (DHCP and BOOTP)**.

9. Click **Add**.

10. Repeat steps 5 through 9 for each controller in the network.
11. Restart the DHCP server and then restart the storage subsystem so that all modifications are applied.

12. Go to "Verifying the TCP/IP protocol and setting up the host or DNS table" on page 37.

Setting up a NetWare DHCP server

A NetWare DHCP server automatically assigns IP addresses and other configuration information to clients upon request or when the clients are restarted.

To set up a NetWare DHCP server, you must complete the following tasks:
1. Install DNS/DHCP Services, either during or after installing NetWare 5.
2. Install the DNS/DHCP Management Console.
3. Create the DHCP server object.
4. Create the subnet address.
5. Create the subnet address range.
6. Create the IP address object.
7. Start the DHCP server.

Installing NetWare 5.1 with DNS/DHCP Services

This section contains instructions for adding Novell DNS/DHCP services during and after the NetWare 5.1 installation.

Adding Novell DNS/DHCP Services during the NetWare 5.1 installation: Do the following to add Novell DNS/DHCP Services during the Netware 5.1 installation:
1. From the Installation Options window, select Custom.
2. From the Components window, select the Novell DNS/DHCP Services check box.
3. Follow the on-screen instructions to complete the NetWare 5.1 installation.

Adding Novell DNS/DHCP Services after the NetWare 5.1 installation: Do the following to add Novell DNS/DHCP Services after the Netware 5.1 installation:
1. Insert the NetWare 5.1 Installation CD into the CD-ROM drive; then, mount the CD as a volume.
2. Load NWCONFIG and select Product Options.
3. Select Install a Product not Listed.
4. Press F3 and specify the volume name of the CD. The X Server-Graphical Console window opens.
5. In the Additional Products and Services dialog box, select the Novell DNS/DHCP Services check box.
6. Follow the on-screen instructions to complete installation.

Note: Installing the DNS/DHCP Service will extend the Novell Directory Services (NDS) schema and create the following NDS objects:
- DNSSDHCP-GROUP Group object
- DNS/DHCP Locator object
- RootServerInfo Zone object

Installing the DNS/DHCP Management Console

Do the following to install the DNS/DHCP Management Console and NetWare Administrator snap-in files on the client workstation you will use to administer DNS and DHCP:
1. If you have not done so, install the latest version of Novell Client 32 on your workstation.
2. From the workstation, run the SYS:PUBLIC\DNSDHCP\SETUP.EXE program.
3. Install the DNS/DHCP Management Console on the local hard-disk drive.
4. Install the NetWare Administrator snap-in files in the SYS:PUBLIC\WIN32 directory.
5. Restart the workstation.
6. To start the DNS/DHCP Management Console, double-click the shortcut icon on the desktop, enter the NDS Tree NAME, and click Launch.

**Note:** You can install the DNS/DHCP Management Console on a workstation, or you can access it from the Tools menu of the NetWare Administrator utility.

### Creating the DHCP server object
Use the DHCP Management Console to create a DHCP server object. A DHCP server object can be created under any of the following objects:
- Organization (O)
- Organization Unit (OU)
- Country (C)
- Locality (L)

Do the following to create a DHCP server object:
1. From the DHCP Management Console, click the **DHCP Service** tab.
2. In the left pane, select **Our Network**.
3. Click Create. The Create New DHCP Object window opens.
4. Select **DHCP Server**; then, click OK. The Create DHCP Server window opens.
5. Select a server; then, click Create. This creates the DHCP server object in NDS, called DHCP_servername.
6. In the DHCP Management Console, locate the icon for the DHCP server object at the bottom of the DHCP Service tab. The server object is displayed with a red line through it. The red line indicates that DHCP server has not been started.
7. Continue with "Creating a subnet object"

### Creating a subnet object
You must do the following to create a DHCP subnet object for each of the subnets for which you want to assign addresses:
1. In the DNS/DHCP Management Console, click the **DHCP Service** tab.
2. Select **Our Network** or the **DHCP Server Object**.
3. Click Create. The Create New DHCP Object window opens.
4. Select **Subnet**; then, click OK. The Create Subnet window opens.
5. For each subnet, type the following information:
   - Subnet name
   - NDS context
   - Subnet address
   - Subnet mask
   - Default DHCP Server
6. Click Create. The DHCP subnet object is created and displayed in the DNS/DHCP Management Console.
Creating subnet address ranges
Do the following to create a subnet address range object:
1. From the DNS/DHCP Management Console, click the **DHCP Service** tab.
2. Select the subnet object under which you want to create the subnet address range object; then, click **Create**. The Create New DHCP Record window opens.
3. Select **Subnet Address Range**; then, click **OK**. The Create New Subnet Address Range window opens.
4. Type the following information for the subnet address range:
   - Subnet address range name
   - Starting address
   - Ending address
5. Click **Create**.
6. Select the **Define Additional Properties** check box; then, set the Range Type to **Dynamic BOOTP and DHCP**.

Creating IP address objects
Use the DNS/DHCP Management Console to create IP address objects. IP address objects are used for the following purposes:
- To exclude an IP address from assignment
- To assign an IP address manually to a specific host
- To record dynamic IP address leases

Do the following to create an IP address object:
1. From the DNS/DHCP Management Console, click the **DHCP Service** tab.
2. Select the subnet object of the target IP address; then, click **Create**.
3. Select **IP Address**; then, click **OK**. The Create IP Address window opens.
4. In the **IP Address** field, type the IP address for the first controller.
5. In the **Assignment** field, select **Manual**.
6. In the **Client Identifier** field, specify the MAC address.
7. In the **MAC Address** field, enter the hardware Ethernet MAC address for the controller.
8. Select the **Define Additional Properties** check box.
9. In the **Hostname field**, type the eight-character name for the controller.
10. In the **Usage** field, select **Permanent**.
11. Repeat step 3 through step 10 for each controller.

Starting the DHCP server
To start the DHCP server, at the DHCP server console, type:

```plaintext
LOAD DHCPSRVR
```

The DHCP server can now respond to client requests and assign IP addresses.

**Notes:**
1. To load the DHCP server automatically each time the server starts, place the DHCPSRVR command in the SYS\SYSTEM\AUTOEXEC.NCF directory.
2. For additional information about setting up, configuring, or using Novell DNS/DHCP Services, refer to the NetWare 5.1 documentation, located on the Novell Documentation CD or at [http://www.novell.com/documentation](http://www.novell.com/documentation) Web site.
Setting up a UNIX BOOTP server

To use a UNIX BOOTP server, you must set up a BOOTP table. Table 11 and the information record (Table 13 on page 89) provide the necessary information.

### Table 11. Required entries for setting up the UNIX BOOTP server

<table>
<thead>
<tr>
<th>Entry</th>
<th>Description</th>
<th>Sample format in BOOTP server</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subnet mask</td>
<td>Mask that is used to route packets to defined subnets</td>
<td>dot notation (sm=255.255.0.0)</td>
</tr>
<tr>
<td>Router</td>
<td>IP address of the host computer that routes packets to networks</td>
<td>dot notation (gw=192.168.128.1)</td>
</tr>
<tr>
<td>Host name for the controller</td>
<td>Host name that is associated with the controller (refer to Table 13 on page 89)</td>
<td>host name (Denver_a)</td>
</tr>
<tr>
<td>IP address</td>
<td>IP address of the controller (refer to Table 13 on page 89)</td>
<td>dot notation (ip=192.168.128.101)</td>
</tr>
<tr>
<td>Ethernet address</td>
<td>The Ethernet address of the controller hardware (refer to Table 13 on page 89)</td>
<td>hexadecimal notation (ha=00a0b8020420)</td>
</tr>
</tbody>
</table>

To set up a UNIX BOOTP server, do the following:

1. Use a text editor to edit the bootptab file in the /etc directory.

   The following is an example of the BOOTP table used to configure the Network A server shown in Figure 6 on page 23:

   ```plaintext
   s4.default: (common settings)
   ht=ether: 
   sm=255.255.255.0: 
   gw=192.168.128.1: 
   hn: 
   denver_a: 
   tc=s4.default: (common settings)
   ip=192.168.128.101: 
   ha=00a0b8020420: 
   denver_b: 
   tc=s4.default: 
   ip=192.168.128.102: 
   ha=00a0b80000d8: 
   ```

   where the s4.default:\ entry denotes settings that are common to all controllers, and the tc=s4.default:\ entry associates this common setting group to a specific controller.

2. If the storage subsystem is running, shut down and then restart the subsystem. This will ensure that the parameters in the BOOTP table take effect.

3. Continue with “Verifying the TCP/IP protocol and setting up the host or DNS table”

### Verifying the TCP/IP protocol and setting up the host or DNS table

Use the following procedure to verify that the TCP/IP protocol software is installed on the management station and to set up the host or DNS table.
Note: Make sure that the host names for the controller match the IP addresses for the controllers.

For Windows NT, do the following:

1. Right-click Network Neighborhood.
3. Click the Protocols tab. If the TCP/IP protocol entry does not appear in the Network Products box, click Add. The Select Network Protocol window opens.
5. Click OK; then, follow the on-screen instructions to install the TCP/IP protocol.
6. Update the DNS table to specify a host name to associate with an IP address.

For Windows 2000, do the following:

1. Right-click My Network Places.
2. Select Properties. The Network and Dial-up Connections window opens.
3. Right-click on a defined network connection.
4. Select Properties. Make sure that the Internet Protocol TCP/IP box under the Components checked that are used by this connection is marked. If not, mark it, click Install and follow the instructions that display.
5. Update the DNS table to specify a host name to associate with an IP address.

If you do not have a DNS server, use a text editor to update the hosts file to link the IP address and controller name entries. The following is an example of the host tables for the controllers connected to Network A as shown in Figure 6 on page 23.

```
# Copyright (c) 1993-1999 Microsoft Corp.
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should be placed
# in the first column followed by the corresponding host name. The IP address
# and the host name should be separated by at least one space.
# Additionally, comments (such as these) might be inserted on individual
# lines or following the machine name denoted by a '# symbol.
# For example:
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host
127.0.0.1 local host
192.168.128.101 denver_a
192.168.128.102 denver_b
```

7. If you want to manage storage subsystems through a firewall, configure the firewall to open port 2463 to TCP data.
# lines or following the machine name denoted by a '#' symbol.
# For example:
# 102.54.94.97  rhino.acme.com  # source server
# 38.25.63.10   x.acme.com    # x client host
127.0.0.1      local host
192.168.128.101 denver_a
192.168.128.102 denver_b

6. To manage storage subsystems through a firewall, configure the firewall to open port 2463 to TCP data.
Chapter 3. Installing software in a standard configuration

This chapter describes how to install the storage-management software in a standard (noncluster) configuration. If you intend to configure your system for clustering, go to Chapter 4, “Installing software in a cluster server environment” on page 49.

If you have existing storage systems, make sure you have read “Installation types” on page 11 and “Managing coexisting storage subsystems” on page 14. Both sections are located in Chapter 1, “Introduction” on page 1.

To ensure proper installation, make sure you have completed all preparation tasks described in Chapter 2, “Preparing for installation” on page 21.

Important: Always check for a README file on any installation media. The README file might contain important information that was not available when the Installation and Support Guide was prepared.

New installation process

The Storage Manager 8.2 software components must be installed on both host computers and management stations.

Management station: A management station is a system that is used to manage the storage subsystem. It can be attached to the storage subsystem in the following ways:

- Through a TCP/IP Ethernet connection to the controllers in the storage subsystem
- Through a TCP/IP network connection to a host computer with host-agent software installed on it, which in turn is directly attached to the storage subsystem through the Fibre Channel input/output (I/O) path

You must install storage-management software on a management station in the following order:
1. Microsoft Virtual Machine (Windows NT 4.0 only)
2. Storage Manager 8.2 Client

Host computer: A host computer (or host) is a system that is directly attached to the storage subsystem through a Fibre Channel I/O path.

You must install storage management software on each host computer in the following order:
1. Microsoft Virtual Machine (Windows NT 4.0 only)
2. Storage Manager 8.2 Client
3. Redundant Disk Array Controller
4. Storage Manager 8.2 Agent
5. Storage Manager 8.2 Utility

If you are installing the Storage Manager software on a Windows NT platform, see “Microsoft Virtual Machine” on page 42 to begin the installation.

If you are installing the Storage Manager software on a Windows 2000 platform, see “Storage Manager 8.2 Client” on page 42 to begin the installation.
Microsoft Virtual Machine

On Windows NT, Microsoft Virtual Machine is required to support the following components:

- Event Monitor option of Storage Manager 8.2 Client
- Storage Manager 8.2 Agent

To install Microsoft Virtual Machine on management stations and host computers running Windows NT 4.0, do the following:

1. Close all programs.
2. Insert the IBM FAStT Storage Manager Version 8.2 CD into the CD-ROM drive.
3. Click Start → Run. The Run window opens.
4. Click Browse. The Browse window opens.
5. Select the CD-ROM drive.
6. Select the \Win32\MSVM\NT folder; then, click Open.
7. Select the MSJavx86-3805.exe file; then, click Open, and follow the instructions on the screen. The Setup Complete window opens.
8. Click No, do not restart the system at this time. Click Finish.
9. Continue with Storage Manager 8.2 Client.

Storage Manager 8.2 Client

This section provides instructions for installing Storage Manager 8.2 Client on management stations and host computers.

Before you install the software, make sure that:

- The management station or host computer has at least 40 MB of available disk space.
- (Windows NT only) Microsoft Virtual Machine software has been installed on the device.

Important: When you install Storage Manager 8.2 Client on a stand-alone host and manage storage subsystems through the Fibre Channel I/O path rather than through the network, you must install the TCP/IP software on the host and assign an IP address to the host.

Installing Storage Manager 8.2 Client

To install Storage Manager 8.2 Client, do the following:

1. Insert the IBM FAStT Storage Manager Version 8.2 CD into the CD-ROM drive.
2. Click Start → Run. The Run window opens.
3. Click Browse. The Browse window opens.
4. Select the CD-ROM drive.
5. Select the \Win32\SMclient folder; then, click Open.
6. Select the setup.exe file; then, click Open. The InstallShield Wizard window opens. The Welcome window opens.
7. Click Next. The End User License Agreement (EULA) window opens.

Note: For Windows NT 4.0, ensure that the Microsoft Virtual Machine is installed before you install the Event Monitor.
8. Read the license agreement and click Yes. The Event monitor window opens.
9. At the prompt, click Yes if you want to install the Event Monitor. The Choose Destination Location window opens.
10. Click Browse to change the destination location.
11. Click Next to start the installation. When the installation is complete, the Operation Complete window opens.
12. Click Finish.
13. Continue with "Verifying the Storage Manager 8.2 Client installation"

Verifying the Storage Manager 8.2 Client installation
To verify that Storage Manager 8.2 Client is installed correctly, do the following:
1. Click Start → Programs.
2. Verify that IBM FASiT Storage Manager 8 Client appears in the Program list. If the IBM FASiT Storage Manager 8 Client appears, go to step 3. Otherwise, repeat "Installing Storage Manager 8.2 Client" on page 42. If the IBM FASiT Storage Manager 8 Client still does not appear, a failure has occurred. Contact your IBM technical-support representative.
3. If you installed the optional Event Monitor service, go to "Verifying the Event Monitor installation". Otherwise, continue to step 4.
4. If you are installing Storage Manager 8.2 Client on a host computer, go to "Redundant Disk Array Controller" on page 44. Otherwise, go to Chapter 5, "Completing the installation" on page 67.

Verifying the Event Monitor installation
This section provides instructions for verifying that the Event Monitor service has been installed correctly on Windows NT and Windows 2000.

Windows NT 4.0
To verify that the Event Monitor service has been installed correctly, do the following:
1. Click Start → Settings → Control Panel. The Control Panel window opens.
3. Verify that the IBM FASiT Storage Manager 8 Event Monitor service is displayed with the status Started. If it is not, click Start. If the service does not start, reinstall the Storage Manager 8.2 Client. If the failure persists, call your IBM technical-support representative.
4. If you are installing the storage-management software on a host computer, go to "Redundant Disk Array Controller" on page 44. Otherwise, go to Chapter 5, "Completing the installation" on page 67.

Windows 2000
To verify that the Event Monitor service has been installed correctly, do the following:
1. Click Start → Programs → Administrative Tools → Services. The Services window opens.
2. Verify that the Storage Manager 8 Event Monitor service is displayed with the startup type Automatic and status Started. If it is not, click Start. If it does not start, reinstall the Storage Manager 8.2 Client. If the failure persists, call your IBM technical-support representative.
3. If you are installing the storage-management software on a host computer, go to
   “Redundant Disk Array Controller” Otherwise, go to Chapter 5, ”Completing the
   installation” on page 67

Redundant Disk Array Controller

RDAC must be installed on each host computer. RDAC contains the multipath
device driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
• You have Administrator privileges on the host computer.
• The host computer has at least 1 MB of available disk space.
• All programs are closed.

If you are installing RDAC on Windows NT 4.0, continue with “Assigning static drive
letters”

If you are installing RDAC on Windows 2000, continue with “Installing the
Redundant Disk Array Controller” on page 45

Assigning static drive letters

Important:
Before installing RDAC, you must assign static drive letters to existing local drives.
Otherwise, problems might occur during new installations and upgrades. When RDAC is
installed, the RDAC utility installs the RDAC device driver before the Windows NT class
driver. If static drive letters have not previously been assigned to local drives, the system
will detect storage subsystem arrays and assign them drive letters before detecting and
assigning drive letters to local drives. If you have software applications using
non-permanent drive letters that are assigned to local drives, and this occurs application
errors will result.

Use the following procedure to manually assign static drive letters on host
computers running Windows NT 4.0:
1. Determine how many partitions are on the system. Click Start → Programs →
   Administrative Tools → Disk Administrator to view the disk configuration and
   check the number of partitions.
2. Check that the following conditions are met:
   • A boot partition exists.
   • The last partition has been created with Disk Administrator or Disk
     Management.
   • The partition has an assigned drive letter with either an unknown status or a
     status other than Unformatted.

   If all conditions are met, go to "Installing the Redundant Disk Array Controller"
on page 45. Otherwise, continue to step 3
3. Create a new partition on your local system or on a storage subsystem using
   the following procedure:
   a. Select a drive with free space; then, click Partition → Create. The partition is
      created with a status of Unformatted and a drive letter is assigned. You can
      delete or change the logical drive at a later time without causing
      reassignment of the boot partition.
b. Click **Partition → Commit Changes Now**. The partition status changes to Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with "Installing the Redundant Disk Array Controller"

### Installing the Redundant Disk Array Controller

To install RDAC, do the following:

1. Insert the *IBM FASiT Storage Manager Version 8.2* CD into the CD-ROM drive.
2. Click **Start → Run**. The Run window opens.
3. Click **Browse**. The Browse window opens.
4. Select the CD-ROM drive.
5. Select one of the following directories:
   - For Windows NT 4.0: `\Win32\SMrdac\NT`
   - For Windows 2000 Server or Professional: `\Win32\SMrdac\W2K`
6. Select the setup.exe file; then, click **Open**. The InstallShield Wizard window opens. The Welcome window opens. Click **Next**. The End User License Agreement (EULA) window opens.
7. Click **Yes** to start the installation. After installing RDAC, the InstallShield Wizard Complete window opens.
8. Select **Yes I want to restart my computer now**; then, click **Finish**.
9. Continue with "Verifying the RDAC installation".

### Verifying the Redundant Disk Array Controller installation

This section provides instructions for verifying that RDAC has been installed correctly on a Windows NT 4.0 and a Windows 2000 operating system.

#### Windows NT 4.0

To verify that RDAC has been installed correctly, do the following:

**Note:** Make sure that all storage subsystems are connected to the host computer and are powered on.

1. Click **Start → Settings → Control Panel**. The Control Panel window opens.
2. Double-click **Devices**. The Devices window opens.
3. Scroll to symarray.
   - If symarray appears with a device status of Started, go to step 4.
   - If symarray does not appear, an error might have occurred. Repeat the procedure outlined in "Installing the Redundant Disk Array Controller". If the failure persists, call your IBM technical-support representative. Otherwise, go to step 4.
4. Do one of the following:
   - If you are managing the storage subsystems using the host-agent method, continue with "Storage Manager 8.2 Agent" on page 46.
   - If you are managing your storage subsystems directly, go to "Storage Manager 8.2 Utility" on page 48.

#### Windows 2000

To verify that RDAC has been installed correctly, do the following:

1. Right-click **My Computer**.
2. Click Start → Programs → Administrative Tools → Computer Management. The Computer Management window opens. Go to the \System Tools\Software Information\Software environment\drives directory.

3. Scroll through the list of device drivers until you find rdacfltr.

4. Verify that rdacfltr is displayed with the state type Running and status OK. If it is not, repeat the procedure outlined in “Installing the Redundant Disk Array Controller” on page 45. If the failure persists, call your IBM technical-support representative. Otherwise,
   - If you are managing the storage subsystems using the host-agent method, continue with “Storage Manager 8.2 Agent”.
   - If you are managing your storage subsystems using the direct-management method, go to “Storage Manager 8.2 Utility” on page 48.

---

**Storage Manager 8.2 Agent**

The Storage Manager 8.2 Agent software *must* be installed if you want to manage the storage subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:
- You have Administrator privileges on the host computer.
- The host computer has at least 1 MB of available disk space.
- RDAC is installed on each host computer. If not, refer to “Redundant Disk Array Controller” on page 44.
- (For Windows NT 4.0) Microsoft Virtual Machine is installed (refer to “Microsoft Virtual Machine” on page 42).
- All storage subsystems are connected to the host computer and are powered on.

**Installing Storage Manager 8.2 Agent**

To install Storage Management 8.2 Agent, do the following:

1. Close all programs.
2. Insert the IBM FAStT Storage Manager Version 8.2 CD in the CD-ROM drive.
3. Click Start → Run. The Run window opens.
4. Click Browse. The Browse window opens.
5. Select the CD-ROM drive.
6. Select the \Win32\SMagent folder; then, click Open.
7. Select the setup.exe file; then, click Open. The InstallShield window opens, showing the status the file unpacking. The Welcome window opens.
8. Click Next. The End User License Agreement (EULA) window opens.
9. Read the license and click Yes to begin the installation. The software installation ends, and the Operation Complete window opens.
10. Click Finish.
11. Continue with “Verifying the Storage Manager 8.2 Agent installation”.

**Verifying the Storage Manager 8.2 Agent installation**

This section provides instructions for verifying that Storage Manager 8.2 Agent has been installed correctly on Windows NT 4.0 and Windows 2000.

**Windows NT 4.0**

To verify that Storage Manager 8.2 Agent has been installed correctly, do the following:
1. Click **Start** → **Settings** → **Control Panel**. The Control Panel window opens.
2. Double-click **Services**. The Services window opens.
3. Scroll through the list of services until you find IBM FASiT Storage Manager 8 Agent.
   - If IBM FASiT Storage Manager 8 Agent appears with a startup type of Started, close the Services window and continue to step 4.
   - If IBM FASiT Storage Manager 8 Agent does not appear with a startup type of Started, click **Start**. If the status changes to Started, go to step 4. If not, refer to Table 12 on page 83 for a possible cause. Otherwise, reinstall IBM FASiT Storage Manager 8.2 Agent. If the problem persists, contact your IBM technical-support representative.
4. Do one of the following:
   - If you plan to use the host-agent software to manage one or more storage subsystems, go to **Storage Manager 8.2 Utility** on page 48.
   - If you do not plan to use the host-agent software to manage one or more storage subsystems, do the following to disable the host-agent service:
     a. Click **Start** → **Settings** → **Control Panel**. The Control Panel window opens.
     b. Double-click **Services**. The Services window opens.
     c. From the list of displayed services, right-click **IBM FASiT Storage Manager 8.0 Agent**.
     d. Click **Properties** → **Startup Type** → **Manual**.
     e. Click **OK**.
5. Continue with **Storage Manager 8.2 Utility** on page 48

**Windows 2000**
To verify that Storage Manager 8.2 Agent has been installed correctly, do the following:

**Note:** Make sure that all storage subsystems are connected to the host computer and are powered on.
1. Click **Start** → **Programs** → **Administrative Tools** → **Services**. The Services window opens.
2. Scroll through the list of services until you find IBM FASiT Storage Manager 8 Agent.
3. If IBM FASiT Storage Manager 8 Agent does not appear with a startup type of Started, click **Start**. If the status changes to Started, go to step 4. If not, refer to Table 12 on page 83 for a possible cause. Otherwise, reinstall IBM FASiT Storage Manager 8.2 Agent. If the problem persists, contact your IBM technical-support representative.
4. Do one of the following:
   - If you plan to use the host-agent software to manage one or more storage subsystems, go to **Storage Manager 8.2 Utility** on page 48.
   - If you do not plan to use the host-agent software to manage one or more storage subsystems, do the following to disable the host-agent service:
     a. Click **Start** → **Programs** → **Administrative Tools** → **Computer Management**. The Computer Management window opens.
     b. Click **Services**.
     c. From the list of displayed services, right-click **IBM FASiT Storage Manager 8 Agent**.
     d. Click **Properties** → **Startup Type** → **Manual**.
Storage Manager 8.2 Utility

This section provides instructions for installing Storage Manager 8.2 Utility on host computers. This component contains utilities that will register and map new logical drives to the operating systems.

Installing Storage Manager 8.2 Utility

To install Storage Manager 8.2 Utility, do the following:
1. Close all programs and insert the IBM FAStT Storage Manager Version 8.2 installation CD in the CD-ROM drive.
2. Click Start → Run. The Run window opens.
3. Click Browse. The Browse window opens.
4. Select the CD-ROM drive.
5. Select the \Win32\SMutil folder; then, click Open.
6. Select the setup.exe file; then, click Open. The InstallShield Wizard window opens, displaying the status of the files unpacking. The Welcome window opens.
7. Click Next.
8. The End User License Agreement (EULA) window opens. Click Yes to begin the installation. After the installation is complete, the Operation Complete window opens.
9. Click Finish.
10. Continue with “Verifying the Storage Manager 8.2 Utility installation”.

Verifying the Storage Manager 8.2 Utility installation

To verify that Storage Manager 8.2 Utility has been installed correctly, do the following:
1. Go to the following directory:

   \installation_directory\IBM_FAStT\Util

   where \installation_directory\ is the directory where you installed the Storage Manager 8.2 Utility.
2. Verify that the directory contains the following files:
   - hot_add.exe
   - SMdevices.bat
   - SMflashcopyassist.exe

   If it does not, reinstall the Storage Manager 8.2 Utility using the procedure outlined in “Installing Storage Manager 8.2 Utility” If the problem persists contact your IBM technical-support representative.
Chapter 4. Installing software in a cluster server environment

This chapter describes how to install the storage-management software in a cluster server environment.

The installation process you will use depends on your storage subsystem environment. If you have existing storage systems, read “Installation types” on page 11 and “Managing coexisting storage subsystems” on page 14.

To ensure proper installation, complete all preparation tasks described in Chapter 2, “Preparing for installation” on page 21.

If upgrading from a previous version of IBM FASTT Storage Manager on a existing cluster, go to “Upgrading from a previous version of the storage-management software” on page 60.

Important: Always check for a README file on any installation media. A README file might contain important information that was not available when the Installation and Support Guide was prepared.

Installing the hardware

The hardware installation involves installing host adapters and storage subsystems. Before you begin the installation of Storage Manager 8.2, make sure that all hardware components are installed correctly for the cluster server configuration.

Configuration options

You can connect the storage subsystem to the cluster nodes either directly or through Fibre Channel switches. Both configurations offer full redundancy. The following figure illustrates both configurations.
Host adapters

Refer to the appropriate host-adapter documentation for specific installation requirements and procedures. The following considerations apply:

- To use the dual-path configuration, do the following:
  - Install two host adapters in each node.
  - Run two fibre channel cables from each node to the storage subsystem.
- If the storage subsystem is connected through a Fibre Channel Arbitrated Loop (FC-AL), ensure that every adapter on the loop has been assigned a unique hard ID. For instructions about changing hard IDs, refer to the documentation provided with your host adapters.
- The correct device driver is installed for the host adapter. Refer to the README file in the \Host_Adapter directory on the IBM FASiT Storage Manager Version 8.2 CD for information on supported host adapters and device drivers.
Storage subsystems

Refer to the appropriate hardware documentation for specific installation requirements and procedures. If you are managing storage subsystems directly, you must connect Ethernet cables to both controllers in each storage subsystem.

Installing Storage Manager in a cluster environment

Do the following to install the storage-management and cluster service software:

1. Power down node B. Start node A.
2. Install the storage-management software on node A. Refer to “Installing the storage-management software” on page 52 for instructions.
3. Complete the procedures detailed in Chapter 5, “Completing the installation” on page 67.
4. Run the Hot Add utility on node A. Refer to “Using the Hot Add utility” on page 78 for instructions.

Note: You may have to restart node A in order to see the newly-added logical drives.

5. Format all shared logical drives as NTFS (NT File System), assign volume labels, and specify a drive letter for each.
   Important: You must assign a permanent (sticky) drive letter to the shared logical drive on both cluster nodes. The two nodes must have the same drive letters on each shared drive. If you do not assign permanent drive letters, Windows might assign different drive letters on each node. Assigning a permanent drive letter ensures that Windows assigns the same drive letter to the partition on both cluster nodes.
6. Shut down node A. Start node B.
7. Install the storage-management software on node B. Refer to “Installing the storage-management software” on page 52 for instructions.
8. To verify the drive letters for the cluster configuration, do one of the following:
   • For Windows NT, click Start → Programs → Administrative Tools → Disk Administrator.
   • For Windows 2000, do the following:
     b. Click Storage → Disk Management.
9. Verify that the following conditions are met:
   • The same logical drives appear on each cluster node.
   • Each cluster node has the same number of partitions defined on the logical drives.
   • Drive letters are assigned to the configured logical drives.
   • The drive letters on the partitions are the same on both cluster nodes.
10. Shut down node B.
11. Install the cluster server software. Refer to “Installing the cluster server software” on page 59 for instructions.
Installing the storage-management software

Before you begin an installation with existing storage subsystems, refer to your hardware installation documentation for the specific configuration. A specific configuration might be required for your hardware to support the storage-management software in a cluster configuration.

The Storage Manager 8.2 software components must be installed on both management stations and cluster nodes.

Management station: A management station is a system that is used to manage the storage subsystem. It can be attached to the storage subsystem in the following ways:

- Through a TCP/IP Ethernet connection to the controllers in the storage subsystem
- Through a TCP/IP network connection to a cluster node with the host-agent software installed

You must install storage-management software on a management station in the following order:
1. Microsoft Virtual Machine (Windows NT 4.0 only)
2. Storage Manager 8.2 Client

Cluster node: The cluster nodes are directly attached to the storage subsystem through a Fibre Channel I/O path.

You must install storage management software on each cluster node in the following order:
1. Microsoft Virtual Machine (Windows NT 4.0 only)
2. Storage Manager 8.2 Client
3. Redundant Disk Array Controller
4. Storage Manager 8.2 Agent
5. Storage Manager 8.2 Utility

If you are installing the Storage Manager software on a Windows NT platform, see "Installing the Microsoft Virtual Machine" to begin the installation.

If you are installing the Storage Manager software on a Windows 2000 platform, see "Storage Manager 8.2 Client" on page 53 to begin the installation.

Installing the Microsoft Virtual Machine

On Windows NT, Microsoft Virtual Machine is required to support the following components:

- Event Monitor option of Storage Manager 8.2 Client
- Storage Manager 8.2 Agent

To install Microsoft Virtual Machine on management stations or cluster nodes, do the following:
1. Close all programs.
2. Insert the IBM FAStT Storage Manager Version 8.2 CD into the CD-ROM drive.
3. Click Start → Run. The Run window opens.
4. Click **Browse**. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\MSVM\NT folder; then, click **Open**.

7. Select the MSJava86-3805.exe file; then, click **Open**.

8. Click **Finish** and follow the instructions on the screen. When the software is installed, the Setup Complete window opens.

9. Click **No, do not restart the system at this time**.

10. Continue with "Storage Manager 8.2 Client".

---

**Storage Manager 8.2 Client**

This section provides instructions for installing Storage Manager 8.2 Client on management stations and cluster nodes.

Before you install the software, make sure that:

- The management station or host computer has at least 40 MB of available disk space.
- All programs are closed.
- For Windows NT systems, that the Microsoft Virtual Machine software has been installed on the device. Refer to "Installing the Microsoft Virtual Machine" on page 52.

**Important:** When you install Storage Manager Client on a stand-alone host and manage storage subsystems through the Fibre Channel I/O path rather than through the network, you must install the TCP/IP software on the host and assign an IP address to the host.

---

**Installing Storage Manager 8.2 Client**

To install Storage Manager 8.2 Client, do the following:

1. Insert the *IBM FASIt Storage Manager Version 8.2* CD into the CD-ROM drive.

2. Click **Start → Run**. The Run window opens.

3. Click **Browse**. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the \Win32\SMclient folder; then, click **Open**.

6. Select the setup.exe file; then, click **Open**. The InstallShield Wizard window opens. The Welcome window opens.

7. Click **Next**. The End User License Agreement (EULA) window opens.

   **Note:** For Windows NT 4.0, ensure that the Microsoft Virtual Machine is installed before you install the Event Monitor.

8. Read the license agreement and click **Yes**. The Event monitor window opens.

9. At the prompt, click **Yes** if you want to install the Event Monitor. The Choose Destination Location window opens.

10. Click **Browse** to change the destination location.

11. Click **Next** to start the installation. When the installation is complete, the Operation Complete window opens.

12. Click **Finish**.

13. Continue with "Verifying the Storage Manager 8.2 Client" on page 54.
Verifying the Storage Manager 8.2 Client
This section provides instructions for verifying that Storage Manager 8.2 Client has been installed correctly.

Do the following to verify that the Storage Manager 8.2 Client software is installed correctly:
1. Click Start → Programs.
2. Verify that IBM FASIT Storage Manager 8 Client appears in the Program list. If the IBM FASIT Storage Manager 8 Client appears, go to step 3. Otherwise, repeat “Installing Storage Manager 8.2 Client” on page 53. If the IBM FASIT Storage Manager 8 Client still does not appear, a failure has occurred. Contact your IBM technical-support representative.
3. If you installed the optional Event Monitor service, go to “Verifying the Event Monitor installation” on page 54. Otherwise, continue to step 4.
4. If you are installing Storage Manager 8.2 Client on a host computer, go to “Redundant Disk Array Controller” on page 56. Otherwise, go to Chapter 5, “Completing the Installation” on page 67.

Verifying the Event Monitor installation
This section provides instructions for verifying that the IBM FASIT Event Monitor service has been installed correctly on the following operating systems:
- Windows NT 4.0
- Windows 2000

Windows NT 4.0: To verify that the IBM FASIT Event Monitor service has been installed correctly, do the following:
1. Click Start → Settings → Control Panel. The Control Panel window opens.
3. Verify that IBM FASIT Storage Manager 8 Event Monitor service is displayed with the status Started. If it is not, click Start. If the service does not start, reinstall the Storage Manager 8.2 Client. If the failure persists, call your IBM technical-support representative.
4. If you are installing the storage-management software on a cluster node, go to “Redundant Disk Array Controller” on page 56. Otherwise, go to Chapter 5, “Completing the Installation” on page 67.

Windows 2000: To verify that the IBM FASIT Storage Manager 8.0 Event Monitor service has been installed correctly, do the following:
1. Click Start → Programs → Administrative Tools → Services. The Services window opens.
2. Verify that the IBM FASIT Storage Manager 8.0 Event Monitor service is displayed with the startup type Automatic and status Started. If it is not, click Start. If the service does not start, reinstall the Storage Manager 8.2 Client. If the failure persists, call your IBM technical-support representative.
3. If you are installing the storage-management software on a host computer, go to “Redundant Disk Array Controller” on page 56. Otherwise, go to Chapter 5, “Completing the Installation” on page 67.

Redundant Disk Array Controller
RDAC must be installed on each cluster node. RDAC contains the multipath device driver that is necessary for controller failover support.
Before you install the software, ensure that the following conditions are met:

- You have Administrator privileges on the cluster nodes.
- Each cluster node has at least 1 MB of available disk space.
- You close all programs.

If you are installing RDAC on Windows NT 4.0, continue with "Assigning static drive letters".

If you are installing RDAC on Windows 2000, continue with "Installing the Redundant Disk Array Controller".

Assigning static drive letters

Important:

Before installing RDAC, you must assign static drive letters to existing local drives. Otherwise, problems might occur during new installations and upgrades. When RDAC is installed, the RDAC utility installs the RDAC device driver before the Windows NT class driver. If static drive letters have not previously been assigned to local drives, the system will detect storage subsystem arrays and assign them drive letters before detecting and assigning drive letters to local drives. If this occurs and you have software applications using non-permanent drive letters that are assigned to local drives, application errors will result.

Use the following procedure to manually assign drive letters on cluster nodes running Windows NT 4.0:

1. Click Start → Programs → Administrative Tools → Disk Administrator to view the disk configuration and check the number of partitions.

2. Check that the following conditions are met:
   - A boot partition exists.
   - The last partition has been created with Disk Administrator or Disk Management.
   - The partition has an assigned drive letter and either an unknown status or a status other than Unformatted.

   If all conditions are met, go to "Installing the Redundant Disk Array Controller". Otherwise, continue to step 3.

3. Create a new partition on your local system or on a storage subsystem using the following procedure:
   a. Select a drive with free space; then, click Partition → Create. The partition is created with a status of Unformatted and a drive letter is assigned. You can delete or change the logical drive at a later time without causing reassignment of the boot partition.
   b. Click Partition → Commit Changes Now. The partition status changes to Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with "Installing the Redundant Disk Array Controller".

Installing the Redundant Disk Array Controller

To install RDAC, do the following:

1. Insert the IBM FASIT Storage Manager Version 8.2 CD into the CD-ROM drive.
2. Click Start → Run. The Run window opens.
3. Click Browse. The Browse window opens.
4. Select the CD-ROM drive.
5. Select one of the following directories:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Directory Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows NT 4.0 Enterprise Edition</td>
<td>\Win32\SMrdac\NT</td>
</tr>
<tr>
<td>Windows 2000 Advanced Server</td>
<td>\Win32\SMrdac\W2K</td>
</tr>
</tbody>
</table>

6. Select the setup.exe file; then, click **Open**. The InstallShield window opens, showing the file unpacking. The Welcome window opens.

7. Click **Next** to begin the installation. After installing RDAC, the InstallShield Wizard window opens.

8. Click **Yes** to restart your computer.

9. Continue with “Verifying the RDAC installation”.

**Verifying the Redundant Disk Array Controller installation**

This section provides instructions for verifying that the Redundant Disk Array Controller has been installed correctly on the following operating systems:

- Windows NT 4.0
- Windows 2000

**Windows NT 4.0**: To verify that RDAC has been installed correctly, do the following:

**Note**: Make sure that all storage subsystems are connected to the host computer and are powered on.

1. Click **Start** → **Settings** → **Control Panel**. A Control Panel window opens, double-click **Devices**.
2. When the Devices window opens, scroll to symarray.
   - If symarray appears with a device status of Started, go to step 3.
   - If symarray does not appear, an error might have occurred. Repeat the procedure outlined in “Installing the Redundant Disk Array Controller” on page 55. If the failure persists, call your IBM technical-support representative. Otherwise, go to step 3.
3. Do one of the following:
   - If you are managing the storage subsystems using the host-agent method, continue with “Storage Manager 8.2 Agent” on page 57.
   - If you are managing your storage subsystems directly, go to “Storage Manager 8.2 Utility” on page 58.

**Windows 2000**: To verify that the Redundant Disk Array Controller has been installed correctly, do the following:

**Note**: Make sure that all storage subsystems are connected to the host computer and are powered on.

1. Right-click **My Computer**.
2. Click **Start** → **Programs** → **Administrative Tools** → **Computer Management**. The Computer Management window opens. Go to the \System Tools\System Information\Software environment\Drivers directory.
3. Scroll through the list of device drivers until you find rdacfltr.
4. Verify that rdacfltr is displayed with the state type Running and status OK. If it is not, repeat the procedure outlined in “Installing the Redundant Disk Array Controller” on page 55. If the failure persists, call your IBM technical-support representative. Otherwise, go to step 5.
5. Do one of the following:
If you are managing the storage subsystems using the host-agent method, continue with "Storage Manager 8.2 Agent."

If you are managing your storage subsystems directly, go to "Storage Manager 8.2 Utility" on page 58.

Storage Manager 8.2 Agent

The Storage Manager 8.2 Agent software must be installed if you want to manage the storage subsystem using the host-agent method.

Before you install the software, ensure that the following conditions are met:

- You have Administrator privileges on the cluster nodes.
- Each cluster node has at least 1 MB of available disk space.
- You have installed RDAC on each cluster node. If you have not done so, refer to "Redundant Disk Array Controller" on page 54.
- (For Windows NT 4.0) You have installed Microsoft Virtual Machine (refer to "Installing the Microsoft Virtual Machine" on page 52).

Installing Storage Manager 8.2 Agent

To install Storage Management 8.2 Agent, do the following:

1. Close all programs.
2. Insert the IBM FAStT Storage Manager Version 8.2 CD in the CD-ROM drive.
3. Click Start → Run. The Run window opens.
4. Click Browse. The Browse window opens.
5. Select the CD-ROM drive.
6. Select the \Win32\SMagent folder; then, click Open.
7. Select the setup.exe file; then, click Open. The InstallShield window opens, showing the status the file unpacking. The Welcome window opens.
8. Click Next. The End User License Agreement (EULA) window opens.
9. Read the license and click Yes to begin the installation. The software installation ends, and the Operation Complete window opens.
10. Click Finish.
11. Continue with "Verifying the Storage Manager 8.2 Agent."

Verifying the Storage Manager 8.2 Agent

This section provides instructions for verifying that Storage Management 8.2 Agent has been installed correctly on the following operating systems:

- Windows NT 4.0
- Windows 2000

Windows NT 4.0: To verify that Storage Manager 8.2 Agent has been installed correctly, do the following:

1. Click Start → Settings → Control Panel. The Control Panel window opens.
3. Scroll through the list of services until you find IBM FAStT Storage Manager 8 Agent.
   - If IBM FAStT Storage Manager 8 Agent appears with a startup type of Started, close the Services window, and continue to step 4 on page 58.
   - If IBM FAStT Storage Manager 8 Agent does not appear with a startup type of Started, click Start. If the status changes to Started, go to step 4 on page 47. If not, refer to Table 12 on page 83 for a possible cause. Otherwise,
reinstall IBM FAStT Storage Manager 8.2 Agent. If the problem persists, contact your IBM technical-support representative.

4. Do one of the following:
   - If you plan to use the host-agent software to manage one or more storage subsystems, go to “Storage Manager 8.2 Utility”.
   - If you do not plan to use the host-agent software to manage one or more storage subsystems, do the following to disable the host-agent service:
     a. Click **Start** → **Programs** → **Administrative Tools** → **Manage**. The Computer Management window opens.
     b. Click **Services**.
     c. From the list of displayed services, right-click **IBM FAStT Storage Manager 8 Agent**.
     d. Click **Properties** → **Startup Type** → **Manual**.
     e. Click **OK**.

5. Continue with “Storage Manager 8.2 Utility”.

**Windows 2000:** To verify that Storage Manager 8.2 Agent has been installed correctly, do the following:

1. Click **Start** → **Programs** → **Administrative Tools** → **Services**. The Services window opens.

2. Scroll through the list of services until you find IBM FAStT Storage Manager 8 Agent.

3. Verify that IBM FAStT Storage Manager Agent is displayed with the startup type Automatic and status Started. If IBM FAStT Storage Manager 8 Agent does not appear with a startup type of Started, click **Start**. If the status changes to Started, go to step 4 on page 47. If not, refer to Table 12 on page 83 for a possible cause. Otherwise, reinstall IBM FAStT Storage Manager 8.2 Agent. If the problem persists, contact your IBM technical-support representative.

4. Do one of the following:
   - If you plan to use the host-agent software to manage one or more storage subsystems, go to “Storage Manager 8.2 Utility”.
   - If you do not plan to use the host-agent software to manage one or more storage subsystems, do the following to disable the host-agent service:
     a. Click **Start** → **Programs** → **Administrative Tools** → **Computer Management**. The Computer Management window opens.
     b. Click **Services**.
     c. From the list of displayed services, right-click **IBM FAStT Storage Manager 8 Agent**.
     d. Click **Properties** → **Startup Type** → **Manual**.
     e. Click **OK**.

5. Continue with “Storage Manager 8.2 Utility”.

**Storage Manager 8.2 Utility**

This section provides instructions for installing the Storage Manager 8.2 Utility software on cluster nodes. This component contains utilities that will register and map new logical drives to the operating systems.

**Installing Storage Manager 8.2 Utility**

To install Storage Manager 8.2 Utility, do the following:
1. Close all programs and insert the IBM FAStT Storage Manager Version 8.2 installation CD in the CD-ROM drive.
2. Click **Start → Run**. The Run window opens.
3. Click **Browse**. The Browse window opens.
4. Select the CD-ROM drive.
5. Select the \Win32\SMutil folder; then, click **Open**.
6. Select the setup.exe file; then, click **Open**. The InstallShield Wizard window opens, displaying the status of the files unpacking. The Welcome window opens.
7. Click **Next**.
8. The End User License Agreement (EULA) window opens. Click **Yes** to begin the installation. After the installation is complete, the Operation Complete window opens.
9. Click **Finish**.
10. Continue with "Verifying the Storage Manager 8.2 Utility installation" on page 48.

**Verifying the Storage Manager 8.2 Utility installation**

To verify that Storage Manager 8.2 Utility has been installed correctly, do the following:

1. Go to the following directory:

   \_installation_directory\IBM_FAStT\Util

   where \_installation_directory\ is the directory where you installed the Storage Manager 8.2 Utility.

2. Verify that the directory contains the following files:
   - hot_add.exe
   - SMdevices.bat
   - SMflashcopyassist.exe

   If it does not, reinstall the Storage Manager 8.2 Utility using the procedure outlined in "Installing Storage Manager 8.2 Utility" on page 48. If the problem persists, contact your IBM technical-support representative.

3. Go to "Installing Storage Manager in a cluster environment" on page 51.

**Installing the cluster server software**

**Important:**

Do not perform this procedure unless you have installed the necessary storage-management software components on both cluster nodes.

To install the cluster server software on Nodes A and B, do the following:

1. Install the cluster server software on Node A, as follows:
   a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for the correct procedure to install the cluster server software.
   
      **Note:** During installation, specify that you want to form a new cluster.
   b. After the system restarts, leave Node A running.

2. Install the cluster server software on Node B, as follows:
a. Refer to the appropriate MSCS documentation for the correct procedure to install the Cluster Server software.

**Note:** During installation, specify that you want to join the existing cluster.

b. After the system restarts, leave Node B running.

3. After installing MSCS, do one of the following:
   - For systems running Windows NT, reinstall Service Pack 6a.
   - For systems running Windows 2000, reinstall Service Pack 2.

**Note:** Refer to Microsoft knowledge base article Q174799 for more information about installing a service pack in a cluster environment.

4. Verify the software installation, as follows:
   a. On either node A or node B, click **Start → Programs → Administrative Tools → Cluster Administration**.
   b. In the **Cluster or Server Name** field, type either the name of the cluster or the name or IP address of one of the nodes.
      - If the installation is successful, the computer names of both nodes appear on the left side of the Cluster Administrator window.
   c. Make sure that the cluster disk groups can be moved between cluster nodes.

5. If both node names do not appear on the left side of the Cluster Administrator window, reinstall the cluster server software. If the problem persists, contact your IBM technical-support representative.

---

**Upgrading from a previous version of the storage-management software**

Be sure that you are familiar with the steps required in a new installation before you continue with the following upgrade procedure.

Choose one of the following two procedures:

- **Performing a scheduled upgrade:** A scheduled upgrade requires scheduling downtime on your cluster server to upgrade the controller firmware and storage-management software. The services and resources offered by the cluster are not available during the upgrade.

  **Note:** The scheduled upgrade is the preferred procedure for upgrading a cluster server configuration.

- **Performing a rolling upgrade:** A rolling upgrade requires upgrading the storage-management software first in node A and then in node B, so that the services and resources offered by the cluster are always available.

**Important:** Do not upgrade your storage subsystem firmware until you have upgraded the storage-management software on all cluster nodes and management stations. If you upgrade your storage subsystem controller firmware to version 05.20.xx.xx, you will not be able to communicate with the controller until you have upgraded to Storage Manager 8.2 software on your management station and cluster nodes. Previously installed versions of Storage Manager will not recognize controllers running version 05.20.xx.xx firmware.
Performing a scheduled upgrade

To perform a scheduled upgrade from Storage Manager version 7.0, 7.01, 7.02, 7.10, 8.0 to Storage Manager 8.2, do the following:

1. Before installing the storage-management software, do the following:
   a. Click Start → Programs → Administrative Tools → Services. The Services window opens.
   b. From the list of displayed services, right-click the cluster server. Then, click Manual.
   c. Stop the cluster server on all nodes in the cluster configuration.
2. Shut down node B.
3. From node A, uninstall the components from the previous version of the storage-management software. To uninstall the storage-management software for Storage Manager Version 7.x, or 8.0 see "Uninstalling storage-management software components" on page 80.
   **Note:** Uninstall the storage-management components in the following order:
   a. Storage Manager Agent
   b. Storage Manager Utility
   c. Redundant Disk Array Controller
   d. Storage Manager Client
4. Verify that the IBM host adapter device driver versions are current. If they are not current, refer to the README file located in the \Host_Adapter directory on the installation CD and upgrade the device drivers.
5. Install the Storage Manager 8.2 Client on node A. Refer to "Storage Manager 8.2 Client" on page 53 for instructions.
6. Install the Redundant Disk Array Controller on node A. Refer to "Redundant Disk Array Controller" on page 54 for instructions.
7. Install the Storage Manager 8.2 Agent on node A. Refer to "Storage Manager 8.2 Agent" on page 57 for instructions.
8. Install the Storage Manager 8.2 Utility on node A. Refer to "Storage Manager 8.2 Utility" on page 58 for instructions.
9. Shut down node A.
10. Restart node B.
11. From node B, uninstall the components from the previous version of the storage-management software. To uninstall the storage-management software for Storage Manager Version 7.x and 8.0, refer to "Uninstalling storage-management software components" on page 80.
12. Verify that the IBM host adapter device driver versions are current. If they are not current, refer to the README file located in the \Host_Adapter directory on the installation CD and upgrade the device driver versions before continuing.
13. Install the Storage Manager 8.2 Client on node B. Refer to "Storage Manager 8.2 Client" on page 53 for instructions.
14. Install the Redundant Disk Array Controller on node B. Refer to "Redundant Disk Array Controller" on page 54 for instructions.
15. Install the Storage Manager 8.2 Agent on node B. Refer to "Storage Manager 8.2 Agent" on page 57 for instructions.
16. Install the Storage Manager 8.2 Utility on node B. Refer to "Storage Manager 8.2 Utility" on page 58 for instructions.
17. Shut down node B.
18. Start up one node at a time and complete the following procedure:
   a. Click **Start → Programs → Administrative Tools → Services**. The Services window opens.
   b. From the list of displayed services, right-click the cluster server. Click **Automatic** to change the cluster server startup option.
   c. Start the cluster server service on node B.

19. Go to Chapter 5, “Completing the installation” on page 67

**Performing a rolling upgrade**

**Important:**

If you have applications installed in the cluster server environment that do not support a rolling upgrade, you must do one of the following:

- Put those resources offline before the upgrade; then, put them back online after the upgrade.
- Perform a scheduled upgrade. A scheduled upgrade requires scheduling downtime on your cluster server to upgrade the controller firmware and storage-management software.

To perform a rolling upgrade from Storage Manager version 7.0, 7.01, 7.02, or 7.10 to Storage Manager 8.2, do the following:

1. From node A, open Cluster Administrator.
2. Double-click the Active Groups folder in the right pane of the Cluster Administrator window.
3. Select each group listed, and move them to node B.
4. Select node A; then, click **File → Pause Node** to pause cluster service in node A.
5. From node A, uninstall the components from the previous version of the storage-management software. To uninstall the storage-management software for Storage Manager Version 7.x or 8.10 refer to "Uninstalling storage-management software components” on page 80.

**Note:** Uninstall the storage-management components in the following order:

- Storage Manager Agent
- Storage Manager Utility
- Redundant Disk Array Controller
- Storage Manager Client

6. Verify that the IBM host adapter device driver versions are current. If they are not current, refer to the README file located in the \Host_Adapter directory on the installation CD and upgrade the device drivers.

7. **Install the Storage Manager 8.2 Client** on node A. Refer to “Storage Manager 8.2 Client” on page 53 for instructions.
8. **Install the Redundant Disk Array Controller** on node A. Refer to “Redundant Disk Array Controller” on page 54 for instructions.
9. **Install the Storage Manager 8.2 Agent** on node A. Refer to “Storage Manager 8.2 Agent” on page 57 for instructions.
10. **Install the Storage Manager 8.2 Utility** on node A. Refer to “Storage Manager 8.2 Utility” on page 58 for instructions.
11. Run Cluster Administrator; then, click **File → Resume Node** to resume cluster service in node A.
12. From node B, open Cluster Administrator.
13. Double-click the Active Groups folder in the right pane of the Cluster Administrator window.
14. Select each group listed, and move them to node A.
15. Select node B; then, click **File → Pause Node** to pause cluster service in node B.
16. From node B, uninstall the components from the previous version of the storage-management software. To uninstall the storage-management software for Storage Manager Version 7.x or 8.10, refer to "Uninstalling storage-management software components" on page 80.
17. Verify that the IBM host adapter device driver versions are current. If they are not current, refer to the README file located in the 'Host_Adapter' directory on the installation CD and upgrade the device drivers.
18. Install the Storage Manager 8.2 Client on node B. Refer to "Storage Manager 8.2 Client" on page 53 for instructions.
19. Install the Redundant Disk Array Controller on node B. Refer to "Redundant Disk Array Controller" on page 54 for instructions.
20. Install the Storage Manager 8.2 Agent on node B. Refer to "Storage Manager 8.2 Agent" on page 57 for instructions.
21. Install the Storage Manager 8.2 Utility on node B. Refer to "Storage Manager 8.2 Utility" on page 58 for instructions.
22. Run Cluster Administrator; then, click **File → Resume Node** to resume cluster service in node B.
23. Go to Chapter 5, "Completing the installation" on page 67.

### Upgrading from Windows NT 4.0 to Windows 2000 in a cluster configuration

To ensure that the services and resources offered by the cluster are always available, you must perform a rolling upgrade. A rolling upgrade requires upgrading the controller firmware, storage-management software, and operating system first in node A and then in node B.

**Important:**

If you have applications installed in the cluster server environment that do not support a rolling upgrade, you must do one of the following:

- Put those resources offline before the upgrade; then, put them back online after the upgrade.
- Perform a scheduled upgrade. A scheduled upgrade requires scheduling downtime on your cluster server to upgrade the controller firmware and storage-management software.

To upgrade from Windows NT 4.0 Enterprise Edition to Windows 2000 Advanced Server, do the following:

1. On node A, open Cluster Administrator.
2. Double-click on the Active Groups folder in the right pane of Cluster Administrator.
3. Make sure that all of the groups failover to node B successfully.
4. Select node A; then, click **File → Pause Node** to pause cluster service in node A.
5. From node A, uninstall all storage-management software components. To uninstall the storage-management software, refer to “Uninstalling storage-management software components” on page 80. The storage-management components should be uninstalled in the following order:
   a. Storage Manager 8.2 Agent
   b. Storage Manager 8.2 Utility
   c. Storage Manager 8.2 Redundant Disk Array Controller
   d. Storage Manager 8.2 Client

6. Follow the instructions from Microsoft to upgrade node A from Windows NT Enterprise Edition to Windows 2000 Advanced Server.

   **Note:** During the upgrade, the existing cluster server installation is detected and clustering for Windows 2000 Advanced Server is installed. When the upgrade is complete, node A will rejoin the cluster and remain paused.

7. Verify that the host bus adapter (HBA) device driver versions are correct. If they are not the certified versions, refer to the README file in the \Host_Adapter directory on the installation CD and upgrade the device driver versions before continuing.

8. Verify that node A was successfully upgraded to Windows 2000 Advanced Server.

9. Install the Storage Manager 8.2 Client on node A. Refer to “Storage Manager 8.2 Client” on page 53 for instructions.

10. Install the Redundant Disk Array Controller on node A. Refer to “Redundant Disk Array Controller” on page 54 for instructions.

11. Install the Storage Manager 8.2 Agent on node A. Refer to “Storage Manager 8.2 Agent” on page 57 for instructions.

12. Install the Storage Manager 8.2 Utility on node A. Refer to “Storage Manager 8.2 Utility” on page 58 for instructions.

13. Run Cluster Administrator; then, click File → Resume Node to resume cluster service in node A.


15. Double-click on the Active Groups folder in the right pane of Cluster Administrator.

16. Make sure that all of the groups failover to node A successfully.

17. Select node B; then, click File → Pause Node to pause cluster service in node B.

18. From node B, uninstall all storage-management software components. To uninstall the storage-management software, refer to “Uninstalling storage-management software components” on page 80. The storage-management components should be uninstalled in the following order:
   a. Storage Manager Agent
   b. Storage Manager Utility
   c. Redundant Disk Array Controller
   d. Storage Manager Client

19. Follow the instructions from Microsoft to upgrade node B from Windows NT Enterprise Edition to Windows 2000 Advanced Server.
Note: During the upgrade, the existing cluster server installation is detected and clustering for Windows 2000 Advanced Server is installed. When the upgrade is complete, node B will rejoin the cluster and remain paused.

20. Verify that the host bus adapter (HBA) device driver versions are correct. If they are not the certified versions, refer to the README file in the \Host_Adapter directory on the installation CD and upgrade the device driver versions before continuing.

21. Verify that node B was successfully upgraded to Windows 2000 Advanced Server.

22. Install the Storage Manager 8.2 Client on node B. Refer to “Storage Manager 8.2 Client” on page 53 for instructions.

23. Install the Redundant Disk Array Controller on node B. Refer to “Redundant Disk Array Controller” on page 54 for instructions.

24. Install the Storage Manager 8.2 Agent on node B. Refer to “Storage Manager 8.2 Agent” on page 57 for instructions.

25. Install the Storage Manager 8.2 Utility on node B. Refer to “Storage Manager 8.2 Utility” on page 58 for instructions.

26. Run Cluster Administrator; then, click File → Resume Node to resume cluster service in node B.

27. Go to Chapter 5, “Completing the installation” on page 67.
Chapter 5. Completing the installation

This chapter contains procedures for using Enterprise Management and Subsystem Management to complete the following installation tasks:

1. Perform an initial automatic discovery of storage subsystems.
2. Add devices, if necessary.
3. Set up alert notifications, if you want.
4. Name the storage subsystems.
5. Download firmware and NVSRAM.
6. Create arrays and logical drives.
7. Define the default host type.
8. Configure the heterogeneous hosts.
9. Perform other storage subsystem tasks.

The Enterprise Management window opens when you start IBM FAStT Storage Manager. Use the Enterprise Management window to:

- Add and discover the storage subsystems
- View all storage subsystems in your management domain
- Perform batch storage subsystem management tasks using the Script Editor

Performing an initial automatic discovery of storage subsystems

To perform an initial automatic discovery of storage subsystems, do the following:

1. Click Start → Programs.
2. Click IBM FAStT Storage Manager 8 Client. The client software starts, displaying the Enterprise Management window and the Confirm Initial Automatic Discovery window.

![Figure 17. Confirm Initial Automatic Discovery window](image)

**Note:** The Enterprise Management window might take several minutes to open. No wait cursor (such as an hourglass) is displayed.
3. Click Yes to begin an initial automatic discovery of hosts and storage subsystems attached to the local subnetwork. After the initial automatic discovery is complete, the Enterprise Management window displays all hosts and storage subsystems attached to the local subnetwork.

Note: The Enterprise Management window might take up to a minute to refresh after an initial automatic discovery.

4. Verify that each host and storage subsystem is displayed in the Enterprise Manager window.

If a hosts or storage subsystem is not displayed, do the following:

- Check the hardware and connections for possible problems (refer to the hardware documentation for specific procedures).
- Refer to the Enterprise Management online help for additional information about discovering storage subsystems.
- If using the direct-management method, verify that all hosts and storage subsystems are connected to the same subnet network. If using the host-agent method, ensure that the fibre channel connection between the host and storage subsystems is made.
- Make sure that all of the preparation steps for setting up the storage subsystem for a direct-managed system in Chapter 2 are completed. If they are, use the Add Device option to add the IP addresses of the Storage subsystem. You add both IP addresses of the controller. Otherwise, you will get a “partially-managed device” error message when you try to manage the storage subsystem.
- If using the host-agent management method, make sure that the Storage Manager 8.2 Agent is installed in the host. Then, verify that you have a fibre channel connection from the storage subsystems to the host that has the Storage Manager 8.2 Agent installed. Then, verify that all of the preparation steps outlined in Chapter 2 have been completed. If they have, run the Hot Add Utility. Then, restart the Storage Manager 8.2 Agent using the information.
Note: In certain situations, a storage subsystem might be duplicated in the device tree after an automatic discovery. You can remove a duplicate storage-management icon from the device tree using the Remove Device option in the Enterprise Management window.

5. Verify that the status of each storage subsystem is Optimal. If a device shows a status of Unresponsive, right-click the device and select Remove Device to delete it from the management domain; then, use the Add Device option to add it to the management domain again. Refer to the Enterprise Management window online help for instructions on removing and adding devices.

6. Continue with “Adding devices”.

Adding devices

You can manually add more hosts or storage subsystems. You can use this option to selectively manage a group of storage subsystems from a Storage Manager 8 Client. You can also use this option to add additional devices to be managed that were not discovered during the Storage Manager 8 Client initial discovery. For more information about this option, refer to the Enterprise Management window online help.

Important:

- When you add new storage subsystems to the existing storage subsystems in a Storage Area Network (SAN) that are managed through the host-agent software, you must stop and restart the host-agent service. When the host-agent service restarts, the new storage subsystem is detected. For more information, refer to “Stopping and restarting the host-agent software” on page 80. Then, go to the Enterprise Management window and click Tools → Rescan to add the new storage subsystems to the management domain.
- When you add new storage subsystems to existing storage subsystems that are managed using the direct-management method, be sure and specify the IP addresses for both controllers.

Continue with “Setting up alert notifications”.

Setting up alert notifications

After you add devices to the management domain, you can set up alert notification to report critical events on the storage subsystems. The following alert-notification options are available:

- Notification to a designated network management station (NMS) using Simple Network Management Protocol (SNMP) traps
- Notification to designated e-mail addresses
- Notification to designated alphanumeric pagers (requires separately supplied software to convert e-mail messages)

Note: You can only monitor storage subsystems within the management domain. If you do not install Event Monitor service, the Enterprise Management window must remain open. If you close the window, you will not receive any alert notifications from the managed storage subsystems. Refer to the Enterprise Management window online help for additional information.
To set up alert notification to a NMS using SNMP traps, do the following:

1. Insert the IBM FASTT Storage Manager Version 8.2 CD into the CD-ROM drive on a network management station (NMS). You need to set up the designated management station only once.

2. Copy the SM820.MIB file from the SM820.mib directory to the NMS.

3. Follow the steps required by your NMS to compile the management information base (MIB) file. (For details, contact your network administrator or see the documentation specific to the storage management product you are using.)

4. Continue with "Naming storage subsystems".

---

### Naming storage subsystems

To name your storage subsystem, do the following:

1. In the Enterprise Management window, select a storage subsystem.

2. Click **Tools → Manage Device**. The Subsystem Management window opens, as shown in Figure 19.

3. Click **Storage Subsystem → Rename**. The Rename Storage Subsystem window opens.

4. Type the name of the storage subsystem (refer to Table 13 on page 89); then, click **OK**.

5. Repeat for each unnamed storage subsystem. For more information, refer to the topic on renaming storage subsystems in the Subsystem Management window online help.

6. Continue with "Downloading firmware and NVSRAM".

---

### Downloading firmware and NVSRAM

This section provides instructions for downloading firmware and NVSRAM. You must download firmware version 05.20.xx before you download NVSRAM.
Downloading firmware

To download firmware version 05.20.xx, do the following:

1. From the Enterprise Management window, select a storage subsystem.
2. Click **Tools ➔ Manage Device**. The Subsystem Management window opens.
3. Click **Storage Subsystem ➔ Download ➔ Firmware**. Follow the instructions that display.
4. Continue with "Downloading NVSRAM"

Downloading NVSRAM

To download NVSRAM, do the following:

1. From the Enterprise Management window, select a storage subsystem.
2. Click **Tools ➔ Manage Device**. The Subsystem Management window opens.
3. Click **Storage Subsystem ➔ Download ➔ NVSRAM**. Follow the instructions that display.
4. Continue with "Creating arrays and logical drives"

Creating arrays and logical drives

A logical drive is the basic structure you create to store data on the storage subsystem. The operating system recognizes a logical drive as a single drive. Choose a RAID level to meet application needs for data availability and maximize Fibre Channel I/O performance.

To create arrays and logical drives, do the following:

1. From the Enterprise Management window, select a storage subsystem.
2. Click **Tools ➔ Manage Device**. The Subsystem Management window opens.
3. Click the **Logical/Physical View** tab.
4. Click **Logical Drive ➔ Create**. The Logical Drive Create wizard starts. Follow the online instructions to create arrays and logical drives.
5. Continue with "Verifying and defining the default host type"

Note: (For cluster configurations) If you add or delete logical drives, you must make them known to both node A and node B.

Verifying and defining the default host type

Before using the logical drives in a host computer, you must specify the host type. The host type determines how the storage subsystem controllers will work with each particular operating system on the hosts to which it is connected. If all of the host computers connected to the same storage subsystem are running the same operating system, and you do not want to define partitioning, you can define a default host type.

To verify the current default host type, do the following:

1. In the Subsystem Management window, click **View ➔ Storage subsystem profile**. A Storage Subsystem Profile window opens.
2. Click the **Mappings folder** tab, and scroll down to NVSRAM Host Type Internal Definitions. The host type name of the index that has the word DEFAULT next to it is the default host type.
3. Click **Close**.
To define a default host type, do the following:

1. Click **Storage subsystem → Change → Default host-type**. The Default Host-type window opens.
2. From the pull-down list, select the host type.
3. Click **OK**.

If you have hosts with different operating systems or if you want to define partitions for the hosts, continue with “Configuring heterogeneous hosts”.

---

### Configuring heterogeneous hosts

The heterogeneous hosts feature enables hosts running different operating systems to access a single storage subsystem. Previous releases of IBM FASTT Storage Manager (versions 7.02 or earlier) required that hosts run the same operating system in order to access a single storage subsystem.

Host computers can run completely different operating systems (for example, Solaris and Windows NT) or variants of the same operating system (for example, Windows NT running in a cluster environment or Windows NT running in a noncluster environment). When a host type is specified in the Define New Host Port window, the heterogeneous hosts feature enables the controllers in the storage subsystem to tailor their behavior (such as LUN reporting) to the needs of the host.

**Important:** To use the heterogeneous host feature, the following conditions must be met:
- Storage partitioning must be enabled.
- During host-port definition, you must set each host type to the appropriate operating system so that the firmware on each controller can respond correctly to the host.

To start the heterogeneous host configuration, do the following:

1. From the Subsystem Management window, click **Mappings View**.
2. Follow the on-screen instructions.
3. Continue with “Performing other storage-subsystem management tasks”.

**Note:** Partitioning is a premium feature. If you disable partitioning, you must contact your IBM technical-support representative to obtain a key to reenable partitioning.

---

### Performing other storage-subsystem management tasks

Other storage subsystem management tasks you can perform include the following:
- Locating a storage subsystem
- Viewing a storage subsystem profile or event log
- Entering or changing a storage subsystem password
- Creating and managing logical drives and arrays
- Using the Performance Monitor
- Creating storage partitions (if applicable) and heterogeneous hosts

**Note:** To create storage partitions, you must obtain the worldwide or port of each host adapter in every host connected to the storage subsystem.
For more information about these and other storage subsystem management tasks, refer to the appropriate topics in the Subsystem Management online help.

After installing IBM FASiT Storage Manager Version 8.2, consider installing the FASiT Management Suite Java (FASTT-MSJ) diagnostic program. You can use this program to verify the status of the fiber channel connections before using the storage subsystem. The program and the IBM FASiT MSJ User's Guide are located on the IBM FASiT Storage Manager Version 8.2 CD.
Chapter 6. Using the storage-management software

This chapter provides information about adding or deleting logical drives, creating FlashCopy logical drives, using the Hot Add and SMdevices utilities, starting and stopping the host-agent software, and uninstalling Storage Manager components.

Adding or deleting logical drives

Use the following instructions to add or delete logical drives in a standard (noncluster) configuration.

Standard (noncluster) configuration for Windows NT

Creating logical drives

When you create logical drives with the storage-management software, you must add the new logical drives to Windows NT. Refer to the Windows NT documentation for details about adding a drive. Each logical drive (not array) is recognized by Windows NT as a single drive.

After creating logical drives, run the Hot Add and SMdevices utilities that are provided with the storage-management software. The Hot Add utility adds newly created logical drives to the operating system, and the SMdevices utility identifies logical drives by their associated operating system device names. For information about using these utilities, see "Using the Hot Add utility" on page 78 and "Using the SMdevices utility" on page 78.

Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click Configure → Reset Configure. This will reset the controller unit and delete all previously-configured logical drives.

Before deleting logical drives with the storage-management software or using Configure → Reset Configuration, use Cluster Administrator to delete the cluster physical disk resources that owns the logical drives that will be deleted. Then, use Disk Administrator to delete any partitions and to unassign drive letters that are associated with the logical drives. Restart the system to remove the configuration information.

Attention: You must use Cluster Administrator and Disk Administrator to delete the cluster physical disk resources, OS partitions, and unassigned drive letters before deleting logical drives or resetting the configuration in Storage Manager. This will avoid damage to your registry information.

Cluster server configuration for Windows NT

To add logical drives in a Windows NT 4.0 cluster server environment, do the following:

1. Using the IBM FASfT Storage Manager 8.2 Client, create arrays and assign them to the appropriate host group by using storage partitioning.
2. Stop the cluster server service in node A. Make sure that all of the cluster groups and resources failover to node B.
3. Disable cluster server service and the cluster disk device in node A by doing the following:
   a. Click Start → Settings → Control Panel. The Control Panel window opens.
b. Click Services. The Services window opens.
c. Select Cluster Server, and click Startup. The Service window opens.
d. Change the Startup Type Setting to Disabled; then, click OK.
e. Close the Services window.
f. Click Start → Settings → Control Panel. The Control Panel window opens.
g. Click Devices. The Device window opens.
h. Select Cluster Disk; then, click Startup. The Devices window opens.
i. Select Disabled; then, click OK.
j. Close the Devices window.

4. Restart node A.
5. Use Disk Administrator to create and format your operating system partitions.
6. Enable cluster server service and the cluster disk device in node A. Make sure that the start-up type is set to System for cluster disk device and Automatic for cluster server service.
7. Restart node A; then, make sure that the cluster server service has started and that the cluster groups and resources have failed back correctly.
8. Stop the cluster server service in node B.
9. Using the procedure outlined in step 3 on page 75, disable cluster server service and the cluster disk device in node B.
10. Restart node B.
11. Use Disk Administrator to reassign the drive letters to match the ones that were assigned to a given disk in node A.
12. Enable cluster server service and the cluster disk device in node B. Make sure that the start-up type is set to System for cluster disk device and Automatic for cluster server service.
13. Restart node B; then, make sure that the cluster server service started and the cluster groups and resources failed back correctly.
14. Stop the cluster server service in node A.
15. Restart node A.
16. After cluster server service has started, use Cluster Administrator to create your physical disk resources.
17. Verify that the physical disk resources can be brought online in both nodes.

Standard (noncluster) configuration for Windows 2000

Use the following instructions to add or delete logical drives in a cluster server environment.

Creating logical drives
When you create logical drives with the storage-management software, you must add the new logical drives to the Windows 2000 operating system. Each logical drive (not array) is recognized by Windows 2000 as a single drive.

After creating logical drives, run the HotAdd and SMdevices utilities that are provided with the storage-management software. The Hot Add utility adds newly created logical drives to the operating system, and the SMdevices utility identifies logical drives by their associated operating system device names. For more information about using these utilities, see "Using the Hot Add utility" on page 78 or "Using the SMdevices utility" on page 78.
Deleting logical drives

**Important:** If you have data or logical drives that you want to keep, do not click Configure → Reset Configure. This will reset the controller unit and delete all previously-configured logical drives.

Before deleting logical drives with the storage-management software or using Configure → Reset Configuration, use Cluster Administrator to delete the cluster physical disk resources that owns the logical drives that will be deleted. Then, use Disk Administrator to delete any partitions and to unassign drive letters that are associated with the logical drives. Restart the system to remove the configuration information.

**Attention:** You must use Cluster Administrator and Disk Administrator to delete the cluster physical disk resources, OS partitions, and unassigned drive letters before deleting logical drives or resetting the configuration in Storage Manager. This will avoid damage to your registry information.

## Cluster server configuration for Windows 2000

To add logical drives in a Windows 2000 cluster server environment, do the following:

1. Using the IBM FAStT Storage Manager 8.2 Client, create arrays and assign them to the appropriate host group by using storage partitioning.
2. Use the Hot Add utility to add the new logical drives to node A.
3. Using the Disk Administrator, create, format, and assign drive letters to the disk partitions on the new logical drives.
4. Use the Hot Add utility to add the new logical drives to node B.
5. Using the Disk Administrator, ensure that the drive letters assigned to the disk partitions on the logical drives are the same on both node A and node B.
6. Restart node A; then, use the Cluster Administrator to create cluster physical disk resources using the new disk partitions on the new logical drives.
7. Bring the cluster resources online in node A.
8. Use cluster administrator to move the cluster physical disk resources to node B.
9. Verify that the resources come online on node B.

## Creating a FlashCopy logical drive

A FlashCopy logical drive is a logical point-in-time image of a logical drive, called a base logical drive. A FlashCopy logical drive has the following features:

- It is created quickly and requires less disk space than an actual logical drive.
- It can be assigned to a host address, so that you can perform backups using the FlashCopy logical drive while the base logical drive is online and accessible.
- You can use the FlashCopy logical drive to perform application testing or scenario development and analysis. This does not effect the actual production environment.
- The maximum number of FlashCopy logical drives allowed is one half of the total logical drives supported by your controller model.

For additional information about the FlashCopy feature and how to manage Flash Copy logical drives, refer to the Storage Manager Subsystem Management online help.
To create a FlashCopy logical drive, do the following:

1. To ensure that you have the accurate point-in-time image of the base logical drive, stop applications and flush cache I/O to the base logical drive. For instructions, see "Using the SMflashcopyassist utility" on page 79.
2. Open the Subsystem Management window. From the Logical View, right-click the base logical drive.
3. Select Create FlashCopy Logical Drive. The Create FlashCopy Logical Drive Wizard starts.
4. Follow the on-screen instructions.
5. Refer to the Subsystem Management online help for instructions on how to add the FlashCopy logical drive to the host.

Using the Remote Mirror feature

The Remote Mirror feature is a purchased premium feature. The Remote Mirror Option is used for online, real-time replication of data between storage subsystems over a remote distance. In the event of a disaster or unrecoverable error at one storage subsystem, you can promote a second storage subsystem to take over responsibility for normal I/O operations. Consult the IBM FAStT Remote Mirror Option Installation and User's Guide, or contact your IBM reseller or IBM marketing representative for more information.

Using the Hot Add utility

The Hot Add utility enables to add new logical drives without restarting the system. The utility registers the new logical drives with the operating system so that you can use Disk Administrator to create partitions, add device names, and so on. The Hot Add utility is part of the Storage Manager 8.2 Utility software package. If you run the program twice and the new logical drives are not displayed in the Disk Administrator window, you must either run Fibre Channel diagnostics, or restart (reboot) the host.

When you finish creating logical drives on a particular storage subsystem, go to the host that is attached to that storage subsystem, and perform the following steps to use the hot add utility:

1. From a DOS or command prompt, change to the installation_directory\IBM_FAStT\Util where installation_directory is the directory where you installed the Storage Manager 8.2 Utility.
2. From a DOS or command prompt, type the following:
   hot_add
3. Press Enter. The new logical drives are available through the Disk Administrator.

Using the SMdevices utility

The Storage Manager 8.2 Utility software includes a utility called SMdevices that you can use to view the storage subsystem logical drive that is associated with a particular operating-system device name. This utility is helpful when you want to create drive letters or partitions using Disk Administrator.
When you finish creating the logical drives on a particular storage subsystem, go to the host that is attached to that storage subsystem, and perform the following steps to use SMdevices:

1. From a DOS or command prompt, change to the installation_directory\IBM_FAST\Util where installation_directory is the directory where you installed the Storage Manager 8.2 Utility.

2. Type:
   SMdevices

3. Press Enter. The software displays device identification information. For example, you might see the following:
   \\.\PHYSICALDRIVE\x [Storage Subsystem Finance, Logical Drive DEBIT, LUN xx, WWN <worldwide_name>]

   where
   - x is the Disk number that displays in Disk Administrator
   - Finance is the name of the storage subsystem
   - DEBIT is the name of the logical drive
   - xx is the LUN number associated with the logical drive
   - worldwide_name is the worldwide name for the logical drive

---

### Using the SMflashcopyassist utility

**Note:** This utility requires that the FlashCopy feature be enabled.

You can use SMflashassist utility to do the following:

- Flush cached data for a logical drive
- Resolve duplicate logical drive signatures between the base logical drives and the FlashCopy logical drives

To flush cached data in a logical drive, do the following:

1. From a DOS or command prompt, change to the installation_directory\IBM_FAST\Util where installation_directory is the directory where you installed the Storage Manager 8.2 Utility.

2. Type the following:
   smflashcopyassist -f logical_drive_letter:

   where logical_drive_letter is the operating-system drive letter that was assigned to the disk partition created on the logical drive

3. Press Enter.

After creating a FlashCopy logical drive and mapping it to the same host as the base logical drive, (for Windows NT only) to resolve duplicate logical drive signatures:

1. Type smflashcopyassist -r
2. Press Enter.
Stopping and restarting the host-agent software

You must stop and restart the host-agent software if you add additional storage subsystems to the management domain of the host-agent software. When you restart the service, the host-agent software discovers the new storage subsystems and adds them to the management domain.

Note: If none of the access logical drives are detected after a restart, the host-agent software automatically stops running. Make sure that there is a good fibre channel connection from the host to the Storage Area Network that the storage subsystem is connected to; then, restart the host or cluster node so that new host-agent-managed storage subsystems can be discovered.

Windows NT

To stop and restart the host-agent software, do the following:
1. Click Start → Settings → Control Panel. The Control Panel window opens.
3. Click IBM FAStT Storage Manager 8 Agent; then, click Stop. The Confirmation window opens.
4. Click Yes.
5. Click Start. The Storage Agent Manager starts.
6. Close the Services window.

Windows 2000

To stop and restart the host-agent software, do the following:
1. Click Start → Programs → Administrative Tools → Services. The Services window opens.
2. Right-click IBM FAStT Storage Manager 8 Agent.
3. Click Restart. The IBM FAStT Storage Manager 8 Agent stops and then starts again.
4. Close the Services window.

Uninstalling storage-management software components

Use the following procedure to uninstall one or more of the components of Storage Manager 8.2. If you are uninstalling components released with an earlier version of the storage-management software, use the procedure that came with the version of the storage-management software that you are currently running.

Important: Do not uninstall the Redundant Disk Array Controller unless instructed by an IBM technical-support representative. The host-agent package requires RDAC to function properly. If you uninstall RDAC in a coexistence environment, you will lose Fibre Channel I/O path failover support for both the version 7.xx and version 8.xx of Storage Manager.


Note: Uninstall the Storage Manager components in the following order:
   a. Storage Manager 8.2 Agent
   b. Storage Manager 8.2 Utility
c. Storage Manager 8.2 Redundant Disk Array Controller

d. Storage Manager 8.2 Client

2. Select the component you want to uninstall from the list of programs (for example, IBM FASTT Storage Manager 8.2 Client).


4. Click Yes to start the uninstallation process.

5. When the uninstallation is complete, click OK.
Chapter 7. Operating-system support

This chapter contains information related to operating the storage-management software in a Windows NT or Windows 2000 environment.

Windows NT and Windows 2000 limitations

**Important:** Always check for a README file. A README file might contain important information that was not available when this *Installation and Support Guide* was prepared.

Table 12 explains limitations that apply when you use the IBM FAStT Storage Manager Version 8.2 with Windows NT and Windows 2000.

<table>
<thead>
<tr>
<th>Limitation</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clicking a vertical scroll arrow (either up or down) causes the scroll box to move all the way to the opposite end of the scroll bar.</td>
<td>This is a known defect in the Java Runtime Environment. Click the scroll box and slide it until you reach the position that you want in the Help window.</td>
</tr>
<tr>
<td>Data or configuration loss might occur during a logical drive migration (removing configured physical drives from one storage subsystem and inserting them into another storage subsystem).</td>
<td>Contact an IBM technical-support representative for assistance in performing this procedure.</td>
</tr>
<tr>
<td>Array migration is not supported because it could cause loss of configuration and data. Array migration consists of removing a set of drives configured with arrays from one storage subsystem and inserting them into another storage subsystem.</td>
<td>Contact an IBM technical-support representative.</td>
</tr>
<tr>
<td>If you manage storage subsystems through the host-agent software and use the storage management software to download controller firmware, the download process can take up to 10 minutes to complete.</td>
<td>None.</td>
</tr>
<tr>
<td>When you configure a new storage subsystem with a single controller, you must place the controller in slot A. The controller firmware cannot recognize or communicate with a single controller until slot A is populated. This restriction does not apply to storage subsystems that were originally configured with two controllers.</td>
<td>None.</td>
</tr>
<tr>
<td>The following loop configuration is not supported: IBM Fibre Channel Hub (machine type 3523) in conjunction with the IBM Fibre Channel Switch (machine types 2109-S16 and 2109-S8) or the IBM Fibre Channel Switch (machine types 3534-F08 and 2109-F16.</td>
<td>None.</td>
</tr>
<tr>
<td>Limitation</td>
<td>Workaround</td>
</tr>
<tr>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>A controller failover occurs in an active/active controller pair, and ownership of arrays transfers from the failed preferred owner to the other controller of the repair. The failed controller is replaced and brought online. The array ownership is not automatically transferred back to the preferred controller owner.</td>
<td>Immediately after replacing the controller, click Storage subsystem → Redistribute Arrays in the Subsystem Management window to redistribute arrays back to their preferred controller owners. For more information, refer to the online help.</td>
</tr>
<tr>
<td>When using 73.4 GB drives, the maximum number of physical drives that can be configured in a single logical drive group is 29.</td>
<td>None.</td>
</tr>
<tr>
<td>After adding a host device to the management domain of more than five clients, the host-agent managed storage subsystems attached to that host become unresponsive.</td>
<td>A single instance of the host-agent software can communicate with no more than five clients.</td>
</tr>
</tbody>
</table>
Table 12. Windows NT and Windows 2000 limitations (continued)

<table>
<thead>
<tr>
<th>Limitation</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>After installing the host-agent software, the error message:</td>
<td>The cause includes:</td>
</tr>
<tr>
<td>Service Error 100</td>
<td>• The host-agent software does not find any controllers with firmware</td>
</tr>
<tr>
<td></td>
<td>version 04.00.02.00 or later. Upgrade the firmware to the latest FW level</td>
</tr>
<tr>
<td></td>
<td>from the IBM support Web site. For more information, see the Direct-</td>
</tr>
<tr>
<td></td>
<td>management method work around.</td>
</tr>
<tr>
<td></td>
<td>• The access logical drive has been removed from NVSRAM or the storage</td>
</tr>
<tr>
<td></td>
<td>partition defined for the host. Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>– Manage the storage subsystem using the direct-management method. See</td>
</tr>
<tr>
<td></td>
<td>Direct-management method work around.</td>
</tr>
<tr>
<td></td>
<td>– Define the access logical drive for the host; restart SMagent. See the</td>
</tr>
<tr>
<td></td>
<td>SMAgent work around for defining additional Access LUN mapping.</td>
</tr>
<tr>
<td></td>
<td>• The NVSRAM on the controllers in a storage subsystem that you want to</td>
</tr>
<tr>
<td></td>
<td>manage contains an access logical drive LUN that is in use by another</td>
</tr>
<tr>
<td></td>
<td>logical drive. OR The NVSRAM on the controllers in a storage subsystem</td>
</tr>
<tr>
<td></td>
<td>that you want to manage contains an access logical drive LUN that is in</td>
</tr>
<tr>
<td></td>
<td>use by another logical drive, or is not supported by the operating system</td>
</tr>
<tr>
<td></td>
<td>or installed patches. For example, the access logical drive is configured</td>
</tr>
<tr>
<td></td>
<td>at LUN 31, and the operating system and service packs support only eight</td>
</tr>
<tr>
<td></td>
<td>LUNs. Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>– Manage the storage subsystem using the direct-management method. See</td>
</tr>
<tr>
<td></td>
<td>Direct-management method work around.</td>
</tr>
<tr>
<td></td>
<td>– Change the LUN mapping for the host access logical drive to a LUN that</td>
</tr>
<tr>
<td></td>
<td>is not in use and is supported by the operating system either from a</td>
</tr>
<tr>
<td></td>
<td>different computer that has management access to the storage subsystem,</td>
</tr>
<tr>
<td></td>
<td>or establish a direct management connection to the storage subsystem</td>
</tr>
<tr>
<td></td>
<td>from the current host. For more information, see the SMAgent work around</td>
</tr>
<tr>
<td></td>
<td>for changing existing Access LUN mapping.</td>
</tr>
</tbody>
</table>

Direct-management method work around

Use these instructions for the direct managed method work around.

1. Connect the two controller Ethernet ports to the network.
2. Follow the direct-management setup instructions in Chapter 2, “Preparing for installation” on page 21 to manage the subsystem directly.
3. Open the Storage Manager 8 Enterprise Management window. Click Edit → Add device.
4. Enter the IP address for the first controller, and click Add.
5. Repeat to add the IP address of the additional controllers.
6. Click Close.
7. Right-click the newly added storage subsystem and select Manage Device. The Subsystem Management window for the storage subsystem opens. Proceed with the storage subsystem management tasks.

**SMAgent work around for defining additional Access LUN mapping**

Use these instructions for Storage Manager Agent 8.2.
1. Go to a different computer that has management access to the storage subsystem, or establish a direct management connection to the storage subsystem from the current host.
2. Start the IBM FASTT Storage Manager 8.0 client and open the Subsystem Management window for the storage subsystem.
3. Click the Mappings View tab.
4. Right-click the Default Group and select Define Additional mappings.
5. Select Access.
6. From the LUN drop-down menu, select Logical Unit Number (LUN) 31.
7. Click Add to define the access LUN.
8. Click Close. In the Define Mapping pane, a LUN with the Access name is displayed.
9. Close the window and restart the host. When the host restarts, the SMagent service starts.

**SMAgent work around for changing existing Access LUN mapping**

Use these instructions for Storage Manager Agent 8.2.
1. Go to a different computer that has management access to the storage subsystem, or establish a direct management connection to the storage subsystem from the current host.
2. Start the IBM FASTT Storage Manager 8.0 client and open the Subsystem Management window for the storage subsystem.
3. Click the Mappings View tab.
4. From the topology pane, select the Default Group or the corresponding host partition.
6. From the LUN drop-down menu, select the Logical Unit Number (LUN) that is supported by your operating system. If it is not available, you must remove one of the existing storage partitioning mappings.
7. Click OK.
8. Close the window, and restart the host. When the host restarts, the SMagent service starts.

**Upgrading from Windows NT 4.0 to Windows 2000**

If you have an existing storage subsystem running Windows NT 4.0, you can upgrade to Windows 2000 if the following conditions apply:
- Your storage subsystem is not the startup (boot) device.
- Your controllers are running firmware versions 04.00.00.00 or later.
Attention: To avoid possible data loss, you must uninstall any previous versions of the storage-management software (refer to "Uninstalling storage-management software components" on page 80) before upgrading your operating system. All storage-management configuration information is deleted during the uninstallation process. A complete reinstallation of the storage-management software is required.

To upgrade from Windows NT 4.0 to Windows 2000, do the following:

1. Verify that the storage subsystem contains no system-dependent files or directories, such as paging files.

2. Uninstall Storage Manager. Refer to “Uninstalling storage-management software components” on page 80. The Storage Manager components should be uninstalled in the following order:
   a. Storage Manager Agent
   b. Storage Manager Utility
   c. Redundant Disk Array Controller
   d. Storage Manager Client

3. Use the instructions from Microsoft to upgrade to Windows 2000.

4. Reinstall Storage Manager. Either refer to the instructions in "Installing Storage Manager 8.2 Client" on page 42 or to the procedure that came with the version of the storage-management software you are currently running.
Table 13 provides a data sheet for recording storage subsystem names, management types, hardware Ethernet addresses, and IP addresses. Make a copy of this table and complete the information for your storage subsystems and controllers. Use the information to set up the BOOTP table for the network server and the host or Domain Name System (DNS) table. The information will also be helpful if you add storage subsystems after initial installation. The column headings show a page reference for detailed instructions about obtaining the information. For a sample information record, refer to Table 9 on page 25.

Table 13. Storage subsystem information record and controller information record

<table>
<thead>
<tr>
<th>Storage subsystem name (page 25)</th>
<th>Management type (page 21)</th>
<th>Controllers—Ethernet and IP addresses, and host name (pages 25 and 27)</th>
<th>Host—IP address and host name (page 27)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Appendix B. Getting information, help, and service

If you need help, service, or technical assistance or just want more information about IBM products, you will find a wide variety of sources available from IBM to assist you. This section contains information about where to go for additional information about IBM and IBM products, what to do if you experience a problem with your computer, and whom to call for service should it be necessary.

Getting information

Information about your IBM server product and preinstalled software, if any, is available in the documentation that comes with your server. That documentation includes printed books, online books, README files, and help files. In addition, information about IBM products is available on the World Wide Web.

On the World Wide Web, the IBM Web site has up-to-date information about IBM products and support. The address for the IBM Personal Computing home page is http://www.ibm.com/pc/.

You can find support information for your IBM products at http://www.ibm.com/pc/support/.

If you click Profile from the support page, you can create a customized support page that is specific to your hardware, complete with Frequently Asked Questions, Parts Information, Technical Hints and Tips, and Downloadable Files. In addition, you can choose to receive e-mail notifications whenever new information becomes available about your registered products.


Getting help and service

If you have a problem with your server product, you will find a wide variety of sources available to help you.

Using the documentation and diagnostic programs

Many problems can be solved without outside assistance. If you experience a problem with your server product, the first place to start is the troubleshooting information in your IBM documentation. If you suspect a software problem, see the documentation, including README files and online help, that comes with the operating system or application program.

Most IBM server products come with a set of diagnostic programs that you can use to help you identify hardware problems. See the troubleshooting information in your IBM documentation for instructions on using the diagnostic programs.

The troubleshooting information or the diagnostic programs might tell you that you need additional or updated device drivers or other software. IBM maintains pages on the World Wide Web where you can get the latest technical information and download device drivers and updates. To access these pages, go to http://www.ibm.com/pc/support/ and follow the instructions.
Calling for service

If you have tried to correct the problem yourself and still need help, during the warranty period, you can get help and information by telephone through the IBM HelpCenter®. The following services are available during the warranty period:

- **Problem determination** - Trained personnel are available to assist you with determining if you have a hardware problem and deciding what action is necessary to fix the problem.
- **IBM hardware repair** - If the problem is determined to be caused by IBM hardware under warranty, trained service personnel are available to provide the applicable level of service.
- **Engineering Change management** - Occasionally, there might be changes that are required after a product has been sold. IBM or your reseller, if authorized by IBM, will make selected Engineering Changes (ECs) available that apply to your hardware.

The following items are not covered:

- Replacement or use of non-IBM parts or nonwarranted IBM parts. All warranted parts contain a 7-character identification in the format IBM FRU Xxxxxxxxx.
- Identification of software problem sources.
- Configuration of BIOS as part of an installation or upgrade.
- Changes, modifications, or upgrades to device drivers.
- Installation and maintenance of network operating systems (NOS).
- Installation and maintenance of application programs.

Refer to your IBM Statement of Limited Warranty for a full explanation of IBM warranty terms. Be sure to retain your proof of purchase to obtain warranty service.

In the U.S. and Canada, these services are available 24 hours a day, 7 days a week. In the U.K., these services are available Monday through Friday, from 9:00 a.m. to 6:00 p.m.

**Note:** Response times vary; may exclude some holidays.

Please have the following information ready when you call:

- Machine type and model
- Serial numbers of your IBM hardware products
- Description of the problem
- Exact wording of any error messages
- Hardware and software configuration information

**Telephone numbers**

Telephone numbers are subject to change without notice. For the most up-to-date phone numbers, go to http://www.ibm.com/pc/support/ and click **Support Phone List**.
<table>
<thead>
<tr>
<th>Country</th>
<th>Telephone number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Austria</td>
<td>Österreich 01-24 592 5901</td>
</tr>
<tr>
<td>Belgium - Dutch</td>
<td>Belgie 02-210 9820</td>
</tr>
<tr>
<td>Belgium - French</td>
<td>Belgique 02-210 9800</td>
</tr>
<tr>
<td>Canada</td>
<td>Toronto only 416-383-3344</td>
</tr>
<tr>
<td>Canada</td>
<td>Canada - all other 1-800-565-3344</td>
</tr>
<tr>
<td>Denmark</td>
<td>Danmark 45 20 82 00</td>
</tr>
<tr>
<td>Finland</td>
<td>Suomi 09-459 6960</td>
</tr>
<tr>
<td>France</td>
<td>France 02 38 55 74 50</td>
</tr>
<tr>
<td>Germany</td>
<td>Deutschland 07032-1549 201</td>
</tr>
<tr>
<td>Ireland</td>
<td>Ireland 01-815 9202</td>
</tr>
<tr>
<td>Italy</td>
<td>Italia 02-7031 6101</td>
</tr>
<tr>
<td>Luxembourg</td>
<td>Luxembourg 298-977 5063</td>
</tr>
<tr>
<td>Netherlands</td>
<td>Nederland 020-514 5770</td>
</tr>
<tr>
<td>Norway</td>
<td>Norge 66 81 11 00</td>
</tr>
<tr>
<td>Portugal</td>
<td>Portugal 21-791 51 47</td>
</tr>
<tr>
<td>Spain</td>
<td>España 91-662 49 16</td>
</tr>
<tr>
<td>Sweden</td>
<td>Sverige 08-477 4420</td>
</tr>
<tr>
<td>Switzerland</td>
<td>Schweiz/Suisse/Svizzera 058-333 0900</td>
</tr>
<tr>
<td>United Kingdom</td>
<td>United Kingdom 01475-555 055</td>
</tr>
<tr>
<td>U.S.A. and Puerto Rico</td>
<td>U.S.A. and Puerto Rico 1-800-772-2227</td>
</tr>
</tbody>
</table>

In all other countries or regions, contact your IBM reseller or IBM marketing representative.

**International Warranty Service**

If you travel with your server product or relocate it to a country where your server machine type is sold, your server product might be eligible for International Warranty Service, which automatically entitles you to obtain warranty service throughout the warranty period. Service will be performed by IBM or by IBM resellers who are authorized to perform warranty service.

Service methods and procedures vary by country, and some services might not be available in all countries. International Warranty Service is delivered through the method of service (such as depot, carry-in, or on-site service) that is provided in the servicing country. Service centers in certain countries might not be able to service all models of a particular machine type. In some countries, fees and restrictions might apply at the time of service.

To determine whether your server product is eligible for International Warranty Service and to view a list of the countries where service is available, go to http://www.ibm.com/pc/support/, and click **Warranty Lookup**. Eligible IBM server products are identified by their four-digit machine types. For more information about International Warranty Service, see Service Announcement 601-034 at http://www.ibm.com/. Click **Support & downloads**, click **Announcement letters**, and click **Announcements search**. In the **Search by letter number only** field, type 601-034, and click **Search**.
Purchasing additional services

During and after the warranty period, you can purchase additional services, such as support for IBM and non-IBM hardware, operating systems, and application programs; network setup and configuration; upgraded or extended hardware repair services; and custom installations. Service availability and service name might vary by country or region.

For more information about these services, contact your IBM marketing representative.
Appendix C. Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this publication to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product, and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Some software may differ from its retail version (if available) and may not include all user manuals or all program functionality.

IBM makes no representations or warranties regarding third-party products or services.

Edition notice

© COPYRIGHT INTERNATIONAL BUSINESS MACHINES CORPORATION, 2000, 2002. All rights reserved.
Trademarks

The following terms are trademarks of International Business Machines Corporation in the United States, other countries, or both:

- Active PCI
- e-business logo
- FlashCopy
- IBM
- ServeRAID
- ServerProven
- TotalStorage
- xSeries

Lotus, Lotus Notes, and Domino are trademarks of Lotus Development Corporation and/or IBM Corporation in the United States, other countries, or both.

Intel, Celeron, MMX, LANDesk, Pentium, Pentium II Xeon, Pentium III Xeon, and Xeon are trademarks of Intel Corporation in the United States, other countries, or both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Linux is a registered trademark of Linus Torvalds.

Other company, product, or service names may be the trademarks or service marks of others.
Index

A
access volume
detecting after host restart 80
alert notifications 69
automatic host discovery 68
automatic storage subsystem discovery 68

B
BOOTP server
UNIX 37
BOOTP table 37

C
cluster server
software, installing 59
software, verifying installation 60
configuration types
cluster server 11
custom server configuration 9
installing storage manager 7.02 9
standard (noncluster) configuration 9
creating arrays and logical drives 71

D
DHCP/BOOTP server 22
setting up 32
directly managed storage subsystems 6
Disk Administrator utility
deleting LUNs 75, 77
disk configuration 44, 55

E
Enterprise Management window
adding devices 69
alert notifications 69
component of SMclient 4
Help 1
Ethernet MAC address 25
eexisting storage subsystem 11
operating system requirements 15
system hardware requirements 15

F
fabric switches 16
FAStT Management Suite Java 1, 73
FAStT-MSJ 1, 73
Fibre Channel
Concepts Guide 1
host adapter 16
managed hub 16
firmware requirements 17

firmware, downloading 70

H
hardware Ethernet address (pre-installation task) 24
hardware requirements 16
heterogeneous hosts
defining types 72
overview 72
host adapters 16
host port, defined 72
host table
pre-installation tasks 24
setup 37
host-agent management method
advantages 5
described 5
host-agent software
automatically stops 80
stopping and starting 80
Hot Add utility, using 78

I
installation process
cluster server configuration 11
installation types
hardware environments 11
new storage subsystem 11
installing software (standard configuration) 44, 57

L
limitations
Windows NT 83

M
MAC address, Ethernet 25
managed hub 16
management methods for storage subsystem
direct 6
host-agent 5
management station 16

N
naming storage subsystems 25
new storage subsystem 11

O
operating system limitations
Windows NT 83
operating system requirements 18

© Copyright IBM Corp. 2000, 2002
97
premium feature key 1, 2
publications, related xii

disk space requirements 18
installing on Windows 2000 44, 54
related publications xii
rolling upgrade 60
rolling upgrade of storage-management software 60

scheduled upgrade 60
scheduled upgrade of storage-management software 60

Simple Network Management Protocol (SNMP)
traps 22
SMclient disk space requirements 18
SMdevices utility, using 78
SMutil disk space requirements 18
software requirements 18
starting Subsystem Management 70

storage management software
administrators privilege 18
hardware requirements
BOOTP server 16
fabric switches 16
host adapters 16
managed hub 16
storage subsystem 16
UNIX BOOTP server 16
installation requirements 15
new terminology 3
storage subsystem 16
storage subsystems 51
directly managed 6
discovery of host-agent managed 80
naming 70

Subsystem Management window
component of SMclient 4
Help 1

TCP/IP protocol verification 37
trademarks 96

Universal Xport device 19
UNIX BOOTP server 16
upgrading from previous version of storage-management software 61
rolling upgrade 62
scheduled upgrade 61
upgrading from Windows NT to 2000 (continued)
in a standard configuration 86

Windows NT 83
Disk Administrator utility 75, 77
limitations 83
