Type 0 Complex
 rf90386a.exe  (No diagnostics disk needed)

Type Zero Minus 64F0782 (No L2 Cache)
Type Zero  04G3884 (64KB L2 Cache)

Type 0 and 8595 DBA ESDI Support (Yes, Virginia, it DOES work)
   ESDI Support for Convenience Partition?
Type 0 Success in 8595-OH9
Type 0 Booting Experiences
Type 0 Difficulties with 9595 (lack of planar ADFs?)

Type 0 Minus! 64F0782


OS1 40.0000MHz oscillator
U1 Delay Line?
U2 80386DX-20 Sigma Sigma
U3 90X8134 DMA Controller
U6 33F5946 CPU Gate Array
U7 80387DX-20 Math Co-Processor
U8 33F5944 Memory Controller GA
U9 57X4111 MS700
U? BIOS 57F2943 1989
0
Some of the support chips look like from the P70 I've been playing with.

Type Zero 04G3884 (64KB L2 Cache)



D1 Solder pads for LED
OS1 40.0000 Osc
U1 386DX-20
U2 385-20 Memory / Cache Controller
U4 90X8134 DMA Controller 
U9 33F5946 CPU Gate Array
U10 387DX-20
U21 84F9413 BIOS
U23 33F5944  Memory Controller GA
U29, 30, 42, 43 TC5588J-25
U44 57X4111 MS700
0

90X8134 DMA Controller (Also used on K complexes)
A82385  Also in "revised" 20MHz and 25MHz (20MHz version!) 8580 planars, and the Mod. 70-Axx "processor complex card".
TC5588J-25 are 64K cache for the 386DX-20.

Supports (4) 85nS and 80nS 2MB SIMMs on the risers and 8MB on an expansion card. Supports Spock from one to three can version. Most likely the short Tribble as well.



From Rich Wolos
   I had these -402 beasts.  Converted them all to 486, no problems now. Just have to reload the IML on hard drive.  Usually do a LLF first. The -402 will only accept 4x 2/85 (2MB 72pin simms FRU# 92F0104) = 8-mb on motherboard, 8-mb more on an expansion card.  Bootable refdisk for that 90386 is only available by backing up.  Keep a copy before you switch, may be useful someday <g>.


Type 0 and 8590 Planar DBA ESDI Support
Update from Daniel Hamilton! Confessions of a Model 90 386 (update)

   I took down my Model 90s today and booted them up.  I started up the old 402 and got another itch to try to do something with those ESDI ports.  I experimented back in early 2006 with this (I went and found my old posts here before trying again, to make sure I wasn't repeating mistakes of the past).  :)  However, this time I found out something that partially disproves something I had revealed here back then.  My original post read:

8590-402 reveals more secrets...

Q: Is ESDI bootable on a Type-0 Processor Complex?
A: No: IML Error I9990080 (IML not supported on primary disk drive)

The answer is not incorrect, but it is *incomplete*.  The correct answer is Yes AND No actually.  ESDI will boot with the T0 I found today.  The catch is that it just cannot be the IML drive.  What I did before was remove the Spock adapter and therefore removed the original 160MB SCSI disk that came with the system (which was the IML disk as well).  However if the SCSI adapter/disk is NOT removed, the ESDI drive works just fine, and actually will preempt the SCSI disk in the
boot sequence by default!

I can see how this would have helped upgrades from Model 70s (which I've read postulated elsewhere is a major reason for the Model 90s). A administrator could simply remove the hard disk from a production Model 70 and just stick it in a new Model 90 and turn it on...presto, the system boots up with the ESDI disk as C:, and the fast SCSI disk sets waiting as D: drive.  Neat.

So a correction 4 years in the making is...

Q: Is ESDI bootable on a Type-0 Processor Complex?
A: Yes:  ESDI disk will boot as long as another IML-capable disk is installed on the system. IML Error I9990080 (IML not supported on primary disk drive) will occur if only the ESDI disk is installed.

ESDI Support for Convenience Partition?
Tim Clarke opines:
   So, in theory, you could IML from the RefDisk and then boot to an ESDI-only system via the "Start Operating System" option from it's menu, I'd guess. Also, have you considered that the Type-0 complex might have "Convenience Partition" support in its ROM(s), if IBM were experimenting with the IML support for non-SCSI drives at that time? If you ensure that there are no more than 3 partition entries in the master partition table and a good 4MB of space available on the ESDI drive, you could then try the "Create System Partition" option on an ESDI-only setup? The Convenience Partition's type byte is 0x3F, IIRC.

Type 0 Success in 8595-OH9
   The Type 0 will work in an 8595-0H9, with some patience.  First putting in a spare T0 would result in no video.  Taking other T0 out of working -402 and placing it into -0H9 worked.  After video was achieved with this T0, swapping back the previously non-working T0 would work also.  Do some T0's have more "kick" to them?  They some are leaders, some are followers.
   Working -0H9 configuration was stock, except for the changing memory from 70ns nonparity to 80ns parity (Model 70 386 memory).  -0H9 had "newest" SCSI w/Cache. -402 had older SCSI w/Cache but made no difference.

Type 0 Booting Experiences
I got it to work in another 8590-0H9.  The weird thing (and telling) was this:
Two machines:
8590-402: Stock T0 complex.
8590-0H9: Stock T2 complex.

I have a second T0 complex (I had before getting the 402), here-after referred to as T0-2.  T0-2 would not work initially if swapped with the original T0 in the 402.  No video.  I then flipped the password-reset jumper on the planar.  Put T0-2 back in, and it worked.  Great, now I know the complex works.

I just got the 0H9.  It came with a T2 complex.  I checked the planar, same FRU as the one in the 402.  So I swapped the memory for some 80ns parity memory (2x2MB).  Went ahead and flipped the password-reset jumper.  Powered up, no video, nothing.  I was stumped.  So then I took the T0 in the 402 and put it in the 0H9.  Viola, it worked.  Okay, what's going on?  I put T0-2 back in AND IT ALSO WORKED, although it wouldn't just minutes earlier.  So I had two functional T0 machines functioning.  I seemed to finally have the recipe for success.

The recipe is: One 8590 with Spock SCSI.  Put at least 1 PAIR of 80ns Parity SIMMs in (Model 70 386 Memory).  Flip the password-reset jumper.  Cross your fingers and push the power switch.

Type 0 Difficulties in 9595
Daniel Hamilton's story with 9595s...
    On the Model 95 XP (0MG), the T0 seems to not be able to access IML via the floppy controller.  You'll always get I99900x1 or I99900x2 errors. I took the 160MB SCSI drive from the 402 and put it in the 9595.  It then came back with a I999003x error, Disk IML record incompatible with system board.  Someone mentioned the planar ADF is missing and could be causing the problem.  I need to investigate this further. I finally ended up with I9990033 errors.

9595 Main Page