To install AIX 5.3 via CDs, - Put first CD into drive and if a JS20 blade, change Media Tray focus. - Get a console to the machine. If this is a JS20 blade, get a SOL (Serial Over Lan) console connection by establishing an ssh session to blades1 ssh -l admin blades1 and console -T blade[2] You won't be able to connect though 'till 47 seconds after you power the blade up. You get this error message, SOL is not ready - From http://blades1, go to Blade Tasks -> Power/Restart and power on the blade. - After 47 seconds, connect to the SOL console (see above), where you can monitor progress via the 4-digit POST/BIOS progress indicators. When it gets to E1AD, you'll see a little clock-like \-/| indicator after it, which says it's trying to boot the CD. If it fails, it kicks you back to the MM's system> prompt. - You can accept all the default settings for AIX (Fresh Install on hdisk0). After 18 minutes, it'll ask for the second CD. ********************************************** * During the install, you'll get a lot of * * "Missing Filesets" messages, but all but * * the devices.pci got installed, so I didn't * * worry about this. * ********************************************** After rebooting, - Set terminal type to vt100 Then used the initial smitty to - Accept License Agreements - Set Date and Time - Change / Show Date & Time - Change Time Zone Using System Defined Values --> PST8PDT Warning! If you adjust the clock back more than a few minutes, which I had to do, it's best to reboot right away, else you may get confused with out-of-order files in a ls -ltr command, and files with future time stamps. - Set root Password - Configure Network Communications - TCP/IP Startup --> en0 Setting HOSTNAME to supa2 Internet ADDRESS to 10.222.211.(61+n) Network MASK to 255.255.255.0 NAMESERVER Internet ADDRESS to 199.221.80.141 NAMESERVER DOMAIN Name to 199.221.80.141 Default Gateway Address to 10.222.211.1 Then, most important of all, - Tasks Completed - Exit to Login !!! Reboot now if you set the time back more than 5 minutes. Then I could telnet to the machine and finish the configuration from a telnet window. ----------------------------------------------------------------------------- Configure myself as a NIM client (although they're already all defined, I need an /etc/niminfo file). niminit -a name=supa2 -a pif_name=en0 -a master=supa1.delphion.com -a platform=chrp This writes an /etc/niminfo file and puts this line in /etc/inittab nimclient:2:once:/usr/sbin/nimclient -S running > /dev/console 2>&1 that informs nim the machine is up and running, which is kinda cute. On the NIM master, a lsnim -l supa2 command then shows ... Mstate = currently running ... It might have also changed things in /etc/security, but I couldn't be sure because the time & time zone settings changed the sort order of ls -ltr. ----------------------------------------------------------------------------- Add this line to /etc/hosts file, vi /etc/hosts Go10.222.211.62 supa1 supa1.delphion.com else you'll get 0042-001 nim: processing error encountered on "master": 0042-006 m_cust: (From_Master) connect Error 0 rshd: 0826-826 The host name for your address is not known. rshd: 0826-826 The host name for your address is not known. when you do the nim -o cust below, due to the fact that reverse name resolution doesn't work here. I'm still trying to get that fixed. ----------------------------------------------------------------------------- Install extra software. From the nim master, supa1, target=supa2 nim -o allocate -a installp_bundle=Extra_Software \ -a lpp_source=530lpp_res $target nim -o cust -a installp_bundle=Extra_Software \ -a lpp_source=530lpp_res $target nim -o allocate -a installp_bundle=Extra_AIX \ -a lpp_source=530lpp_res $target nim -o cust -a installp_bundle=Extra_AIX \ -a lpp_source=530lpp_res $target nim -o allocate -a installp_bundle=openssh \ -a lpp_source=530lpp_res $target nim -o cust -a installp_bundle=openssh -a lpp_source=530lpp_res \ -a accept_licenses=yes $target ----------------------------------------------------------------------------- Customize everybody's environment with my preferences cp -p /etc/profile /etc/profile.orig scp -p root@supa1:/etc/profile /etc/profile to pick up my set -o vi, my c alias, ksh prompt, etc. ----------------------------------------------------------------------------- Customize ssh environment vi /etc/ssh/sshd_config to set X11Forwarding yes UseDNS no Subsystem sftp /usr/sbin/sftp-server and vi /etc/ssh/ssh_config to set ForwardX11 yes stopsrc -s sshd startsrc -s sshd vi /etc/ssh/sshd_config /etc/ssh/ssh_config ----------------------------------------------------------------------------- Added these lines to the bottom of /etc/filesytems vi /etc/filesystems Go /export/home: dev = "/home" vfs = nfs nodename = sunas1 mount = true options = bg,hard,intr account = false /dfs: dev = "/dfs" vfs = nfs nodename = sunas1 mount = true options = bg,hard,intr account = false Then mkdir /export /export/home /dfs mount /export/home mount /dfs - - - - - - - - - - - - - - - - - - - - - - - - - - I still seem to be missing these 3 filesets, but I don't know where - - I got them. They're on supa1. - - eclipse2.rte 2.1.3.0 Eclipse Integrated Tool - - infocenter.man.EN_US.files 5.3.0.30 AIX manual files - U.S. - - infocenter.man.EN_US.libs 5.3.0.30 AIX manual libs - U.S. English - - - - - - - - - - - - - - - - - - - - - - - - - - ----------------------------------------------------------------------------- Install all AIX updates cd /dfs/software/fixes/AIX_5.3_ML_4 smitty update_all ----------------------------------------------------------------------------- To get DNS correct, echo 'nameserver 199.221.80.141' > /etc/resolv.conf echo 'nameserver 199.222.82.28' >> /etc/resolv.conf echo 'search delphion.com eagan.tshmg.com' >> /etc/resolv.conf ----------------------------------------------------------------------------- To get NTP configured (note we're using Dialog's NTP server, not afs1), echo 'server time.ext.dialog.com' >> /etc/ntp.conf startsrc -s xntpd chrctcp -a xntpd ----------------------------------------------------------------------------- To install the C/C++ compiler & setting the /usr/bin links, cd /dfs/software/base/C_C++.v8_For_AIX_5.3 smitty installp Remember to toggle the "ACCEPT new license agreements?" to yes. ./replaceCSET ----------------------------------------------------------------------------- To increase some file systems chfs -a size=20971520 /var chfs -a size=20971520 /tmp chfs -a size=1048576 /home ----------------------------------------------------------------------------- To make it so nobody trips over any system limits (all too common), vi /etc/security/limits and set everything in the default: clause except nofiles, to -1. default: fsize = -1 core = -1 cpu = -1 data = -1 rss = -1 stack = -1 nofiles = 2000 ----------------------------------------------------------------------------- To set up this machine as a NIS client (Don't do this on supa1 !!!) chypdom -B delphion.com mkclient -B -S supa1.delphion.com ----------------------------------------------------------------------------- To be able to send mail, cd /etc/mail cp -p sendmail.cf sendmail.cf.orig vi sendmail.cf and add Djdelphion.com after 'my official domain name' around line 87 Also add DSrelay.int.dialog.com after '"Smart" relay host (may be null)' around line 97 And change the DM line on line 135 'who I masquerade as' to DMdelphion.com stopsrc -s sendmail startsrc -s sendmail -a '-bd -q30m' ----------------------------------------------------------------------------- * Move getty up in /etc/inittab between fbcheck & srcmstr. vi /etc/inittab * Tweak system dump parameters sysdumpdev -d /var/adm/ras sysdumpdev -K -d = Continue boot if copy fails -K = Always allow system dump