Using the IBM @server xSeries 135 Web Server Appliance

Describes the features of the xSeries 135 appliance

Explains how to set up the appliance

Covers how to use the management tools

Redpaper

David Watts
Jean-Yves Touzac
Gayle Solheim

ibm.com/redbooks
Using the IBM @server xSeries 135 Web Server Appliance

August 2001
Take Note! Before using this information and the product it supports, be sure to read the general information in “Special notices” on page 55.

First Edition (August 2001)

This edition applies to the IBM @server xSeries 135, 8672-24X and 8654-5CX.

Comments may be addressed to:
IBM Corporation, International Technical Support Organization
Dept. HZB  Building 662
P.O. Box 12195
Research Triangle Park, NC 27709-2195

When you send information to IBM, you grant IBM a non-exclusive right to use or distribute the information in any way it believes appropriate without incurring any obligation to you.

© Copyright International Business Machines Corporation 2001. All rights reserved.
Note to U.S Government Users - Documentation related to restricted rights - Use, duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule Contract with IBM Corp.
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Preface</strong></td>
<td>v</td>
</tr>
<tr>
<td>The team that wrote this redpaper</td>
<td>v</td>
</tr>
<tr>
<td>Special notice</td>
<td>vi</td>
</tr>
<tr>
<td>IBM trademarks</td>
<td>vi</td>
</tr>
<tr>
<td>Comments welcome</td>
<td>vi</td>
</tr>
</tbody>
</table>

### Chapter 1. Overview

1. **What is a server appliance?** 2
   - 1.1.1 The role of appliances in e-business 2
2. **xSeries 135 overview** 3
   - 1.2.1 Preloaded software 4
   - 1.2.2 Working with the tools 6
3. **Managing the appliance environment** 7

### Chapter 2. Deployment and configuration

1. **Installation considerations** 10
   - 2.1.1 Network connectivity 10
2. **Initial setup** 12
3. **Setting up multiple systems** 17
4. **IAAConfig** 21
   - 2.4.1 Reprovisioning 21
5. **Appliance System Manager** 27
   - 2.5.1 Backup/restore system configuration files 30
   - 2.5.2 Backup/restore user directories 31
   - 2.5.3 E-mail alerting 32
6. **IBM HTTP Server** 33
   - 2.6.1 Using the proxy cache 34
7. **Creating Web sites** 35
   - 2.7.1 PHP 37
8. **Load balancing** 39
9. **Tuning and performance** 40
   - 2.9.1 Factors affecting Web server performance 40

### Chapter 3. Management

1. **Software management** 44
   - 3.1.1 IBM Director 44
2. **Advanced System Management service processor** 49
3. **Comparing the management tools** 54

### Special notices

- 55
Preface

The computer industry has been evolving for a number of years from a model of using general-purpose computers for everything to a new model where specialized systems are used more and more for specific purposes. Purpose-built client devices and servers offer the advantages of speed, lower cost, ease of deployment and ease of use.

The latest generation of IBM server appliances, which support both Web and infrastructure requirements, are value-priced, preconfigured and rapidly deployable—without sacrificing functionality, performance or scalability.

This paper describes how to set up and use the IBM @server xSeries 135 Web Server appliance. This Red Hat Linux-based appliance is ideal for medium to large enterprises, Internet Service Providers (ISPs), and Application Solution Providers (ASPs). It is preconfigured with hardware and software and is designed for quick and easy setup out of the box, which greatly reduces deployment time for enterprises with multiple Web hosts.

The team that wrote this redpaper

This redpaper was produced by a team of specialists from around the world working at the International Technical Support Organization, Raleigh Center.

David Watts is a Senior IT Specialist at the IBM ITSO Center in Raleigh. He manages residencies and produces redbooks on hardware and software topics related to xSeries systems and associated client platforms. He has authored over 20 redbooks; his most recent books include Integrating IBM Director with Enterprise Management Solutions and Implementing Asset ID. He has a Bachelor's degree in Engineering from the University of Queensland (Australia) and has worked for IBM for over 12 years. He is an IBM Professional Server Specialist and an IBM Certified IT Specialist.

Gayle Solheim is an xSeries Systems Engineer in Eau Claire, Wisconsin. She has over 15 years of experience in the computer industry, and has worked in the areas of software development, performance modeling and analysis, technical marketing and system testing. She has worked for IBM for the past two years. She holds a degree in Computer Science from the University of Minnesota. Her areas of expertise include xSeries systems management using IBM Director, Windows NT/2000 and Microsoft Back Office products.

Jean-Yves Touzac is an IT specialist with IBM France. He has six years of experience in IT. He has been a pre-sales specialist on network and communications adapters for three years, a PSG Garter Group Consultant for Total Cost of Ownership (TCO), and a pre-sales specialist in system management for one year, then in pre-sales on thin client in the IBM Personal Computing Division. He is now an xSeries Field Technical Sales Specialist (FTSS) in the IBM Server Division. His areas of expertise include Windows NT, Linux, networking, thin client architecture, and xSeries and Netfinity servers.

Thanks to the following people for their contributions to this project:

Travis Appleman, Technical Project Manager, xSeries Appliance Development
Dustin Fredrickson, xSeries Performance Group, Raleigh
Tim Green, xSeries Appliance Development Team, Raleigh
Susan C. McLeod, World Wide Brand Manager, xSeries Appliances, Raleigh
Paul Schroeder, Developer and author of arpfind, Linux Technology Center, Austin
Special notice

This publication is intended to help customers, business partners and IBM employees understand what Web server appliances are, how they fit into existing computing environment, and how to set and use the xSeries 135 for immediate productive use. The information in this publication is not intended as the specification of any programming interfaces that are provided by the xSeries 135 Web Server Appliance. See the PUBLICATIONS section of the IBM Programming Announcement for xSeries 135 Web Server Appliance for more information about what publications are considered to be product documentation.

IBM trademarks

The following terms are trademarks of the International Business Machines Corporation in the United States and/or other countries:

- e (logo)®
- IBM ®
- Netfinity

Comments welcome

Your comments are important to us!

We want our redpapers to be as helpful as possible. Send us your comments about this red paper or other redbooks in one of the following ways:

Use the online Contact us review redbook form found at:

  ibm.com/redbooks

Send your comments in an Internet note to:

  redbook@us.ibm.com

Mail your comments to the address on page ii.
Overview

This chapter provides an overview of the IBM @server xSeries 135 Web server appliance. The following topics are covered:

- Benefits of server appliances
- Overview of x135 models
- Description of x135 preloaded software
- How to manage your x135 appliances
1.1 What is a server appliance?

*Server appliance* is a relatively new term used to describe a server which is optimized for a specific function. Like other kinds of appliances, server appliances are designed for a single purpose. Common applications for server appliances include file storage, Web hosting, and Web caching.

Because an appliance is designed to perform a single function, much of the complexity found in traditional multi-purpose servers can be eliminated, making it possible to streamline the hardware, operating system, and associated applications, resulting in a system with the following characteristics:

- Low cost
- High performance
- Quick deployment
- Ease of maintenance and management

The xSeries 135 is a full-function, 1U Web server appliance, and is targeted at medium to large enterprises, Internet Service Providers (ISPs), and Application Solution Providers (ASPs). It is preconfigured at the factory with hardware and software. The x135 is designed for quick and easy setup out of the box, which greatly reduces deployment time for enterprises with multiple Web hosts.

1.1.1 The role of appliances in e-business

Appliances fit nicely into today’s e-business infrastructure, which is depicted in Figure 1-1. Rather than having several expensive general purpose servers, the trend is to use appliances in just such an environment. Each appliance is designed to perform a specific task within the e-business model, and to do it faster, more cost-effectively, and with less IT intervention.
The xSeries 135 (and the Windows equivalent model, x130) fits into the category of Web hosting appliances, which means that its function is to efficiently serve pages requested by a potentially large number of Web users. Some of the roles that appliances are fulfilling include Web hosting, Web caching, load balancing, and file/print/storage serving. Understanding each of these roles will help to build a robust e-business infrastructure.

**Web hosting**

Web server appliances are integrated hardware/software systems that serve content over the Internet using a standard markup language (such as HTML, XML, or WML). Appliance Web servers accept requests from clients and return the appropriate content. In addition to standard Web server software, Microsoft IIS, the application set may include other software such as SSL security and Active Server Pages (ASPs).

**Web caching**

Caching appliance servers are systems that select and store Web data for quick access on the network. The most frequently requested content from the Web client side is stored on the caching server. As a result, the network can more quickly fulfill requests for Web pages.

A caching server is deployed in two different scenarios:

- If it sits in front of the Web servers (that is, the provider side) it is called a reverse cache; it reduces the Web server load and enhances overall site performance.

- If it sits in front of the Web client, it is called a forward cache and it reduces traffic on the wide area network (WAN).

**Load balancing**

The load balancing server appliance identifies the traffic by reading the following information: the HTTP request header, cookies, and URL. The load balancing appliance is positioned between the network and server array. It continuously monitors each server for service and application availability and performance and routes incoming traffic to the most available device. A load balancing appliance typically optimizes connectivity for a server, firewall or cache.

**File/print/storage serving**

This type of appliance is generally referred to as a Network Attached Storage (NAS) appliance. NAS appliances are designed to handle the exponential demand for storage expansion, and allow customers to easily add storage on demand. NAS appliances typically provide storage capacities ranging from hundreds of gigabytes up to several terabytes.

### 1.2 xSeries 135 overview

The xSeries 135 represents the second generation of Web server appliances from IBM, and delivers optimal performance, functionality and manageability for Linux-based Web hosting environments.

Two models of the x135 are available:

- The Value model, based on the IBM @server xSeries 300 server with a single Intel 800 MHz Celeron processor and IDE disk subsystem.

- The Performance model, based on the IBM @server xSeries 330 with an Intel 1 GHz Pentium III processor and support for a second CPU, and a SCSI disk subsystem.
Table 1-1 summarizes the key differences between the Value and Performance lines.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Value model</th>
<th>Performance model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model</td>
<td>8672-24X</td>
<td>8654-5CX</td>
</tr>
<tr>
<td>Processor type</td>
<td>800 MHz Intel Celeron</td>
<td>1 GHz Intel Pentium III</td>
</tr>
<tr>
<td>Maximum number of processors</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>Maximum memory</td>
<td>1.5 GB</td>
<td>2 GB</td>
</tr>
<tr>
<td>Hard disk drives</td>
<td>IDE</td>
<td>SCSI</td>
</tr>
<tr>
<td>Integrated Advanced Systems Management service processor</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Cable chaining technology (C2T)</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>

The integrated Advanced System Management processor is standard on the Performance model, and is part of the system board design, rather than a separate PCI adapter. It provides monitoring of CPUs, memory, fans, system temperature, and power supply voltage.

Cable chaining technology, C2T, is a new cable connection design which significantly reduces the number of cables and connectors required by simply daisy-chaining the keyboard, mouse and video signals from one system to another, without the need for a console switch. Using C2T, up to 42 x130 appliances can be configured in a single rack without the massive amounts of cables and connections previously required.

### 1.2.1 Preloaded software

The xSeries 135 appliance has a pre-installed operating system and application software, including programs to configure, manage, and maintain your server. The x135 is designed for remote management, which is performed using the tools described below.

**Red Hat Linux 6.2**

Red Hat Linux 6.2 is pre-installed on the appliance, making it easier to deploy the unit by reducing the time spent in installation, initial configuration and Web site configuration. Production services such as HTTP and FTP servers and Web management are active once you have started the machine, allowing you to use the machine immediately. IBM has developed Web-based tools to remotely manage the Linux machine.

**IBM HTTP Server**

The IBM HTTP Server Version 1.3.12.2 (which is based on Apache 1.3.12 Unix) includes the base Web serving functions and an administrative server for Web-based management. To enable easy deployment, the HTTP server is already configured and started at boot time.

**IBM Advanced Appliance Configuration Utility 2.0**

The IBM Advanced Appliance Configuration Utility (IAAConfig) is a management tool which detects the presence of xSeries appliances on the network, and enables you to set up and manage the network configuration for one or more appliance servers. IAAConfig also provides a launch point for the Appliance System Manager, and includes a reprovisioning tool, which enables you to create an appliance image and apply it to other servers on your network. The reprovisioning tool provides a quick and easy way to set up new servers.
IAAConfig has two components: an agent, which is pre-installed on the x135, and a console which runs on a Windows system. The console is a Java-based application that is included on the supplementary CD-ROM shipped with your server. The IAAConfig console should be installed on a Windows workstation. If your environment contains multiple appliances, we recommend that you designate a laptop, server, or workstation as a management console, and that you perform all management tasks from this console.

Figure 1-2 depicts a sample IAAConfig console window, which shows configuration information for an x135. To start the Appliance System Manager in a Web browser, click the blue Start Web Management button located at the bottom of the window.

Additional information on the IAAConfig utility can be found in Chapter 2, “Deployment and configuration” on page 9 and in the IBM xSeries 135 Installation Guide.

![Image of IBM Advanced Appliance Configuration Utility console](image)

**Figure 1-2  IBM Advanced Appliance Configuration Utility console**

**IBM Appliance System Manager**

The Appliance System Manager is a Web-based tool which enables you to remotely control, manage, monitor, audit, and configure your server. Appliance System Manager is useful for an administrator who does not want to use a command line to configure his or her Linux system. The Appliance System Manager is covered in detail in 2.5, “Appliance System Manager” on page 27.

**IBM Director agent**

The Tivoli agent is installed and loaded at startup, and it provides support to IBM Director. You can integrate your appliance into a workgroup system management such as IBM Director, or in an enterprise system such as Tivoli Enterprise. It provides a useful inventory function. IBM Director is described in more detail in 3.1.1, “IBM Director” on page 44.
**PHP 4.0 support**

PHP is a server-side, cross-platform, HTML embedded scripting language and is implemented as a plug-in of the HTTP server. PHP is a project of the Apache Software Foundation.

PHP is different from a CGI script written in other languages such as Perl or C. Instead of writing a program with commands to output HTML, you write an HTML script with some specific code embedded. PHP is executed on the server and includes functions such as form data, dynamic page content generation, cookies and database support.

**E-mail alerting**

This function lets you monitor the following critical situations and send an e-mail to the administrator or to an e-mail list when the threshold is exceeded:

- Filesystem over x% full
- Processor load over x%
- Web server not responding
- Host x not responding to ping
- Memory usage over x%
- Unexpected reboot

1.2.2 Working with the tools

The first tool you have to set up is IAAConfig, which is a Java application used to manage all the appliances. This is the starting point of management.

As you can see in Figure 1-3, IAAConfig is able to launch the Appliance System Manager using Web management, and the Appliance System Manager can launch the IBM HTTP Server configuration tool. Using a browser and the Web administration interface, you can also access the tools using specific TCP/IP ports.
1.3 Managing the appliance environment

In order to easily deploy and install your IBM server appliances, we recommend that you install a Windows workstation on the same physical subnet as your appliances, and designate it as a systems management console. This machine can be a laptop, workstation, or server, and will be used by your system administrator to deploy and manage your appliances.

All of the client software required to successfully manage your xSeries 130 server environment is pre-installed on each appliance. We recommend that you install the following software on the management console:

- A supported Web browser (Internet Explorer V4.01 or Netscape Navigator) so that you can access the Appliance System Manager on the appliance.
- IBM Advanced Appliance Configuration Utility (IAAConfig), which is included on the supplementary CD-ROM shipped with your server.
- FTP server (required for IAAConfig reprovisioning capability).
- Optionally, the IBM Director console. A license for the IBM Director server is not shipped with the appliance. If the management console is an xSeries or Netfinity system, you will have received a license and the software for IBM Director.
- VT Emulator (for Linux users).

Figure 1-4 shows a sample configuration for managing your xSeries 135 appliances.

Figure 1-4  xSeries 135 remote management architecture
Deployment and configuration

In this chapter, we present some methods for deploying and configuring your xSeries 135 appliances. Detailed examples are provided on how to use the configuration tools that are pre-installed on the x135. The following topics are covered:

- Planning the installation
- Initial setup and configuration
- Setting up multiple systems
- Best practices
- Load balancing
- Tuning and performances
2.1 Installation considerations

IBM appliances reduce setup time by eliminating the software installation, configuration and fine-tuning steps. Less time spent setting up and configuring servers also means that your IT staff has more time for other projects. Rack configuration, cabling, remote hardware management and IP address assignment are still required planning steps:

**Rack configuration**

Packaged in a 1U form factor, 42 servers can fit in one Netfinity 42U rack, or 22 servers in a NetBay22. To install the appliances in the rack, follow the instructions in the *IBM xSeries 135 Installation Guide* which is shipped with the server.

**Cabling**

The performance model includes a new product from IBM called Cable Chaining Technology (C2T). C2T significantly reduces the number of cables and connectors required and eliminates the need for console switches. All appliances in the rack are simply daisy-chained together and a keyboard, mouse and monitor are connected to the last appliance.

**Hardware management**

The performance model includes an integrated Advanced Systems Management (ASM) processor and two RS-485 systems management ports. You can use the RS-485 connectors to create an Advanced Systems Management bus between your xSeries 135 appliance servers or other xSeries servers. This allows you to connect from one Advanced Systems Management processor to another on the same bus.

The Advanced Systems Management bus is designed to connect up to 12 devices or appliance servers. It is common practice to connect another xSeries server with the IBM Remote Supervisor adapter or an Advanced Systems Management PCI adapter to your Advanced Systems Management bus, which means that you can connect a maximum of 11 appliance servers together. If you have more than 11 appliance servers, some planning must be done to determine how to configure the Advanced Systems Management buses for your appliances. The *IBM xSeries 135 Installation Guide* includes detailed instructions on how to configure the Advanced Systems Management bus using the RS-485 ports.

**IP address assignment**

Each of the x135 appliances in your environment requires at least one IP address, and two if you are using the second built-in Ethernet adapter. The IBM Advanced Appliance Configuration Utility (IAAConfig) provides the capability to automatically assign host names and IP addresses to all appliances on the network. If you wish to take advantage of this feature, you will need to reserve a range of IP addresses for input to IAAConfig.

2.1.1 Network connectivity

The x135 has two Ethernet ports. One possible use of these ports is to connect to two separate networks, public and private. The public network is not able to reach the private network, preserving system security, and network bandwidth used by administrative tasks stays on the private network.
Figure 2-1 shows an example of how to implement the x135 in a network environment.

In Figure 2-1, we implement two separate networks using the two Ethernet adapters to secure the operations and to split the administrative tasks from the production network.

As you can see from the figure, we recommend that you have a management console so that you can remotely perform administrative tasks, including:

- Network settings
- IBM HTTP Server configuration
- FTP and Telnet access
- Backup/recovery using an FTP server
- PHP setup
- Appliance System Manager tasks

You can also use this management console for Web page design.

The management console can be a laptop, workstation, or server, and will be used by your system administrator to deploy and manage your appliances. In order to effectively manage your x135 appliance servers, install the following software on the management console:

- Web browser
  - Supported Web browsers are Internet Explorer, versions 4.01 and higher, and Netscape Navigator.
- IBM Advanced Appliance Configuration Utility (IAACfg) console
  - IAACfg is located on the supplementary CD-ROM shipped with your server. To install it, run SETUP.EXE located in the IAACfg directory on the CD-ROM. You will be asked to reboot your server when the installation is complete.
FTP server (optional)
An FTP server is only required if you plan to use the IAAConfig reprovisioning feature. For more information on reprovisioning, see 2.4.1, “Reprovisioning” on page 21 in this redpaper, or the IBM xSeries 135 User’s Reference.

You may use any FTP server, but if you are running Microsoft Windows NT 4.0 or Windows 2000 on the management console, FTP is included as a component of Internet Information Services (IIS). For more information on installing IIS and FTP, please refer to the Windows product documentation.

IBM Director console (optional)
The IBM Director console is only required if you currently use, or plan to use, IBM Director as part of your enterprise management solution. The IBM Director console is installed from the IBM Director CD-ROM. See 3.1.1, “IBM Director” on page 44 for information about IBM Director and the Linux appliance.

Additional information on IBM Director architecture and installation can be found in the redbook Integrating IBM Director with Enterprise Management Solutions, SG24-5388.

Note: The IBM Director CD-ROM and a license for IBM Director server are not supplied with the appliance. If you are using a Netfinity or xSeries server (not an xSeries appliance) as your management console, you can use the license that was shipped with it.

### 2.2 Initial setup

The first step in configuring your appliance is to set the following:

- Language
- Root password
- Network settings

The default user ID is administrator and the password is password. You can change this using the Appliance System Manager tool once the initial setup is complete.
There are four ways you can set up your appliances:

**Locally, through a pearl script**

Enter the command `/opt/CSM/scripts/setup.pl` and follow the prompts. The window prompting you for the network settings is shown in Figure 2-2:

```
Welcome to the Appliance Setup Program

Host name --> red10-10-10-11
Domain name --> domain
IP address --> 10.10.10.11
Network mask --> 255.255.0.0
Gateway (optional) --> 10.10.10.1
Primary domain name server (optional) -->

Press 'Enter' to continue.
```

Please verify the data and make any necessary changes.
0) Host name : red10-10-10-11
1) Domain name : domain
2) IP address : 10.10.10.11
3) Network mask : 255.255.0.0
4) Gateway (optional) : 10.10.10.1
5) Primary domain name server (optional) :
6) Language : English

Enter number to change -->
9) Exit and complete setup.
```

Figure 2-2  Network settings via setup.pl

Reboot the server upon completion.

**Locally, using a configuration file on diskette**

Format a non-system DOS diskette, put on it a file named initsys.ini. The contents of the file are similar to those shown in the example in Figure 2-3.

```
#=======================================
#Network Parameters for Appliance x135
#=======================================
IPaddress=10.10.22.33
NetworkMask=255.255.0.0
Hostname=RED10-10-22-33
GatewayAddress=10.10.10.1
NameServerAddress=10.10.10.2
Password=password
#========================================
```

Figure 2-3  Example: initsys.ini on the diskette

Put the diskette in the diskette drive of the Appliance and power it on. The default boot sequence of CD-ROM, hard disk, diskette, and network means that the diskette drive is not viewed as a boot device when the hard disk has an operating system on it.
During the Linux boot sequence, the presence of a diskette is checked by the process readinitdiskette and the initsys.ini file is read to apply the initial settings. The same process will not work once you have used this method once — the next time you boot with the diskette in the drive, it is ignored. This is for security reasons.

This method is useful when you are preparing for deployment but the network is not available.

**Remotely, through a browser**

Boot the appliance, then from a remote system, access port 3939 of the appliance using the following URL:

http://desired-appliance_ip_address:3939

With this method, the desired IP address you enter in the URL is not already assigned to the appliance. When you request this URL on port 3939, all systems in the network (within the confines of local routers and gateways) receive the request and the appliance responds by accepting and assigning itself the address. This is achieved using the IBM-developed process arpfind. Here is how arpfind works:

Arpfind uses libpcap (packet capture), which is used by tcpdump and other packet-sniffing programs, to sniff address resolution protocol (ARP) packets on the LAN in order to determine the IP address of the machine where arpfind is installed. The machine essentially has no IP address upon initial boot (the default Ethernet adapter (eth0) is assigned an IP address of 0.0.0.0, which means “this host”). This is necessary to initialize the Linux TCP/IP stack.

When the appliance is cabled up and powered on, it has no real IP address. At this time, an rc script starts arpfind during the bootup process. The rc script is disabled once the machine has been configured, so that arpfind does not run again. Arpfind then puts the Ethernet adapter into promiscuous mode so that it can start to sniff packets, and starts an infinite loop doing so.

The administrator who is setting up the appliance will start a Web browser on another system and enter the URL http://appliance_ip:3939, where appliance_ip is the IP address they wish to assign to their new appliance. This causes the remote system to send out ARP requests in order to locate the machine with appliance_ip on the network, which, of course, does not exist at this point. The port, 3939, is the port that arpfind is also listening on for a HTTP connection.

Under the covers, arpfind essentially looks at each ARP request packet that it finds on the LAN until it finds one which does not get an ARP reply. For each ARP request that it sees, it starts a timing thread of approximately 10 seconds. If it has not gotten a reply after the time has expired, it will construct its own ARP packet and send out a repeat ARP request for that IP address. If it still does not see a reply, it sets its IP address to the address which was in the ARP request. This will time out after 45 seconds, and arpfind will go back into sniff mode if it does not receive a HTTP connection on port 3939.

At this point, the Linux TCP/IP stack on the appliance is able to respond to those ARP queries which are coming from the machine with the Web browser. The machine with the Web browser, which now knows where our appliance is (that is, its hardware address), is able to make a connection to appliance_ip on port 3939. The HTTP server portion of arpfind simply sends a redirect to the real Web server which is running the appliance initial setup utility. Now arpfind knows that it has the IP address it was intended to get, and it will shut down. Once the administrator finishes setting all the necessary network information using the setup utility, the setup utility calls the underlying PERL script which disables arpfind on boot time.

With arpfind running successfully on your appliance, you will now see the initial network configuration page when you can configure the rest of the network parameters.
For example, we entered the following URL into the browser on a remote system to connect to the Linux appliance:
http://10.10.22.22:3939
a. After a short pause, you will get a window similar to that shown in Figure 2-4.

![Initial Configuration: Network Parameters](image)

**Figure 2-4**  Initial screen using port 3939

**Tip:** With some browsers (notably Internet Explorer), you may have to click the Refresh button once or twice, since some browsers time out before making the connection. Once the connection is made, arpfind will pick up the IP address you put in your browser, and start the initial configuration process.
b. Enter your own correct network configuration information and click **Next**; you will see a window like that shown in Figure 2-5:

![Initial Configuration: Network Parameters](image)

**Figure 2-5  Setting complete network settings**

- The server will now reboot in order to write the network settings in the Linux configuration files. The initial configuration is now complete.

**Remotely, through the IAAConfig utility**

This tool provides you with the ability to configure the appliance from the management console. Once the appliance is discovered by IAAConfig, you can configure it; select **Appliance > Start Web Management**. This launches a browser where you can configure the system. The network settings window is similar to Figure 2-4.

The IAAConfig tool is covered in detail in 2.4, “IAAConfig” on page 21.

For more information on the four methods, see the publication *xSeries x135 User’s Reference*.
Now that the initial configuration has been completed, the appliance is ready to be used. The HTTP Server is configured to run at startup, and the default home page contains links to documentation and administration, as shown in Figure 2-6:

![Figure 2-6 Default home page](image)

### 2.3 Setting up multiple systems

The easiest and recommended way to configure multiple appliance servers is to use the IBM Advanced Appliance Configuration (IAACfg) Utility. When started, IAACfg will automatically discover all IBM xSeries appliance servers that are running and connected to the same physical subnet. IAACfg also provides the capability to define groups, which provide a mechanism to categorize discovered appliances and configure them with predefined network settings.

**Note:** The Advanced Appliance Configuration utility configures and reports the TCP/IP settings for the top Ethernet port (port 1) on each appliance only. Be sure to connect the port 1 Ethernet connector on each appliance to the same subnet as your system running the Advanced Appliance Configuration Utility.

IAACfg should be run from your management console. The following steps outline the procedure for configuring multiple appliances using IAACfg:

1. Leave all appliances powered off.
2. Decide if you want to assign the appliance server network settings (including static IP addresses) using IAACfg, or assign them using another network management utility such as DHCP.
3. Configure desired network and server name settings using IAACfg. Detailed instructions for completing this step are provided in “Creating a group in IAACfg” on page 18.
4. Power on all appliances. If you elected to have IAAConfig assign host names to your appliances, you will need to restart each one in order for the name change to take effect.

**Creating a group in IAAConfig**

IAAConfig uses groups to logically list appliances and to automatically apply predefined network settings to newly installed and discovered appliance servers. Groups are defined by appliance type or purpose, as shown in step 3 below. The appliance group determines what purpose an appliance must serve to be included in the group.

Follow the steps below to start IAAConfig and define a group for your appliances.

1. Start IAAConfig on the management console (Click **Start -> Programs -> IBM Advanced Appliance Configuration Utility -> IBM Advanced Appliance Configuration Utility**).
2. Click **Group -> Create Group**, which starts the IAAConfig Group Wizard window shown in Figure 2-7.
3. Enter a unique Group Name to identify the group. After deciding how you want to group appliances, select one of the three options for Appliance Group Type:
   - xSeries Network Attached Storage Appliances
   - xSeries Web Hosting Appliances (including the xSeries 135)
   - All xSeries Appliance Servers

   If the x135 is the only appliance being managed by IAAConfig, then you can select the **xSeries Web Hosting Appliances group** type. If you expect to include other IBM appliances in your network in the future, and you want IAAConfig to assign network settings for the new appliances, you can select the **All xSeries Appliance Servers** group.

4. If you want IAAConfig to assign IP addresses to appliances in your network, select **Yes**, otherwise select **No**. If you select **No**, you can have a DHCP server on the network assign IP addresses to your appliances, or you can manually assign them yourself. Click **Next** to continue.

   If you selected **No** under Network Settings in Figure 2-7, skip to step 9. If you selected **Yes**, you'll see the window shown in Figure 2-8.
5. Enter the IP address range, subnet mask, default gateway, and DNS address that you want the IAAConfig group to automatically assign to your appliances.

**Note:** The IAAConfig Group feature only configures the first Ethernet port and only lets you assign static IP addresses. You cannot configure the appliances to use DHCP. You can configure the second port later, using the Appliance System Manager tool (see 2.5, “Appliance System Manager” on page 27).

6. Click **Next** to continue, and you’ll see the window in Figure 2-9.

---

**Figure 2-8**  Group creation wizard - TCP/IP network settings

**Figure 2-9**  Group creation wizard- host name assignment type
7. Select the desired type of host name assignment for this group in the drop-down menu. The three choices are:
   – Use Current host name
   – Use “i”+model+serial number
   – Use Prefix and IP-Address

   The example in Figure 2-9 shows the Use Prefix and IP-Address option. If you choose this option, all your appliance names will begin with the same prefix characters, and you need to enter a Host Name Prefix in the field. For example, we entered the following:

   ![Sample host name settings](image)

   Figure 2-10   Sample host name settings

8. Enter a domain name if desired, and click **Next** to continue. Figure 2-11 now appears.

   ![Enabling reprovisioning](image)

   Figure 2-11   Enabling reprovisioning

9. This is used when you want to use IAAConfig's capability to remotely create and apply operating system images to multiple appliance servers within the group. This is discussed in 2.4.1, “Reprovisioning” on page 21. Click **Finish**.

   At this point, you have just completed creating a group and are ready to assign your appliances to it.

10. Power on your appliances. They can be powered on individually, or all at the same time.

    After they are up and running, IAAConfig will scan the network, assign each one to the group you created and assign network settings as per the group settings.
11. After all appliances have started, click **File -> Rescan Network** to force a network scan. At this point, you should see the appliances displayed in the IAAConfig under the appropriate group.

If you elected to have the group assign host names to your appliances, you will need to restart each one in order for the name change to take effect. A red restart indicator message will appear on the right-hand pane of the status window for each appliance.

Other utilities are useful for rolling out multiple appliance systems:

The IAAConfig utility lets you copy one system to another, as described in “Creating a group in IAAConfig” on page 18. This method allows you to deploy your own configured system image.

You can also use IAAConfig to reset to the factory image by clicking **Appliance -> Restore to factory setting**. A factory image is already stored on the machine to allow you to restore the system. This method just restores the system files and configuration — it does not affect your customized Web pages.

You can also duplicate the IBM HTTP Server configuration using the Backup/Restore feature of the Appliance System Manager tool. See 2.5.1, “Backup/restore system configuration files” on page 30 for details.

### 2.4 IAAConfig

In this section, we describe the useful functions of the management tools. Since many of the tools are Windows-based, you will need to install and configure a Windows system on the same TCP/IP network to act as the management console for IAAConfig, Appliance System Manager. We recommend that you put all management tools on this system.

As described in 1.2.1, “Preloaded software” on page 4, the IBM Advanced Appliance Configuration Utility (IAAConfig) is a Windows-based management tool which detects the presence of xSeries appliances on the network, and enables you to set up and manage the network configuration for one or more appliance servers. IAAConfig also provides a launch point for the Appliance System Manager, and includes a reprovisioning tool, which enables you to create an appliance image and apply it to other servers on your network. The reprovisioning tool provides a quick and easy way to set up new servers.

Appliance System Manager is discussed in 2.5, “Appliance System Manager” on page 27 and reprovisioning is discussed below.

IAAConfig automatically discovers new appliances, but you can also click **File -> Rescan Network** to force a complete discovery of all appliances.

You can create a group to do specific tasks, such as doing initial setup and managing appliance images, or you can set one group for all functions. In IAAConfig, click **Group -> Create Group** as described in 2.3, “Setting up multiple systems” on page 17.

### 2.4.1 Reprovisioning

You also can use IAAConfig to copy one system to another for an easy deployment. This is known in IAAConfig as **reprovisioning**.
The first steps are to create a group and an initial image:

1. Create a group using IAAConfig by clicking **Group -> Create Group**. You will see the window shown in Figure 2-12:

   ![Figure 2-12 Group settings](image)

   **Figure 2-12   Group settings**

   1. Create a group using IAAConfig by clicking **Group -> Create Group**. You will see the window shown in Figure 2-12:

   2. Name the group. We entered **Image**.

   3. From the Appliance Group Type pull-down menu, select **All xSeries Appliance Servers**.

   4. For **Allow this Group to assign the network settings?**, select **No**.

   5. Click **Next**. You will see the window shown in Figure 2-13:

   ![Figure 2-13 Group Settings: reprovisioning](image)

   **Figure 2-13   Group Settings: reprovisioning**
6. Select **Enable Reprovisioning** and click **Next**. The next window you’ll see is the FTP setup for reprovisioning, as shown in Figure 2-14:

![FTP Setup for Reprovisioning](image)

**Figure 2-14**  Group settings: FTP setup for reprovisioning

7. Enter the name or IP address of your FTP server in the Remote Host Name field. In the Remote Directory field, enter the directory name where the reprovisioning images will be stored on the FTP server. Enter the user name and password credentials for your FTP server where indicated. Click **Finish** when done.

Reprovisioning requires an FTP server on which to store the appliance images. We recommend that the FTP server reside on your remote management console.

8. Click **Finish**.

9. Drag the appliance you want to clone onto the group. In our example, we dragged RED10-10-10-20 to the Image group.

Figure 2-15 show the new group and its related settings:
10. Right click the appliance and click **Create Appliance Image**.

---

**Figure 2-15** Specific group for reprovisioning

**Figure 2-16** Creating the appliance image
Figure 2-17 appears.

When you create an image for reprovisioning, it is saved as the group name and model number. Although multiple models of appliance servers may belong to a group, only images created from the same model can be applied. This prevents you from applying the image to the wrong server appliance type.

12. Click **Yes** to start the image process.

During the creation process, the FTP site is accessed to verify the write permission. The status of the appliance is **Restore Factory Image**, as shown in Figure 2-18.

The appliance is then rebooted and a local copy of the image is made. When the copy is complete, the source system restarts Linux and the image is transferred to the FTP server.
Once you have created an image of your system, you can apply it to another appliance:

1. Right-click the new appliance and click **Apply Appliance Image** (see Figure 2-19):

![Figure 2-19 Reprovisioning](image1)

2. Figure 2-20 appears, giving you the file name of the image that is about to be installed.

![Figure 2-20 Applying the image](image2)

3. Click **Yes** to begin the process.

You can also restore an appliance back to its original factory preload. This image is permanently stored on the appliance in a special Linux VFAT partition. From IAAConfig with the appliance selected, click **Appliance -> Restore Factory Image** (see Figure 2-21):

![Figure 2-21 Applying the factory image](image3)
Chapter 2. Deployment and configuration

2.5 Appliance System Manager

Appliance System Manager is a Web-based tool used to remotely manage the Linux appliance. You can start Appliance System Manager through IAAConfig by selecting the appliance, then clicking **Start Web Management**, or you can do it manually through one of these URLs:

http://Appliance_IP_address:1959
https://IP_address:1999

We recommend you use the second option, port 1999 and SSL, to establish the session.

Click **Administration -> Appliance System Administration** from the menus in the left navigation bar (see Figure 2-22).

![Standard administration HTTP page returned by the server](image)

Figure 2-22 Standard administration HTTP page returned by the server

You will be prompted to log into the appliance (see Figure 2-23). By default, the user ID is **administrator** and the password is **password**; however, you must change this after the initial configuration.

![Logging into Appliance System Manager](image)

Figure 2-23 Logging into Appliance System Manager

The main Appliance System Manager window now appears (see Figure 2-24):
Using the IBM xSeries 135 Web Server Appliance

The menus in the left navigation bar are as follows. Complete descriptions are available in the Appliance System Manager Administration Guide.

**Status**

System processes — displays a list of the active processes on the appliance and is similar to the ps command.

Disk usage

System usage — displays the statistics for the system times of the CPU and disk input/output. All the times displayed are in jiffies (1/100th of a second).

System load — displays the number of jobs in the run queue in 1, 5, and 15 minute load averages.

Memory usage — displays the amount of current free memory and swap memory, in KB.

Kernel interrupts — displays the statistics for interrupts for each IRQ disk and swap pages.

Adapters — displays the status of the appliance’s network adapters.

RPM status — displays information about the software currently installed on the system.

**Operations**

Start/stop/restart Web server

Start/stop appliance

Backup/restore

– Configuration

– User directories
Install maintenance — lets you view, download and install current and previous fixes to the appliance.

**Configuration**

View hardware  
Set language  
Set date and time  
Set services FTP / Telnet / console  
Configure NFS file systems  
Email alerts  
  − Configure SMTP server and admin email  
  − Event list  
    • File system over x%  
    • Processor load over x%  
    • Web server not responding  
    • Host not responding to PING  
    • Memory usage over x%  
    • Unexpected reboot  

Network  
  − System  
  − Adapters  
  − Static route  
  − DNS  
  − Local host name  
  − IBM HTTP Server administration  
Set PHP

**Security**

Manage administrators  
Manage users  
System access  
  − ASM  
  − FTP  
  − Telnet  
System password  
Manage SSL certificate

**Logs**

System  
  − ASM

By default, the service FTP is enabled, but the Telnet service is disabled. The Telnet service can be enabled through the **Configuration -> System Services** menu.
2.5.1 Backup/restore system configuration files

To maintain security on your system, you should save important files using the backup/restore feature, as shown in Figure 2-25.

1. Click **Operations -> Backup/Restore** to access the functions.

2. Click **Backup Configuration**, then click the **New Backup** button.

3. Click **Copy To Server**.
4. Fill out the form:
   - The IP address of the FTP server which stores the backup
   - The specific FTP directory to use
   - The name of the file where the backup will be stored
   - The user ID and password to associate with the backup

5. Click **Submit**.

To restore a backup, you will follow similar steps.

### 2.5.2 Backup/restore user directories

You can also back up and restore user directories. If you are using the appliance to host user’s Web pages, you can use this procedure to save and restore those directories.

1. Click **Operations -> Backup/Restore -> Backup User Directories**. Figure 2-27 appears.

   ![Figure 2-27 Backing up user directories](image)

2. Select the type of backup: **Full** or **Incremental**.
3. Fill in the rest of the fields.
4. Click **Submit**.

The restore process is almost identical.
2.5.3 E-mail alerting

This function monitors the appliance and can send e-mail to the configured administrator. To configure the e-mail address, click Configuration -> E-mail. Figure 2-28 appears:

![Configuration: E-mail]

Figure 2-28  E-mail initial configuration

Enter your e-mail address and the address of your SMTP server, then click Submit.

The next step is to specify the events you want to monitor and receive e-mail when an alert occurs. Click E-mail alerts -> Event list.
We want to monitor all the events, so we select the **Enabled** box next to each event. To simulate an event, we restarted the IBM HTTP Server and an e-mail was sent to the administrator console which had the following text:

```
From root
Subject Cron <root@your_hostname>
httpd restarted
```

For more information, see the *Appliance System Manager Administration Guide* or use the online help at this address:

```
https://appliance_ip:1999
```

and click **Documentation**.

### 2.6 IBM HTTP Server

The IBM HTTP Server is based on the Apache HTTP server; on the appliance, it is configured to start at startup, with no cache activated. You can start configuring the IBM HTTP Server using Appliance System Manager by clicking **Configuration -> Network -> IBM HTTP administration** or by using the URL:

```
https://IP_address:8009
```

The initial configuration page for IBM HTTP Server, shown in Figure 2-30, is the common page to use to administrate the HTTP server.
2.6.1 Using the proxy cache

The IBM HTTP Server can use a cache to improve performance when serving pages. This cache is not activated by default, although you can activate it using a three step process.

Note: To help you configure the cache, you can activate the help facility, which provides field-level help, at the bottom of the window, as shown in Figure 2-31.

1. Activate the proxy module
   a. Click Basics Settings -> Module Sequence.
   b. Click Select a module to add.
   c. Select the module proxy (libproxy.so).
   d. Click Apply.
   e. Click Submit.

2. Activate the proxy
   a. Click Proxy -> Proxy Settings.
   b. Set Enable Proxy to On.
   c. Set Buffer size for outgoing HTTP and FTP connections to 0.
   d. Click Submit.
3. Configure the proxy
   a. Click **Proxy -> Proxy Cache**.
   b. In the Cache Root Location field, enter `/opt/IBMHTTPServer/proxy`
   c. Set Cache Force Completion Percentage to 75.
   d. Click **Submit**.

When you have finished, restart the IBM HTTP Server.

![Figure 2-31 Proxy cache configuration with online help active](image)

After you have made these changes, we recommend that you save your configuration using the Appliance System Manager tool (see 2.5.1, “Backup/restore system configuration files” on page 30). Using the backup facility, you can restore your tuning on another system or the same system after a reprovisioning from factory image.

### 2.7 Creating Web sites

The purpose of this section is not to explain how to build a Web site, but to provide specific information related to the Linux appliance. The page contents have to be created on the user’s systems, not on the appliance itself. In this section, a user is a page content creator.

IBM HTTP Server uses the concept of home directory for user access, and users can only access the contents of their own home directories, so one directory must exist per user.
The administrator has to create and activate the users who are able to put Web content on the server. To create a user with Appliance System Manager, use the Security function, as shown in Figure 2-32:

![Security:List Users](image)

Table 2-1   URL mappings

<table>
<thead>
<tr>
<th>Administrator</th>
<th>user_creator</th>
</tr>
</thead>
<tbody>
<tr>
<td>linux</td>
<td>/home/webroot/public_html</td>
</tr>
<tr>
<td></td>
<td>/home/user_creator/public_html</td>
</tr>
<tr>
<td>http</td>
<td>http://IP_addr/</td>
</tr>
<tr>
<td></td>
<td>http://IP_addr/~user_creator</td>
</tr>
<tr>
<td>ftp</td>
<td>ftp://webroot:password@IP_addr/public_html</td>
</tr>
<tr>
<td></td>
<td>ftp://user_creator:password@IP_addr/public_html</td>
</tr>
</tbody>
</table>
For example, if the creator uses FTP to store the file my_page.htm into the default user directory, they would use:

ftp://creator:password@9.20.21.22/public_html

To later access that page, you would use:

http://9.20.21.21/~creator/my_page.htm

**Tip:** The default user directory is public_html and is set by a directive of IBM HTTP Server. If you want to change it, go to the Appliance System Manager and click **IBM Administration Server -> Mappings -> Usernames Directories -> Username-to-directory Translation.**

### 2.7.1 PHP

To use this feature, you first have to activate PHP server capabilities using Appliance System Manager (see Figure 2-33):

![Configuration:PHP:Enable](image)

**Warning:** If you prefer any other configuration, do not use the buttons below; they will lose any Web server configuration you have done for PHP.

For more information about PHP, see

http://www.php.net
To do a simple test to verify your PHP configuration, you can create a file called my_dynamic.php, as shown in Example 2-1:

Example 2-1  my_dynamic.php file

```html
<html>
<head><title>PHP Test</title></head>
<body>
<?php echo "You can show a PHP sample, OK ??<p>"; ?>

<?php
if(strstr($HTTP_USER_AGENT,"MSIE")) {
 ?>
 <center><b>You are using Internet Explorer</b></center>
 <?
 } else {
 ?>
 <center><b>You ARE NOT using Internet Explorer</b></center>
 <?
 }
 ?>
</body></html>
```

This example executes a sample test in order to show what Web browser you are using. The results are shown in Figure 2-34:

![PHP Test - Netscape](image)

*Figure 2-34  Example of a simple PHP script*

This very simple example shows how PHP is useful to produce dynamic HTTP pages. The creation of Web-based applications with this script encoding feature will give you similar functions to .jsp (Java server page) or .asp (active server page) files, and allow you to improve Web security and enhance Web page content.
2.8 Load balancing

Balancing the IP traffic along the Web nodes can be done in different ways:

DNS approach

This approach takes advantage of the fact that the browser must first resolve the name into an IP address and contact a DNS. Most Linux distributions use the Berkeley Internet Name Daemon (BIND daemon) and the DNS server. To balance the traffic, this DNS uses a feature called round-robin to regularly balance from one to another node.

Reverse proxy

This method is the reverse of the HTTP proxy server and operates in the opposite direction of the commonly known one (hence the name). In other words, the proxy either forwards absolute URLs or translates them to relative URLs, but instead of serving the request itself, it determines the appropriate back-end server dynamically, turns the request over to it, and then forwards the response back to the client.

The x135 appliance does not have the DNS service installed on it by default. You can install such a package, but it is not a supported configuration. To implement an external, supported solution, the Web servers can be put behind an external server working as a load balancer using, for example, IBM Network Dispatcher.
2.9 Tuning and performance

In this section, we describe a number of separate settings which can have an impact on performance.

The Webadmin tools in Appliance System Manager provide functions to monitor the system, but these are not designed to tune your system. The key to good performance is to monitor the system resources regularly and analyze the changes. The standard monitoring tool is `top`, which shows all the processes running in the system (see Figure 2-35):

```
1:07pm up 19:38, 1 user, load average: 0.88, 0.86, 0.88
53 processes: 62 sleeping, 1 running, 0 zombie, 0 stopped
CPU states: 6.7% user, 1.5% system, 91.8% idle
Mem: 261638K av, 254924K used, 7312K free, 0K shrd, 149576K buff
Swap: 514048K av, 0K used, 514048K free
```

Look at memory or CPU usage and which processes are using them. To work with a process, use the command `ps`. Also, the `vmstat` command can be useful to monitor CPU, memory, input/output, swap space, system, and process activity.

If you wish to benchmark your system, before and after any system change, we recommend that you use WebBench from Ziff Davis. Be aware of the effect that active pages versus static pages have on your system's performance.

2.9.1 Factors affecting Web server performance

The appliances are already well configured for most customers, so you will most likely not need to make any changes. However, if your system has a very heavy load, some changes may have positive and measurable effects.
The following are pointers that can help you improve your server’s performance:

Network configuration
Be sure your entire network is working properly before using the tuning process; verify that your switches are configured for the correct speed and that full duplex is also fixed.

Tivoli agent
The Tivoli agent is installed and started on the appliance by default. If you are not using the Tivoli management console or IBM Director, you can free some memory and resources for your applications by disabling this agent. The easiest way to stop it from coming back up is to delete a file by entering:

```
rm /etc/rc.d/rc3.d/S90TWGagent
```
This will remove the symbolic link to the Tivoli agent:

```
S90TWGagent > /etc/rc.d/init.d/TWGagent
```
To later recreate the link, enter:

```
ln -sf /etc/rc.d/init.d/TWGagent /etc/rc.d/rc3.d/S90TWGagent
```

IBM HTTP Server logs
This function is useful to evaluate the number of transactions your Web server was handling; you can log errors or pages served. To enhance your Web server bandwidth, you can disable the log files. This will free some disk and CPU resources for the Web server tasks. To do this, follow these steps:

a. Go to \http://IP_Address:8008\n
b. Click **Logs -> Logfiles -> Delete**.

c. Click **Submit**.

IBM HTTP Server MaxRequestPerChild Directive
This parameter, by default, is set to 500. For heavily loaded system, you can increase this value (to 300,000 for example). You could also just set it to 0, which means unlimited requests, although this may increase chance of a memory leak.

Set this via **Performance -> Server Settings**.

IBM HTTP MaxClients Directive
By default, this parameter is set to 150 and may need to be reduced on heavily loaded systems. Try to set a lower value. Set this via **Performance -> Server Settings**.

Services
The fewer services are running, the better. Disable the maximum possible number of unused services once you have properly configured the system. Telnet, FTP services can be disabled using Advanced Systems Management.

SMP kernel
The x135 uses a multi-processor kernel on both the Value and the Performance models. If your system only has one processor and you cannot (or have no plans to) upgrade to a second processor, you could consider changing to a uniprocessor kernel.

**Note:** Modifying the kernel is not supported by IBM.
To change from the SMP kernel to the unikernel, use the following commands. You should verify that the file vmlinuz-2.2.19-6.2.1 is approximately 600 KB and not approximately 1.6 MB.

```bash
cd /boot
ln -s vmlinuz vmlinuz-2.2.19-6.2.1
/sbin/lilo
```

You should not have to change other linkings for system.map, initrd, modules, and so forth. Reboot the appliance once the commands have been executed.

To change from the unikernel to the SMP kernel, use the following commands and reboot:

```bash
cd /boot
ln -s vmlinuz vmlinuz-2.2.19-6.2.1smp
/sbin/lilo
```
Management

This chapter introduces two additional tools for managing your xSeries 135:

- IBM Director
- Advanced System Management service processor

These two tools are in addition to the products covered in the previous chapter:

- IBM Advanced Appliance Configuration Utility, discussed in 2.4, “IAAConfig” on page 21
- Appliance System Manager, discussed in 2.5, “Appliance System Manager” on page 27
3.1 Software management

There are two primary ways to manage your x135:

Using workgroup management with IBM Director
Using point-to-point management with Appliance System Manager

Appliance System Manager is described in 2.5, “Appliance System Manager” on page 27 in this redpaper, and in Chapter 7 of the IBM xSeries 135 User's Reference.

For information on the use of IBM Director beyond what is covered in this redpaper, refer to the following IBM Redbooks:

- Integrating IBM Director with Enterprise Management Solutions, SG24-5388
- Netfinity Director - Integration and Tools, SG24-5389
- Netfinity Server Management, SG24-5208

3.1.1 IBM Director

**Important:** IBM Director server is not shipped with the x135 appliance. The client, however, is shipped and pre-installed. To use the functions of IBM Director, you will need to purchase and install IBM Director on a separate system which can act as your management console.

IBM Director is a comprehensive systems management solution designed for use with IBM IBM @server xSeries servers, IBM desktops and ThinkPad notebooks. It provides centralized alerting, problem determination and inventory functions.

IBM Director is useful to manage systems on your network from a centralized console, and brings you the advantages of workgroup management. This means that you can manage many systems at the same time (for example, do an inventory on a group or on all machines).

IBM Director includes three components: client, server and console. The IBM Director client, (also called the Tivoli agent), is pre-installed on the xSeries 135 appliance. The IBM Director server is the heart of the IBM Director product and is installed on a Windows server. It provides the management application logic and persistent data store of management information via an SQL database. Clients communicate with the Director server through the Director agent. Any events generated by the client, whether the result of hardware alerts or monitored resources, are forwarded to the Director server.

The IBM Director console is a Windows application that serves as the user interface to the IBM Director-managed environment. It can reside on the same system as the Director server, or on another remote Windows workstation.

If you plan to use the IBM Director framework to manage your x135 appliances, we recommend that you carefully plan your systems management architecture and network. The Redbooks above will provide information on how to do this.
From the IBM Director console you can see a list of tasks available to Linux clients. Right-click the appliance in the Group Contents panel to display the menu in Figure 3-1:

![IBM Director Console](image)

**Figure 3-1  Available functions with the Linux IBM Director agent**

**Tips:**

The tasks available through the Linux client are a subset of those available through the Windows client.

The system name of the Linux appliance is initially localhost.localdomain. You can rename this by clicking **Rename** in the menu in Figure 3-1. To determine which system is which, one method is to gather inventory and review the IP address of each.

Immediately after the Linux appliance is discovered by IBM Director, a lock symbol may appear to the left of the of the host name. This indicates that the system is locked to prevent unauthorized access. To unlock access, right-click the system in the Group Contents panel, and click **System Access**. In the login window, enter the user ID `root` and the root's password.

Tasks available on Linux systems include the following:

- **Perform Inventory Collection**
  
  This function gathers hardware, software, system and user information. You can view the results of the collection using the View Inventory task.

- **Event Log**
  
  All events that the Director agent on the appliance receives are logged in the event log. You can also configure event action plans to perform actions based on those events.
View Inventory

This function lets you review the inventory that was previously collected either through the Perform Inventory Collection function or the scheduler. A sample of the type of information that is available from the x135 is shown in Figure 3-2:

<table>
<thead>
<tr>
<th>Available Queries</th>
<th>Query Results: Installed Packages (202)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom ( ).</td>
<td>Name</td>
</tr>
<tr>
<td></td>
<td>setup-2.1.8-1</td>
</tr>
<tr>
<td></td>
<td>lilo-system-1.3.5-1</td>
</tr>
<tr>
<td></td>
<td>lilo-system-3.0.4-1</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-10</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-15</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-20</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-25</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-30</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-35</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-40</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-45</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-50</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-55</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-60</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-65</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-70</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-75</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-80</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-85</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-90</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-95</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-100</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-105</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-110</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-115</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-120</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-125</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-130</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-135</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-140</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-145</td>
</tr>
<tr>
<td></td>
<td>liloconfig-1.8.5-150</td>
</tr>
</tbody>
</table>

**Figure 3-2  Inventory example**

Process Management

This task lists all the running processes on the appliance. From the list, you can select processes to monitor (such that you will get an alert if the process starts, stops, or fails to start), and you can manually stop a process (see Figure 3-3 on page 47).
Figure 3-3  Process Management

File Transfer

This function lets you make files transfer from the system running the IBM Director console to the Linux appliance, as shown in Figure 3-4:

Figure 3-4  File transfer between Windows and Linux systems
Remote Session

The Director client also lets you open a remote shell prompt (see Figure 3-5). The response time is satisfactory, but our testing shows that it is slower than a separate Telnet session.

Tip: Before you can use the Remote Session function, you must enable the Telnet server on the appliance, using Appliance System Manager. Click Configuration -> Services, then set Telnet to On to activate the Telnet service. If you do not enable Telnet, you will receive the following error if you attempt to start a remote session via Director:

![Error message]

```
[root@RED10-10-10-10 tivoliwg]# df
Filesystem            1k-blocks    Used     Available Use% Mounted on
/dev/sda2              1517952     430412   1010428  30% /
/dev/sda6              13185884      1502   12640106   0% /home
/dev/sda3              2048000    177408   1870592   9% /images
[root@RED10-10-10-10 tivoliwg]# ls -la
total 48
drwxr-xr-x 11 root root 4096 Jun 18 11:55 .
drwxr-xr-x  7 root root 4096 Jun 18 11:54 ..
drwxr-xr-x  3 root root 4096 Jun 27 10:07 SwPkInst
drwxr-xr-x  3 root root 4096 Jun 18 11:55 bin
drwxr-xr-x  5 root root 4096 Jun 27 10:39 classes
drwxr-x---  2 root root 4096 Jun 27 11:00 data
drwxr-xr-x  4 root root 4096 Jun 18 11:54 jre
drwxr-xr-x  2 root root 4096 Dec 13 2000 lib
drwxr-xr-x  2 root root 4096 Jun 27 10:41 log
drwxr-xr-x  3 root root 4096 Jun 18 11:55 proddata
drwxr-xr-x  2 root root 4096 Jun 27 10:41 tempdata
-rw-rw-r--  1 root root 146 Dec 13 2000 version.key
[root@RED10-10-10-10 tivoliwg]# ps
  PID  TTY     TIME CMD
 2374 pts/0  00:00:00 login
 2395 pts/0  00:00:00 bash
 2498 pts/0  00:00:00 ps
[root@RED10-10-10-10 tivoliwg]#
```

Figure 3-5  Remote shell via IBM Director

Resource Monitors

Here you can set thresholds on certain system settings, such as CPU use, and create event action plans to receive alerts on those triggers. Drag the resource from the tree view onto the white space in the right-hand pane (see Figure 3-6 on page 49).
3.2 Advanced System Management service processor

The x135 Performance model has an Advanced System Management service processor, that is a technology improvement to help in hardware event management; it can be managed using centralized system management or point to point management, and can communicate directly with other service processors, using the Advanced Systems Management interconnect.

The Value model does not have the Advanced System Management service processor (and no management port to service processor interconnect), but this model does support Wake on LAN which lets you remotely power on the system as the system processor can do. It can also provide processor temperature, fan speed, and voltage, using an onboard Winbond W83791D chip. This means that it can be managed by tools such as IBM Director.

You can access the service processor directly using an ANSI terminal connected to the serial port on the appliance (see Figure 3-7). Connect using 8 data bits, no parity and 1 stop bit.

```
Local System x135
2 - Monitors
3 - Error Logs
4 - SP Configuration
5 - System Services
6 - System Power
7 - Boot
B - Remote Terminal Status
E - Storage
R - Remote SP Access
Y - Disconnect Current Login
Z - Start Remote Video
```

Figure 3-7 Accessing the service processor through the serial port
With other xSeries and Netfinity systems with Advanced System Management service processors, you can also access it directly using IBM Director. However, the current version of the IBM Director agent for Linux does not allow this connection and you will get the following message if you attempt to drag one of the Advanced System Management onto the x135 in IBM Director:

![Figure 3-8 IBM Director Linux agent error](image)

The solution to this problem is to connect the RS-485 port of the x135 to the equivalent port on another system, such as a system with the Advanced System Management PCI adapter installed. This other system cannot be an x135, however. We recommend that your management console have a Advanced System Management service processor for this purpose.

To connect to the x135’s service processor through the RS-485 link using IBM Director, do the following:

1. From the management console, start IBM Director. Drag the Advanced Systems Management Integrated Console task onto the management console system (NF4500R1 in Figure 3-9):

![Figure 3-9 Starting the Advanced Systems Management console on the management console](image)

Tip: To determine if the connection to the service processor is active, look for the or icon to the left of the first-level menus. If the icon is not present, then you do not have an active connection.

2. Click Options -> Change Connection -> Interconnect to attach to the x135 using the RS-485 connection (see Figure 3-10 on page 51).
3. You will be prompted to choose an available machine to work with and to provide a user ID and password (see Figure 3-11):

   By default, these are:
   - User ID: USERID (uppercase)
   - Password: PASSW0RD (with a zero, uppercase)
4. Now you are connected to the service processor on the x135 (see Figure 3-12):

If your management console has an Advanced System Management PCI Adapter (or IBM Remote Supervisor Adapter), you can connect the adapter to your Ethernet network using the RJ-45 port on the card. With this connection and the RS-485 connection to the x135, you can also access the service processor, using other methods besides IBM Director:

- Web browser
- Telnet client

Once you are connected to the x135 service processor, you can configure hardware alerts by clicking **Configuration Settings -> Remote Event Settings** (see Figure 3-13 on page 53):

You can also configure your SP with a setup diskette (use the supplementary CD to create it).
Enter a name for the alert in the Name field. In the Type field, select how you want the alert sent. If you selected **TCP/IP** in the Type field, enter the destination IP address in the Number field. If you selected **Netfinity serial**, enter the telephone number (or leave it blank for a null modem).

Click **Entry enabled** to activate this alert. Select the events that you want notification on. Click **Apply/Add**.

**Tip:** You can also configure the Advanced System Management service processor using the Advanced Systems Management setup diskette. You can create this diskette using the supplemental CD-ROM that comes with the appliance.

Another useful function is the remote control of system power (see Figure 3-14), accessible through System Power Control. You can stop or restart any machine connected on the RS-485 network:
3.3 Comparing the management tools

The management tools are used in the following ways:

IBM Advanced Appliance Configuration Utility, as described in 2.4, “IAAConfig” on page 21, runs on the Windows management console and is used for initial configuration and for the deployment of multiple appliances.

Appliance System Manager, as described in 2.5, “Appliance System Manager” on page 27, also runs on the Windows management console, is used to install, administer, and maintain your system, and brings you all the standard Linux configuration tools using a Web browser.

IBM Director is useful in performing inventory across all of your appliances and is the standard management platform for other IBM Intel-based systems, including xSeries and Netfinity servers, ThinkPads and IBM desktop PCs. IBM Director also provides an interface to the service processor for Performance models of the appliance.

The Advanced System Management service processor, as described in 3.2, “Advanced System Management service processor” on page 49, provides hardware-level information, alerting and control. The service processor is accessed using IBM Director, a Web browser, Telnet or ANSI terminal via the appliance’s serial or RS-485 ports.

Table 3-1 shows a brief comparison:

<table>
<thead>
<tr>
<th>Installation</th>
<th>IBM Director</th>
<th>IAAConfig</th>
<th>Appliance System Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial network settings</td>
<td>-</td>
<td>Restore factory image</td>
<td>-</td>
</tr>
<tr>
<td>Change network settings</td>
<td>-</td>
<td>Back up user data</td>
<td>-</td>
</tr>
<tr>
<td>Add HDD</td>
<td>-</td>
<td>Back up configurations</td>
<td>-</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Administration</th>
<th>IBM Director</th>
<th>IAAConfig</th>
<th>Appliance System Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory</td>
<td>-</td>
<td>Change network settings</td>
<td>-</td>
</tr>
<tr>
<td>Remote session</td>
<td>-</td>
<td>Back up configurations</td>
<td>-</td>
</tr>
<tr>
<td>Monitor resources</td>
<td>-</td>
<td>Change passwords</td>
<td>-</td>
</tr>
<tr>
<td>Add users</td>
<td>-</td>
<td>Add users</td>
<td>-</td>
</tr>
<tr>
<td>View logs</td>
<td>-</td>
<td>View logs</td>
<td>-</td>
</tr>
<tr>
<td>Monitor resources</td>
<td>-</td>
<td>Monitor resources</td>
<td>-</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Maintenance</th>
<th>IBM Director</th>
<th>IAAConfig</th>
<th>Appliance System Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Handle service processor management</td>
<td>-</td>
<td>Access to Appliance System Manager</td>
<td>-</td>
</tr>
<tr>
<td>Start/stop</td>
<td>-</td>
<td>Start/stop</td>
<td>-</td>
</tr>
<tr>
<td>Add HDD</td>
<td>-</td>
<td>Add HDD</td>
<td>-</td>
</tr>
</tbody>
</table>
Special notices

References in this publication to IBM products, programs or services do not imply that IBM intends to make these available in all countries in which IBM operates. Any reference to an IBM product, program, or service is not intended to state or imply that only IBM's product, program, or service may be used. Any functionally equivalent program that does not infringe any of IBM's intellectual property rights may be used instead of the IBM product, program or service.

Information in this book was developed in conjunction with use of the equipment specified, and is limited in application to those specific hardware and software products and levels.

IBM may have patents or pending patent applications covering subject matter in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to the IBM Director of Licensing, IBM Corporation, North Castle Drive, Armonk, NY 10504-1785.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact IBM Corporation, Dept. 600A, Mail Drop 1329, Somers, NY 10589 USA.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The information contained in this document has not been submitted to any formal IBM test and is distributed AS IS. The use of this information or the implementation of any of these techniques is a customer responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. While each item may have been reviewed by IBM for accuracy in a specific situation, there is no guarantee that the same or similar results will be obtained elsewhere. Customers attempting to adapt these techniques to their own environments do so at their own risk.

Any pointers in this publication to external Web sites are provided for convenience only and do not in any manner serve as an endorsement of these Web sites.

The following terms are trademarks of other companies:
Tivoli, Manage. Anything. Anywhere., The Power To Manage., Anything. Anywhere., TME, NetView, Cross-Site, Tivoli Ready, Tivoli Certified, Planet Tivoli, and Tivoli Enterprise are trademarks or registered trademarks of Tivoli Systems Inc., an IBM company, in the United States, other countries, or both. In Denmark, Tivoli is a trademark licensed from Kjøbenhavns Sommer - Tivoli A/S.

C-bus is a trademark of Corollary, Inc. in the United States and/or other countries.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and/or other countries.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States and/or other countries.

PC Direct is a trademark of Ziff Communications Company in the United States and/or other countries and is used by IBM Corporation under license.

ActionMedia, LANDesk, MMX, Pentium and ProShare are trademarks of Intel Corporation in the United States and/or other countries.

UNIX is a registered trademark in the United States and other countries licensed exclusively through The Open Group.

SET, SET Secure Electronic Transaction, and the SET Logo are trademarks owned by SET Secure Electronic Transaction LLC.

Other company, product, and service names may be trademarks or service marks of others.