# Contents

<table>
<thead>
<tr>
<th>Figures</th>
<th>ix</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>x</td>
</tr>
</tbody>
</table>

## Chapter 1. Introduction

- About this Handbook .................................. 1
- New Software Features .................................. 1
- Understanding the Restrictions .......................... 2
  - Restrictions for the Cluster Server Environment .......... 6
- Hardware and Software Requirements ......................... 7
  - Hardware Configuration .................................. 7
  - Operating System ...................................... 7
  - Host Adapters ......................................... 7
  - Checking the Hardware .................................. 7
- Setting Up Fibre Channel Host Adapters ....................... 8
- Selecting the Correct Installation Procedure ............... 8

## Chapter 2. Installing Software on a Standard Configuration

- Where to Start ......................................... 9
- Upgrading from a Previous Installation ...................... 9
- Assigning Drive Letters ................................ 10
- Installing the Storage Management Software ................. 11

## Chapter 3. Installing Software in a Cluster Server Environment

- Where to Start ......................................... 13
- Upgrading from a Previous Installation ...................... 13
- Cluster Server Overview ................................ 15
  - Required Components ................................... 16
- Quick Installation Summary ................................ 17
- Installing the Hardware ................................ 20
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Names</td>
<td>57</td>
</tr>
<tr>
<td>Controller/LUN Names</td>
<td>57</td>
</tr>
<tr>
<td>Redundant Controller Support</td>
<td>59</td>
</tr>
<tr>
<td>Creating Logical Units</td>
<td>60</td>
</tr>
<tr>
<td>Deleting Logical Units</td>
<td>60</td>
</tr>
<tr>
<td>Accessing Raw Partitions</td>
<td>60</td>
</tr>
<tr>
<td>Creating and Deleting LUNs in a Cluster Server Environment</td>
<td>61</td>
</tr>
<tr>
<td>Background Monitor</td>
<td>61</td>
</tr>
<tr>
<td>Command Line Utilities</td>
<td>62</td>
</tr>
<tr>
<td>Adding New RAID Controller Units to Your Configuration</td>
<td>63</td>
</tr>
<tr>
<td>Using the putntlog Utility</td>
<td>63</td>
</tr>
<tr>
<td>Uninstalling the Storage Management Software</td>
<td>64</td>
</tr>
<tr>
<td>Chapter 7. Troubleshooting</td>
<td>65</td>
</tr>
<tr>
<td>Troubleshooting Tables</td>
<td>65</td>
</tr>
<tr>
<td>Locating Solutions</td>
<td>65</td>
</tr>
<tr>
<td>Configuration Application</td>
<td>70</td>
</tr>
<tr>
<td>Firmware Upgrade</td>
<td>72</td>
</tr>
<tr>
<td>General</td>
<td>73</td>
</tr>
<tr>
<td>Recovery Guru/Health Check</td>
<td>77</td>
</tr>
<tr>
<td>Replacing Controllers</td>
<td>81</td>
</tr>
<tr>
<td>Problems Bringing the New Controller Online</td>
<td>81</td>
</tr>
<tr>
<td>Incompatible Firmware Detected</td>
<td>82</td>
</tr>
<tr>
<td>Appendix A. Specifications</td>
<td>85</td>
</tr>
<tr>
<td>Hardware Specifications</td>
<td>85</td>
</tr>
<tr>
<td>Host Adapter Information</td>
<td>85</td>
</tr>
<tr>
<td>Fibre Channel Hubs</td>
<td>85</td>
</tr>
<tr>
<td>Fibre Channel Fabric Switches</td>
<td>86</td>
</tr>
<tr>
<td>Firmware Specifications</td>
<td>86</td>
</tr>
<tr>
<td>Cluster Server References</td>
<td>86</td>
</tr>
<tr>
<td>Appendix B. Notices</td>
<td>87</td>
</tr>
</tbody>
</table>
Trademarks ................................................................. 87

Index. ........................................................................ 89
Figures

Figure 1. Installing the RAID Controller on a Fibre Channel Loop .................... 21
Figure 2. Firmware Upgrade Screen .......................................................... 34
Figure 3. Recovery Main Screen ................................................................. 38
Figure 4. Recovery Screen/Exceptions Found .............................................. 39
Figure 5. Recovery Procedure Screen .......................................................... 40
Figure 6. Main Configuration Screen .......................................................... 41
Figure 7. Main Module Profile Screen ......................................................... 43
Figure 8. Example of RDAC I/O Data Path Redundancy ................................. 59
Tables

Table 1. Windows NT Restrictions and Notes ........................................... 3
Table 2. Cluster Server Restrictions and Notes ........................................ 6
Table 3. Upgrading the Storage Management Software (Standard Installation) .......... 10
Table 4. Upgrading the Storage Management Software (Cluster Server) ............ 14
Table 5. Cluster Server Required Components .......................................... 16
Table 6. Cluster Server Environment Installation (summary) .......................... 17
Table 7. Fibre Channel Loop ID Byte Definition ....................................... 30
Table 8. Firmware Confirmation Screen Elements ...................................... 36
Table 9. Configuration Display Columns ................................................. 41
Table 10. Possible Parameters to Change ............................................... 45
Table 11. Contents of an SNMP Trap Message ......................................... 53
Table 12. Changeable Parameters in the rmparams File .............................. 55
Table 13. Troubleshooting Entries by Category ....................................... 66
Table 14. Troubleshooting Entries Organized by Component ....................... 66
Table 15. Troubleshooting Entries Organized by Application ..................... 68
Table 16. Troubleshooting Entries Organized by Software ......................... 70
Table 17. Configuration Changes Troubleshooting .................................. 70
Table 18. Controller Firmware Upgrade Troubleshooting .......................... 72
Table 19. Troubleshooting Generally Applicable to All Applications ............. 73

© Copyright IBM Corp. 1998, 1999
Table 20. Recovery Guru/Health Check Troubleshooting  . . . . . . . . . . . . . . . . . . . . . . . 77
Chapter 1. Introduction

This chapter gives an overview of the software, the software requirements, and steps you must take before installing the software.

About this Handbook

This Installation and User’s Handbook provides installation and setup information for SYMplicity™ Storage Manager software version 6.22 in a Microsoft® Windows NT™ environment. Use this Installation and User’s Handbook to do the following:

• Determine the hardware and software required to install this software
• Install the software
• Set up software parameters
• Identify storage management features unique to the NT operating system
• Troubleshoot the installation and NT operation

This handbook is accompanied by the SYMplicity Storage Manager User’s Handbook. The User’s Handbook describes how to use the storage management software after installation. Some procedures in that book may be affected by information given in this book (for example, see the information in this handbook on creating and deleting LUNs).

You should use this Installation and User’s Handbook after installing the RAID controller unit hardware. After you install and set up the software, go to the User’s Handbook for further information on using the software and maintaining the RAID controller units.

New Software Features

This release of the storage management software contains the following new features:

• Faster LUN creation. The controller now performs background formatting to create logical unit numbers (LUNs) faster.

• SMART/PFA support. Through the use of Self-Monitoring Analysis and Reporting Technology (SMART), the storage management software now reports predictive failure analysis (PFA) flags on drives.
• Firmware autosynch. When you replace a controller with firmware level 3.00.X or higher, the firmware on the new controller automatically synchronizes with the firmware on the remaining controller.

• Fibre Channel Loop ID. For Fibre Channel topologies, a new nvutil option allows you to set the Fibre Channel Loop ID for the controller.

• Backup log redirection. When the threshold limit is reached, you now can set the location for your old log file.

• Windows NT Event Log capability. You can use the new putntlog command-line utility to write the contents of a RAID event to the Windows NT Event Log.

• Parity Check/Repair Enhancement. You now can choose to not repair errors during automatic parity check/repair.

• Additional failure types detected and appropriate recovery procedures added in the Recovery Guru. Support for two additional configurations: independent controller and multi-host. See the User’s Handbook for more detailed information.

• Packaging. With this release, the controller firmware and the storage management software are packaged separately on the installation CD.

Understanding the Restrictions

Always check for a readme file on any installation media. This file may contain important information that was not available at the time this Installation and User’s Handbook was prepared.
The following table explains the restrictions that apply when using Windows NT.

### Table 1: Windows NT Restrictions and Notes

<table>
<thead>
<tr>
<th>Restriction/Note</th>
<th>Application</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>The SymArray driver must be loaded <em>before</em> the Windows NT SCSI class driver or RDAC will not work.</td>
<td>Installation and Setup</td>
<td>None. The installation procedure sets up the SymArray driver to load before the native NT SCSI class driver. This is necessary to provide RDAC protection in the event of a connection failure. Note that this means that internal SCSI drives appear after RAID controller unit drives in the Disk Administrator utility. Also, “sticky” drive letters must be assigned before the storage management software is loaded. Care must be taken when using applications that expect the internal SCSI drives to be mapped first (see also &quot;Accessing Raw Partitions&quot; on page 60). If it is necessary that the NT SCSI driver be loaded first, RDAC must be disabled.</td>
</tr>
<tr>
<td>Multi-host has <em>only</em> been tested with the Microsoft Cluster Server (MSCS) environment. Without additional host-based clustering software to manage conflicts between the host machines, Windows NT alone does not support the multi-host configuration.</td>
<td>Installation and Setup</td>
<td>Use only the Single-host or Independent Controller Host-RAID controller unit configurations if not using the Cluster Server environment. For more information on the types of Host-RAID controller unit configurations supported by the storage management software, see the <em>User’s Handbook</em>, “Types of Host-RAID Controller Unit Configurations Supported.” For information on the Cluster Server environment, see “Cluster Server References” on page 86.</td>
</tr>
<tr>
<td>IBM does not recommend using the RAID controller unit as a boot device (that is, install the Windows NT operating system and the storage management software on LUN 0 of the RAID controller). However, if you require this configuration, you must prepare the host machine to boot from the module before installing any software. <strong>NOTE</strong> The storage management software has been tested with the RAID controller unit as the boot device <em>only</em> for a single host-RAID controller unit configuration.</td>
<td>Installation and Setup</td>
<td>Call the IBM PC Help Center. <strong>CAUTION</strong> If you use the RAID controller unit as a boot device, you must never delete LUN 0 or use File → Reset Configuration (Configuration Application) or you will lose your boot device and operating system.</td>
</tr>
</tbody>
</table>
RDAC failover does not work during system dump if the dump/swap device is a RAID controller unit LUN different from the LUN used for the boot device.

Do not create a RAID controller unit LUN having only dump/swap areas. It is acceptable to put the dump/swap area on the same LUN as the boot device.

Do not use Microsoft’s Network Monitor™ service with the storage management software. Monitoring the network connections with this service can result in problems, such as blue screens.

Stop the Network Monitor service if you have it installed before using the storage management software:

1. Select Control Panel → Services.
2. Highlight the Network Monitor service.
3. Select Stop.

The raidutil utility does not always generate an error message even when an operation fails. For example, using raidutil -R to reset the controller battery age without LUN 0 created causes the operation to fail. However, there is no error message.

Anytime you use raidutil to perform an operation, it is a good idea to verify that the operation was completed successfully. For example, after creating LUNs, you might want to use the lad utility to verify your configuration.

Cannot reliably change font size in the storage management software’s displays.

Table 1: Windows NT Restrictions and Notes (continued)

<table>
<thead>
<tr>
<th>Restriction/Note</th>
<th>Application</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>RDAC failover does not work during system dump if the dump/swap device is a RAID controller unit LUN different from the LUN used for the boot device.</td>
<td>Installation and Setup</td>
<td>Do not create a RAID controller unit LUN having only dump/swap areas. It is acceptable to put the dump/swap area on the same LUN as the boot device.</td>
</tr>
<tr>
<td>Do not use Microsoft’s Network Monitor™ service with the storage management software. Monitoring the network connections with this service can result in problems, such as blue screens.</td>
<td>Installation and Setup</td>
<td>Stop the Network Monitor service if you have it installed before using the storage management software: 1. Select Control Panel → Services. 2. Highlight the Network Monitor service. 3. Select Stop.</td>
</tr>
<tr>
<td>The raidutil utility does not always generate an error message even when an operation fails. For example, using raidutil -R to reset the controller battery age without LUN 0 created causes the operation to fail. However, there is no error message.</td>
<td>General</td>
<td>Anytime you use raidutil to perform an operation, it is a good idea to verify that the operation was completed successfully. For example, after creating LUNs, you might want to use the lad utility to verify your configuration.</td>
</tr>
<tr>
<td>Cannot reliably change font size in the storage management software’s displays.</td>
<td>General</td>
<td>None.</td>
</tr>
</tbody>
</table>
Selecting some operations may result in an error message for the selected RAID controller unit indicating that I/Os were occurring or filesystems were present. This occurs when a second application/option requests exclusive access while the affected LUNs and Windows NT drive letters are already locked by another operation.

When creating or deleting LUNs, or using File → Reset Configuration, the Windows NT host requires a restart in order to see the configuration changes properly.

### Table 1: Windows NT Restrictions and Notes (continued)

<table>
<thead>
<tr>
<th>Restriction/Note</th>
<th>Application</th>
<th>Workaround</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selecting some operations may result in an error message for the selected RAID controller unit indicating that I/Os were occurring or filesystems were present. This occurs when a second application/option requests exclusive access while the affected LUNs and Windows NT drive letters are already locked by another operation.</td>
<td>Configuration, Recovery, Maintenance/Tuning</td>
<td>1 Wait for any operation that requires exclusive access to finish before performing another operation on the affected RAID controller unit or drive group/LUNs. 2 If no other storage management operations are running, then some other Windows NT application may be using/displaying the drive letters. If you suspect this is the case, close other Windows NT applications, such as File Manager, then reselect the storage management software and try the operation again. Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration (Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and Firmware Upgrade → Offline method (Maintenance/Tuning).</td>
</tr>
<tr>
<td>When creating or deleting LUNs, or using File → Reset Configuration, the Windows NT host requires a restart in order to see the configuration changes properly.</td>
<td>Configuration</td>
<td>Restart the host system anytime you create or delete drive groups/LUNs.</td>
</tr>
</tbody>
</table>

Chapter 1. Introduction 5
### Restrictions for the Cluster Server Environment

#### Table 2: Cluster Server Restrictions and Notes

<table>
<thead>
<tr>
<th>Restriction/Note</th>
<th>Application</th>
<th>Workaround</th>
</tr>
</thead>
</table>
| Groups do not revert back to the preferred node after the Cluster Service is resumed. | Installation and Setup | Most likely, the Groups are not set to a preferred node. Do one of the following:  
- Set the preferred node option:  
  a. Select the node.  
  b. Select Group → Properties.  
  c. Set the Preferred Node option for the desired node.  
- Manually move the Groups back to the node:  
  a. Select the node.  
  b. Select File → Pause Node.  
  c. Select the Group you want the node to own, and select File → Move Group. Repeat for every group that you want the node to own.  
  d. Select the node again.  
  e. Select File → Resume Node. |
| Drive letters of shared logical units do not match in Disk Administrator on both nodes. | Installation and Setup | Use the Tools → Assign Drive Letters in the Disk Administrator on the appropriate node to ensure that the drive letters are the same as those assigned to node A.  
For example, if node A had an internal hard disk at drive letter c: and node B had two internal hard disks at c: and d:, then the shared disk letters would not match (node A would start at drive d: and node B would start at drive e:, therefore, you would have to change the drive letter at node A to start at drive e:). |
| Both node names do not appear in the Cluster Administrator window. | Installation and Setup | 1. Select Control Panel → Add/Remove Programs to uninstall the storage management software on both systems.  
2. Verify that there is not an IP conflict on the network and that all cabling is installed correctly and securely.  
3. Begin this procedure again, starting with "Upgrading from a Previous Installation" on page 9. |
Hardware and Software Requirements

Before installing the storage management software, make sure you have the following components installed.

- Hardware Configuration
- Operating System
- Host Adapters

In addition, make sure you have checked the hardware.

Hardware Configuration

The following hardware is required:

- At least an 800 x 600 resolution graphics card and mouse.

- RAID controller unit with Series 4 controllers (see "Appendix A. Specifications" for a list of supported controllers and firmware requirements).

- A minimum controller firmware version depending on your controller model (see Table "Firmware Specifications" starting on page 86 for a list of firmware levels).

- One or two host machines with a Host-RAID controller unit configuration supported by this software (see "Appendix A. Specifications" for information on supported configurations).

Operating System

Windows NT Server 4.0 (for the standard environment) or Windows NT 4.0 Enterprise Edition (for the Cluster Server environment) operating system installed on the host machines connected via Fibre Channel cable to the RAID controller units.

This software was tested with Microsoft Service Pack 3.

Host Adapters

See "Appendix A. Specifications" for a list of the host adapters tested with this software.

Checking the Hardware

Use the following checklist to make sure that the RAID controller units have been connected correctly to your host system. If necessary, refer to the documentation supplied with your RAID controller unit:
• Cable connections correct and secure?
• Host-Side IDs set properly?

**IMPORTANT** For the greatest level of I/O path protection, provide each controller in a RAID controller unit with its own data path connection (that is, cable, hub, and host adapter) into the host system.

Continue with "Setting Up Fibre Channel Host Adapters" on page 8.

### Setting Up Fibre Channel Host Adapters

If you are using Fibre Channel, you must set up the host adapters. Use the following procedure:

1. Go to the hba directory on this software’s Installation CD.

2. Consult any readme file in that folder. This file will give specific instructions on what you need to do to set up your Fibre Channel host adapters.

3. Perform any required operations.

### Selecting the Correct Installation Procedure

The procedure you need to use to install the storage management software depends upon the configuration of the system.

<table>
<thead>
<tr>
<th>If You Want To:</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install the software on a standard, Host-RAID controller unit configuration.</td>
<td>&quot;Chapter 2. Installing Software on a Standard Configuration&quot;</td>
</tr>
<tr>
<td>Install the software and make the RAID controller unit the boot device.</td>
<td>Table 1 &quot;Windows NT Restrictions and Notes&quot; starting on page 3. Call the IBM PC Help Center.</td>
</tr>
<tr>
<td>Install the software in a Cluster Server environment.</td>
<td>Cannot have more than 5 Emulex Fibre Channel host adapters on the same loop with the NTS310x9 driver.</td>
</tr>
</tbody>
</table>
Chapter 2. Installing Software on a Standard Configuration

This chapter describes how to install or upgrade the storage management software on a standard configuration (single host or independent controller configuration).

Where to Start

Are you upgrading from a previous version of the storage management software?

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to &quot;Assigning Drive Letters&quot; on page 10.</td>
<td>Go to &quot;Upgrading from a Previous Installation&quot; on page 9.</td>
</tr>
</tbody>
</table>

Upgrading from a Previous Installation

If you are upgrading from a previous version of storage management software, read the following note; then, use the current version of the storage management software to perform the tasks given in Table 3.

**NOTE**  
rmparams and rmscript.bat files — During the upgrade/installation procedure, your current rmparams file will be saved as rmparams.ori and the rmscript.bat file will be saved as rmscript.ori. You can refer to these old files after installation to determine if you want to customize the new files with any changes you may have made. Do not copy the old files over the new; doing so may destroy new parameters or script that was installed with the new version.
To ensure RDAC functionality, the installation procedure loads the SymArray driver before the native NT class driver. However, this means that the system will see the RAID controller unit’s LUNs first, before it sees any local SCSI drives, and will assign drive letters accordingly. Therefore, before you install this software, you must have “sticky” drive letters assigned to your existing local drives.

**IMPORTANT** The storage management software can not be installed unless drive letters are assigned to existing drives.

Use the following procedure to assign “sticky” drive letters:

1. Start Disk Administrator (select Start → Programs → Administrative Tools → Disk Administrator), and view the disk configuration on your system. Check the number of partitions.

   **If you have two or more partitions:**
   Go to Step 2.

   **If you have only one partition:**
   Go to Step 3 on page 11.

   **Table 3: Upgrading the Storage Management Software (Standard Installation)**

<table>
<thead>
<tr>
<th>Task to Perform</th>
<th>Why Perform This Task?</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 From any application, select File → Save Module Profile.</td>
<td>To retain a copy of your current configuration for each RAID controller unit and the current module names. This copy can be used for reference, but cannot be used to automatically reload the configuration.</td>
</tr>
<tr>
<td>2 Make sure All information types is selected, and select OK. IMPORTANT Be sure to save this information file to the same disk drive where the storage management software is installed (such as, c:). However, you should place it in a different directory than the software’s installation, so that this file is not removed during the installation procedure.</td>
<td></td>
</tr>
<tr>
<td>3 Exit the storage management software completely, making sure the previous version is not currently open or running.</td>
<td>To avoid problems with overwriting or deleting old files during installation.</td>
</tr>
<tr>
<td>4 Continue with &quot;Installing the Storage Management Software&quot; on page 11.</td>
<td>To upgrade to the new version.</td>
</tr>
</tbody>
</table>
2. If you have at least two partitions (the boot partition and one other partition) and both of the following conditions apply:
   - The last partition you created was created with Disk Administrator
   - The partition has a drive letter assigned and has a status of “Unknown” or has a file system on it (that is, it has a status other than “Unformatted”).

   You are finished with this procedure; continue with "Installing the Storage Management Software" on page 11. If both conditions do not apply, proceed to Step 3 on page 11.

3. Create a new partition.

   IMPORTANT If you have no room for a second partition on your local system, you can use a RAID controller unit LUN for the second partition. The RAID controller unit should have at least one LUN configured on it. You can access the RAID controller unit LUN without having installed the storage management software. Connect the RAID controller unit to the system and then restart the system. The RAID controller unit LUNs will appear in Disk Administrator, and you will be able to create a second partition on a RAID controller unit LUN using the procedure below. Note that you can delete or modify the RAID controller unit LUN later without causing the boot partition drive letter to be reassigned.

   a. Select a drive containing some free disk space.
   b. Select Partition → Create. The partition is created (a drive letter is assigned and the partition status is “Unformatted”).
   c. Select Partition → Commit Changes Now. The partition status changes to “Unknown,” and sticky drive letters are assigned to all your existing partitions.

4. Continue with the next section, "Installing the Storage Management Software" on page 11.

Installing the Storage Management Software

Use the following procedure to install the storage management software in a standard configuration.

IMPORTANT You must have administrator privileges to access this software. This installation procedure requires a restart of the operating system. Therefore, make sure that other users are not on the system when installing this software.
If you are using the independent controller configuration, you must perform this procedure on both hosts.

In the following examples, c: is designated as your boot drive and d: is designated as the CD-ROM device drive. Be sure to select the correct drives for your system.

1. Insert the Installation CD into your CD-ROM drive.

2. To begin the installation program:
   a. Select Start → Settings → Control Panel → Add/Remove Programs.
   b. Select Install and follow the instructions on the screen.
   c. When you see d:\symsm\setup.exe, select Finish.

3. Follow the instructions on the screen to complete the installation procedure.

**IMPORTANT** During installation, you will be prompted to define the directory path where you want this software installed. If you are defining your own directory path, do not use special characters for the directory name (such as, #, $, or +). The default path is \program file\symsm on your boot drive. For the purpose of providing examples of the installation requirements, this Installation Handbook will refer to the default directory on drive c:.

4. When installation is completed, remove the CD and restart the system.

5. Verify the storage management software is installed and the Disk Array Monitor service is running:
   a. Select Start → Programs. SYMplicity Storage Manager should appear in the list.
   b. Select Start → Settings → Control Panel → Services. The Disk Array Monitor should be running if this service’s status is Started.

6. Continue with "Chapter 4. Initial Startup Procedures"
This chapter describes how to install or upgrade the storage management software in the Multi-Host configuration, using Cluster Server software.

Where to Start

Are you upgrading from a previous version of the storage management software?

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to &quot;Cluster Server Overview&quot; on page 15.</td>
<td>Continue with &quot;Upgrading from a Previous Installation&quot; on page 13.</td>
</tr>
</tbody>
</table>

Upgrading from a Previous Installation

If you are upgrading from a previous version of storage management software, read the following note and use the current version of the storage management software to perform the tasks given in Table 4.

**NOTE** During the upgrade/installation procedure, your current rmparams and rmscript.bat files will be saved as rmparams.ori and rmscript.ori. You can refer to these old files after installation to determine if you want to customize the new files with changes you may have made. Do not copy the old files over the new; doing so may destroy new parameters or script that was installed with the new version.
### Table 4: Upgrading the Storage Management Software (Cluster Server)

<table>
<thead>
<tr>
<th>Task to Perform</th>
<th>Why Perform This Task?</th>
</tr>
</thead>
<tbody>
<tr>
<td>1  From any application, select File → Save Module Profile.</td>
<td>To retain a copy of your current configuration for each RAID controller unit and the current module names. This copy can be used for reference, but cannot be used to automatically reload the configuration.</td>
</tr>
<tr>
<td>2  Make sure All information types is selected, and select OK.</td>
<td>To avoid problems with overwriting or deleting old files during installation.</td>
</tr>
<tr>
<td><strong>IMPORTANT</strong> Be sure to save this information file to the same disk drive where the storage management software is installed (such as, c:). However, you should place it in a different directory than the software’s installation, so that this file is not removed during the installation procedure.</td>
<td></td>
</tr>
<tr>
<td>3  Exit the storage management software completely, making sure the previous version is not currently open or running.</td>
<td>To verify that your resources are up and running.</td>
</tr>
<tr>
<td>4  Using Cluster Administrator, you should pause the node and move all Groups that it owns before upgrading the storage management software.</td>
<td></td>
</tr>
<tr>
<td>5  Select node A.</td>
<td>To upgrade to the new version of storage management software on node A.</td>
</tr>
<tr>
<td>6  Select File → Pause Node.</td>
<td></td>
</tr>
<tr>
<td>7  Select a Group that node A owns, and select File → Move Group. Repeat for every Group owned by node A.</td>
<td></td>
</tr>
<tr>
<td>8  Upgrade the software on node A.</td>
<td></td>
</tr>
<tr>
<td>a Insert the installation CD into your CD-ROM drive on node A.</td>
<td></td>
</tr>
<tr>
<td>b Select Start → Settings → Control Panel → Add/ Remove programs</td>
<td></td>
</tr>
<tr>
<td>c Select Install and follow the instructions on the screen.</td>
<td></td>
</tr>
<tr>
<td>d When you see d:\native\symsm\setup.exe, select Finish.</td>
<td></td>
</tr>
<tr>
<td>e Follow the instructions on the screen to complete the installation procedure.</td>
<td></td>
</tr>
<tr>
<td>f When the installation is complete, remove the CD and restart the system.</td>
<td></td>
</tr>
</tbody>
</table>
Cluster Server Overview

The storage management software has been tested with Cluster Server software to support the Multi-Host RAID controller unit configuration. For details on specific server-host adapter models tested with this software, see "Cluster Server References" on page 86.

The hardware components of this configuration consist of a pair of server-host adapter systems connected to one or more high-performance RAID controller units. This configuration provides a hardware RAID implementation and features high-availability functions such as hot-swap redundant fans, power supplies, and hot-swap drives for increased data protection and reliability.

Continue with the next section, "Required Components" on page 16.
Required Components

Before installing the RAID controller unit and the storage management software in the cluster server environment, you will need the hardware/software components listed in Table 5.

Table 5: Cluster Server Required Components

<table>
<thead>
<tr>
<th>Component Description</th>
<th>Important Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Two nodes with a PCI Ethernet adapter installed in each node.</td>
<td>These nodes will be node A and node B in your cluster server environment. Microsoft recommends two Ethernet adapters in each node (one for intercommunication between the nodes and one for client access over the network). IMPORTANT You must configure both nodes (servers) to use the TCP/IP protocol over all interconnects. However, routers can be placed between the cluster and its clients. If all interconnects must run through a hub, isolate each interconnect by using separate hubs. Also, ensure that both nodes on the cluster are in the same domain (not workgroup).</td>
</tr>
<tr>
<td>One interconnect (cross-over) cable installed between each PCI ethernet adapter installed in each node.</td>
<td>None</td>
</tr>
<tr>
<td>Microsoft Windows NT Server, Enterprise Edition 4.0 (including Service Pack 3) installed on each of your nodes.</td>
<td>IMPORTANT Make sure you do not install the Cluster Server Software until told to do so in this chapter.</td>
</tr>
<tr>
<td>Netfinity Fibre Channel PCI Adapters.</td>
<td>See &quot;This appendix describes the configuration specifications for this software.&quot; for a list of the host adapters tested with the cluster server environment.</td>
</tr>
</tbody>
</table>
Table 5: Cluster Server Required Components (continued)

<table>
<thead>
<tr>
<th>Component Description</th>
<th>Important Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAID controller unit (with two RAID controllers).</td>
<td>You should have unpacked the RAID controller unit, connected the appropriate power cables, and placed it in the proper location for installation into the Cluster Server environment. Instructions on checking Host-Side IDs and connecting the cables are provided in the appropriate product handbook (see the documentation list on page 86).</td>
</tr>
<tr>
<td>SYMplicity Storage Manager For Windows NT (version 6.22).</td>
<td>This storage management software is provided on a CD-ROM and included with the RAID controller unit.</td>
</tr>
<tr>
<td>A minimum controller firmware version depending on your controller model and configuration type (single- or dual-bus).</td>
<td>Controller firmware is provided on the storage management software’s CD-ROM. Always use the most current version of firmware available for the controller you are using (see Table on page 86).</td>
</tr>
</tbody>
</table>

Continue with the next section, "Quick Installation Summary" on page 17.

Quick Installation Summary

Table 6 summarizes the tasks required to install the storage management software in a cluster server environment for the first time. See the next section, "Installing the Hardware" on page 20 for the complete procedure.

Table 6: Cluster Server Environment Installation (summary)

<table>
<thead>
<tr>
<th>Step</th>
<th>Node A</th>
<th>Node B</th>
<th>Additional Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Install the nodes and network environment (ethernet adapters, interconnect cables, TCP/IP protocol).</td>
<td>See your hardware documentation.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Install Windows NT Server, Enterprise Edition 4.0 (including Microsoft Service Pack 3).</td>
<td>See your Windows NT operating system documentation.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>IMPORTANT</strong> Do not install the Cluster Server Software at this time.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Install the host adapters and drivers.</td>
<td>See &quot;Installing the Host Adapters&quot; on page 20.</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Install the RAID controller units between nodes A and B.</td>
<td>See &quot;Installing the RAID Controller Units&quot; on page 20.</td>
<td></td>
</tr>
<tr>
<td>Step</td>
<td>Node A</td>
<td>Node B</td>
<td>Additional Details</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>Turn on node B, but do not allow Windows NT to boot.</td>
<td><strong>NOTE</strong> To suspend the booting of Windows NT, press the spacebar at the Operating System (OS) loader screen. See &quot;Installing the Software on Node A&quot; on page 22.</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>Turn on node A and boot Windows NT.</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>Assign “sticky” drive letters to the drives on Node A.</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>Install the storage management software.</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>Verify the controller firmware version for the RAID controller unit and upgrade if necessary.</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>Set NVSRAM values for the Cluster Server environment.</td>
<td>See &quot;Setting Up the RAID Controller Units&quot; on page 24.</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>Configure logical units (LUNs) using the storage management software.</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>Use Windows NT Disk Administrator to partition RAID controller unit LUNs and assign drive letters.</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td>Shut down Windows NT but leave node A running (do not turn off the node).</td>
<td>See &quot;Shutting Down Node A&quot; on page 25.</td>
</tr>
<tr>
<td>14</td>
<td></td>
<td>Boot Windows NT.</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td>Assign “sticky” drive letters to the drives on Node B.</td>
<td>See &quot;Installing the Software on Node B&quot; on page 25.</td>
</tr>
<tr>
<td>16</td>
<td></td>
<td>Install the storage management software.</td>
<td></td>
</tr>
</tbody>
</table>
Table 6: Cluster Server Environment Installation (summary) (continued)

<table>
<thead>
<tr>
<th>Step</th>
<th>Node A</th>
<th>Node B</th>
<th>Additional Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>17</td>
<td></td>
<td>Use Windows NT Disk Administrator to verify the LUN drive letters are the same as those assigned to node A (in Step 12).</td>
<td>See &quot;Verifying Drive Letters&quot; on page 27.</td>
</tr>
<tr>
<td>18</td>
<td></td>
<td>Shut down Windows NT but leave node B running (do not turn off the node).</td>
<td>See &quot;Shutting Down Node B&quot; on page 27.</td>
</tr>
<tr>
<td>19</td>
<td>Start Windows NT and insert the CD-ROM containing the Cluster Server Software.</td>
<td></td>
<td>See &quot;Installing the Cluster Server Software&quot; on page 27.</td>
</tr>
<tr>
<td>20</td>
<td>Install the Cluster Server Software and Form A New Cluster.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Keep Windows NT running on node A.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Start Windows NT and insert the CD-ROM containing the Cluster Server Software.</td>
<td></td>
<td>See &quot;Installing the Cluster Server Software&quot; on page 27.</td>
</tr>
<tr>
<td>23</td>
<td>Install the Cluster Server Software and Join The Existing Cluster.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>Keep Windows NT running on node B.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Test the Cluster Server software installation by starting Cluster Administrator.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Continue with the next section, "Installing the Hardware" on page 20, for the complete installation procedure.
Installing the Hardware

Hardware installation involves installing host adapters and RAID controller units.

Installing the Host Adapters

See the documentation accompanying your host adapter for installation information and requirements. The following considerations apply:

• Ensure that the BIOS on each Fibre Channel host adapter is disabled.
• Install the correct driver for the IBM Fibre Channel host adapter.
• Continue with the next section, "Installing the RAID Controller Units" on page 20.

Installing the RAID Controller Units

Figure 1 on page 21 shows the hardware components involved with installing the RAID controller unit (nodes, host adapters, RAID controller unit drives and controllers, and applicable cables). Figure 1 on page 21 also shows a Fibre Channel connection using either a single or dual bus configuration.

• For best results, use the dual bus configuration. It provides the fullest RDAC protection and functionality in the event there is a problem with the connection along one bus.
• Use the appropriate RAID controller unit installation documentation, making sure to check each controller on the back of the module to be sure that each controller has a unique Host-Side ID setting.

NOTE RAID controller unit controllers are normally preset to IDs 4 and 5.

Continue with the next section, "Installing the Storage Management Software" on page 22.
Figure 1. Installing the RAID Controller on a Fibre Channel Loop
Installing the Storage Management Software

**IMPORTANT** Make sure you do not install the Cluster Server Software until told to do so in this chapter.

Installing the Software on Node A

**CAUTION** Once you have connected the RAID controller units to both nodes, do not boot Windows NT on both nodes at the same time until you have installed the Cluster Server Software on at least one node. To suspend the booting of Windows NT, press the spacebar at the Operating System (OS) loader screen.

**Assigning Drive Letters**

The installation procedure loads the SymArray driver before the native NT class driver. This is necessary to enable RDAC functionality. However, this means that the system will see the RAID controller unit’s LUNs first, before it sees any local SCSI drives, and will assign drive letters accordingly. Therefore, before you install this software, you must have “sticky” drive letters assigned to your existing local drives.

**IMPORTANT** The storage management software cannot be installed unless drive letters are assigned to existing drives.

Use the following procedure to assign “sticky” drive letters:

1. Start Disk Administrator (select Start → Programs → Administrative Tools → Disk Administrator), and view the disk configuration on your system. Check the number of partitions.

<table>
<thead>
<tr>
<th>If you have two or more partitions:</th>
<th>If you have only one partition:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to Step 2.</td>
<td>Go to Step 3.</td>
</tr>
</tbody>
</table>

2. If you have at least two partitions (the boot partition and one other partition) and both of the following conditions apply:
   - The last partition you created was created with Disk Administrator
• The partition has a drive letter assigned and has a status of “Unknown” or has a file system on it (that is, it has a status other than “Unformatted”).

You are finished with this procedure; continue with "Installing the Storage Management Software on Node A" on page 23. If both conditions do not apply, proceed to Step 3.

3. Create a new partition.

**IMPORTANT** If you have no room for a second partition on your local system, you can use a RAID controller unit LUN for the second partition. The RAID controller unit should have at least one LUN configured on it. You can access the RAID controller unit LUN without having installed the storage management software. Connect the RAID controller unit to the system and then restart the system. The RAID controller unit LUNs will appear in Disk Administrator, and you will be able to create a second partition on a RAID controller unit LUN using the procedure below. Note that you can delete or modify the RAID controller unit LUN later without causing the boot partition drive letter to be reassigned.

a. Select a drive containing some free disk space.

b. Select Partition → Create. The partition is created (a drive letter is assigned and the partition status is “Unformatted”).

c. Select Partition → Commit Changes Now. The partition status changes to “Unknown,” and sticky drive letters are assigned to all your existing partitions.

4. Continue with the next section, "Installing the Storage Management Software on Node A" on page 23.

**Installing the Storage Management Software on Node A**

**IMPORTANT** You must have administrator privileges to access this software. This installation procedure requires a restart of the operating system. Therefore, make sure that other users are not on the system when installing this software.

In the following procedure, c:\ is designated as your boot drive and d:\ is designated as the CD-ROM device drive. Be sure to select the correct drives for your system.

1. From node A, insert the Installation CD into your CD-ROM drive.

2. To begin the installation program:
a. Select Start → Settings → Control Panel → Add/Remove Programs.
b. Select Install and follow the instructions on the screen.
c. When you see d:\native\symsm\setup.exe, select Finish.

3. Follow the instructions on the screen to complete the installation procedure.

**IMPORTANT** During installation, you will be prompted to define the directory path where you want this software installed. If you are defining your own directory path, do not use special characters for the directory name (such as, #, $, or +). The default path is \program file\symsm on your boot drive. For the purpose of providing examples of the installation requirements, this *Installation Handbook* will refer to the default directory on drive c:.

4. When installation is completed, remove the CD and restart the system.

5. Verify the storage management software is installed and the Disk Array Monitor service is running:
   a. Select Start → Programs. SYMplicity Storage Manager should appear in the list.
   b. Select Start → Settings → Control Panel → Services. The Disk Array Monitor should be running if this service’s status is Started.

6. Continue with the next section, "Setting Up the RAID Controller Units" on page 24.

**Setting Up the RAID Controller Units**

Go to "Chapter 4. Initial Startup Procedures" and perform the procedures given to set-up the RAID controller unit. Specifically:

- Make sure the correct version of controller firmware is installed (see "Verifying and Upgrading Controller Firmware" on page 31).

- Make the necessary changes to the NVSRAM files (see "Setting NVSRAM Values" on page 36).

- Run a health check to insure that the RAID controller unit is operating correctly (see "Running Recovery Guru/Health Check" on page 37).

- Configure your RAID controller units as much as possible, including using Disk Administrator to partition them and assign drive letters. You do not have to completely configure your RAID controller units, but remember that if you make changes in the future, you must also make them known to node B. See "Determining the Current Configuration" on page 40.

After you have completed the procedures given in "Chapter 4. Initial Startup Procedures", return here and continue with the next section, "Shutting Down Node A."
Shutting Down Node A

1. Shut down Windows NT, but leave node A running (do not turn off the node).

2. Continue with the next section "Installing the Software on Node B."

Installing the Software on Node B

After you have verified the software installation on node A and configured logical units, install the software on node B using the same procedure you used on node A. However, you do not need to configure any logical units.

Assigning Drive Letters

Before you install this software, you must have “sticky” drive letters assigned to your existing local drives.

IMPORTANT The storage management software cannot be installed unless drive letters are assigned to existing drives.

Use the following procedure to assign “sticky” drive letters:

1. Boot Windows NT on node B.

2. Start Disk Administrator (select Start → Programs → Administrative Tools → Disk Administrator), and view the disk configuration on your system. Check the number of partitions.

<table>
<thead>
<tr>
<th>If you have two or more partitions:</th>
<th>If you have only one partition:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to Step 3.</td>
<td>Go to Step 4 on page 25.</td>
</tr>
</tbody>
</table>

3. If you have at least two partitions (the boot partition and one other partition) and both of the following conditions apply:
   - The last partition you created was created with Disk Administrator
   - The partition has a drive letter assigned and has a status of “Unknown” or has a file system on it (that is, it has a status other than “Unformatted”).

   You are finished with this procedure; continue with "Installing the Storage Management Software on Node B" on page 26. If both conditions do not apply, proceed to Step 4 on page 25.

4. Create a new partition.
IMPORTANT If you have no room for a second partition on your local system, you can use a RAID controller unit LUN for the second partition. The RAID controller unit should have at least one LUN configured on it. You can access the RAID controller unit LUN without having installed the storage management software. Connect the RAID controller unit to the system and then restart the system. The RAID controller unit LUNs will appear in Disk Administrator, and you will be able to create a second partition on a RAID controller unit LUN using the procedure below. Note that you can delete or modify the RAID controller unit LUN later without causing the boot partition drive letter to be reassigned.

a. Select a drive containing some free disk space.
b. Select Partition → Create. The partition is created (a drive letter is assigned and the partition status is “Unformatted”).
c. Select Partition → Commit Changes Now. The partition status changes to “Unknown,” and sticky drive letters are assigned to all your existing partitions.

5. Continue with the next section, "Installing the Storage Management Software on Node B."

Installing the Storage Management Software on Node B

1. From node B, insert the Installation CD into your CD-ROM drive.
   
   NOTE In the following examples, c: is designated as your boot drive and d: is designated as the CD-ROM device drive. Be sure to select the correct drives for your system.

2. To begin the installation program:
   a. Select Start → Settings → Control Panel → Add/Remove Programs.
   b. Select Install and follow the instructions on the screen.
   c. When you see d:\native\symsm\setup.exe, select Finish.

3. Follow the instructions on the screen to complete the installation procedure.

IMPORTANT During installation, you will be prompted to define the directory path where you want this software installed. If you are defining your own directory path, do not use special characters for the directory name (such as, #, $, or +). The default path is \program file\symsm on your boot drive.

4. When installation is completed, remove the CD and restart the system.
5. Verify the storage management software is installed and the Disk Array Monitor service is running:
   a. Select Start → Programs. SYMplicity Storage Manager should appear in the list.
   b. Select Start → Settings → Control Panel → Services. The Disk Array Monitor should be running if this service’s status is Started.

6. Continue with the next section, "Verifying Drive Letters."

Verifying Drive Letters
1. Use the Windows NT Disk Administrator to verify that the drive letters assigned to the configured logical units are the same as those assigned to node A (in "Partitioning Logical Units and Assign Drive Letters" on page 48).

2. If the drive letters are not the same, go to "Chapter 7. Troubleshooting".

3. Continue with the next section, "Shutting Down Node B."

Shutting Down Node B
1. Shut down Windows NT, but leave node B running (do not turn off the node).

2. Continue with the next section, "Installing the Cluster Server Software" on page 27.

Installing the Cluster Server Software
1. Install the Cluster Server software on Node A
   a. Refer to the Microsoft Clustering For Windows NT Server Administrator’s Guide for the correct procedure to install the Cluster Server Software.
      
      NOTE During installation, specify that you want to Form A New Cluster.
   b. After the system restarts, leave node A up and running.

2. Install the Cluster Server software on Node B.
   a. Refer to the Microsoft Clustering For Windows NT Server Administrator’s Guide for the correct procedure to install the Cluster Server Software.
      
      NOTE During installation, specify that you want to Join The Existing Cluster.
   b. After the system restarts, leave node B up and running.

3. Verify the software installation.
   a. On either node (A or B), select Start → Programs → Administrative Tools (Common).
b. Click on Cluster Administrator.

c. In the “Cluster or Server Name” prompt, type either the name of the cluster or the name/IP address of one of the nodes.

d. If the installation was successful, the computer names of both nodes appear on the left side of the Cluster Administrator window.

4. Do both node names appear?

<table>
<thead>
<tr>
<th></th>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Go to &quot;Chapter 7. Troubleshooting&quot;</td>
<td>Go to &quot;Chapter 5. Customizing the Installation&quot;</td>
</tr>
</tbody>
</table>
Chapter 4. Initial Startup Procedures

This chapter contains procedures to ensure that the storage management software operates properly and to determine if your system configuration meets your needs:

If you are using a fibre channel arbitrated loop configuration, you can use the nvutil utility to set the preferred loop IDs for the controllers on the loop.

**IMPORTANT** You must specify a device name for the controller for which you want to set the preferred loop ID. Otherwise, the loop ID you specify will be assigned to every controller on the loop.

To set the preferred loop ID, type the following on the command line:

```
nvutil -i <Loop ID number> <device name>
```

**Notes:**

1. The `<Loop ID number>` is the preferred loop ID you want to set.
2. The `<device name>` is the device name for the controller.

You can select a value between 0 and 125 in hexadecimal. Loop ID 126 is reserved for an FL Port or an N/FL Port. Loop ID 127 indicates that the device does not have a hard or preferred address. The loop ID is assigned an arbitration priority with 0 being lowest and 126 being highest. Note that the loop ID is not the same thing as the Arbitrated Loop Physical Address (AL PA), but rather an index to valid AL PAs.

Bit 7 of Byte 3 is used to indicate one of two modes of operation. If bit 7 is set to 0, then bits 6-0 specify a base value that is added to the Host Bus SCSI ID to create the Loop ID. If bit 7 is set to 1, then bits 6-0 indicate the loop ID.

Table 7 "Fibre Channel Loop ID Byte Definition" starting on page 30 shows the possible values and the resulting loop IDs.
### Table 7: Fibre Channel Loop ID Byte Definition

<table>
<thead>
<tr>
<th>Bit</th>
<th>7</th>
<th>6</th>
<th>5</th>
<th>4</th>
<th>3</th>
<th>2</th>
<th>1</th>
<th>0</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value</td>
<td>0</td>
<td>0x00 - 0x7f</td>
<td>Loop ID Base (added to Host Bus SCSI ID)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>1</td>
<td>0x00 - 0x7d</td>
<td>Loop ID (Host Bus SCSI ID ignored)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>1</td>
<td>0x7e</td>
<td>No Loop operation (initializes as Point-to-Point or Fabric only)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>1</td>
<td>0x7f</td>
<td>No preferred address</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Starting the Software

**IMPORTANT** You must have administrator privileges to access this software.

1. Start Windows NT if it is not already running. Select Start → Programs → SYMpliance Storage Manager.

2. The application names appear under SYMpliance Storage Manager (Configuration, Maintenance and Tuning, Recovery, and Status). For a description of some key terms used in the applications, refer to the “Common Definitions” section in the *User’s Handbook* or the Online Help glossary.

3. Do your modules have an Independent Controller configuration?

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
</table>

### Setting Up Independent Controllers

If your RAID controller units are using an Independent Controller configuration, you need to perform the procedure below to indicate the configuration to the storage management software.
1. Start any storage management software application.

2. When the Module Selection screen appears, highlight the module that has independent controllers, and select Edit.

3. Click the box next to “Independent Controllers?” and select OK.
   
   You return to the main Module Selection screen, and the “Indep. Cntrls?” column now says Yes.

4. Assign names to the modules, if desired, and add any comments (you may want to add location details or other unique information to further clarify the module name).

5. Repeat this procedure for all modules using this configuration.


Assigning Names to the Modules

The installation procedure assigns default names to each RAID controller unit (in the form <hostname_XXX>). You can assign other names to the modules, if desired, to aid in identifying them.

If you do not want to assign names to the modules at this time, continue with the next section, "Verifying and Upgrading Controller Firmware" on page 31. Otherwise, perform the following procedure:

1. Start any storage management software application.

2. When the Module Selection screen appears, highlight the module that has independent controllers, and select Edit.

3. Assign a name to the module and add any comments (you may want to add location details or other unique information to further clarify the module name).

4. Perform this procedure on each RAID controller unit you want to assign a name to.

5. Continue with the next section, "Verifying and Upgrading Controller Firmware" on page 31.

Verifying and Upgrading Controller Firmware

If your RAID controller units do not contain the most recent version of controller firmware, you will need to download the correct version to the RAID controller unit controllers (including any previously installed RAID controller units). Downloading new
firmware almost always includes downloading a new NVSRAM file. Use the following procedures to determine the current firmware level and to download new firmware, if necessary.

Determining Controller Firmware Version Level

**NOTE** Be sure to perform these steps from each host machine if your RAID controller units have an Independent Controller configuration. In addition, be sure to check the firmware level on all RAID controller units attached to the host system.

You can quickly see what the controller firmware version is by using Module Profile:

1. Start the Configuration application, select the RAID controller unit you want to check, then select Module Profile → Controllers.
2. Verify the firmware level is the most recent version (see "Firmware Specifications" on page 86 for a list of the firmware levels and controllers supported by this software).
3. Select OK when finished viewing.
4. Check all the RAID controller units on your system.
5. Do all the controllers on your system have the required version of firmware?

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>You must upgrade to the most recent</td>
<td>Go to &quot;Setting NVSRAM Values&quot; on page 36.</td>
</tr>
<tr>
<td>version immediately. Continue with</td>
<td></td>
</tr>
<tr>
<td>&quot;Upgrading the Controller Firmware</td>
<td></td>
</tr>
<tr>
<td>Version&quot; on page 32.</td>
<td></td>
</tr>
</tbody>
</table>

Upgrading the Controller Firmware Version

For complete details on the Firmware Upgrade option, refer to the “Upgrading Controller Firmware” procedure in the Maintenance/Tuning Chapter of the *User’s Handbook*.

Perform the following steps to download new controller firmware.

1. Copy the firmware files, the fwcompat.def file, and the NVSRAM files to the \program files\symsm\lib directory.
2. Determine whether you can upgrade the firmware using the Online or Offline method. If you must use the Offline method, make sure that you stop all I/O to the controllers you are going to upgrade. Note that if you must download an NVSRAM file, you must use the Offline method (because you will have to restart the RAID controller unit before the new settings take effect).
3. Start the Maintenance and Tuning application.

4. Select the RAID controller unit containing the controllers you want to upgrade. Select All RAID controller units to download firmware to all controllers in all RAID controller units.

5. Click on the Firmware Upgrade button or select Options → Firmware Upgrade from the drop-down menus.

6. Read the Important Notes screen, and select OK.

7. A screen appears asking you to select the online or offline procedure. Select either:
   - Online to upgrade firmware while the selected RAID controller unit receives I/O.
   - Offline to upgrade firmware when the selected RAID controller unit is not receiving I/O.

8. After selecting Online or Offline, the screen displays “Verifying the controller state” while the software checks the selected RAID controller units for restrictions based on the type of firmware upgrade you selected. If there are no restrictions, a screen like Figure 2 on page 34 is displayed.
Figure 2. Firmware Upgrade Screen

This display shows the controllers in the selected RAID controller units and their current Firmware levels. Make sure both controllers are highlighted here if you want to download firmware to both controllers. Note that for firmware levels 3.0 and higher, the fibre channel level is the same as the firmware level because the fibre channel firmware is contained in the firmware file.

Click here to begin the download after you have selected the firmware files to load or entered the name of the NVSRAM file in the path box.

Click here to cancel without downloading any new files.

This screen displays the compatible firmware files found by fwcompat.def. That program checks the default subdirectory for files. Highlight the version level you want to download.

Note that for firmware versions 3.0 or higher, the firmware (appware) file contains the fibre channel firmware, so no fibre channel file is listed here.

The path is updated to show the files currently selected in the Compatibility display. You can also enter a file name here to download that file (this is how to download an NVSRAM file).
9. Depending on whether you are downloading NVSRAM files or upgrading controller firmware, do one of the following:

**IMPORTANT** Remember, you need to download any NVSRAM files first, before downloading any new firmware files.

- To download an NVSRAM file, type its complete path information in the path box and select OK. Continue with Step 11.
- Select controller firmware, highlight the version level you want to download. Continue with Step 10.

10. Select OK with the correct version level highlighted.

You either receive notification that a problem occurred, or you have a final confirmation that the upgrade process is about to begin.

**IMPORTANT** Once you click OK at the “Firmware is about to start” prompt in Step 11, do not select any other options or exit the Maintenance/ Tuning Application until the upgrade process is complete. You can, however, monitor the upgrade progress.

11. Select OK and follow the upgrade progress.

A histogram for the selected RAID controller unit indicates the download progress of the NVSRAM or firmware files. This graphic shows the amount of progress as a percentage and starts over at 0% for each file if you have more than one. If you selected All RAID controller units, the module number is updated as each module begins its upgrade process.

When the NVSRAM download or the firmware upgrade is finished, you see a summary report indicating whether the upgrade is Successful or Failed. Table 8 on page 36 shows the information this screen displays.

**NOTE** If you selected All RAID controller units, it is possible that the upgrade was successful for some modules, but not for others. The final summary report should indicate which modules were not successful and give an appropriate cause. For more information, refer to your User’s Handbook.
12. After the download is completed, select OK to return to the Maintenance/ Tuning screen.

13. Did you download an NVSRAM file or new firmware?

<table>
<thead>
<tr>
<th>New Firmware</th>
<th>NVSRAM file</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are finished with this procedure. Continue with the next section, &quot;Setting NVSRAM Values&quot; on page 36</td>
<td>Continue with Step 14</td>
</tr>
</tbody>
</table>

14. At the command line, type:

```
nvutil -vf
```

This utility checks and corrects any settings on all controllers in your RAID controller units to ensure that certain settings in the NVSRAM are setup correctly for this software.

15. Turn the power to the RAID controller unit off and then on again to establish the new NVSRAM settings.

16. Go back to Step 9 on page 35 and download any new firmware files.

### Setting NVSRAM Values

You need to change NVSRAM settings so that the RAID controller units perform correctly on your configuration if *either* of the following two conditions applies:

- Your RAID controller units are *not* connected to a network
• Your RAID controller units are being used in a dual bus Cluster Server environment.

If your RAID controller units do not need updating, continue with the next section, "Running Recovery Guru/Health Check" on page 37. Otherwise, perform the following procedure:

1. Determine the .def file you need to use.

   The .def files are located in \program files\symsm\lib directory. At this time, you need to use one of two files. Either:
   
   - networkoff.def — If the RAID controller unit has no network connections.
   - reseton.def — If the RAID controller unit is being used with a Cluster Server on a dual bus configuration.

   **NOTE** You will see two other .def files in the directory: networkon.def and resetoff.def. These files can be used to restore the original NVSRAM settings.

2. From the command line, enter:

   \nvutil -vf <def_file_name>

   where <def_file_name> is the name of the required def file (determined in Step 1).

3. Turn the power to the RAID controller unit off and then on again to establish the new NVSRAM settings.

4. Perform this procedure from each host attached to an affected RAID controller unit.

5. Continue with the next section, "Running Recovery Guru/Health Check" on page 37.

**Running Recovery Guru/Health Check**

Use the following steps to ensure that the RAID controller units attached to your host system are all operational.

   **NOTE** Be sure to perform this step from each host machine if using the Independent Controller configuration.

Use the following procedure to run Recovery Guru/Health Check.

1. Start the Recovery application.

2. Select All RAID controller units to check all the modules on your system.
3. A screen like Figure 3 is displayed.

4. Click on the Recovery Guru/Health Check button or select Options → Recovery Guru from the drop-down menus. The software checks all the selected modules for non-optimal statuses.

5. Were non-optimal statuses found?

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are finished with this procedure. Continue with the next section, &quot;Determining the Current Configuration&quot; on page 40.</td>
<td>A screen like Figure 4 is displayed. Continue with Step 6.</td>
</tr>
</tbody>
</table>

6. If exceptions are found, highlight the exception and click on Show Procedure for recommendations on how to fix the problem (see Figure 5 on page 40).
7. Print out the procedure, if desired.

8. Follow the procedure given to recover from the component failure.

9. After correcting any problems, reselect Recovery Guru/Health Check until all RAID controller units are Optimal.

10. Continue with the next section, "Determining the Current Configuration" on page 40.
Now that you have successfully installed the software, you need to use it to identify each RAID controller unit connected to your host system and determine the module’s current configuration (for example, number of drives, number of controllers, logical units).

This software has assigned a number for each RAID controller unit connected to your host system. These designations are shown in the RAID controller unit selection list near the top of each application’s screen (see Figure 6 on page 41).

Perform the following steps for each RAID controller unit to identify the module and determine its current configuration. If you need a definition of a Drive Group, RAID controller unit, or Logical Unit, refer to the “Common Definitions” section in the User’s Handbook or the Online Help glossary.

1. Use the following steps to view the current drive groups and logical units in a RAID controller unit.
   a. Select the Configuration Application.
The Module Selection screen appears. If you have more than one RAID controller unit connected to your host system, each RAID controller unit appears in the list.

b. Highlight the first RAID controller unit in the list, and select OK.

The main Configuration screen is displayed (see Figure 6 on page 41). Table 9 on page 41 describes the items in the display.

c. View the current drive groups and logical units.

As you highlight an element in the Module Information display on the left of the screen, the display on the right changes to show those elements. You cannot select or highlight any item in right side of the display (it is information only).

![This is the currently selected RAID controller unit.]

These buttons are active or grayed out depending on what RAID controller unit structure is currently highlighted in the directory tree.

This gives information on the drive groups and logical units in the RAID controller unit. The items displayed here depend on what is highlighted in the directory tree display to the left.

The display shown here is the master display, shown when the RAID controller unit itself is selected. See Table 9 for a description of the elements in the display.

![This shows the RAID controller unit as a directory tree structure. At the top is the RAID controller unit, then the controllers, then the drive groups owned by the controller, then the logical units and drives in that drive group. Clicking on the different structures changes the display on the right of the screen.]

Figure 6. Main Configuration Screen

<table>
<thead>
<tr>
<th>Column Heading</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group/Ctl</td>
<td>The controller (A or B) or drive group.</td>
</tr>
<tr>
<td>Drives</td>
<td>The number of drives in the drive group.</td>
</tr>
<tr>
<td>Total (MB)</td>
<td>The total capacity of the drive group, after accounting for RAID level.</td>
</tr>
</tbody>
</table>

Table 9: Configuration Display Columns
2. Use the following steps to physically locate and label a RAID controller unit.

   a. Click on the Locate Module button, select Module → Locate from the drop-down menus, or right-click on a module or group item in the Module tree (if in the Configuration Application).

   b. Click Start on the Locate Module screen. The activity lights flash on the drive canisters in this module. Remember that the RAID controller unit is the entire unit and not a particular set of drives.

   c. Physically locate the RAID controller unit with the flashing activity lights.

   d. Once you have identified the RAID controller unit, place a sticker label on it for future reference.

      The label should correspond to the name of the RAID controller unit (for example, <hostname>_001, <hostname>_002, etc.).

   e. Click Stop to stop the flashing of the activity lights.

---

**IMPORTANT**

It is very important that you save the profile of each RAID controller unit during initial installation and any time you change your configuration. You can use this information as a reference if you need to perform any recovery or maintenance tasks. See Step 3.

---

3. Use the following steps to save and print a RAID controller unit’s profile information.

**Table 9: Configuration Display Columns (continued)**

<table>
<thead>
<tr>
<th>Column Heading</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remaining (MB)</td>
<td>The total capacity remaining in the drive group.</td>
</tr>
<tr>
<td>LUN</td>
<td>The logical units (LUNs) in the drive group.</td>
</tr>
</tbody>
</table>
| Name/ID              | The name or ID of the controller, logical unit, or drive, depending on the display.  
      • Controller and logical unit names are assigned by the operating system and can’t be changed.  
      • Drive IDs are the channel number and SCSI ID of the drives. |
| RAID Level           | The RAID level of the logical unit.                                         |
| Capacity (MB)        | The capacity of the logical unit.                                           |
| Status               | The current status of the logical unit. If a status other than Optimal appears here, run Recovery Guru/Health Check to determine what the problem is, and, if necessary, what action to take. |
a. Select the desired RAID controller unit, then select File → Save Module Profile.
A screen shows the different types of information you can save.

b. Make sure All is selected (all of the buttons should be depressed), and select OK to save all of the types of information.
A screen display prompts you to enter a filename.

c. Enter an appropriate path and filename on the Selection line, and select OK.
The information is saved to the path and filename you specified.

d. Print the Module Profile information you saved in Step c using your host system's printer utility.

4. Use the following steps to view a RAID controller unit’s profile. (Optional)

a. Select the desired RAID controller unit → Module Profile.
A summary information screen appears (see Figure 7) showing information about the controllers, drives, and logical units in the RAID controller unit.

b. Select Controllers, Drives, or LUNs for more detailed information on these components.

c. Select OK to exit the profile information.

This display gives information on the selected module.

Figure 7. Main Module Profile Screen
5. Use the following steps to view details on specific drives in a drive group (optional):

   a. Highlight the drive group or individual drives you want to locate.
   
   b. Click on the List/Locate Drives button or select Options → List/Locate drives from the drop-down menus.
   
   c. Use the drive location information [x,y] provided in the list to physically locate individual drives in the module.

      [x,y] corresponds to a specific drive in the RAID controller unit, and indicates the channel number and SCSI ID for that drive, where the channel number is always listed first. You can also select Locate to flash the drives' activity lights in the RAID controller unit.
   
   d. Select OK to exit the drive information.

6. Repeat Steps 1 through 3 (and 4 - 5 if desired) for each RAID controller unit connected to your host system.

   You should have enough information to understand the configuration for each RAID controller unit.

7. Continue with the next section, "Determining if Changes are Needed" on page 44.

**Determining if Changes are Needed**

In the previous section ("Determining the Current Configuration" on page 40) you should have performed the following tasks for each RAID controller unit connected to your host system:

<table>
<thead>
<tr>
<th>Activity</th>
<th>Step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reviewed each module's current configuration (controllers, drives, and logical units/drive groups).</td>
<td>Step 1 on page 40.</td>
</tr>
<tr>
<td>Identified each RAID controller unit using Locate Module, and placed a sticker label on it.</td>
<td>Step 2 on page 42.</td>
</tr>
<tr>
<td>Saved the Module Profile information to a file using File → Save Module Profile, and printed the information.</td>
<td>Step 3 on page 42.</td>
</tr>
</tbody>
</table>

Now, you need to determine if you need to make any changes to the configuration to meet the requirements of your environment.

1. Use Table 10 and the Module Profile information you saved and printed to assist you in determining if any changes are necessary.
2. Continue with the next section, "Configuring RAID Controller Units" on page 47.

Table 10: Possible Parameters to Change

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Why Change?</th>
<th>For More Details,</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Parameters</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Controller Mode</td>
<td>Applicable controller modes are single active, active/passive, or active/active.</td>
<td>If you have an active/passive controller pair, you should consider changing it to active/active for best performance.</td>
<td>• Refer to the Maintenance/Tuning chapter in the User’s Handbook. \  \  • Use the online help for the Maintenance/Tuning Application.</td>
</tr>
<tr>
<td>Auto Parity Check/Repair</td>
<td>An automatic parity check/repair process runs each day or once a week at a specific time. Default is auto parity disabled.</td>
<td>If you want to enable the check/repair or change the time when it runs.</td>
<td></td>
</tr>
<tr>
<td>Hot Spare Drives</td>
<td>A hot spare drive is a drive that acts as a standby in case a drive fails in a RAID 1, 3, or 5 logical unit. The hot spare adds another level of redundancy to your RAID controller unit.</td>
<td>If you want to create new or additional hot spare drives for added protection.</td>
<td>• Refer to the Configuration chapter in the User’s Handbook. \  \  • Use the online help for the Configuration Application.</td>
</tr>
<tr>
<td>Polling Interval</td>
<td>The array monitor checks the RAID controller units periodically looking for events and failures. The default is to check every 5 minutes.</td>
<td>If you want to increase or decrease the frequency of the polling interval. If you have a lot of modules, you may need to increase this interval because the amount of time needed to check and return results can increase.</td>
<td>• Refer to the Status chapter in the User’s Handbook. \  \  • Use the online help for the Status Application.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
<td>Why Change?</td>
<td>For More Details,</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>RAID Level</td>
<td>Specifies how the data is striped across the drive and whether or not the drive group has redundancy.</td>
<td>If the current RAID Level is not appropriate for your environment, or you need to change the number of drives.</td>
<td>• Refer to the Configuration chapter in the <em>User’s Handbook</em>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Use the online help for the Configuration Application.</td>
</tr>
<tr>
<td>Segment Size</td>
<td>Specifies in 512-byte blocks how much data is written to one drive before data is written to another drive in the group.</td>
<td>If the segment size is not appropriate for your environment.</td>
<td></td>
</tr>
<tr>
<td>LUN Capacity</td>
<td>Specifies in megabytes (MB) how much capacity is available on the logical unit.</td>
<td>If you want to increase the capacity of the LUN (you will have to delete the LUN and recreate it).</td>
<td></td>
</tr>
<tr>
<td>Number of Drives in the Drive Group</td>
<td>The number of drives in the drive group. Adding drives increases the drive group’s capacity, but not the capacity of the LUNs in the drive group.</td>
<td>If you want to add drives to the drive group. <strong>NOTE</strong> You can not reduce the number of drives in the drive group, only add drives. To reduce the number of drives, you will have to delete the LUNs and recreate them.</td>
<td>• Refer to the Configuration chapter in the <em>User’s Handbook</em>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Use the online help for the Configuration Application.</td>
</tr>
</tbody>
</table>
Table 10: Possible Parameters to Change (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Why Change?</th>
<th>For More Details,</th>
</tr>
</thead>
</table>
| Caching Parameters            | Specifies the caching parameters for each logical unit.| If you want to enable or disable any of these parameters.                  | • If you are creating new logical units, refer to the Configuration chapter in the *User’s Handbook* or use the online help.  
  • To change caching parameters on existing logical units, refer to the Maintenance/Tuning chapter in the *User’s Handbook* or use the online help. |
| LUN Assignment and LUN Balancing | Determines what controller owns which logical units/drive groups. | To reassign or balance the logical units/drive groups between controllers in an active/active controller pair. | • If you are creating new logical units, refer to the Configuration chapter in the *User’s Handbook* or use the online help.  
  • To change LUN Assignments on existing logical units, refer to the Maintenance/Tuning chapter in the *User’s Handbook* or use the online help. |
| Reconstruction Rate           | Determines how quickly reconstruction occurs on a logical unit when a failed drive is replaced. | To increase or decrease the reconstruction performance.                     | • Refer to the Maintenance/Tuning chapter in the *User’s Handbook*.  
  • Use the online help for the Maintenance/Tuning Application. |

Configuring RAID Controller Units

Perform the following procedures to change the logical unit/drive group configuration of your RAID controller units.
**Configuring Logical Units on Your RAID Controller Units**

Use the Configuration Application of the storage management software to view the current logical unit configuration and to make any necessary changes.

**NOTE** Refer to the SYMPLICITY Storage Manager User’s Handbook for detailed information on using the Configuration application. Also, you can make configuration changes after completing the installation process. You don’t have to make all your changes now.

1. Select Start → Programs → SYMPLICITY Storage Manager → Configuration.

   The main Configuration screen is displayed.

2. Set up the logical units with the desired drives, RAID Levels and parameters.

3. If you add, change, or delete logical units, you will need to restart your system.

4. Continue with the next section, "Partitioning Logical Units and Assign Drive Letters."

**Partitioning Logical Units and Assign Drive Letters**

1. Use the Windows NT Disk Administrator to partition the logical units and assign drive letters. Refer to your Windows NT online help for further details.

   **NOTE** If you are installing the software in a cluster server environment, remember that node B will need to see the same logical unit-drive letter assignment as you are setting up now for node A.

2. Continue with the next section, "What’s Next?" on page 49.
What’s Next?

Now that you have successfully completed the installation of the software, do one of the following:

• If you are installing the software in a Cluster Server environment, return to "Shutting Down Node A" on page 25 and continue with the installation procedure.

• Go to "Chapter 5. Customizing the Installation" if you want to set up SNMP notification or make other changes to support the software.

• Refer to the User’s Handbook for detailed information on how to use each application. Note that "Chapter 6. Operating System Support" in this book gives information specific to the NT operating system.

• Go to "Chapter 7. Troubleshooting" for troubleshooting tips on common problems you may encounter as you use this software with the Windows NT operating environment.
Chapter 5. Customizing the Installation

This chapter describes how to customize your software installation.

Controller Limits

**NOTE** In order to change the number of available controllers, you must edit the \program files\symsm\rmparams file. Read this section and the "Disabling the Module Selection Screen" and "Setting Up SNMP Notification" sections before modifying the rmparams file so that you can make all your rmparams changes at the same time.

At installation, the storage management software is limited to 16 RAID controllers. This limit is determined by the System_MaxControllers parameter setting in the rmparams file. If your system has more than 16 RAID controllers, change the parameter in the rmparams file to reflect the actual value (see "Changing the rmparams File" on page 54).

Disabling the Module Selection Screen

**NOTE** In order to disable the Module Selection screen, you must edit the \program files\symsm\rmparams file. Read this section and the "Controller Limits" and "Setting Up SNMP Notification" sections before modifying the rmparams file so that you can make all your rmparams changes at the same time.

By default, the Module Selection screen is displayed every time you start a storage management application. Refer to the “Selecting A Module” section in the *User’s Guide* for information on this screen.

If you want to disable this screen, you must change the System_DefaultModuleSelect parameter in the rmparams file (see “Changing the rmparams File” on page 54).

Setting Up SNMP Notification

The following sections describe the SNMP notification setup process.
NOTE  In order to enable or disable the SNMP notification option, you must edit the `\program files\symsm\rmparams` file. Read this section and the "Controller Limits" and "Disabling the Module Selection Screen" sections before modifying the `rmparams` file so that you can make all your `rmparams` changes at the same time.

---

**Enabling SNMP Notification**

This software can provide remote notification of RAID events to a designated Network Management Station (NMS) using Simple Network Management Protocol (SNMP) traps.

Use the following procedure to set up the NMS, to enable or disable this notification option for each host, and to understand the contents of an SNMP trap message.

1. **Set up the NMS.** You only need to set up your designated NMS *once*. Use the following procedure to compile this software’s Management Information Base (MIB) into your NMS.

   a. Copy the `\program files\symsm\rm6traps.mib` file to the network management station.

   b. Follow the steps required by your specific network management station to compile the MIB.

   **NOTE**  The MIB was written to standard version 1 SNMP syntax. It was designed specifically for the storage management software. It is *not* applicable to other companies’ RAID products.

2. **Make sure the host system is connected to the network with the NMS station.**

3. **Enable this notification on your host.** You must edit three parameters in the `\program files\symsm\rmparams` file so that the software will know where to direct the SNMP trap messages when a RAID Event occurs. Go to "Changing the rmparams File" on page 54.

**Contents of an SNMP Trap Message**

Refer to Table 11 on page 53 for a description of the contents of an SNMP trap message.
If the trap type is anything other than informational, you should use the Status or Recovery Applications to get more information or specific instructions on how to remedy the problem. Do not remove the SNMP message until the problem has been corrected since most trap notifications associated with this software are not persistent.

### Table 11: Contents of an SNMP Trap Message

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host IP Address</td>
<td>The standard IP address dot notation for the host where the RAID controller unit is attached.</td>
</tr>
<tr>
<td>Host Name</td>
<td>The text name assigned to the host.</td>
</tr>
<tr>
<td>Trap Type</td>
<td>There are four trap types:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Informational</strong> — No failure has occurred. Information is provided that an event, such as a logical unit creation, has occurred.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Degraded Array</strong> — A subsystem component failure has occurred. The module is still operational but now lacks redundancy in some area. (For example, a drive failure resulting in a degraded logical unit, a power supply failure, or a failure of one controller in a controller pair.)</td>
</tr>
<tr>
<td></td>
<td>- <strong>Failed Array</strong> — A failure has occurred that leaves a module or logical unit unable to communicate. (For example, a failure of the controller in a single-controller RAID controller unit or a multiple drive failure resulting in a dead logical unit.)</td>
</tr>
<tr>
<td></td>
<td>- <strong>Critical</strong> — This is a small category of failures that may require timely intervention to correct. (For example, the two-minute warning from an uninterruptible power supply or a warning that write-back cache has been disabled due to a low battery.)</td>
</tr>
<tr>
<td>Affected RAID Controller Unit</td>
<td>Indicates which RAID controller unit had the event (for example, sonne_001).</td>
</tr>
<tr>
<td>Condition Description</td>
<td>A brief description of the event.</td>
</tr>
</tbody>
</table>

### Disabling SNMP

Perform the following steps to disable this notification on your host and stop this software from sending SNMP traps:

1. In the `\program files\symsm\rmparams` file, change the value of the `SNMP_Action_Number` line to 0 (see "Changing the rmparams File" on page 54).
2. Save the rmparams file and copy it to the backup directory. It is critical that you have a backup copy of this file.

Changing the rmparams File

The \program files\symsm\rmparams file is used to store several configurable options available through this software. Table 12 on page 55 shows a list of the parameters in the file that you may need to change during initial installation.

---

**IMPORTANT** Before you edit the rmparams file, make sure you read "Controller Limits" on page 51, "Disabling the Module Selection Screen" on page 51, and "Setting Up SNMP Notification" on page 51. Decide which of these parameters you want to change and make all the changes at the same time.

If you installed an upgrade of the storage management software, you may want to refer to the rmparams.ori file to determine if you want to make additional customized changes to the new file. Remember, the new file contains new parameters for this version, so do not replace it with the old file.

Most of the options in the rmparams file (other than the ones shown in Table 12 on page 55) should not be changed except through the graphical user interface (GUI).

For more information about the rmparams file, read the text file about rmparams. From the installation directory, type:

`help rmparams`

Because of the critical nature of the rmparams file, you should make a backup copy of the file in a directory other than the installation directory before you modify the current file. If this file becomes corrupted or missing, you should copy the backup rmparams file to the installation directory to resume normal operation. Furthermore, if you make any changes to this file directly or use the options in the GUI that write to this file (such as log settings), always copy the new version of the file to the backup directory once you are sure the changes work.

---

1. *Before* making any changes to the rmparams file for the first time, save the original file and copy it to the backup directory.

2. Make any necessary changes to the rmparams file using Table 12 on page 55.

3. Save the rmparams file, and copy it to the backup directory.
Table 12: Changeable Parameters in the `rmparams` File

<table>
<thead>
<tr>
<th>Description</th>
<th>When To Change</th>
<th>How To Change</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SNMP_Target_IP_Address=xxx.xx.xx.xx</strong></td>
<td>If you want to enable SNMP.</td>
<td>Change this value to the dotted notation IP address of the network management system where the MIB has been compiled. On most systems, this IP address can also be a dotted notation multicast address or broadcast address.</td>
</tr>
<tr>
<td>Provides the SNMP IP Address for remote notification.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>SNMP_Community_Name=NONE</strong></td>
<td>If you want to enable SNMP.</td>
<td>Add the community name. The most commonly used community name is public; however, your network environment may require another name.</td>
</tr>
<tr>
<td>Provides the community name to be used for SNMP remote notification.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>SNMP_Action_Number=0</strong></td>
<td>If you want to enable SNMP.</td>
<td>Change this value to either 1 or 2. 1 will send SNMP traps to the designated NMS station. 2 means that all the relevant data is written to the file <code>trap.dat</code>. <strong>IMPORTANT</strong> Setting this parameter to 0 will completely disable the SNMP option.</td>
</tr>
<tr>
<td>Indicates the SNMP trap notification option you want to use.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>System_DefaultModuleSelect=TRUE</strong></td>
<td>If you want to disable the Module Selection screen (see &quot;Disabling the Module Selection Screen&quot; on page 51).</td>
<td>Change TRUE to FALSE.</td>
</tr>
<tr>
<td>Determines whether or not the Module Selection screen is displayed each time you open an application.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>System_MaxControllers=16</strong></td>
<td>If you have more than 16 RAID Controllers (see &quot;Controller Limits&quot; on page 51).</td>
<td>Change the 16 to the appropriate number.</td>
</tr>
</tbody>
</table>
Setting Up Scriptable Notification Options

The rmscript.bat file is accessed by the status monitor and automatic parity check whenever these utilities find an exception. By default, no action is taken. You can edit this file to specify a set of actions to take when an error is found.

For example, if you want to install third-party notification software to perform various events (such as, faxing or paging), you would add the appropriate script for each event near the end of this file (making sure the del %1 remains the last line in the file). Consult the third-party’s software documentation for specific details.

NOTE If you installed an upgrade of the storage management software, you may want to refer to the rmscript.ori file to determine if you want to make additional customized changes to the new file. Remember, the new file contains new script for this version, so you must not replace it with the old file.

For more information, read the text file about rmscript.bat. From this software’s installation directory, type:

```
help rmscript
```
Chapter 6. Operating System Support

This section contains information related to operating this software with the Windows NT operating environment. See "Understanding the Restrictions" on page 2 for other important notes about using this software in an NT environment.

Number of LUNs

There are two limits on the number of logical units you can have.

- Windows NT limits the maximum number of logical units (LUNs) per RAID controller unit to eight (8) (whether the module has a single controller or redundant controllers). Therefore, if you have a RAID controller unit with two active controllers, the total number of LUNs between them cannot be more than eight.

- Your host adapter has a maximum number of LUNs it can support. Consult your host adapter documentation for more information.

Module Names

By default, module names are assigned in the order in which the system detects the module. The default name displayed is derived from the name of the host machine where the storage management software is installed. For example, you see <hostname>_001, <hostname>_002, and so on.

The controllers and logical units in the module have unique device names. See the next section, "Controller/LUN Names" on page 57 for more information.

Controller/LUN Names

The storage management software uses device names in the form Drive#, where # is a device number, to identify controllers and logical units (LUNs). These device names appear in various screen displays, usually related to a controller’s identification.

**NOTE** These names do not match the disk# used in the Disk Administrator utility which represent configured logical units and corresponding filesystems.
The device numbers are assigned on a controller basis, eight to a controller, representing the maximum number of LUNs allowed on a RAID controller unit in Windows NT. The device numbers assigned to a controller depend (in descending order) on the port, path, and ID of the controller.

**Example**

Assume RAID controller unit 1 has only one controller. RAID controller unit 2 has two active controllers on different ports. Device numbers are assigned to these controllers in groups of eight in the order they are detected on the system:

- RAID controller unit 1, controller A (port 0, path 1, HOST ID 5) uses device names Drive8 through Drive15. The controller is Drive8.

- RAID controller unit 2, controller A (port 0, path 1, HOST ID 3) uses device names Drive0 through Drive7. The controller is Drive0.

- RAID controller unit 2, controller B (port 1, path 0, HOST ID 2) uses device names Drive16 through Drive23. The controller is Drive16.

Within the numbers assigned to a controller, the controller itself always uses the lowest assigned number. The lowest numbered logical unit also uses this number. After that, logical units are assigned device names sequentially, even if the logical unit doesn’t exist. For example, if a controller is assigned device names Drive8 through Drive15, and contains logical units 0, 3, 4, and 6, the following device names are used:

<table>
<thead>
<tr>
<th>Module Element</th>
<th>Device Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller</td>
<td>Drive8</td>
</tr>
<tr>
<td>LUN 0</td>
<td>Drive8</td>
</tr>
<tr>
<td>LUN 3</td>
<td>Drive11</td>
</tr>
<tr>
<td>LUN 4</td>
<td>Drive12</td>
</tr>
<tr>
<td>LUN 6</td>
<td>Drive14</td>
</tr>
</tbody>
</table>

Note that in a redundant controller configuration, a maximum of 8 LUNs can exist between the two controllers, even though 16 numbers are available.
Redundant Controller Support

The storage management software supports redundant controllers on a Windows NT system using the Redundant Disk Array Controller (RDAC) driver. The RDAC driver is part of the storage management software package and is installed automatically.

For RAID controller units with redundant controllers, this host-based driver manages the I/O data paths. If a component fails on the data path (cable, controller, host adapter, and so on) and the host loses communication with a controller, the RDAC driver automatically reroutes all I/O operations to the other controller.

*Figure 8 on page 59* illustrates how RDAC provides this redundancy when the host application generates a request for I/O to Controller A, but Controller A fails. Use the information at the bottom of the figure to follow the I/O data path.

For more information on how to use the redundant controller feature, refer to the *User’s Handbook*.

![Diagram showing RDAC I/O Data Path Redundancy](image-url)

**Figure 8.** Example of RDAC I/O Data Path Redundancy
Creating Logical Units

After creating logical units (LUNs) using the Configuration Application, you have to add them to the operating system. See your Windows NT documentation for details on adding a drive. Remember each logical unit (not a drive group) is seen by the operating system as one drive.

**NOTE** Windows NT will not recognize any configuration changes (such as, creations/deletions) until you restart it. Therefore, after creating LUNs with this software, restart the operating system.

Deleting Logical Units

**CAUTION** If you are using the RAID controller unit as a boot device, do not delete LUN 0 or use File → Reset Configuration or you will lose your boot device.

*Before* deleting LUNs with this software or using File → Reset Configuration, stop I/Os to the affected RAID controller unit. Then use the Disk Administrator utility to delete any partitions and to deassign drive letters associated with those LUNs. If you do not use this utility first, registry information will be corrupted.

**NOTE** Windows NT will not recognize any configuration changes (such as, creations or deletions) until you restart it. Therefore, after deleting LUNs with this software, restart the operating system.

Accessing Raw Partitions

Many database applications address raw partitions for their data. In the Disk Administrator utility, the partition information is shown as “unknown.” The order of these partitions could be rearranged whenever a dead LUN is present and the system is booted without restoring the LUN (which to Windows NT is the same as removing a physical drive and booting), possibly causing data corruption.

Data corruption occurs because the raw partition's namespace in the registry that the application is addressing has now been changed or moved. The application, however, will continue to write to that partition or device as though it were the correct one. The workaround for this is to be sure that all LUNs are Optimal and fully reconstructed before running any utilities that re-address the raw partition namespaces (rearrange their ordering in Disk Administrator.)
Creating and Deleting LUNs in a Cluster Server Environment

When you create logical units on one node in a cluster server environment, you also must assign the same drive letter on the other node.

Whenever you create or delete logical units, you must restart both nodes in the cluster server. Before you restart a node, you must move all cluster resources from the node you are going to restart to the other node. Use the Cluster Administrator to move resources between nodes.

**IMPORTANT** Never restart or perform a managed shutdown on a cluster server node if it currently owns cluster resources.

For example, after you create a new logical unit on node A, you must perform the following steps:

1. Move all cluster resources from node A to node B.
2. Restart node A.
3. Assign a drive letter to the new LUN on node A.
4. Move all cluster resources from node B to node A.
5. Restart node B.
6. Assign the same drive letter to the new LUN on node B.
7. Move any cluster resources belonging to node B from node A back to node B.

**Notes:**

a. You can use this same procedure if you delete a logical unit from node A, but you must skip steps 3 and 6.

b. If the Disk Administrator shows any abnormal information (for example, disks offline, missing drive letters, partitions not shown, etc.), try restarting the Windows NT system. If restarting the system does not help, run Recovery Guru to diagnose the problem and obtain troubleshooting information.

**Background Monitor**

The storage management software has a background monitor that automatically polls all RAID controller units and checks for problems or events at a specified interval. If any problems or events are detected, the information is written to the default log file. This becomes an historical record of past component failures, general status changes, and configuration changes.
The polling interval can be changed from the default of every five minutes. For best results, use the default value or smaller to ensure that you are notified about problems or events as close as possible to when they occur.

**CAUTION** Setting this value too small (with Status → Options → Log Settings) could cause the check to affect system I/O performance. However, setting this value too large could cause delay notification of serious problems.

### Stopping the Disk Array Monitor Service

**CAUTION** You should *only* stop this monitoring service if you are specifically instructed to do so by Recovery Guru, the troubleshooting documentation, or your Customer Services Representative. However, doing so means that *none* of the RAID controller units connected to the host will be checked during this time. Be sure to restart the monitor when instructed.

2. Highlight the Disk Array Monitor Service
3. Select Stop. When the status changes to Stopped, close the Services Application.

### Starting the Disk Array Monitor Service

This background monitor automatically starts when you run the storage management software. However, it will be necessary to manually start this process if you have stopped it for some reason.

2. Highlight the Disk Array Monitor Service.
3. Select Start. When the status changes to Started, close the Services Application.

When you have manually stopped the background monitor, you have not been monitoring for some period of time. We recommend that you run Recovery Guru/Heath Check to make sure that no problems have occurred while you had the disk array monitor stopped.

### Command Line Utilities

Although you can perform most necessary storage management tasks through the storage management software, there are command line utilities which allow you to perform these tasks through the DOS command line. For a list of these files and a description, see the “Command Line Interface” chapter in the *User’s Handbook.*
To access the help files for these utilities, type (from the installation directory) help <filename> from the command line. For example, to read the file on the drivutil program, from the installation directory, type:

```
help drivutil
```

## Adding New RAID Controller Units to Your Configuration

If you need to add new RAID controller units to your system after installing the storage management software, use the following procedure to be sure this software recognizes the new module and that its configuration meets your needs.

1. Physically connect the RAID controller unit to your system. Consult the appropriate hardware documentation for this procedure.

2. Close all open applications and restart Windows NT.

3. Go to "Chapter 4. Initial Startup Procedures" to perform the following steps:
   - "Verifying and Upgrading Controller Firmware" on page 31.
   - "Running Recovery Guru/Health Check" on page 37.
   - "Determining the Current Configuration" on page 40.
   - "Determining if Changes are Needed" on page 44.
   - "Configuring RAID Controller Units" on page 47.

## Using the putntlog Utility

The putntlog command line utility included in the storage management software lets you write RAID events to the Windows NT Event Log. Use the following procedure to enable putntlog:

1. Open the `rmscript.bat` file using a text editor.

2. Scroll down through the file until you find the following line:
   ```
   rem putntlog %1
   ```

3. Delete the rem comment line.

4. Save and close the file.
Uninstalling the Storage Management Software

If you are upgrading the storage management software, you do not need to use this procedure first. The previous version’s files are removed or overwritten as needed.

Use the following procedure only if you want to remove the storage management software from your system.

**IMPORTANT** This procedure requires that you shutdown and restart the operating system. Therefore, close all other applications and make sure that other users are not on the system when uninstalling this software.

1. If you do not intend to reinstall this software and are not removing your RAID controller unit from the system, you may need to download your original NVSRAM file to restore your controllers’ configuration.
   a. Obtain a copy of the correct NVSRAM values from your Customer Services Representative (it will be part of the controller firmware’s release media).
   b. Download the new NVSRAM values to the controllers in your RAID controller units using the fwutil command line utility.
   c. If you set NVSRAM parameters during installation with the reseton.def or networkoff.def files (see "Setting NVSRAM Values" on page 36), you may want to run restoff.def or networkon.def to restore these settings to their original values.

**CAUTION** Do not restart the storage management software again after performing Step 1, or the software will reset the NVSRAM values it needs to operate.

2. Select Start \rightarrow Settings \rightarrow Control Panel \rightarrow Add/Remove Programs, and scroll the list to find SYMplicity Storage Manager.

3. With SYMplicity Storage Manager highlighted, select Add/Remove.

4. At the “Uninstall software” screen, select OK.
   You will see screens indicating that this program is removing the appropriate service, registry information, and files.

5. At the “Uninstall Complete” screen, select YES to shutdown and restart the Windows NT system.
Chapter 7. Troubleshooting

This chapter describes the restrictions that apply when using this software and gives information to help you solve problems that may occur. The last section gives important information you may need when replacing failed controllers.

Troubleshooting Tables

The troubleshooting tables that follow provide probable cause and action to take for specific problems you might have as you use the storage management software with the Windows NT operating system.

**IMPORTANT** If you cannot find the problem you are looking for, consult the Online Help for additional troubleshooting information. Also, see "Understanding the Restrictions" on page 2 for additional information.

Locating Solutions

To quickly find the problem-solution you are looking for, use the following tables to locate the problem you are having. It is possible for an entry to appear in more than one table:

- **Category** — organizes problems into general use or specific option groups (page 66).
- **Component** — organizes problems by hardware components, such as controllers, drives, modules, and so on (page 66).
- **Application** — organizes problems for each storage management application, including a group for options common to all applications (page 68).
- **Software** — organizes problems by operating system, storage management software, or command line utility (page 69).
Category

Groups problems into sections for general use or specific options.

Table 13: Troubleshooting Entries by Category

<table>
<thead>
<tr>
<th>Category</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Configuration Application&quot;</td>
<td>70</td>
</tr>
<tr>
<td>&quot;Firmware Upgrade&quot;</td>
<td>72</td>
</tr>
<tr>
<td>&quot;General&quot;</td>
<td>73</td>
</tr>
<tr>
<td>&quot;Recovery Guru/Health Check&quot;</td>
<td>77</td>
</tr>
</tbody>
</table>

Component Search

Organizes individual problems by hardware components, such as controllers, drives, LUNs, RAID controller units, and so on.

Table 14: Troubleshooting Entries Organized by Component

<table>
<thead>
<tr>
<th>Component</th>
<th>Problem</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controllers</td>
<td>Failed during alternate replacement</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td>Firmware upgrade failed</td>
<td>72</td>
</tr>
<tr>
<td></td>
<td>LUN creation error after deleting all LUNs or using Reset configuration</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>Not visible to storage management software</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td>Not visible through switch</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td>Not visible to either operating system or storage management software</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Passive, no LUNs owned after replacement</td>
<td>80</td>
</tr>
<tr>
<td>Fans</td>
<td>Failure detected after replacement</td>
<td>78</td>
</tr>
<tr>
<td>Drives (continued on next page)</td>
<td>Activity lights don’t flash (Configuration → List/ Locate Drives)</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>All drives failed in a drive group</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Failed status, but LUN is Optimal</td>
<td>79</td>
</tr>
<tr>
<td>Component</td>
<td>Problem</td>
<td>See Page</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Drives</td>
<td>Fault light comes on after replacing failed drive</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Fault lights lit (drives continue to fail)</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Missing information in Manual Recovery $\rightarrow$ Drives screen</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Number of drives incomplete or wrong during LUN creation</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Removed drive; no failure reported</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Status other than Optimal</td>
<td>79</td>
</tr>
<tr>
<td>LUNs</td>
<td>Error message during LUN creation after deleting all LUNs or using Reset Configuration</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>Less capacity shows than selected during configuration</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Missing information in Manual Recovery $\rightarrow$ LUNs screen</td>
<td>81</td>
</tr>
<tr>
<td></td>
<td>Not visible to storage management software</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td>Number of drives incomplete or wrong during LUN creation</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Optimal LUN status with failed drives</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Reconstructing status appears, but no drives replaced</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Status other than Optimal</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Status remains Reconstructing</td>
<td>80</td>
</tr>
<tr>
<td>RAID controller units</td>
<td>Failure detected after replacing fan or power supply</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Listed after being removed</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Not visible to either operating system or storage management software</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Status other than Optimal</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Status doesn’t update after a recovery procedure</td>
<td>81</td>
</tr>
<tr>
<td>Power Supplies</td>
<td>Failure detected after replacement</td>
<td>78</td>
</tr>
</tbody>
</table>
**Application Search**

Organizes individual problems for each storage management application, including a group for options common to all applications.

**Table 15: Troubleshooting Entries Organized by Application**

<table>
<thead>
<tr>
<th>Application</th>
<th>Problem</th>
<th>See Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common To Any Application</td>
<td>Cannot select some options</td>
<td>76</td>
</tr>
<tr>
<td></td>
<td>“Cannot secure access to LUNs” message</td>
<td>76</td>
</tr>
<tr>
<td></td>
<td>Select Module lists a RAID controller unit removed from the system</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Status doesn’t update after a recovery procedure</td>
<td>81</td>
</tr>
<tr>
<td>Configuration</td>
<td>Less capacity shows than selected during configuration</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>List/Locate Drives doesn’t work</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>LUN creation error after deleting all LUNs or using Reset Configuration</td>
<td>71</td>
</tr>
<tr>
<td></td>
<td>Number of drives incomplete or wrong during LUN creation</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Reset Configuration doesn’t work</td>
<td>71</td>
</tr>
<tr>
<td>Status</td>
<td>Reconstructing status appears, but no drives replaced</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Status remains Reconstructing</td>
<td>80</td>
</tr>
<tr>
<td>Recovery (continued on next page)</td>
<td>All drives failed in a drive group</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Controller mode is Passive, no LUNs owned after replacement</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Drive fault lights lit (drives continue to fail)</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Drive status other than Optimal</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Failed status, but LUN is Optimal</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Fault light comes on after replacing failed drive</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Failure detected after replacing fan or power supply</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>LUN status other than Optimal</td>
<td>79</td>
</tr>
<tr>
<td>Application</td>
<td>Problem</td>
<td>See Page</td>
</tr>
<tr>
<td>-------------</td>
<td>---------</td>
<td>----------</td>
</tr>
<tr>
<td>Recovery (continued from previous page)</td>
<td>Missing information in Manual Recovery → Drives screen</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Missing information in Manual Recovery → Logical Units screen</td>
<td>81</td>
</tr>
<tr>
<td></td>
<td>Reconstructing status appears, but no drives replaced</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Recovery Guru takes a long time</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Removed drive; but Recovery Guru doesn’t report a failure</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Status doesn’t update after a recovery procedure</td>
<td>81</td>
</tr>
<tr>
<td></td>
<td>Status other than Optimal</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Status remains Reconstructing</td>
<td>80</td>
</tr>
<tr>
<td>Maintenance/Tuning</td>
<td>Controller mode is Passive, no LUNs owned after replacement</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Firmware upgrade failed</td>
<td>72</td>
</tr>
</tbody>
</table>

**Software Search**

Organizes individual problems by operating system, storage management software, and command line utility.
Table 16: Troubleshooting Entries Organized by Software

<table>
<thead>
<tr>
<th>Software</th>
<th>Problem</th>
<th>See Details On</th>
</tr>
</thead>
<tbody>
<tr>
<td>Storage Management</td>
<td>“Cannot secure access to LUNs” message</td>
<td>76</td>
</tr>
<tr>
<td></td>
<td>Can’t select some options</td>
<td>76</td>
</tr>
<tr>
<td></td>
<td>Can’t start the software</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td>Controllers/LUNs not visible</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td>Controllers/RAID controller units not visible</td>
<td>75</td>
</tr>
<tr>
<td></td>
<td>Failure detected after replacing fan or power supply</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>“Not all files removed” message when uninstalling the software</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td>RAID controller unit listed after being removed</td>
<td>75</td>
</tr>
<tr>
<td>Windows NT</td>
<td>Controllers/RAID controller units not visible</td>
<td>75</td>
</tr>
<tr>
<td>Command Line</td>
<td>Batch file commands fail</td>
<td>73</td>
</tr>
</tbody>
</table>

Configuration Application

Includes problems you may have as you use options in the Configuration Application.

Table 17: Configuration Changes Troubleshooting

Number of Drives field (in the main Create LUN screen) show less than the number of drives in the unassigned drive group.

**CAUSE**  There are two main reasons this number could be different than expected:

- This list shows only the maximum number allowed, which is a maximum of 30 drives in a drive group.
- There could be failed or unresponsive drives in the unassigned drive group. Failed drives are not available for configuration; therefore, they are not displayed in this list.

**Less capacity shows than I selected during configuration.**

When using 5+ drives to create a LUN, you could see a capacity slightly less than you selected during configuration; for example, you see 1.97 GB instead of 2 GB on a RAID 5, 9-drive LUN. This can occur because the capacity you select is based on stripe size which depends on segment size times the number of drives.
Table 17: Configuration Changes Troubleshooting (continued)

<table>
<thead>
<tr>
<th>List/Locate Drives</th>
<th>Locate does not work.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ACTION</strong></td>
<td>It is not possible to flash the drive activity lights for a particular drive group if any of the drives has a status other than Optimal. For an explanation of possible drive statuses and recommended action to take, see the Online help.</td>
</tr>
<tr>
<td><strong>CAUSE</strong></td>
<td>Use Module Profile to verify that all drives are Optimal and try again. If any of the drives are not Optimal, select Recovery Guru\Health Check (in the Recovery Application) to correct the problem.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Reset Configuration does not work.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CAUSE</strong></td>
</tr>
<tr>
<td><strong>ACTION</strong></td>
</tr>
<tr>
<td><strong>CAUTION</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>LUN Creation error message is displayed after deleting all LUNs or using File \ Reset Configuration.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CAUSE</strong></td>
</tr>
<tr>
<td><strong>ACTION</strong></td>
</tr>
</tbody>
</table>
Firmware Upgrade

Problems you may have in upgrading firmware.

**Table 18: Controller Firmware Upgrade Troubleshooting**

<table>
<thead>
<tr>
<th>Firmware upgrade does not complete successfully</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CAUSE</strong> This should <em>not</em> happen unless you try to perform some other activity on the module while upgrading controller firmware. If you are upgrading firmware to a redundant controller pair, the progress bar reaches 50% very quickly after downloading a file to the first controller. However, it may take another couple of minutes to reach 100% if it is downloading to a second controller in the module. Do <em>not</em> assume the controller has hung unless the firmware upgrade has not completed after ten minutes or so.</td>
</tr>
<tr>
<td><strong>ACTION</strong></td>
</tr>
<tr>
<td>• To avoid this problem, <em>wait</em> for the controller firmware upgrade to be completed before selecting any other option or exiting Maintenance/Tuning.</td>
</tr>
<tr>
<td>• If it occurs, turn off power to the RAID controller unit and turn it back on; then, immediately try to upgrade the firmware again.</td>
</tr>
<tr>
<td><strong>IMPORTANT</strong> If you are not upgrading the firmware again immediately, check the firmware version of the module’s controllers using Module Profile. The controller firmware could be in an unusable state if some files completed the download process before the controller hung. In this case, your module will not perform properly until the firmware is upgraded.</td>
</tr>
</tbody>
</table>
General

General problems you could have in all applications.

Table 19: Troubleshooting Generally Applicable to All Applications

<table>
<thead>
<tr>
<th>Cannot start the software.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CAUSE</strong></td>
</tr>
<tr>
<td><strong>ACTION</strong></td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td><strong>IMPORTANT</strong></td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
</tbody>
</table>

Controller failed while bringing its alternate Online.

| CAUSE | You have a RAID controller unit with two controllers, one is Offline and the other is Online (Optimal). When you bring the offline controller online, you could see the alternate controller Fail or go Offline. |
| **ACTION** | Bring the newly failed controller Online using the same procedure. |

While uninstalling this software, “not all files were removed” message is displayed.

| CAUSE | If you see this message after performing the uninstall procedure (page 64), the auto parity check/repair service was probably running. The software has been successfully uninstalled; however, there may be some files that were not removed from the installation directory. |
| **ACTION** | Delete any remaining files from the installation directory, then delete the directory. |

Commands run in a batch file fail unexpectedly.

| CAUSE | Utility commands such as fwutil or rdacutil -u that require a controller reboot may return before the controller is ready to accept commands. If the next command is executed before the controller is ready to accept commands, the controller will return an error status. |
| **ACTION** | Include a delay command in the batch file to allow enough time for the controller to finish its action. |
Some controllers/logical units are not visible to storage management software, but are visible to the host

**CAUSE**  It is possible that controllers or logical units might *not* be visible to the storage management software, but will remain visible to Windows NT. Any time an operation is being performed that requires exclusive access to the logical units (LUNs), these LUNs may not appear on the screen *except* in the application where the operation was initiated. The software uses a file (`%program files%\symsm\lunlocks`) to hide these LUNs from the other applications, so that no other operations can be performed on them until the current operation is complete.

**IMPORTANT**  For example, if you started a format in the Recovery Application, these LUNs show a “Formatting” status in Recovery, but may not appear in any other application. Operations that require exclusive access include Delete for LUNs and Reset Configuration (Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and Firmware Upgrade → Offline method (Maintenance/Tuning).

Should the utility/application holding the LUN lock come to an abnormal termination, these LUNs may remain hidden from the other applications.

**ACTION**

1. Wait for the operation to be completed, or perform operations on a different RAID controller unit.
2. If you still do *not* see controllers or LUNs that you know exist, do the following:
   a. Close all your applications and exit the storage management software completely.
   b. Run the clean.bat script to delete certain files that could be hiding information from this software.
3. Restart the application where you had the problem and verify that the controller/LUNs are now visible.

The host cannot see the controller connected through a switch

**CAUSE**  When the controller attempts to log in by issuing a FLOGI, it receives no response or the response is lost. After a system restart, the switch does not provide information about the device, and the controller does not issue a new FLOGI.

**ACTION**  To work around the problem:

1. Disconnect the cable that connects the controller to the switch.
2. Reconnect the cable so the settings can take effect.

**NOTE**  Disconnecting and reconnecting the cable causes the controller to issue a new FLOGI. The switch will respond to the controller, and the controller will show the hosts as being logged in.
Some controllers/RAID controller units are not visible at all

**CAUSE** If controllers or RAID controller units are not displayed and you know they exist, there could be some faulty connection between the RAID controller unit and the host adapter/network card. It also possible that the storage management software or your operating system doesn’t recognize the devices yet. Less likely, the NVSRAM settings for the module’s controllers may not be set properly to run this software. Normally, these settings are changed automatically during installation and any incorrect settings are detected and corrected by the software.

**ACTION**

1. Verify there is no problem on the data path:
   - Check the interface cables and Host-side IDs of the controllers. If they appear OK, turn off power to the module, and turn it back on.
   - Check the I/O connection cables for bent pins in the connectors, for connectors that are not on straight, or for cables that are kinked or crimped. Select Recovery Guru/Health Check and follow the recovery procedures for any component problem detected.

2. If you have replaced or added controllers/RAID controller units after installing this software, be sure to follow the procedures for your operating system to recognize the new devices (see your operating system documentation).

3. If you see a message (on the console) that incorrect NVSRAM settings have been fixed, immediately restart the RAID controller unit so the new settings can take effect. If you suspect that the NVSRAM settings for the module’s controllers may not be set properly to run this software, use RAID Manager For DOS™ to verify your NVSRAM settings or call your Customer Services Representative.

A RAID controller unit is listed that I have removed from my system.

**CAUSE** The storage management software does *not* automatically remove modules from configuration; thus, a module you remove will continue to be listed in the RAID controller unit Selection box and the Module Selection screen.

**ACTION** If you wish to remove a RAID controller unit, do the following:

1. Physically remove the module from your host system.
2. Choose Select Module.
3. Highlight the module you wish to remove.
4. Select Remove. The RAID controller unit no longer appears in the Module Selection screen or the RAID controller unit Selection Box.

Table 19: Troubleshooting Generally Applicable to All Applications (continued)
I cannot select some options.

**CAUSE** Some options are grayed out or are unavailable because:

- The selected RAID controller unit does not support that option.
- The option cannot be performed for the item you selected.
- The option is not active until you select some item.
- The option is no longer applicable because a maximum has been reached.

**ACTION** Recheck your selection and try again.

For more specific information, refer to the Procedures section in the *User’s Handbook* that describes the particular option, or consult Online Help, “Why Are Some Options Grayed Out?”

“Cannot secure access to the LUNs” message is displayed (operations won’t run for a selected RAID controller unit).

**CAUSE** Most likely a second application has requested exclusive access to the selected RAID controller unit when some other application has already secured access. Many operations require exclusive access to the affected drive group/LUNs until its operation is completed (this software “locks” these components to secure this access). Also, if the affected LUNs are under some other software’s control, the storage management software cannot gain exclusive access. Either this message is displayed, or the second request is denied and you see an error message indicating that the module has I/Os occurring or filesystems are present.

Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration (Configuration); formatting a LUN with Options → Manual Recovery → Logical Units (Recovery); and Firmware Upgrade → Offline method (Maintenance/Tuning).

**CAUTION** If you are using a multi-host configuration, you must use caution when performing the tasks that need exclusive access to ensure that the two hosts do not send conflicting commands to the controllers in the RAID controller units.

**ACTION**

1. Wait for any operation that has secured exclusive access to the LUNs to be completed before performing another operation on the same RAID controller unit.

2. If no other storage management software operations are running, and you think another application may be running (from your operating system or third-party software), close the other application, then reselect the storage management software and try again.
Recovery Guru/Health Check

This table describes problems you may have in running Recovery Guru/Health Check or the Manual Recovery Options in the Recovery application.

Table 20: Recovery Guru/Health Check Troubleshooting

Recovery Guru/Health Check results take a long time to display.

**CAUSE** Normally you see Recovery Guru/Health Check’s results in a few seconds. However, if you have selected All RAID controller units or there are I/O operations running, you might notice a delay. Also, there could be instances where an unresponsive component or other status change affects the controller’s ability to provide a result in Recovery Guru/Health Check, although such occurrences are rare.

**ACTION** If you experience long delays in performing Recovery Guru/Health Check, you might try checking one RAID controller unit at a time or selecting Recovery Guru/Health Check at a time of low system I/O.

**NOTE** A background check occurs at regular intervals for all RAID controller units (results are logged to Message Log); the default setting is five minutes. You can change the frequency of this check by using Options → Log Settings.

Recovery Guru/Health Check doesn’t report a drive failure when I remove a drive.
If there is no I/O occurring for that drive, Recovery Guru/Health Check reports an Unresponsive Drive. If there is I/O occurring, the controller will fail the drive (and Recovery Guru/Health Check reports this, too).

**CAUTION** You should *never* remove drives from a module unless the controller has marked them as failed. Doing so could result in data loss for the affected logical unit/drive group. If you suspect problems with a drive, it is best to select Recovery Guru/Health Check and follow the instructions provided.

**Software detects a failure even after I replaced a fan or power supply (recover from a Module Component Failure).**

**CAUSE** The software continues to report the condition as a failure for approximately ten minutes after replacing a fan or power supply due to the controller’s polling interval.

**ACTION** Wait for the controller to poll the module (default is ten minutes) after performing this recovery procedure before re-selecting Recovery Guru.

**Drive status other than Optimal.**

**CAUSE** You have a Failed, Offline, or Replaced drive (which is reconstructing), or a logical unit is being formatted. For an explanation of possible drive statuses and any recommended action to take, see the Online help.

**ACTION** For Failed or Offline drives, select Recovery Guru/Health Check and follow the step-by-step procedures provided. No action is required if the drives are Replaced or the LUN is Reconstructing or Formatting. However, if the drives remain Replaced and the LUN status was Dead, Recovery Guru/Health Check may report the RAID controller unit as Optimal. If this occurs, you need to manually begin the format process for the LUN/drive group (Options → Manual Recovery → LUNs → Format).

**Drives continue to fail (fault lights lit).**

**CAUTION** It is possible that a drive channel has failed. A drive channel failure is indicated when all the drives on the same channel are Failed and/or Unresponsive. Depending how the logical units have been configured across these drives, the status of the logical units may be Dead, Degraded, or Optimal (if hot spare drives are in use).

**ACTION** Select Recovery Guru/Health Check and follow the step-by-step procedure given.

**Drive fault light came on after I replaced a failed drive.**

**CAUSE** This light may come on momentarily when a drive in a RAID 1, 3, or 5 LUN begins reconstruction.

**ACTION** Wait a few minutes for the fault light to go off and the drive activity lights to begin flashing steadily. This indicates that reconstruction is occurring. The drive’s status changes to Replaced and the logical unit’s status changes to Reconstructing.

However, if the fault remains on, select Recovery Guru/Health Check and follow the procedure provided.
Failed Drive status appears, but logical unit status is still Optimal.

**CAUSE**  A drive on the logical unit has failed and a hot spare has taken over for it.

**NOTE**  To see if a hot spare is being used, use List/Locate Drives in the Configuration Application. The hot spare’s drive status is either In Use or Standby (not being used).

**ACTION**  Select Recovery Guru/Health Check and follow the procedure provided.

Logical unit status other than Optimal.

**CAUSE**  You have a Failed drive or a Replaced drive which is reconstructing, a logical unit is being formatted, or the LUN is Inaccessible because it is owned by the other controller (possible if the RAID controller unit has an Independent Controller configuration). For an explanation of possible logical unit statuses and any recommended action to take, see the Online Help.

**ACTION**  For Dead or Degraded logical units, select Recovery Guru/Health Check and follow the step-by-step procedures it provides for restoring the logical units. However, if the drives remain Replaced and the LUN status was Dead, Recovery Guru may report the RAID controller unit as Optimal. If this occurs, you need to manually begin the format process for the LUN/drive group (Options → Manual Recovery → LUNs → Format).

LUN status changed to Reconstructing, but no drives have been replaced.

**CAUSE**  A hot spare has taken over for a failed drive and the data is being reconstructed on it. The logical unit’s status returns to Optimal as soon as reconstruction is completed.
Table 20: Recovery Guru/Health Check Troubleshooting (continued)

| LUN status doesn’t change from Reconstructing. |
| CAUTION  | This could occur after a Manual Recovery task is completed, especially LUN Reconstruction, or because data was reconstructed on a hot spare (the hot spare drive becomes In Use, the LUN status changes to Reconstructing, but may not return to Optimal when reconstruction is completed). |
| IMPORTANT | If reconstruction was interrupted on a hot spare drive because another drive failed in the same drive group/LUN, the LUN is probably Dead (with two Failed drives) and you have lost data. You should select Recovery Guru/Health Check and follow the procedure provided to replace the newly failed drive. |
| ACTION | Wait for the background monitor to run (default is five minutes) and to update the status, or to update immediately, do one of the following: |
| • Re-select the RAID controller unit. |
| • Exit and re-enter the application. |

All Drives in a Drive Group fail.

| CAUSE | If all the drives in a configured drive group fail and are then physically replaced, Recovery Guru/Health check will still show the replaced drives as failed. Their status is not upgraded to Replaced, although the LUN status will show Dead LUN. |
| ACTION | In this case, follow the Recovery Guru/Health Check procedure to reformat the LUNs in the drive group. |
| IMPORTANT | If you turn the power to the RAID controller unit off and then on again, the LUNs in the drive group are deleted, and the replaced drives are returned to the unassigned drive group, still failed. Follow the procedure given in Health Check to recreate the deleted LUNs. |

Controller mode is Passive and it doesn’t own any LUNs after replacing a Failed controller.

| CAUSE | After using Recovery Guru to replace the failed controller and Options → Manual Recovery → Controller Pairs to place it back Online, the controller is Optimal but in the Passive mode rather than Active. This is most likely to occur for controller B. |
| ACTION | With the newly replaced controller Optimal, use Controller Mode → Change To Active/Active (Maintenance/Tuning application) to make the controller Active. You can either redistribute drive groups/LUNs during this mode change, or later you can use LUN Balancing (Maintenance/Tuning Application) to assign specific drive group/LUNs to each active controller. |

Information is missing in the Options → Manual Recovery → Drives screen.

| CAUSE | The drives for the selected RAID controller unit are unassigned (that is, they are not part of a configured drive group). For these drives, there is no LUN, RAID Level, or logical unit status to report. However, you should still see information for the drives’ location and status. |
| ACTION | Select another module, or use the Configuration application to create logical units using those unassigned drives. |
Replacing Controllers

Use Recovery Guru/Health Check (Recovery Application) to diagnose and correct problems with your RAID controller unit components. If you are replacing a failed controller and experience problems, use the following procedures as recommended.

Problems Bringing the New Controller Online

You have replaced a controller and saw a message while trying to bring the new controller Online that told you to check your controller connections and if still having problems to consult this section.

Problem Summary

One of the problems that could be preventing you from bringing the controller back online is that the new replacement controller has 2.5.X firmware (or earlier) while the remaining operational controller in your RAID controller unit has 3.X firmware. If this is the problem, you will see a new entry for a RAID controller unit using the Select Module option because the controller with 2.5.X firmware is being recognized as a single-controller RAID controller unit instead of being coupled with the controller with 3.X firmware. If you suspect this is the problem, use the following steps.

1. Exit all storage management applications, except the Recovery Application.

Caution: You need to stop the storage management’s background monitor from running during this procedure in Step 2 on page 82. However, doing so means that none of the RAID controller units connected to the host will be checked during this time. Be sure to restart the monitor when instructed.
2. Stop the Disk Array Monitor from running.
   a. Select Control Panel → Services.
   b. Highlight the Disk Array Monitor service.
   c. Select Stop.
3. Using the Recovery Application, choose Select Module. Scan the list of RAID controller units displayed. You should see your original RAID controller unit. Do you also see a new entry with the default name of <hostname>_XXX?

<table>
<thead>
<tr>
<th>No</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Something else is causing the controller not to be brought back online. Consult your Customer Services Representative.</td>
<td>You have the 2.X/3.X problem mentioned above. Go to Step 4.</td>
</tr>
</tbody>
</table>

4. Highlight the new RAID controller unit entry with the default name of <hostname>_XXX and select Remove.
5. Exit ALL storage management applications.
6. Restart the Recovery Application and make sure that the affected RAID controller unit is selected.
7. Select Manual Recovery → Controller Pairs, highlight the controller that is Offline, and select Place Online.
   Once the controller is placed Online you see an incompatible firmware detected message. Refer to the next section, "Incompatible Firmware Detected" on page 82.

Incompatible Firmware Detected

You have replaced a controller and saw a message after the new controller was brought Online telling you that incompatible firmware has been detected and to consult this section.

Problem Summary

The correct procedure for upgrading the controller firmware depends on the controller firmware versions of both controllers and the controller slot location of the replaced controller. Use the following steps to determine the correct procedure.

1. Using the Recovery Application, select Module Profile → Controllers and determine the following:
• Record the controller name/ID for both controllers. Be sure to note which is currently controller A and which is controller B. You will need this information to identify the controllers during this procedure.

• Record the firmware version of both controllers. Be sure to note which version applies to the old controller and which to the new, replaced controller. You will need this information to determine the correct procedure to follow for upgrading the controller firmware.

2. If necessary, restart the Disk Array Monitor Service.
   a. Select Control Panel → Services.
   b. Highlight the Disk Array Monitor service.
   c. Select Start.

3. Select only the replaced controller to upgrade the 3.X firmware using the normal procedure (Maintenance/Tuning → Firmware Upgrade → Offline method).

Consult the User’s Handbook or online help for further details.
Appendix A. Specifications

This appendix describes the configuration specifications for this software.

Hardware Specifications

The following Host-RAID controller unit configurations are supported.

- **Single-Host Configuration** — one host machine is connected by two fibre channel loops to each controller in a RAID controller unit.

- **Independent Controller Configuration** — two host machines are connected to a dual-controller RAID controller unit. One host machine is connected by a Fibre Channel loop to one controller, and a second host machine is connected by another Fibre Channel loop to the other controller.

- **Multi-Host Configuration** — A pair of servers each with host adapters connected to one or more RAID controller units. Windows NT requires a Cluster Server environment.

**NOTE** For an explanation of a RAID controller unit, see the “Common Definitions” section in the User’s Handbook or the Online Help glossary. For more information on the types of Host-RAID controller unit configurations supported by the storage management software, see the “Module Configurations” section in the User’s Handbook.

Host Adapter Information

Currently the only Fibre Channel host adapter that has been tested is the IBM Netfinity Fibre Channel PCI adapter.

For the latest information on supported host adapters, drivers, installation procedures, and so on, consult the IBM Web site. (See "Chapter 8. Getting Help, Service, and Information")

Fibre Channel Hubs

The storage management software was tested with the IBM Netfinity Fibre Channel Hub.
Fibre Channel Fabric Switches

This software was tested with the following fabric switches:

• IBM 16 Port Switch
• IBM 8 Port Switch

IMPORTANT If your host system cannot see a controller connected through a fabric switch, see "The host cannot see the controller connected through a switch" on page 74.

Firmware Specifications

The 4766 Controller requires firmware version 3.0 or later.

Cluster Server References

Depending on the number of host adapters in each server, the Cluster Server may use either a single- or dual-bus configuration.

The following references are provided for component-specific documentation if needed:

• Microsoft Clustering For Windows NT Server Administrator’s Guide
• IBM Netfinity Server documentation for your server
Appendix B. Notices

Notices

References in this publication to IBM products, programs, or services do not imply that IBM intends to make these available in all countries in which IBM operates. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Subject to IBM’s valid intellectual property or other legally protectable rights, any functionally equivalent product, program, or service may be used instead of the IBM product, program, or service. The evaluation and verification of operation in conjunction with other products, except those expressly designated by IBM, are the responsibility of the user.

IBM may have patents or pending patent applications covering subject matter in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to:

    IBM Director of Licensing
    IBM Corporation
    North Castle Drive
    Armonk, NY 10504-1785
    U.S.A.

Licensees of this program who wish to have information about it for the purpose of enabling: (1) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact IBM Corporation, Department 80D, P.O. Box 12195, 3039 Cornwallis, Research Triangle Park, NC 27709, U.S.A. Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

Trademarks

The following terms are trademarks of the IBM Corporation in the United States or other countries or both:

IBM
Netfinity

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States, other countries, or both.
Intel is a registered trademark of Intel Corporation.

Other company, product, and service names may be trademarks or service marks of others.
A
Adding RAID Modules 63
Administrator privileges 11, 23
arraymon.exe
   see Disk array monitor
Auto parity check/repair
described 45

B
Background monitor 61
   see also Disk array monitor
Batch file
delay command 73
fails unexpectedly 73
Battery age reset
   restriction 4
BIOS
   disabling for cluster server 20
Blank screen
   manual recovery
drives 80
   logical units 81
Boot device
dump/swap device and 4
LUN 0 and 3, 60
   reset configuration and 3, 60

C
Cables
   checking 8, 75
Cannot secure access to LUNs message 76
Capacity
   less than expected 70
Channel failure 78
Checking
cable connections 8
cables 75
disk array monitor 12, 24, 27
hardware and software 7
module status 37
clean.bat script
   when to use 73, 74
Cluster server 3
   assigning drive letters 48
   BIOS 20
      configurations supported 86
      defined 15, 86
      documentation for 15, 86
dual bus configuration
      NVSRAM settings required 37
   fibre channel installation 20
   firmware required 17, 86
   hardware installation 20
   host adapters
      fibre channel 85
      installation 20
      installation summary 17
      installing software on 13
      node names don’t appear 6
      NVSRAM settings for 36
      preferred node
      troubleshooting 6
   RAID module installation 20
   required components 16
   software installation 27
   support for 85
   verifying installation 27
   Windows NT versions 16
Command line utilities
   fwutil 73
   help files for 62
   lad 4
Commands

see Command line utilities

Component failures
unexpected 78

Component status
unexpected 81

Configuration

determining
controller firmware version 32

current setup 40

to change 44

hardware 7

host-RAID Module types 85

multi-host restrictions 3

NVSRAM values for 36

resetting 3, 71

types supported 3

see also Independent controller configuration

see also Multi-host configuration

see also Single-host configuration

Configuration application

List/Locate, Locate won’t work 71

main screen illustrated 41

reset won’t work 71

restrictions 5

starting 40

troubleshooting 70

Controllers

can’t bring online 81

firmware mismatch 82

firmware supported 86

firmware upgrade 31

host-side ID 75

cluster server 20

incompatible software 82

mode

passive after replacing 80

names 57

not Active after replacing 80

not visible 74

not visible on screen 75

number of allowed 48, 51

changing 55

replacing 81, 82

can’t bring online 81

supported 7

troubleshooting 73

see also Firmware

Creating logical units

see Logical unit, creating

D

Database applications 60

Deleting logical units

see Logical unit, deleting

Device name

defined 57

Directory

installation naming restriction 12, 24, 26

Disk Administrator utility

deleting LUNs and 60

Disk array monitor

checking 12, 24, 27

stopping 73

stopping and restarting 62, 74

see also Background monitor

Drive letters

assigning 3, 6, 10, 18, 22, 24, 25, 48
	node mismatch 6

verifying 19, 27

Drivers

Emulex restrictions 8

information on 85

NT class 3, 10, 22

RDAC 59

symarray 3, 10, 22

Drives

assigning letters to 3, 6, 10, 18, 22, 24, 25, 48

failed 70

failures

all in drive group 80

keep failing 78

fault light on 78

number for drive group 78

unexpected 70

removing 78
status
  non-optimal 78
  unresponsive 70, 71, 78
  verifying drive letters 19, 27
drives
  removing 77
drivutil utility
  help file for 63
Dump/swap device 4

E
Emulex driver restrictions 8
Error messages
  see Messages
Ethernet 16
Exclusive access 74, 76
  multi-host configuration and 76

F
Failed drives 70
  all in drive group 80
Fans
  replacing 78
Fault light
  drives 78
Fibre channel 7
  host adapters
    loop restriction 8
    setting up 8
  hubs supported 85
Files
  batch, failed 73
  clean.bat 73, 74
  fwcompat.def 32
  lunlocks 74
  see Command line utilities
  see also rmparams file
  see also rmscript.bat
Firmware
  default directory 32
  mismatch detected 82
  mismatch or incompatible software 82
  upgrading 31
    progress of 35
    required 7
    unsuccessful 72
  versions supported 86
  viewing version level 32
Font size 4
fwcompat.def file 32
fwutil utility
  restriction 73
  see also Command line utilities

G
Graphics card 7

H
Hardware
  checking 7
  cluster server 15, 86
  fibre channel hubs 85
  host adapters 85
  requirements 7
Health check
  how long it takes 77
  running a 37
  see also Recovery Guru
Host adapter 7
  BIOS
    disabling for cluster server 20
    cluster server
      fibre channel 85
      installation 20
    Emulex restrictions 8
    fibre channel
      number allowed on loop 8
      setting up 8
      information on 85
      LUN limit 57
Host-RAID Module configuration types
  defined 85
  restrictions 3
Host-side ID 8, 75
Hot spare
  described 45
  in use 79
  logical unit status and 79
  troubleshooting 80
Hubs (fibre channel) 85
I
Incompatible software detected 82
Independent controller configuration 3
defined 85
firmware downloads and 32
indicating 30
installing software on 9
recovery guru and 37
Installation
cluster server software 27
default directory 12, 23, 26
directory naming restriction 12, 24, 26
preparation for 7
RAID modules
   cluster server 20
storage management software 11
   cluster server 13
   standard configuration 9
uninstalling 64
Installation and support guide
description 1

L
lad utility 4
List/Locate Drives
   locate won’t work 71
Logical unit
cannot secure access message 76
   capacity
      less than expected 70
changing parameters 45
creating 5, 48
deleting 5, 48, 60
limits per host adapter 57
limits per module 48, 57
names 57
not visible to software 74
parameters 46, 70
restart required 60
status
   non-optimal 77, 79
      remains at Reconstructing 80
      shows Reconstructing 79
LUN 0
   battery age reset and 4
   boot device and 3
deleting 60
   lunlocks file 74

M
Maintenance/Tuning application
   restrictions 5
Manual recovery
drives
   blank screen 80
   logical units
      blank screen 81
Message log 61
Messages
cannot secure access to LUNs 76
   non-optimal Health Check results 37
   not all files removed 73
   see also Trap messages
MIB file 52
Microsoft Cluster Server software 3
documentation for 15, 86
   see also Cluster server
Mismatch firmware detected 82
Module profile
   main screen illustrated 43
   saving 10, 14
Module selection screen 31, 41
defined 51
   disabling 51, 55
Module status
   non-optimal 77
   unexpected 81
Mouse 7
MSCS
   see Cluster server
Multi-host configuration 13
defined 85
   support for 85
   see also Cluster server
   see also Restrictions

N
NMS
   see SNMP
Not all files removed message during unin-
stall 73
Notification
see rmscript.bat
see SNMP
NT class driver 3, 10, 22
Number of drives  limitaton 70
NVS RAM
changing 24
default directory 32
downloading 32
incorrect settings 75
restoring original settings 37, 64
setting 36, 75
uninstalling the software and 64
nvutil utility 36, 37
see also Command line utilities

P
Parameters
changing configuration 45
changing in rmparams file 55
described for SNMP 55
logical unit 45
polling interval 61
Parity check/repair
default auto setting 45
PCI Ethernet 16
Polling interval 61
Power supplies
replacing 78

R
RAID Manager for DOS 75
RAID Module
adding new 63, 75
can’t access 5
checking cables 8
checking status 37
cluster server installation 20
configurations supported 3, 85
configuring 47
identifying configuration 40
independent controllers and 30
LUN limit 57
not visible on screen 75
removing configuration 75
saving profile 10
raidutil utility
restriction 4
see also Command line utilities
Raw partitions 60
RDAC
defined 59
dump/swap device and 4
illustrated 59
symarray driver and 3, 10, 22
rdacutil utility
restriction 73
see also Command line utilities
Reconstruction
drive fault light 78
Recovery application
restrictions 5
Recovery guru 75, 79, 80
independent controllers and 37
removing modules 75
takes a long time 77
troubleshooting 77
recovery guru
removing drives 77
Reset configuration 71
boot device and 3, 60
doesn’t work 71
Restart
when required 36, 37, 60
Restrictions
batch file failed 73
can’t see controllers 74
cannot secure access to LUNs 76
cluster server 6
configuration changes 5
database applications and 61
drive letters assigned 10
Emulex drivers 8
LUN limits 48, 57
LUNs not visible 74
multi-host configuration not allowed 3
number of controllers 48, 51
rmparams file
backup copy 54, 73
changeable parameters 55
changing 54
help file for 54
missing 73
upgrade installation and 9, 13
rmscript.bat
help file for 56
scriptable notification 56
upgrade installation and 9, 13

S
Screen illustrations
configuration application 41
exceptions found 39
firmware upgrade 34
Module Profile 43
recovery main screen 38
recovery procedure screen 40
Scriptable notification
see rmscript.bat
SCSI 7
SCSI ID
see Host-side ID 8
Select Module
screen display parameter 55
Service pack 7
Simple network management protocol
see SNMP
Single-host configuration 3
defined 85
installing software on 9
SNMP
disabling 53
enabling 52
MIB file and 52
parameters described 55
set up NMS 52
trap messages
contents 52
Software
background monitor 61
can’t view LUNs 74
customizing 51
doesn’t start 73
exclusive access required 74, 76
incompatible versions detected 82
installing 11
options grayed out 76
requirements 7
uninstalling 64
upgrading

cluster server 13
pre-installation tasks 10, 14
using with Microsoft Cluster Server software 3
Special characters
restriction 12, 24, 26
Starting
background monitor 62
Status
non-optimal 78
unexpected 81
Sticky drive letters
see Drive letters
Symarray driver 3, 10, 22

T
Trap messages
contents 52
see also SNMP
Troubleshooting
Configuration application 70
failed drives 78
general for all applications 73
List/Locate won’t work 71
locating solutions 65
replacing controllers 81
can’t bring online 81
firmware mismatch 82
incompatible software 82
second controller fails 73
uninstalling 73
Windows NT 65
troubleshooting 65

U
Unassigned drives
failed 70
Uninstalling
not all files removed message 73
NVSRAM and 64
procedures 64
Unresonspive drives 70, 71, 78
Upgrading
firmware 32
pre-installation tasks 10, 14
software
cluster server 13
standard installation 9
User Guide
when to use 1, 49

W
Windows NT
cluster server support 3
creating LUNs and 48, 60
deleting LUNs and 48, 60
device names on 57
Disk Administrator utility 60
drive letters locked 5
enterprise edition 7, 16
event log 73
font size 4
LUN limits 48, 57
module names on 57
NT class driver 3, 10, 22
privileges required 11, 23
service pack required 7
support for 57
symarray driver and 10, 22
troubleshooting 65
versions supported 7