Date: October 15, 2001
You can protect against network adapter failure using AIX's Etherchannel support. Etherchannel allows you to create a "logical" ethernet adapter out of 2 physical adapters. If the primary network adapter fails, AIX seemlessly moves network traffic to the surviving adapter using the same IP address.
The Etherchannel function is available in AIX 4.3.3+. Documentation is scarce, so here's a quick "how to". In this example, we assume we have two physical adapters (ent1 and ent2) that we want to group as a logical interface:
smit => devices => communications => etherchannel =>"Add an Etherchannel"
(fastpath "smit etherchannel")
Add An Etherchannel Type or select values in entry fields. Press Enter AFTER making all desired changes. [Entry Fields] Etherchannel Adapters ent1 ent2 Enable ALTERNATE ETHERCHANNEL address no ALTERNATE ETHERCHANNEL address [] Mode netif_backup Internet Address to Ping [] Number of Retries [] Retry Timeout (sec) []
This will create a "logical" interface using the next available adapter name ("ent3"). From here, configure an IP address on the logical interface ent3.
ALTERNATE ETHERCHANNEL = yes allows you to specify a "MAC" address. (Not necessary)
Mode = round-robin provides higher aggregate bandwidth by distributing outgoing packets over multiple network adapters. However "round-robin" does not distribute incoming packets, nor does it provide adapter failover. Use "netif_backup" if you want failover.
Internet Address to Ping: IP address for "keep alive". Optional as most failures detected at link layer
Bruce Spencer,
baspence@us.ibm.com
You can configure multiple etherchannels on a single system. Be
aware that each etherchannel constitutes an additional ethernet interface.
The "no" option, ifsize (default 8), needs to be increased to include not
only the ethernet interfaces for each adapter, but also any etherchannels
that are configured. See the "no" command documentation in regards to modifying
ifsize.
The adapters in an etherchannel need to be configured to the same speed
(10 or 100 Mbps) and mode (half or full duplex).
Etherchannel is configured through smit. I will use the following setup to show how etherchannel is configured: there will be 2 ethernet adapters, ent0 and ent1, in the etherchannel and there is no etherchannel alternate address specifed. There are 5 ethernet adapters to choose from.
Execute:
# smitty etherchannelwhich produces a screen that looks like:
Etherchannel Move cursor to desired item and press Enter. List All Etherchannels Add An Etherchannel Change / Show Characteristics of an Etherchannel Remove An Etherchannel |
Then choose "Add An Etherchannel" selection:
Etherchannel Move cursor to desired item and press Enter. List All Etherchannels Add An Etherchannel Change / Show Characteristics of an Etherchannel Delete An Etherchannel -------------------------------------------------------------------------- | Available Network Adapters | | | | Move cursor to desired item and press F7. | | ONE OR MORE items can be selected. | | Press Enter AFTER making all selections. | | | | > ent0 | | > ent1 | | ent2 | | ent3 | | ent4 | | | | F1=Help F2=Refresh F3=Cancel | | F7=Select F8=Image F10=Exit | F1| Enter=Do /=Find n=Find Next | F9 -------------------------------------------------------------------------- |
As instructed, select one more more of the listed adapters.
NOTE | The "Available Network Adapters"
displays all of the ethernet adapters. If one selects an ethernet adapter
that is already being used (i.e. has an interface defined), then one will
get an error similar to:
Method error (/usr/lib/methods/cfgech): 0514-001 System error: Method error (/usr/lib/methods/chgent): 0514-062 Cannot perform the requested function because the specified device is busy. |
Add an Etherchannel Type or select values in entry fields. Press Enter AFTER making all desired changes. [Entry Fields] Etherchannel Adapters ent0 ent1 + Enable ALTERNATE ETHERCHANNEL address no + ALTERNATE ETHERCHANNEL address [] + Mode standard + Enable GIGABIT ETHERNET JUMBO frames no + Internet Address to Ping [] Number of Retries [] # Retry Timeout (sec) [] # |
After hitting the enter key:
COMMAND STATUS Command: OK stdout: yes stderr: no Before command completion, additional instructions may appear below. ent5 Available |
NOTE | Since an alternate address was not specified, the config method for the etherchannel changed the alternate address of ent1 to the hardware address of ent0. If an alternate address was specified, both ent0 and ent1 would have that alternate address. |
Then add an interface, en5 for standard ethernet or et5 for IEEE 802.3, through the normal means. The easiest way is to use the "Minimum Configuration & Startup" TCP/IP smit menu.
Execute:
# smitty etherchanneland choose the "List All Etherchannels" selection:
Etherchannel Move cursor to desired item and press Enter. List All Etherchannels Add An Etherchannel Change / Show Characteristics of an Etherchannel Remove An Etherchannel COMMAND STATUS Command: OK stdout: yes stderr: no Before command completion, additional instructions may appear below. ent5 Available Etherchannel |
Execute:
# smitty etherchannelThen choose "Change / Show Characteristics of an Etherchannel" selection:
Etherchannel Move cursor to desired item and press Enter. List All Etherchannels Add An Etherchannel Change / Show Characteristics of an Etherchannel Remove An Etherchannel -------------------------------------------------------------------------- | Available Etherchannels | | | | Move cursor to desired item and press Enter. | | | | ent5 | | | | F1=Help F2=Refresh F3=Cancel | | F8=Image F10=Exit Enter=Do | F1| /=Find n=Find Next | F9 -------------------------------------------------------------------------- |
To change the Alternate etherchannel address to 1234deadbeef:
Change / Show Characteristics of an Etherchannel Type or select values in entry fields. Press Enter AFTER making all desired changes. [Entry Fields] Etherchannel ent5 + Enable ALTERNATE ETHERCHANNEL address yes + ALTERNATE ETHERCHANNEL address [0x1234deadbeef] + |
After hitting the enter key:
COMMAND STATUS Command: OK stdout: yes stderr: no Before command completion, additional instructions may appear below. ent5 changed |
NOTE | If one wants to add or delete an ethernet adapter from the etherchannel, one must use the "Remove an Etherchannel" smit menu selection, then re-add the etherchannel with the "Add An Etherchannel" smit menu selection. |
# smitty etherchannelThen choose "Remove an Etherchannel" selection:
Etherchannel Move cursor to desired item and press Enter. |
Choose 'ent5', then hit the enter key:
COMMAND STATUS Command: OK stdout: yes stderr: no Before command completion, additional instructions may appear below. ent5 deleted ent0 changed ent1 changed |
The entstat command will give the aggregate statistics of all the adapters in an etherchannel. If entstat is run with the "-d" option, the statistics of each of the individual adapters is printed.
There are three modes for Etherchannel. Each control the method
the channel uses to send and receive packets.
"Etherchannel" is a registered trademark of Cisco Systems, Inc.